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EKKO_Project Software Installation Contact information

Should you have any questions concerning the installation, please contact us at:

Sensors & Software Inc.
1040 Stacey Court
Mississauga, Ontario
Canada L4W 2X8
Tel:(905) 624-8909
Toll Free: 1-800-267-6013
Fax:(905) 624-9365

E-mail: sensoft_customerservice@spx.com
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EKKO_Project Software Installation USB Dongle

1 USB Dongle

The USB-Dongle that came with your system contains the EKKO_Project software
installation and PDFs of the EKKO_Project manuals.

~/Z Sensors &
= Software
License Key
back ‘

front

Insert the USB-Dongle into a USB port of your computer.

In a few seconds, the USB-Dongle should be recognized, and a driver installed to
access it.
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If the USB-Dongle is not recognized by the computer, move it the USB-Dongle to a
different USB port on your computer and see if it opens using the new USB port.

If the computer still does not recognize the dongle, see Dongle Troubleshooting.

Select the "Open folder to view files” option. The files and folders on the USB-
Dongle are listed.

Software installations are also available on the Sensors & Software website
(www.sensoft.ca) after registering and logging in.



http://www.sensoft.ca/
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2 EKKO_Project Data Processing Software

2.1 Installing EKKO_Project

Use EKKO_Project to manage, display, edit, process, and interpret GPR data.

1. To install EKKO_Project, open the EKKO_Project folder and double-click the
EKKO_Project Setup.EXE program to run it.

2. Follow the installation instructions.
3. After installation, run EKKO_Project using one of the following methods:
e Double-click the EKKO_Project desktop icon.
e Click Start > Programs > Sensors & Software GPR > EKKO_Project.

EKKO_Project is dongle protected, so ensure the USB-dongle is inserted in a USB
port whenever you run the EKKO_Project software.

2.2 EKKO_Project Manuals
The EKKO_Project manuals can be accessed in two ways:
1) On the EKKO_Project toolbar click Help.
2) On the USB dongle, open the \EKKO_Project Vx Ry\Manuals folder.

Viewing the PDF documents in this folder requires the Adobe Acrobat Reader
is installed on your computer. If required, use the link to go to the Adobe
website and download the Adobe Reader.
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3 EKKO_Project Installation Troubleshooting

3.1 Error Running SETUP.EXE

1) If there is an error after running the SETUP.EXE file, the problem may be a
permissions issue. The user may not have the rights to install software on
the computer.

2) Right click on the setup.exe program and select "Run as Administrator".

3) If that still does not allow the SETUP.EXE file to run, check with Information
Technology (IT) and ask them to help install EKKO_Project.

3.2 Warnings and Messages while Installing

Some software applications require the installation of additional software resources
and libraries. Messages may be displayed asking for permission to install these
components, or, if these resources are already present on the computer, a message
like the following may be displayed:

~ Microsoft Visual C++ 2010 x86 Redistributable Maintenance.El:-&

Microsoft Visual C++ 2010 x86 Redistributable Maintenance
You can repair your installation or remove it from this computer. (5% ]

Flease, select one of the following options:

© Repair Microsoft Visual C++ 2010 xB6 toits original state.

Remove Microsoft Visual C++ 2010 x86 Redistributable from this computer.

Yes, send information about my setup experiences to Microsoft Corporation.

For more information, read the Data Collection Policy.

If this occurs, select the “"Repair” option.

3.3 “table [template] already exists” error

[
EKKO_Project X

| table [template] already exists, press Ok to exit

We believe the error is caused by special characters in the Windows Username (the
name used when you login to the computer). The file referenced in the error is
stored in a subfolder of c:\users\USERNAME. If USERNAME has a special character,
some processes may not link correctly, and the error occurs. For example, if you
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have José as the username, in some places it may be referenced as Jose without the
accent instead, causing problems.

To see if this is the issue, create a new login for the computer using only a-z/A-Z/0-9
characters and try running EKKO_Project with the new Windows username.

Even if the Windows username does not appear to special characters in it, we have
seen cases where this error is resolved by creating a new Windows Username for
that computer, logging in under that username and running EKKO_Project.
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4 Dongle Troubleshooting

4.1 Dongle not Recognized by Computer

If the red USB dongle is inserted in a USB port of your computer but, when you
attempt to run the EKKO_Project software, you constantly get this error message:

EKKO_Project X

E/g EKKO_Project V5 R3 - License NOT Activated.

Please insert the USB License Key and click Retry.
To request or activate a demonstration or temporary license click Demo.

To close EKKO_Project click Cancel.

Destroy License Demo Cancel

The problem may be either:

1) Cannot Read License: Your computer does not recognize the dongle and
therefore cannot read the License Key on the dongle.

2) License Conflict: The computer has an older EKKO_Project license, from a
previous version or a trial version, and there is a conflict between the old
license on the computer and the new license on the dongle.

If you think that it may be a license conflict, follow the solution in section 4.2 below.
If EKKO_Project has never been installed on this computer before, try the following:

1) Remove the dongle from the USB port, reboot your computer, insert the red
USB dongle in a USB port and run the EKKO_Project software.

If you still get the same error message above and EKKO_Project will not run,
go to Step 2.

2) Try the red dongle in a different USB port on the computer. The light inside
the red USB dongle will illuminate when it is recognized by the computer.

If you still get the same error message above and EKKO_Project will not run,
go to Step 3.

3) With no dongle in the USB port, run EKKO_Project. When you get the
message above, insert the dongle into a USB port of the computer and click
on the Retry button.

If you still get the same error message above and EKKO_Project will not run,
go to Step 4.

4) Try the following:
i Press Ctrl+Alt+Del.
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ii. Select “Start Task Manager” from the menu.

iii. Select the Services Tab

iv. Find the CrypKey License and make sure the Status is "Running”. If it
is not running, right-click on the “Status” for CrypKey License and
select “Start Service”.

»

Name PID Description Status
COMSysApp COM+ System Applica... Stopped
cphs Intel(R) Content Prote...  Stopped

Credential Vaul... 2100 Credential Vault Host ...  Running
Credential Vaul... 2128  Credential Vault Host ...  Running

CrypKey License 2772  CrypKey License Runnire
CryptSvc 1900  Cryptographic Services  Runni
CscService Offline Files Stopp
dbupdate Dropbox Update Servi...  Stopp

dbupdatem Dropbox Update Servi... Stopp

DbxSvc 2832 DbxSvc Running
DecomLaunch 940 DCOM Server Process... Running
defragsvc Disk Defragmenter Stopped

Dell Foundation... 4780  Dell Foundation Se

Dell.Command...
DellDigitalDelivery

Ly -

<

—~—- P

UL

Processes: 154 CPU Usage: 1%
V. Exit from the Task Manager.
vi. Run EKKO_Project.

rvices Running

Dell.CommandPower...  Stopped
Dell Digital Delivery Se... Stopped

Miimmina

\. Y Services... ;

Physical Memory: 297

i

Start Service
Stop Service

Go to Process

»

4.2 Restriction File Moved, License Tag File Not Found,
Program Moved or Sitekey Bad Password Error

After running EKKO_Project, you get one of the following error messages:

=2
[

| - : .
' We apolegize for any inconvenience.

& Error(s) occured during EKKCO_Project V3 R1's license validation.

If problem persists, please contact Sensors & Software.

-15E1F: RESTRICTION FILE MOVED
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EKKO_Praject - =]

I.-"'_"‘-.I Error(s) occured during EKKO_Project V3 R1's license validation.
‘S’ We apologize for any inconvenience.
If problem persists, please contact Sensors & Software,

-1E8F: INITIALIZATION: LICEMSE TAG FILE NOT FOUND

EKKO_Project V5 R3 X

Error(s) occured during EKKO_Praoject V5 R3's license
validation.
We apologize for any inconvenience.
If problem persists, please contact Sensors & Software,

-5E1F: PROGRAM MOVED OR SITEKEY BAD PASSWORD

or there is a license conflict, try the following:

1)
2)

3)
4)

5)
6)
7)

Uninstall EKKO_Project using Control Panel > Programs and Features
Click the Start button and, in the “"Search programs and files” field, type in
%programdata% and press Enter.

Find the EKKO_Project folder and delete it.

Click the Start button and, in the “Search programs and files” field, type in
%appdata% and press Enter.

Find the Sensors & Software folder and delete it.

Reinstall EKKO_Project

Run EKKO_Project.

4.3 Driver Failed or Busy, Invalid Path, Could Not Start
NGN, Error Writing to File crp32002.ngn or
EKKO_Project Frozen on Splash Screen

o T W

{ \ Error(s) occured during EKKO_Project V3 R1's license validation.
' We apologize for any inconvenience,
If problem persists, please contact Sensars & Software.

-24E8F INITIALIZATION: DRIVER FAILED OR BUSY
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£XX0_Project V4 R3

Emorls) ocoured durng XKD Progect VA RY's koerse valdation
We apologize for arvy ncomverience
M problem persists, please contact Sensors & Software.

L

lject

3615 INVALID PATH

=]

4 Sensors &
] /" Software

validation.

@ Error(s) occured during EKKO_Project VS R3's license

We apologize for any inconvenience,
If problem persists, please contact Sensors & Software.

-29E8F: INITIALIZATION: COULD NOT START NGN

OK

1) Navigate to the C:\ProgramData\EKKO_Project folder on the computer.
2) Double-click on the CKS.EXE file to run it.
3) Run EKKO_Project.

If you still get the same error, the problem may be the CrypKey License Not

Running

1) Press Ctrl-Alt-Del and then select Task Manager from the list. Then go the
Services tab and confirm that the CrypKey License program is running.

File Options View Help

oo S

| Applications I Processes| Services |Performanoe I Networking I Users |

=

MName FID  Desciption Status Group
Browser 112 Computer Brow...  Running netswvcs
bthsery Bluetooth Supp...  Stopped bthsves |E
CertPropSvc 112 Certificate Prop...  Running netsves
dr_optimization_v2.0.5072... Microsoft .NET ...  Stopped NfA
dr_optimization_v2.0.5072... Microsoft .MET ...  Stopped NfA
dr_optimization_v4.0.3031... Microsoft \MET ...  Stopped NfA
dr_optimization_v4.0.3031... Microsoft \MET ...  Stopped NfA
CCIM: ﬁxim s ﬁmin Ha

CrypKey License 1583  CrypKey License Running NfA
CryptSvc 1228 Cryptographic...  Running NetworkSe. ..
CscService 980 Offline Files Runining LocalSyste...
DcomLaunch 724 DCOM Server P...  Running DeomLaunch
defragsve Disk Defragmen... Stopped NfA

l Dhep 944 DHCP Client Runining LocalServic...
Dnscache 1228 DNS Client Runining NetworkSe. ..
Ant3ewr Wired &tnCnnfin Stnnned InralSvete S

' |Processes: 82

CPU Usage: 2%

Physical Memory: 58%
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2) If it is not running, right-click on the “Status” for CrypKey License and select
“Start Service”.

File Options View Help

Apphca(lcns! Processes| Services | Performance | Networking \ Users

Name ~ PID  Description Status (4
COMSysApp COM+ System Applica... Stopped |
cphs Intel(R) Content Prote... Stopped !
Credential Vaul... 2100  Credential Vault Host ... Running I =
Credential Vaul... 2128  Credential Vault Host... Running |
CrypKey License 2772  CrypKey License Runnina-——-t
CryptSve 1900  Cryptographic Services  Runni art Service
CscService Offline Files Stopp Stop Service
dbupdate Dropbox Update Servi...  Stopp
dbupdatem Dropbox Update Servi... Stopp Go to Process
DbxSvec 2832 DbxSvc Running |
DcomLaunch 940 DCOM Server Process... Running |
defragsve Disk Defragmenter Stopped I
Dell Foundation... 4780  Dell Foundation Services Running |
Dell.Command... Dell. CommandPower...  Stopped |
DellDigitalDelivery Dell Digital Delivery Se... Stopped I _
:t” = H'h“’n S : == »
¥ Services...
Processes: 154 CPU Usage: 1% Physical Memory: 29%

4) Exit from the Task Manager.
5) Run EKKO_Project.

If you still get the same error, the problem may be Permissions:

The user may not have permission to run or access files in the following folder:
C:\ProgramData\EKKO_Project. Note that his is a hidden folder; in Windows
Explorer, check the View menu option Hidden Items, to see it.

Ensure the user has permission to access files in this folder.

If you still get the same error, the problem may be Anti-Virus Software:

The computer’s anti-virus software may consider files in the
C:\ProgramData\EKKO_Project as threats and won’t allow them to run. Add this
folder or at least the .NGN files in this folder to the anti-virus software’s “whitelist”.

4.4 Ckldrv.sys File Error

When trying to run EKKO_Project, if you get an error message related to the
Ckldrv.sys file and delete this file, and then reinstall EKKO_Project.

4.5 Corrupt or Damaged Dongle

If none of the solutions above solve the problem with the dongle and you have no
success on multiple computers, the dongle may be corrupt or damaged.

When you contact us for any dongle issues, it is best if you have your dongle serial
number or sales order number handy so that we can promptly assist you. The dongle
serial number is the name of the dongle that appears in your file explorer window
when the dongle is inserted into a USB port of your computer, as shown below:

10
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m 3220000090 (D:)
e |
504 MB free of 961 MB

You can also find the dongle serial humber written on the envelope (bottom left
corner) that contains the dongle when you first received it. The envelope would have
the Sales Order # (top right corner) and the Dongle Serial #; both can be used to
find your account when you contact us.

USB Dongle Instructions

1) Insert in a USB port
2) Select “Open folder to view files"
3) Double-click the “Software Installation &

Systom Documentation.PDF* file

11
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5 EKKO_Project Runs but with Errors

If you see the following error messages or similar ones when running EKKO_Project:

EKKO_Project

l L unable to open database file file: interp.sdhb, press Ok to exit

EKKO_Project EX|

Could not open project:

l"\ ChUsers\Rockin\AppDatatLocal\Termp\ssi_gpz\9476-d7b6-76ba-fc3f\gr
id07-Grid 20001grid01-Grid 20001.gfpGFP file preblem: File net found.
Err Moz -3 in file gpz_gfp.cpp, press Ok to continue,

The errors indicate that the user does not have the rights to access or create files in
certain folders used by EKKO_Project on the PC. You will need to ask you IT
specialist to provide you with the proper read/write permissions to access the
folders.

The other option is to right-click on the program icon on the Desktop and select "Run
as Administrator” from the menu:

Open
Troubleshoot compatibility

Fun with graphics processor 3
Open file location

innature Icons
1Fgl Run as administrator

Scan for Viruses...

B Add to archive...

B Add to "EKKO_Project.rar”

B Compress and email...

B Compress to "EKKO_Project.rar” and email
Pin to Taskbar
Pin to Start Menu

Restore previous versions

Send to »

Cut
Copy
Paste

Create shortout
Delete
Rename

Properties

This option resolves application permission errors.

12
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6 Missing Windows in EKKO_Project

If, when running EKKO_Project, you cannot find some of the windows and tabs that
are supposed to be visible, such as the Layer View, Acquisition tab, Processing tab

and Attachments tab, do the

following:

1) Go to View > Toolbars and Docking Windows and make sure the window

is checked on.

B2 EKKO_Project
File Edit View Tools Window Help

D & Units >| - &
New Op Average Trace Amplitude Plot (ATA)... otoslicer SuSwFr:wRary - F
Average Frequency Spectrum Plot (AFS)... Report
Project Expl Trace Plot... :
. lapView - 250MHzData-All.g
F CMP/WARR Analysis..
New Lines¢ T » o3 AN
L 45,
«J Pan =
={_ B0 250 ! o
o a2 Export Animation... E
353
= E,d Save View(s) 50
I8 Copy View(s) be
=, ] E
Eﬁj Export View(s) b0 3
[E v Use Getting Started dialog 151
= Toolbar Text
L Toolbars and Docking Windows. Pl ¥ | standard
EEEE V| Status Bar v | View Control
= (6175 e v | Acquisition
= Scale Lines v | Processing
-2 Drill Locator v | Attachments
(mz © ¢ ;
= Edit Drill Diameter | ler i
i v | Project Explorer
- E-— line2
—— line3 1 Customize...
(= [ 357

2) Look at the edges of the EKKO_Project window to see if the windows are set
to “Auto Hide” and are sitting off the edge.

l!_‘ New Project - {

J

New

J
Open S

File Edit View

Scale Lines Zc

:

13
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If this is the case, it is possible to drag and drop the window to a new location on the
screen.

3) Look to see if the window has become a tab with another window:

I_L_—,q. J— linaf v

Project Explorer Layer V

[§¥]
lyv]

If this is the case, it is possible to drag and drop the window to a new location
on the screen.

4) Minimize the open windows and make sure the missing windows are not in
behind other windows.

5) Go to Help > Restore Factory Defaults. This should make all the windows
visible.

6) If the windows are still not visible, go into View > Toolbars and Windows
> Customize.

Under the Toolbars tab, Reset All. Under the Keyboard tab, Reset All.
Under the Menu tab, Reset.
Customize X

Commands Toolbars Keyboard Menu Options

Toolbars:

v Reset

+|Slice Slider - MapView

+/|Standard

| View Control Reset Al
New...

Rename
Delete
Show text labels

Close
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