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Sensors & Software Inc. Product License, Copyright, Liability and  

Warranty Information 

Important 

Please read this document carefully before using the SOFTWARE PRODUCT or assembling the HARDWARE 

PRODUCT. By using the storage media or assembling the hardware, you are agreeing to be bound by the 
terms of this agreement. If you do not agree to the terms of this agreement, promptly contact Sensors & 
Software, Inc. at the address indicated at the end of this document. 

Definition 

The word PRODUCT as used herein defines any item sold by Sensors & Software, Inc. and may be 
comprised of HARDWARE PRODUCT which consists of physical objects and SOFTWARE PRODUCT which 
means computer programs, codes and related support materials. 

Software Product License Agreement 

In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. does not 
sell any rights to its Software products. Rather, Sensors & Software, Inc. I grant the right to use its 
software, CDs, memory sticks (or other storage media) and documentation (hereafter collectively called 
SOFTWARE PRODUCT) by means of a SOFTWARE PRODUCT license.  You acknowledge and agree that 
Sensors & Software, Inc. retains worldwide title and rights to all its software and that the SOFTWARE 

PRODUCT contains proprietary materials protected under copyright, trademark and trade secret laws. 

Grant of Software Product License 

In consideration of payment of the license fee which is the price you pay for the SOFTWARE PRODUCT and 
your agreement to abide by the terms and conditions of this License Agreement, Sensors & Software, Inc. 
grants to you, the Licensee, a non-exclusive right to use the SOFTWARE PRODUCT under the following 
conditions: 

You may: 

• use the SOFTWARE PRODUCT on a single workstation owned, leased or otherwise controlled by you; 

• copy the SOFTWARE PRODUCT for backup purposes in support of your use of the product on a single 
workstation. 

You may not: 

• copy, distribute or sell copies of the SOFTWARE PRODUCT or accompanying written materials, 
including modified or merged SOFTWARE PRODUCT to others; 

• sell, license, sublicense, assign or otherwise transfer this license to anyone without the prior written 
consent of Sensors & Software, Inc.; 

• modify, adapt, translate, decompile, disassemble, reverse engineer or create derivative works 
based on the SOFTWARE PRODUCT. 

Termination 

This license is effective until terminated. You may terminate the license at any time by returning the 
SOFTWARE PRODUCT and all copies to Sensors & Software, Inc.  The license will automatically terminate 
without notice by Sensors & Software, Inc. if you fail to comply with any terms or conditions of this 
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agreement.  Upon termination, you agree to return all copies of the SOFTWARE PRODUCT to Sensors & 
Software, Inc. 

Update Policy 

Sensors & Software, Inc. may create, from time to time, updated versions of its SOFTWARE PRODUCT.  At 
its option, Sensors & Software, Inc. will make such updates available to licensees who have paid the 
update fee. 

Product Warranty, Limited Remedy and Limited Liability  

Sensors & Software, Inc. warrants the PRODUCT to be free from defect in material and workmanship under 
normal use for a period of one year (365 days) from the date of shipment.  Any third-party computer 
systems or other items not manufactured directly by Sensors & Software, Inc. purchased with any 

PRODUCT or independently from Sensors & Software, Inc. are subject to the original manufacturer's 
warranty and are not the responsibility of Sensors & Software, Inc. 

Sensors & Software, Inc. makes no other warranties including, but not limited to, any implied warranty of 
merchantability or fitness for a particular purpose.  If the PRODUCT is defective within the warranty period 
stated above, your exclusive remedy shall be, at Sensors & Software, Inc.’s option to replace or repair the 
Sensors & Software, Inc. PRODUCT or refund the purchase price of the Sensors & Software, Inc. 
product.  Except where prohibited by law, Sensors & Software, Inc. will not be liable for any loss or 
damage arising from this Sensors & Software, Inc. product, whether direct, indirect, special, incidental or 
consequential regardless of the legal theory asserted. 

All statements, technical information, and recommendations related to any Sensors & Software, Inc. 
PRODUCT are based on information believed to be reliable, but the accuracy or completeness is not 
guaranteed.  Before using any PRODUCT, you must evaluate it and determine if it is suitable for your 
intended application.  You assume all risks and liability associated with such use.  Any statements related 
to the PRODUCT, which are not contained in Sensors & Software, Inc. current publications, or any 
contrary statements contained on your purchase order shall have no force or effect unless expressly 
agreed upon, in writing, by an authorized officer of Sensors & Software, Inc. 

Sensors & Software, Inc. warrants the CD, memory stick or other storage media on which the SOFTWARE 
PRODUCT is furnished to be free from defects in material and workmanship under normal use for a period 
of ninety (90) days from the date of purchase as evidenced by a copy of your invoice. 

Except as specified above, any SOFTWARE PRODUCT is provided "as is" without warranty of any kind, either 
expressed or implied, including, but not limited to, the use or result of use of the product in terms of 
correctness, accuracy, reliability, currentness or otherwise. The entire risk as to the results and 
performance of the PRODUCT is assumed by you. If the PRODUCT is defective or used improperly, you, and 
not Sensors & Software, Inc. or its dealers, distributors, agents, or employees, assume the entire cost of 
all necessary servicing, repair or correction. 

Sensors & Software, Inc.'s entire liability and your exclusive remedy for SOFTWARE PRODUCT shall be, at 
Sensors & Software, Inc.'s option, either: 

• the replacement of any storage media (CD, memory stick etc.) or hardware components which do 
not meet Sensors & Software, Inc.'s Limited Warranty and which are returned to Sensors & 
Software, Inc. postage prepaid with a copy of the receipt, or 

• if Sensors & Software, Inc. is unable to deliver a replacement storage media which is free of 
defects in material or workmanship, Licensee may terminate this agreement and have the license 
fee refunded by returning all copies of the SOFTWARE PRODUCT postage prepaid with a copy of the 
receipt. 
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If failure of any PRODUCT resulted from accident, abuse or misapplication, Sensors & Software, Inc. shall 
have no responsibility to replace the SOFTWARE PRODUCT, refund the license fee, or replace or repair the 
HARDWARE PRODUCT. 

Do not tamper with any PRODUCT.  PRODUCT contains no user serviceable parts.  If tampering is 
evident in Sensors & Software, Inc.’s opinion, warranty is void and null. 

No oral or written information or advice given by Sensors & Software, Inc., its dealers, 
distributors, agents or employees shall create a warranty or in any way increase the scope of this 
warranty and you may not rely on any such information or advice. 

Neither Sensors & Software, Inc. nor anyone else who has been involved in the creation, 
production or delivery of the PRODUCT shall be liable for any direct, indirect, special, exemplary, 
incidental or consequential damages, claims or actions including lost information, lost profits, or other 
damages arising out of the use or inability to use this PRODUCT even if Sensors & Software, Inc. has been 
advised of the possibility of such damages. 

This warranty gives you specific rights.  You may have other rights which vary from province to province, 
territory to territory and certain limitations contained in this limited warranty may not apply to you. 

General 

No right, license, or interest to any Sensors & Software, Inc. trademarks is granted hereunder with the 
purchase of the PRODUCT or the SOFTWARE PRODUCT license. 

Governing Law 

In the event of any conflict between any provision in this license agreement and limited warranty and any 
applicable provincial legislation, the applicable provincial legislation takes precedence over the 
contravening provision.  This agreement shall be governed and construed in accordance with the laws of 
the Province of Ontario, Canada. 

Serviceability 

Should any term of this agreement be declared void or not enforceable by any court of competent 
jurisdiction, the remaining terms shall remain in full effect. 

Waiver 

Failure of either party to enforce any of its rights in this agreement or take action against any other party 
in the event of a breach of this agreement shall not be considered a waiver of the right to subsequent 
enforcement of its rights or actions in the event of subsequent breaches by the other party. 

Acknowledgement 

You acknowledge that you have read this agreement, understand it and agree to be bound by its terms 
and conditions. You further agree that this agreement is the complete and exclusive statement of 
agreement between the parties and supersedes all proposals or prior agreements oral or written between 
the parties relating to the subject matter of this agreement. 

Should you have any questions concerning this agreement, please contact in writing: 
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Sensors & Software Inc. 

1040 Stacey Court 

Mississauga, Ontario 

Canada L4W 2X8 

Tel:(905) 624-8909 

Toll Free: 1-800-267-6013 

Fax:(905) 624-9365 

E-mail: customerservice@sensoft.ca 

Sensors & Software, Inc. trademarks are listed at: www.sensoft.ca/trademarks 

1999-00236-05 
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1 Introduction 
Ground Penetrating Radar (GPR) data is often presented as two-dimensional cross-sections of 
the subsurface. Interpreting data from GPR line cross-sectional images can be confusing and 
labor intensive. 

In areas where GPR data has been collected over an area, either by collecting the data in an 
organized XY grid or by walking back and forth and covering the area in a semi-random path, 
processing and displaying the data as a series of map images, called depth slices, is a very 
intuitive way of interpreting data.  

The SliceView module generates depth slices that provide highly detailed subsurface 
information that can enhance GPR data interpretation and presentation. Displaying GPR 
responses as depth slices allows users to see the spatial correlation of targets, making 
interpretation easier as they can differentiate real targets from targets of no interest. For 
example, responses from utilities tend to produce linear targets while local targets, such as 
rocks, appear as point targets. This type of display can greatly enhance the interpretation of 
large data volumes. 

The SliceView module consists of two parts, SliceView-Grid and SliceView-Lines that process 
the GPR data depending on how it was collected.   

Use SliceView-Grid to generate depth slices from GPR data collected in an XY grid.  Here is a 
plot of grid data displayed in the MapView window of EKKO_Project: 

 

 

GPR data collected as an XY grid is processed using SliceView-Grid 
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Use SliceView-Lines to generate depth slices from GPR data collected in a semi-random path to 
cover the area.  The data must have GPS or some other method to position the line(s) in 2D 
space.  Here are two examples plotted in the MapView window in EKKO_Project: 

 

Data collected in a semi-random path to cover the area of interest is processed using SliceView-Lines 

 

Use SliceView to: 

• Analyze data by viewing depth slices at increasing depths  

• Reprocess data using a different velocity 

• Save data images to graphic image files to include in reports 

• Extract the local project (XY) positions or global (GPS) positions of targets and write them to 
reports. 

 

In addition, SliceView-Grids also: 

 

• Displays grid data collected with GPS depth slices on Google Earth 

• Exports grid data to 3D data files and 3D visualization software (available from Sensors & 
Software) 
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2 Opening SliceView-Grid 
SliceView is an optional module of the EKKO_Project software. To access SliceView-Grid, you 
must first open EKKO_Project.  

SliceView-Grid only works with project files containing grids. 

To open EKKO_Project, click Start > All Programs > Sensors & Software GPR > 
EKKO_Project. 

 

The Getting Started dialog box automatically opens to assist you to select a grid.  

 

In the Getting Started dialog box, click  

 

Alternatively, click  to create a new project with a grid or grids. 

 

 

 

In the Open dialog box, navigate to and then select a grid or project file.  

 

Note: If you are opening a project only gpz files are listed, if you are adding a grid to a 
project file, only .gfp files are listed. 

 

Click Open. 
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The grid is displayed in the Project Explorer: 

 

 

Note: GFP files can contain more than one grid survey but SliceView can only process one 
grid from a GFP file. If the GFP file contains more than one grid, you must select one grid 
survey from the list. 

In Project Explorer, select a grid.  

 

In the EKKO_Project menu bar, click Tools > SliceView-Grid.  

Alternatively, right-click in the Project Explorer window and click SliceView-Grid. 

 

The SliceView-Grid window opens:  

 

Depth Slice View 

Menu bar 

Toolbar 

GPR Line View 

Status 

bar 
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Figure 1: The SliceView-Grid window. 

The following conceptual grid image displays the relationship between depth slice images and X 
and Y GPR line images.  

 

The first time SliceView opens a grid, it processes the grid data using default settings that are 
appropriate for most data sets.  See Data Processing to see the settings and edit them if 
necessary.  

Use the following table as a guide to working with the SliceView-Grid window: 

Item Description 

Menu bar Most SliceView-Grid operations can be performed through the menu 

bar. 

To learn more, see the menu bar. 

Toolbar Most SliceView-Grid operations can be performed through the toolbar. 

To learn more, see the toolbar. 

Depth Slice View The Depth Slice window displays the current depth slice images. 

To learn more, see Depth Slice View. 

GPR Line view The GPR Line View displays the current GPR line image. 

To learn more, see GPR Line View. 

2.1 Active Window 

SliceView-Grid typically displays two windows at a time; the Depth Slice and the GPR Line 
windows. Only one window can be active and accept changes at a time. The active window is 
the one that was last selected by clicking in it with the mouse cursor and is usually identified by 
its darker title banner and a red X in the top corner.  



SliceView User’s Guide Opening SliceView-Grid 

 

 
6 

To make changes in a particular window, first ensure it is the active window.  The active window 
is also checked in menu bar window list.  Often, trying to edit a window immediately makes it the 
active window.   

 

2.2 Depth Slice View  

The Depth Slice View displays slices of the current grid survey data. 

 

Figure 2: Depth SliceView 

The slice images currently supported in SliceView-Grid are 

• Depth Slices: images of the average GPR signal amplitudes in the specified depth 
range (or thickness). Depth slice images are dependent on the current Signal Velocity 
value. 

• Time Slices: images of the average GPR signal amplitude in the specified time range. 

Depth Slice 

Legend 

Fiducials/

Flags 

Scale 

GPR Line 

Cursor line 

Collected 

Lines 

Depth Slice 

Image 
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The Plan View window title banner lists the current depth or time range used to generate 
the slice image. The optional Depth Slice Legend on the upper right also lists the depth 
or time range of the current slice image as well as other information. 

• PCD Slice: for Conquest grid data, the Power Cable Detector (PCD) slice can be 

displayed by selecting the  button on the Toolbar.   

 

 

 

Axes scales corresponding to the X and Y positions appear on the left and top of the depth slice 
image respectively. 

To learn more about working in Depth Slices, see the Menu bar or Toolbar sections.   
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2.3 GPR Line View 

The GPR Line View displays the X or Y line indicated by the red colored grid line in the Depth 
Slice View.  

 

Figure 3: GPR Line View 

  

Slice 

Cursor 

Lines 
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Axis 

Scale 

Grid 
GPR Line 

Legend 

Depth 
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Time 
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For Conquest grid data, the Power Cable Detector (PCD) response is displayed below the grid 
line.   

 

 

To learn more about working with the GPR Line images, see the Menu bar or Toolbar sections.   
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2.4 Opening a New Window  

To open a new Depth Slice View, in the menu bar click Window > New Depth Slice View 
Window. 

To open a new GPR Line View, in the menu bar click Window > New GPR Line Window. 

When multiple windows are opened at once, only one GPR line window and one Depth Slice 
View window can be modified. These windows are indicated by the same bright green 
number in the upper left corner along the title banner. 
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3 Toolbar 
Most SliceView-Grid operations can be performed through the toolbar. If the Toolbar is not 
visible, in the Menu Bar, click View > Toolbar. 

 

To display a brief description of a toolbar button, hold your cursor over the button for at least 
one second.  

 

A description is also displayed in the Status Bar. 

Use the following table as a guide to working with the SliceView-Grid Toolbar: 

Item  Description  

 

Data Processing 

To open the Data Processing dialog box, click the Data Processing icon. 

To learn more, see Data Processing. 

 

Hyperbola Velocity 

Calibration 

To calculate a velocity value using hyperbola fitting, click the Hyperbola Velocity 

Calibration icon. 

To learn more, see Hyperbola Velocity Calibration. 

 

Save Image As… 

1. Click the Save Image As icon to save the image in the Active Window to a 

graphics image file.  

2. Open the Save File dialog box. 

3. Select the folder to save the image to. 

4. Enter the File name. 

5. Select the Save as type option (jpg, bmp, gif, png, tiff),   

6. Click Save. 

 

Save View 

To save the image in the Active Window and attach it to the project file.   

When the GPR Summary Report is selected in EKKO_Project, the user can 

select from the images attached to project to appear in the report. 

To learn more, see GPR Summary Report in the EKKO_Project manual.  

 

Copy current image 

to clipboard 

To save the image in the Active Window to the clipboard, click the Copy current 

image to clipboard icon. 

 

Print 

Click the Print icon to print the image in the Active Window. 

 

Display Settings 

To open the Settings dialog box, click the Display Settings icon. 

To learn more, see Slice Settings or GPR Line Settings. 
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Item  Description  

 

Decrease 

Sensitivity 

1. To decrease how sensitive the image is to small signal variations, select 

the image you want to change. 

2. Click the Decrease Sensitivity icon.  

Sensitivity decreases by 5% each time you click the icon. The sensitivity 

range is 0 to 100%. The default is 100% (most sensitive). 

To learn more, see Sensitivity. 

 

Increase Sensitivity 

1. To increase how sensitive the image is to small signal variations, select 

the image you want to change. 

2. Click the Increase Sensitivity icon.  

Sensitivity increases by 5% each time you click the icon. The sensitivity 

range is 0 to 100%. The default is 100% (most sensitive). 

To learn more, see Sensitivity. 

 

Decrease Contrast 

1. To decrease contrast, select the image you want to change. 

2. Click the Decrease Contrast icon.  

Contrast decreases by 5% each time you click the icon. The contrast range 

is 0 to 100%. The default is 100%. 

To learn more, see Contrast. 

 

Increase Contrast  

1. To increase contrast, select the image you want to change. 

2. Click the Increase Contrast icon.  

Contrast increases by 5% each time you click the icon. The contrast range 

is 0 to 100%. The default is 100%. 

To learn more, see Contrast. 

Decrease Gain If the Gain value is a numbered level, this button is enabled: 

1. To decrease gain, select the window (depth slice or GPR line) you want to 

change. 

2. Click the Decrease Gain icon.  

The gain level value will decrease by 1, stopping at 1.  

To learn more about gaining the GPR Line, see Gain. 

To learn more about gaining depth slices, see Amplitude Equalization Gain. 

Increase Gain If the Gain value is a numbered level, this button is enabled: 

1. To increase gain, select the window (depth slice or GPR line) you want to 

change. 

2. Click the Increase Gain icon.  

The gain level value will increase by 1, stopping at 12.  

To learn more about gaining the GPR Line, see Gain. 

To learn more about gaining depth slices, see Amplitude Equalization Gain. 

Gain Value Use dropdown to select Auto, User or a Numbered Gain Level for the currently 

active window (either GPR line or Depth Slice window). 

To learn more, see Gain. 

To learn more about gaining the GPR Line, see Gain. 

To learn more about gaining depth slices, see Amplitude Equalization Gain. 
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Item  Description  

 

PCD 

To display the Power Cable Detector (PCD) image for Conquest data. 

 

Toggle Collected 

Lines  

To display data lines in the depth slice view window that correspond to all the 

data lines collected during the grid survey, click the Toggle Collected Lines 

icon. 

 

Toggle Scale Grid 

Lines 

To display grid lines that correspond to the major position labels in the depth 

slice view window, click the Toggle Scale Grid Lines icon.  

 

Toggle Legend 

Viewing 

To display a legend in either the Depth Slice View or GPR Line View window, 

click the Toggle Legend Viewing icon. 

 

 

Display FID Text 

Fiducial markers are added at significant positions during data collection. 

To display or hide fiducial markers, click the Display FID Text icon. 

To learn more, see Show Fiducials. 

 

Zoom Out 

Click the Zoom Out icon to display more of the image, making it smaller and 

possibly less detailed. 

 

Zoom In 

To display a more detailed view of a smaller area of the image, click the Zoom 

In icon. 

 

Select Zoom Area 

To zoom in on a specific area of the selected window, Select Zoom Area. 

1. Click the Select Zoom Area icon. 

2. Click in the image and drag the cursor to the dimensions you want to 

magnify. 

A box will be superimposed on the image as you drag it.  

3. Release the mouse to zoom in on the selected area. 

 

Fit to Window 

To return the grid to full size, click the Fit to Window icon. 

 

Pan View 

To drag and drop data images around a zoomed-in image, click the Pan View 

icon. 

To learn more, see Pan. 

 

Move Slice Up 

To scroll up through the image one depth slice per click until you reach the 

highest depth slice, click the Move Slice Up icon. 

If a GPR line window is open, the slice cursor lines (Figure 4) on GPR line 

image move up to match the slice image. 

Moving through slice images provides insight into the depth of various features 

in the 3D volume. 

To learn more, see Navigation. 
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Item  Description  

 

Move Slice Down 

To scroll down through the image one depth slice per click until you reach the 

lowest depth slice, click the Move Slice Down icon. 

If a GPR Line window is open, the slice cursor lines on the GPR line image 

move down to match the slice image. 

Moving through slice images provides insight into the depth of various features 

in the 3D volume. 

To learn more, see Navigation. 

 

Line Left 

With a GPR Line pane open, click the Line Left icon to move left one Y GPR 

Line image at a time.  

To use this feature, Y-lines will have been collected and included to generate a 

depth slice image. 

To learn more, see Navigation. 

 

Line Right 

With a GPR Line pane open, click the Line Right icon to move right one Y GPR 

Line image at a time. 

To use this feature, Y-lines will have been collected and included to generate a 

depth slice image. 

To learn more, see Navigation. 

 

Line Up 

With a GPR Line pane open, click the Line Up icon to move up one X GPR Line 

image at a time. 

To use this feature, X-lines will have been collected and included to generate a 

depth slice image 

To learn more, see Navigation. 

 

Line Down  

With a GPR Line pane open, click the Line Down icon to move down one X 

GPR Line image at a time. 

To use this feature, X-lines will have been collected and included to generate a 

depth slice image. 

To learn more, see Navigation. 

 

Horizontally Tile 

Windows 

To display all open windows so they are tiled horizontally, click the Horizontally 

Tile Windows icon. All panes are resized so they are all visible and accessible. 

To learn more, see Tile Horizontally. 

 

Vertically Tile 

Windows 

To display all open windows so they are tiled vertically, click the Vertically Tile 

Windows icon. All panes are resized so they are all visible and accessible. 

To learn more, see Tile Vertically. 

 

Measure Distance 

on Image 

To measure the velocity from a hyperbola in the grid data set, click the Measure 

Distance on Image icon.  

 

Help 

Click the Help icon to open the SliceView-Grid Help file. 
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4 Status Bar 
To display the status bar, on the bottom of the screen, click View > Status Bar.  

Hold the mouse cursor over toolbar buttons to display screen tips on the status bar.  

The right side of the status bar displays information about the position of the mouse cursor: 

  

Cursor  on the depth slice Cursor on the GPR line images 

4.1 GPS on the Status Bar 

If GPS files are available or, if the Local – Global Coordinate relationship has been defined 
using GFP_Edit, moving the mouse cursor around the depth slice or GPR Line image displays 
GPS positions on the right side of the status bar. 

 

The GPS information format is defined by the GPS Format; this could be Latitude-Longitude (in 
decimal degrees or degrees-minutes-seconds) or UTM (Universal Transverse Mercator) or both. 

Note: there may be a difference between GPS positions on GPR Lines displayed in the 
SliceView-Grid and LineView software. 

In LineView, which displays individual GPR lines, the GPS position is based by interpolating 
the GPS positions saved to the GPS file during data collection. 

In SliceView-Grid, which displays multiple GPR lines combined into a grid, GPS positions 
are determined by using the defined Local-Global Coordinate Relationship and grid line 
positions.   

Therefore, the GPS positions for any individual line in the grid displayed in SliceView-Grid 
will differ slightly from the GPS file collected with that line and used in LineView.  
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4.2 Exporting Status Bar Information  

The Export Status Bar Information feature allows you to extract significant positions from the 
data image and copy them to other documents.   

a. To copy the data information text from the status bar, position the mouse cursor in the 
position you want to record, and then press F8.  

Press Shift + F8 to save the column headings text. 

Paste the text into another document, such as MS Word or Excel.   

To create a file similar to the following example, press Shift + F8 and then paste the first line 
into the document.  

Press F8 for all the subsequent lines. 
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5 Menu Bar 
The SliceView-Grid menu bar contains links to a number of features that help you to navigate 
through, and work with, SliceView-Grid. 

 

The following sections describe the SliceView-Grid Menu Bar features. 

5.1 File  

 

5.1.1 Export Data 

SliceView-Grid data can be exported as a 3D file or depth slices to various formats:  

• 3D files can be exported in HDF (Hierarchical Data Format) or CSV (Comma Separated 
Values) files. 

• Depth Slices can be exported to Google Earth KMZ, Surfer ASCII GRD, or CSV (Comma 
Separated Values) files. 
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5.1.1.1 3D 

Click File > Export Data > 3D to export grid survey data to an HDF or CSV file for processing 
and visualization with third-party software such as Golden Software’s Voxler (available from 
Sensors & Software). 

 

The following image shows 3D GPR data in Voxler: 

 

Data is exported as the 3D location of each point within the grid (X, Y, Z) and the average signal 
strength at that point (amplitude). The X and Y voxel dimensions are controlled by the Slice 
Resolution value, while the Z voxel dimension is controlled by the Thickness value. 

Increasing slice resolution and reducing depth slice thickness before generating the 3D file may 
produce better 3D image resolution. 

The default processing for depth slices and 3D files reveal linear targets such as utilities, rebar, 
foundations, and point targets (archaeological artefacts and human remains). With some types 
of data, default processing may not be appropriate for the 3D data display. For example, to 
display geological data in 3D, turn off the migration and enveloping processes (DME 
Processing).  

To preserve flat-lying layers in the data, turn off Background Subtraction. 
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The following image displays 3D geological data in Voxler that was processed in SliceView-Grid 
without Migration or Envelope processing: 

 

Geological data that has not received envelope processing is best displayed when slice 
thickness is set finer than the default thickness, ideally the same as the temporal sampling 
interval. This is typically about 1/5 of the default slice thickness value. 

5.1.1.2 3D HDF  

HDF files are a binary format that can be viewed in software such as Voxler (available from 
Sensors & Software). 

a. To export 3D data to HDF, in the menu File > Export Data > 3D.  

b. In the Save As dialog box, in the Save as type drop-down list click Voxler HDF file. 

c. Select the folder you want to save this data to. 

d. Click Save. 

When a grid survey is exported to HDF, the HDF file is named the same as the GFP file, 
with the grid name appended to the name, for example GPRData-Grid.HDF. 

e. If Voxler is installed on the computer, Voxler launches automatically generates 3D images 
with pre-set parameters for the following types of 3D displays. 

 

1) Volume Render (Volrender) displays the whole cube of data and allows the user to 
modify the transparency to highlight GPR reflections of certain signal strength.  For 
example, it is common to make weak GPR reflectors transparent and only display 
the strongest reflections in the data. 

2) ClipPlanes slice through the cube of data, like depth slices but with the advantage of 
slicing at any angle through the data cube. 

3) Isosurfaces show all the points of a single, user defined GPR amplitude value in the 
cube with all other data transparent; great for showing the strongest reflectors in the 
data.   
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In the example above, GPR grid data is displayed in 3D in Voxler as a volume render 
(purple cube), a clip plane (top of purple cube) and an isosurface (grey, linear objects). 

 

To edit the view, select the display, for example, Volrender, in the Network Manager window 
and modify the properties in the Property Manager window.   

 

For each type of data display, there are many properties to adjust, but some of the more 
important ones when viewing GPR data are described below. 

 

Volrender Properties 
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Change the Render method to 3D textures to provide a smoother image. 

 

If desired, change the Colormap by clicking on the colormap and selecting a new colormap. 

Open the Colormap Editor by clicking on the  

 

In the Colormap Editor change the Opacity Mapping to Middle Ramp and modify the 
opacity of the data by moving the opacity line: 

 

This allows the user to make weak reflections in the data cube translucent or invisible and 
the stronger reflections visible. 

 

ClipPlane Properties 

 

 

 

Modify the Normal direction by changing the X, Y and Z values.  Z = -1 to slice from top to 
bottom in a GPR cube. You can adjust these values to slice through the cube on an angle, 
for example X = 1, Y =1 and Z =1. 

 

Slide the Distance from Center slider to change the position of the slice. 
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Isosurface Properties 

 

Change the Colormap by clicking on the colormap and selecting a new colormap. 

 

Slide the Isovalue slider to change the amplitude value to display. 

 

5.1.1.3 3D CSV  

CSV files can be imported into many programs; Microsoft Excel for example. 

a. To export 3D data to a CSV file, in the menu bar click File > Export Data > 3D. 

In the Save As dialog box, in the Save as type drop-down list click XYZ-Amplitude Pairs. 

Select the folder you want to save this data to. 

Click Save.  

The header line indicates the X, Y, Z and depth columns with the half-width of the voxel (or cell) 
in that direction. The header line also lists the total number of samples in the CSV file. 

The CSV file lists depth or time depending on the Slice Units setting. 

5.1.1.3.1 Depth 

The CSV file format is X Y Z depth amplitude where amplitude values represent the average 
signal strength in the thickness of the depth slice. 

The Z values (column three) represent elevation values with the surface at elevation zero (0.0) 
and the values are negative. The depth values (column four) are the same as the Z values, but 
positive. 

X ± 0.0250m Y ± 0.0250m Z ± 0.00250m Depth ± 0.0025m Amplitude A/D 

0.025 0.025 -0.003 0.003 2801 

0.025 0.075 -0.003 0.003 4432 

0.025 0.125 -0.003 0.003 4195 

0.025 0.175 -0.003 0.003 3826 

0.025 0.225 -0.003 0.003 3315 

0.025 0.275 -0.003 0.003 2465 

0.025 0.325 -0.003 0.003 2698 
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5.1.1.3.2 Time 

The CSV file Time format is X Y Z Time Amplitude. 

The Z values (column three) are time values with the surface at time zero (0.0) so the values 
are negative; Time values (column four) are the same, but the values are positive. 

X ± 0.0250m Y ± 0.0250m Z ± 0.0500m Time ± 0.0500ns Amplitude A/D 

0.025 0.025 -0.05 0.05 384 

0.025 0.075 -0.05 0.05 633 

0.025 0.125 -0.05 0.05 495 

0.025 0.175 -0.05 0.05 581 

0.025 0.225 -0.05 0.05 476 

0.025 0.275 -0.05 0.05 342 

5.1.1.4 Current Slice  

5.1.1.4.1 Exporting Slice(s) to Google Earth 

SliceView-Grid will not export to Google Earth unless a there is relationship between project 
coordinates and GPS coordinates.  

EKKO_Project automatically creates a relationship if you have .GPS files. 

If you do not have GPS data, or want to change the relationship, use the GFP_Edit program. To 
learn more, see the Editing Grids in GFP_Edit. 

a. To export the current slice to a Google Earth KMZ file, in the menu bar click File > Export 
Data > Current Slice. 

To export all slices to a Google Earth KMZ file, in the menu bar click File > Export Data > 
All Slices.  

In the Export slice dialog box, in the Save as type drop-down list click Google Earth KMZ. 

The file defaults to the file and current folder name, but you can rename the file before 
saving it. 

5.1.1.4.2 Viewing Slices in Google Earth 

To display Google Earth (.kmz) files, Google Earth must be installed and the computer must 
have internet access.  

Open .kmz files using one of the following methods: 

• After saving a .kmz file, Google Earth automatically launches displaying the kmz file. 

• From Windows Explorer, navigate to the kmz and double-click the file. 

• Open Google Earth. Click File > Open, navigate to the kmz file, and then open it. 

When a kmz file opens, Google Earth displays the GPR slice location and superimposes it over 
the ground image. 

The following images displays a GPR slice plotted in Google Earth: 
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The Places pane enables slice display, line collection, and fiducial markers. 

The .kmz file is listed in the Fly to tab Places pane, Temporary Places file. When exiting, 
Google Earth prompts you to save the .kmz file to My Places. 

The Google Earth default view displays Collected Lines and Fiducial Markers on the data 
image. 
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Collected Lines 

Collected Lines are listed in the Places pane, Temporary Places file. To enable or disable this 
feature, select or deselect the Collected Lines checkbox. 
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Fiducial Markers 

Fiducial Markers are listed in the Places pane, Temporary Places file.  

To enable or disable this feature, select or deselect the Fiducials checkbox.  

To display individual Fiducial Markers, click the plus sign (+) beside the Fiducial option.  
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Depth Slices 

Depth Slices are listed in the Places pane, Temporary Places file.  

• To display the list of slices, click the plus sign (+) beside the kmz file name.  

• To select a different depth slice image, in the Depth Slice list, click a slice. 

 

Google Earth Accuracy 

Google Earth images may be not always align with the actual GPS location. Google Earth may 
also place Depth slice images at high latitudes incorrectly.  

The grid position can be adjusted using GFP_Edit. To learn more, see Exporting Grids to 
GFP_Edit. 

5.1.1.4.3 Surfer ASCII Grid Files 

Surfer is third-party processing and visualization software developed by Golden Software for 
plotting two-dimensional data such as GPR depth slices. 

a. To export the current slice to a Surfer ASCII Grid (.grd) file, select File > Export Data > 
Current Slice. 

To export the all slices to Surfer ASCII Grid files, select File > Export Data > All Slices.  

In the Export slice dialog box, in the Save as type drop-down list click Surfer ASCII grid (grd). 
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The file name defaults to the file and current folder name, but you can rename the file before 
saving it. 

The following table displays an example of .GRD file: 

 

5.1.1.4.4 CSV File 

CSV (Comma Separated Values) files can be imported into many programs similar to Microsoft 
Excel. 

a. To export the current slice to a .csv file, click File > Export Data > Current Slice. 

To export the all slices to a .csv files, click File > Export Data > All Slices. 

In the Export slice dialog box, in the Save as type drop-down list, click Comma Separated 
Values (.csv). 

The file name defaults to the file and current folder name, but you can rename the file before 
saving it. 

The header line indicates the X, Y, Z and depth columns with the half-width of the voxel (or cell) 
in that direction. The header line also lists the total number of samples in the CSV file. 

The CSV file(s) list X, Y, and depth columns with the half-width of the voxel (or cell) in that 
direction. The header line also lists the total number of samples in the CSV file. 

The CSV file list Depth or Time depending on the Slice Units setting. 
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5.1.2 Advanced File Options 

Use the Advanced File Options menu to perform more advanced SliceView-Grid operations 
such as clean up intermediate files, remove all processing from the current GFP file, or restore 
the Default Application Settings.  

 

Note: Processing is not lost, just recalculated. 

5.1.2.1 Clean Intermediate Files on Exit 

Intermediate files are stored in your project GPZ file to enable images to be displayed quickly. 
After opening a file and processing GPR data files, SliceView-Grid generates intermediate files 
that display depth slices and GPR line images.  

To automatically delete intermediate files when you exit SliceView-Grid, click Clean 
Intermediate Files on Exit. 

If hard disk space is not an issue, leave this option unchecked so data images can display more 
quickly by not reprocessing data every time a file opens.  

For small grids, data can be reprocessed and displayed quickly, but large grids may still take 
many minutes to process. 

5.1.2.2 Remove SliceView-Grid Processing from GFP 

SliceView-Grid files save data files names, grid geometry, and selected data processing for 
GPR data files.  

To delete data processing settings from the file, click Remove SliceView Processing.  

Note: Only use this option when you are trying to recover from a data processing error. 

5.1.2.3 Restore Default Application Settings 

To reset file settings to the default value, click Restore Default Application Settings.  

Note: Only use this option when a severe error has occurred and recovery using other 
means has not solved the problem. 

5.1.3 Exit 

Click Exit to close SliceView-Grid and return to EKKO_Project. 
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5.2 View 

To open the View menu, in the menu bar click View. 

 

 

Use the following table as a guide to working with the View menu: 

Item Description 

Export Image Click Export Image to send a depth slice or GPR line view to the clipboard, 

save it as a graphics image file, or send it to a printer. 

To learn more, see Export Image. 

Settings  Click Settings to adjust the GPR line and slice image color palette, line, scale 

and cursor colors, contrast, and sensitivity values.  

To learn more, see Slice Settings or GPR Line Settings. 

Sensitivity Increase Click Sensitivity Increase to make the image more sensitive by five percent 

increments. 

To learn more, see Sensitivity. 
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Item Description 

Sensitivity Decrease To make the image less sensitive by five percent increments, click Sensitivity 

Decrease. 

To learn more, see Sensitivity. 

Contrast Increase To increase contrast by five percent increments, click Contrast Increase. 

To learn more, see Contrast. 

Contrast Decrease To decrease contrast by five percent increments, click Contrast Decrease. 

To learn more, see Contrast. 

Zoom To increase or decrease the size of the depth slice or GPR line image, click 

Zoom. 

To learn more, see Zoom. 

Pan To move images within a zoomed-in display, click Pan. 

To learn more, see Pan. 

Show Collected 

Lines 

To superimpose lines onto the Depth Slice image to display where a grid’s data 

lines were collected, click Show Collected Lines. 

Use this feature when a partial grid or partial lines were collected in a survey to 

avoid having to interpret a target in an area where no data was collected. 

To learn more, see Show Collected Lines. 

Show Scale To display scales around the image, click View > Show Scale.  

For Depth Slice images, X and Y position scales are displayed across the top 

and left side of the image respectively.  

To view the Depth Slice scale, see the Depth Slice View image. 

For GPR Lines, a depth scale is displayed on the left side of the image. A time 

scale is displayed on the right side of the image and a position scale is 

displayed across the top of the image. 

To view the GPR Line scale, see the GPR Line View image. 

Show Scale Grid To superimpose a grid of dashed lines onto the depth slice or GPR line image, 

click View > Show Scale Grid.  

To learn more, see Show Scale Grid. 

Show Legend To display a legend with the depth slice (Figure 2) or GPR Line (Figure 3) 

image, click View > Show Legend. 

The Depth Slice Legend, displayed to the right of the slice image, contains 

depth slice information including the slice range, resolution, velocity, data 

collection date, data analysis date, and settings including data processing, color 

palette, sensitivity, and contrast. For Conquest grid data it also displays the 

maximum PCD level in the grid. 

To view the Depth Slice Legend, see the Depth Slice View image. 

The GPR Line Legend, displayed below the GPR line image, contains GPR line 

information including the line name, velocity, data processing, gain, color 

palette, contrast, and sensitivity. For Conquest grid data it displays the 

maximum PCD level in the Conquest grid line. 

To view the GPR Line Legend, see the GPR Line View image. 
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Item Description 

Show Slice  To display the depth slice image, click View > Show Slice.  

Show Slice displays only the position of collected lines without the slice image. 

This option defaults to on. 

Show 

Flags/Fiducials 

To display flags/fiducials (Figure 2), click View > Show Flags/Fiducials. 

Flags/Fiducials are markers and/or comments added during data acquisition at 

specific trace positions along the line. 

To learn more, see Show Flags/Fiducials. 

Show Flag/Fiducial 

Text 

To display text associated with the fiducials, click View > Show Flag/Fiducial 

Text. 

If the grid survey data does not contain any fiducials, this option is greyed out. 

Skip Traces If the data file contains positions where traces were skipped during data 

collection, display this information on the GPR Line image by clicking View > 

Show/Hide > Skipped Traces. 

Skipped traces appear as colored rectangles on the bottom of the GPR line. 

Font Use the Font option to define the font you want to use for the position, depth and 

time axes, and the text in the legends. 

Changing font type and size can increase the available screen area to display 

data images on and improve the readability of printed images or graphics image 

files. 

Toolbar To display the toolbar below the menu bar, click View > Toolbar (Figure 1). 

Status Bar To display the status bar along the bottom of the SliceView-Grid window, click 

View > Status Bar (Figure 1). 

GPS Format To open the Configure GPS Format dialog box, click View > GPS Format. 

To learn more, see GPS Format. 

5.2.1 Export Image 

To export any depth slice or GPR line view to the clipboard, save it as a graphics image file, or 
send it to a printer, click Export Image. 

 

Use the following table as a guide to working with the Export Image menu: 

Item Description  

Copy to Clipboard  Click Copy to Clipboard to copy the depth slice or GPR Line image in the 

active window to the clipboard for pasting into other documents. 
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Item Description  

Save as File To save an electronic copy of the image in the active window: 

1. Click Save as File.  

2. In the Save File dialog box, navigate to the folder you want to save the 

image in. 

3. In the File name field, enter a name for the file. 

4. In the Save as type drop-down list, select the graphics format file type.  

5. Click Save. 

Save all Slices  To save an electronic copy of all depth slice images in the active window: 

1. Click Save All. 

2. In the Save File dialog box, navigate to the folder you want to save the 

image in. 

3. In the File name field, enter a name for the file. 

4. In the Save as type drop-down list, select the graphics format file type. 

5. Click Save. 

Print  To print a hard copy of the image click Print. 
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5.2.2 Settings 

The Settings option allows you to change how GPR line and depth slice images are displayed 
through color palettes, line, scale and cursor colors, contrast, and sensitivity values. 

You can access the Settings option from the menu bar or the toolbar. 

5.2.2.1 Slice Settings 
a. In the menu bar, click View > Settings to adjust the slice image color palette, line, scale and 

cursor colors, contrast, and sensitivity values of GPR line and slice images. 

Alternatively, in the toolbar click . 

The Slice Settings dialog box opens: 

 

Use the following table as a guide to working with the Slice Settings dialog box: 

Item  Description 

Slice  Click Slice to open the Depth Slice Settings dialog box. 

GPR Line To open the GPR Line Settings dialog box, click GPR Line. 

To learn more, see GPR Line Settings. 

Mixed, X, Y Select Mixed, X, or Y as a grid data collection method option. 

To learn more, see Lines in Depth Image Slice. 

Color Palette To change the depth slice image color, click the Color Palette drop-down 

list. 

To learn more, see Slice Color Palette. 
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Item  Description 

Sensitivity Move the Sensitivity slider to increase or decrease the sensitivity of the 

image to small signal variations. 

Alternatively, enter a percentage number into the Sensitivity text box. 

To learn more, see Sensitivity.  

Contrast Move the Contrast slider to increase or decrease the contrast of the image 

to small signal variations. 

Alternatively, enter a percentage number into the Contrast text box. 

To learn more, see Contrast. 

Cursor  To change the color of the grid line indicating the position, within the grid, of 

the current GPR Line displayed in the GPR Line window, click Cursor. 

To learn more, see Cursor Color. 

Lines  To change the color of lines corresponding to the GPR lines collected 

during the grid survey, click Lines. 

To learn more, see Lines Color. 

Scale  To change the color of the scale grid lines, click Scale.  

To learn more, see Scale Color. 

Defaults Click Defaults to revert the settings to their default values. 

Preview To display the effects of the slice setting change before applying them, click 

Preview. 

OK Click OK to apply your changes. 

Cancel Click Cancel to close the Settings dialog box; all changes will be lost. 

Auto Preview Select Auto Preview to see the effect of changes made to the settings, 

including Sensitivity, Contrast and the Color Palette. 
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5.2.2.1.1 Generating Depth Slices with GPR Lines 

In the Slice Settings dialog box, select the GPR Lines used to generate the depth slices; the 
options are: X lines only, Y lines only, or Mixed (X and Y lines).  

X Grids 

X-grids are areas covered by a series of parallel lines in the X direction: 

 

In the Slice Settings dialog box, click the X option to generate a depth slice using only X data 
lines in the grid.  

The GPR Line view display only X-direction lines: 
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Y Grids 

Y-grids are areas covered by a series of parallel lines in the Y direction: 

 

In the Slice Settings dialog box, click the Y option to generate a depth slice image using only Y 
data lines in the grid. The GPR Line view displays only Y data lines. 

Click the X or Y lines option to emphasize targets perpendicular to the line direction. In the 
following image, rebar are running in two directions, but the rebar parallel to the X lines have 
been eliminated: 

 

Click the Y lines only option to display rebar perpendicular to the Y lines and eliminate the 
parallel rebar parallel. 
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Mixed Grids 

Mixed grid areas are covered by lines in both the X and Y directions 

 

In the Slice Settings dialog box, click Mixed to generate depth slice images based on both X 
and Y lines.  

The GPR Line view displays an X line or a Y line 
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5.2.2.1.2 Slice Color Palette 

In the Settings dialog box, click the Slice Color Palette drop-down to select depth slice image 
colors from a predefined color palette. Experiment with the palette to determine the best colors 
for the selected grid scan data set. The default color palette for slices is jet.  

 

5.2.2.1.3 Sensitivity  

The Sensitivity settings control how sensitive an image is to small signal variations. Sensitivity 
values range from 0 to 100%, least sensitive to most sensitive (default 100%). 

Before changing a sensitivity value, make sure that the depth slice image you want to change is 
in the active window. 

To adjust sensitivity move the slide left to decrease sensitivity and right to increase sensitivity: 

 

You can also adjust sensitivity from the menu bar and toolbar: 

Increase Sensitivity  

• To increase sensitivity by 5% increments, in the Menu bar, click View > Sensitivity 
Increase. 

• To increase sensitivity by 5% increments, in the Toolbar, click the sensitivity increase  
icon. 

• To increase sensitivity by 10% increments, press Shift while clicking the menu or toolbar. 

• To increase sensitivity by 10% increments, press Ctrl while clicking the menu or toolbar. 
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Decrease Sensitivity  

Decreasing sensitivity widens the color palette around the zero signal level, removing weaker 
signals in the image so only the strongest signals are visible. 

• To decrease sensitivity by 5% increments, in the Menu bar, click View > Sensitivity 
Decrease. 

• To decrease sensitivity by 5% increments, in the Toolbar, click the sensitivity decrease  
icon. 

• To decrease sensitivity by 10% increments, press Shift while clicking the menu or toolbar. 

• To decrease sensitivity by 10% increments, press Ctrl while clicking the menu or toolbar. 

Depth Slice Images  

Depth Slice signals vary from zero to extreme positive values. As sensitivity decreases, the 
color associated with the zero signal level on the left side of the color palette widens to the right 
resulting in the weaker signals being removed from the image. 

  

  

Sensitivity default 100% Sensitivity 50% 

5.2.2.1.4 Contrast 

The Contrast setting enables you to control how much of the image area is at the extremes of 
the color palette. Contrast ranges from 0 to 100%, less contrast to more contrast (default 0% -
no added contrast). 

Before changing contrast values, make sure the depth slice image you want to change is the 
active window. 

Contrast Increase  

• To increase contrast by 5% increments, in the Menu bar, click View > Contrast Increase. 

• To increase contrast by 5% increments, in the Toolbar, click increase contrast  icon. 

• To increase contrast by 10% increments, press Shift while clicking the menu or toolbar. 

• To increase contrast by 10% increments, press Ctrl while clicking the menu or toolbar. 
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Contrast Decrease 

• To decrease contrast by 5% increments, in the Menu bar, click View > Contrast Decrease. 

• To decrease contrast by 5% increments, in the Toolbar, click the decrease contrast  
icon. 

• To decrease contrast by 10% increments, press Shift while clicking the menu or toolbar. 

• To decrease contrast by 10% increments, press Ctrl while clicking the menu or toolbar. 

As contrast increases, more data is displayed at the extreme value of the color palette. Contrast 
helps make weak targets more visible in the image. 

Depth Slice Images 

Depth Slice signals vary from zero to extreme positive values. As contrast increases, the color 
associated with the extreme positive signal level on the right side of the color palette widens to 
the left, resulting in the weaker signals appearing stronger in the image. 

  

  

Contrast default 0 Contrast 50 % 
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5.2.2.1.5 Cursor Color 

Cursor Lines are colored lines indicating 

• The position of the GPR Line displayed in the GPR Lines view in the grid displayed in the 
Depth Slice view (Figure 5). 

• The thickness range of a depth slice is indicated by two parallel lines superimposed on the 
GPR Line image (Figure 4).  

 

Figure 4: Slice Cursor line and Scale Grid 

a. To change the line color, in the Settings dialog box, click Cursor.  

 

Slice Cursor 

Lines 

Scale Grid 
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In the Color dialog box, select a color that provides high cursor line visibility on the depth slices 
and GPR Lines. 

Click OK. 

The GPR Line Cursor Line in the depth slice view is not visible if the Show Collected Lines 
option has been turned off. 

 

Figure 5: GPR line cursor line 

5.2.2.1.6 Lines Color 

Lines corresponding to all the GPR lines collected during the grid survey can be displayed in the 
Depth Slice view. 

This option is only available if the Depth Slice view is the active window.  

a. To change Line Color, in the Settings dialog box, click Lines. 

b. In the Color dialog box, select a line color that provides high line visibility on the depth 
slices. 

c. Click OK. 

GPR line 

Cursor Line 
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5.2.2.1.7 Scale Color 

Scale Grid Lines correspond to major position and depth labels can be superimposed on the 
depth slice and the GPR Lines. 

 

The Show Scale Grid option only applies to the image in the active window.  

a. To change Scale Color, in the Settings dialog box, click Scale. 

b. In the Color dialog box, select a line color that is visible on the image. 

c. Click OK. 

Scale 
Scale 
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5.2.2.2 GPR Line Settings 
a. Click View > Settings to adjust the GPR Line color palette, line, scale and cursor colors, 

contrast, and sensitivity values of GPR line and slice images. 

Alternatively, in the toolbar click . 

The GPR Line Settings dialog box opens: 

 

 

Use the following table as a guide to working with the GPR Line Settings dialog box: 

Item  Description 

GPR Processing To select the type of processing to apply to the current active GPR line 

image, click the GPR Processing drop-down list. 

To learn more, see GPR Processing. 

Color Palette To change the GPR Line color, click the Color Palette drop-down. 

To learn more, see Color Palette. 

Sensitivity Move the Sensitivity slider to increase or decrease the sensitivity of the 

image to small signal variations. 

Alternatively, enter a percentage number into the Sensitivity text box. 

To learn more, see Sensitivity. 

Contrast Move the Contrast slider to increase or decrease the contrast of the image 

to small signal variations. 

Alternatively, enter a percentage number into the Contrast text box. 

To learn more, see Contrast. 
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Item  Description 

Cursor To change the color of the depth lines superimposed on the GPR Line view 

indicating the depth range of the depth slice displayed in the Depth Slice 

view, click Cursor.  

To learn more, see Cursor Color. 

Scale Click Scale to change the color of the scale grid lines.  

To learn more, see Scale Color. 

Depth Limit Depth Limit enables you to change the maximum depth displayed on GPR 

line images. 

To learn more, see Depth Limit. 

Gain Gain "amplifies” the strength of the GPR data signals in the GPR line 

images.  

To learn more, see Gain. 

Defaults Click Defaults to revert the settings to their default values. 

Preview To display the effects of the slice setting change before applying them, click 

Preview. 

OK Click OK to apply your changes. 

Cancel Click Cancel to close the Settings dialog box; all changes will be lost. 

AutoPreview To see the effect of changes made to the settings, including Sensitivity, 

Contrast and the Color Palette, select Auto Preview. 

5.2.2.2.1 GPR Processing 

Advanced users who understand GPR Processing routines, such as Dewow, background 
subtraction, migration, and enveloping can use this feature to apply processing to a GPR Lines. 

a. To access the GPR Processing type, in the Settings dialog box, click the GPR Processing 
drop-down list. 

Select a processing routine. 

 

• The recommended and default GPR Processing option is Dewow + Bgr. Subtraction + 
Gain. 

• To display the GPR Lines with the same processing as the depth slices, click Depth 
Slice Processing.  

Contrast, Sensitivity and Gain are locked to the GPR Line settings dialog and cannot be 
changed in the Slice Settings dialog. 

To learn more, see Data Processing. 
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5.2.2.2.2 GPR Line Color Palette 

Click the GPR Line Color Palette to select the color palette you want the GPR Lines to use. 
One color palette may best highlight the features in a data set, so experiment with the palettes 
to determine the best color palette for a particular data set. 

 

The default color palette for GPR line images is bone. 

5.2.2.2.3 Sensitivity  

The Sensitivity settings control how sensitive an image is to small signal variations. Sensitivity 
values range from 0 to 100%, least sensitive to most sensitive (default 100%). 

Before changing a sensitivity value, make sure that the GPR line image you want to change is in 
the active window. 

To adjust sensitivity move the slide left to decrease sensitivity and right to increase sensitivity: 

 

You can also adjust sensitivity from the menu bar and toolbar: 

Increase Sensitivity  

• To increase sensitivity by 5% increments, in the Menu bar, click View > Sensitivity 
Increase. 

• To increase sensitivity by 5% increments, in the Toolbar, click the sensitivity increase  
icon. 

• To increase sensitivity by 10% increments, press Shift while clicking the menu or toolbar. 

• To increase sensitivity by 10% increments, press Ctrl while clicking the menu or toolbar. 
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Decrease Sensitivity  

Decreasing sensitivity widens the color palette around the zero signal level, removing weaker 
signals in the image so only the strongest signals are visible. 

• To decrease sensitivity by 5% increments, in the Menu bar, click View > Sensitivity 
Decrease. 

• To decrease sensitivity by 5% increments, in the Toolbar, click the sensitivity decrease  
icon. 

• To decrease sensitivity by 10% increments, press Shift while clicking the menu or toolbar. 

• To decrease sensitivity by 10% increments, press Ctrl while clicking the menu or toolbar. 

GPR line Images  

GPR line signals vary from extreme negative values to extreme positive values with the zero 
signal in the middle. As sensitivity decreases, the color associated with the zero signal level 
widens resulting in the weaker signals being removed from the image. 

  

  

Sensitivity default 100% Sensitivity 80% 

5.2.2.2.4 Contrast 

The Contrast setting enables you to control how much of the image area is at the extremes of 
the color palette. Contrast ranges from 0 to 100%, less contrast to more contrast (default 0% -
no added contrast). 

Before changing contrast values, make sure the GPR Line image you want to change is the 
active window. 

Contrast Increase  

• To increase contrast by 5% increments, in the Menu bar, click View > Contrast Increase. 

• To increase contrast by 5% increments, in the toolbar, click increase contrast  icon. 

• To increase contrast by 10% increments, press Shift while clicking the menu or toolbar. 

• To increase contrast by 10% increments, press Ctrl while clicking the menu or toolbar. 
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Contrast Decrease 

• To decrease contrast by 5% increments, in the Menu bar, click View > Contrast Decrease. 

• To decrease contrast by 5% increments, in the toolbar, click the decrease contrast  icon. 

• To decrease contrast by 10% increments, press Shift while clicking the menu or toolbar. 

• To decrease contrast by 10% increments, press Ctrl while clicking the menu or toolbar. 

As contrast increases, more data is displayed at the extreme value of the color palette. Contrast 
helps make weak targets more visible in the image. 

GPR Line Images 

GPR line signals vary from extreme negative values to extreme positive values with zero in the 
middle. As contrast increases, the colors associated with the high positive and negative signal 
levels at the ends of the color palette widen resulting in the weaker signals appearing stronger 
in the image. 

  

  

Contrast default 0 Contrast 50 
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5.2.2.2.5 Cursor Color 

Cursor Lines are colored lines indicating 

• The position of the GPR Line displayed in the GPR Lines view in the grid displayed in the 
Depth Slice view (Figure 5). 

• The thickness range of a depth slice is indicated by two parallel lines superimposed on the 
GPR Line image (Figure 4).  

 

Figure 6: Slice Cursor line and Scale Grid 

a. To change the line color, in the Settings dialog box, click Cursor.  

 

Slice Cursor 

Lines 

Scale Grid 
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In the Color dialog box, select a color that provides high cursor line visibility on the depth slices 
and GPR Lines. 

Click OK. 

The GPR Line Cursor Line in the depth slice view is not visible if the Show Collected Lines 
option has been turned off. 

 

GPR line 

Cursor Line 
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5.2.2.2.6 Scale Color 

Scale Grid Lines correspond to major position and depth labels can be superimposed on the 
depth slice and the GPR Lines. 

 

The Show Scale Grid option only applies to the image in the active window.  

b. To change Scale Color, in the Settings dialog box, click Scale. 

c. In the Color dialog box, select a line color that is visible on the image. 

d. Click OK. 

5.2.2.2.7 GPR Line Depth Limit 

Use Depth Limit to change the maximum depth displayed on GPR line images.  

To access Depth Limit, in the Settings dialog box select a depth limit setting. 

 

Scale 
Scale 
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• Max: Displays the full depth range of GPR line data (default setting). 

 

• User: Select User to enter the maximum depth value to display in the GPR line image in the 
ft. text box. 

 

• Slice Depth Limit: Select Slice Depth Image to enter a multiplication factor for the Slice 
Depth Limit.  
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For example, a multiplication factor of two sets the GPR Line depth limit to twice the current 
slice depth limit. A multiplication factor of 0.5 zooms the slice depth limit to only show the 
shallow data in the GPR Line view.  

Setting the Depth Limit to a value larger than the maximum GPR line depth displays the full 
depth and time axes of the GPR line, but data below the maximum depth will be blank. 

Note: Use Depth Limit only to display GPR Lines. If the depth limit setting is less than the 
maximum depth, it does not limit the GPR Line data used for generating depth slices. 

Depth slices deeper than the depth limit are still visible, but the slice cursor lines on the GPR 
line that define the thickness of the depth slice fall off the bottom of the GPR line as you scroll 
down through the depth slices. 

To learn how to limit the maximum data depth to generate depth slices, see the Slice Depth 
Limit. 

5.2.2.2.8 Gain 

Gain enables you amplify the strength of the GPR data signals in the GPR line images (similar 
to adjusting the volume knob on a radio). Gain is only applied to the GPR line image display; 
changing gain has no effect on depth slice images. 

a. To add Gain to GPR Processing, in the Settings dialog box, select the Gain checkbox. 

 

Select the Auto, Level or User option. 

• Auto uses the average decay curve of the GPR signal strength over time to calculate an 
appropriate gain parameter values for attenuation, maximum gain and start gain. If the GPR 
line images are properly gained using the Auto gain setting, use it. 

If an Auto gain does not gain the GPR line properly, try using the gain Levels.   

 

Level uses 12 pre-defined settings for Start Gain, Attenuation and Maximum Gain (see 
details below) that increase from a low gain at 1 to a high gain value at 12.  Typically one of 
these 12 settings applies a suitable gain to the GPR line.  If not, select a gain level that is 
close and then switch to a User and modify the gain parameters (see below) until the gain is 
the best.  

 

The gain level is changed in this dialog but can also be changed using the Gain Level 
dropdown list and the Gain Level increase or decrease buttons on the Toolbar.  Note that 
the gain is applied to the data in the currently selected window, either the GPR line or the 
Depth Slice window. 
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This makes it easy to quickly scroll through several pre-set gain levels and find one that 
makes the GPR line look the best. 

 

• User allows the 3 gain parameters to be manually set:  

• Start Gain: In the Start Gain text box, enter the zero depth value at the top of the GPR 
line. Start Gain values are usually 1 to 3 (1 default). 

• Attenuation: To learn more, see Attenuation. 

• Maximum Gain: In the Maximum Gain text box, enter a value between 20 and 1000 
(500 default). 

Maximum Gain is the highest multiplication factor that can be applied to GPR line data. 
Attenuation stops increasing once it reaches Maximum Gain.  

Since the strongest GPR signals are returned from shallow targets at the top of the GPR line, 
the gain applied to the GPR lines increases with increasing depth.  

Gain begins with the Start Gain value at the top of the GPR line, increases at a rate defined by 
the Attenuation value, and levels off to a constant multiplier when the Maximum Gain value is 
reached. 
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The following image displays a GPR line image with the gain function shape and parameters on 
the right.  

 

In most cases, Start Value is 1 to 3, Attenuation (a), which controls steepness, is 0.5 to 50, 
and Maximum Gain, which cuts off the exponential rise, is 20 to 1000. To avoid over-gaining 
data, start with low attenuation and maximum gain values and increase as necessary. 

Attenuation 

Attenuation values define the steepness value of the gain. Lower values result in a more 
gradual slope, while higher values produce steeper slopes. The ramp rises from the Start Gain 
value up to the Maximum Gain value. 

  

A low attenuation value produces a clear GPR line image High attenuation values overgain data producing an unclear 

image 



SliceView User’s Guide Menu Bar 

 

 
57 

a. To select an attenuation value, in the Gain pane, click the User option. 

In the Attenuation drop-down list, click a value between 0.0 and 50.0. 

You can enter another value into the text box. 

Attenuation values apply gain to the GPR lines in the same way that the Amplitude Equalization 
Gain value applies gain to the slices. When you find an attenuation value the produces clear 
GPR line images that are not over-gained, you can apply the same gain value to User 
Amplitude Equalization to produce quality depth slice images. 

5.2.2.3 Apply Default to Contrast Sensitivity 

To apply the default contrast and sensitivity values to the active window, in the menu bar, click 
View > Apply Default to Contrast Sensitivity. 

5.2.3 Zoom 

Use Zoom to increase or decrease the size of the depth slice or GPR line image in the active 
window. 

To access Zoom, in the menu bar, click View > Zoom. 

 

There are four Zoom options: 

Option Description 

Fit to Window To zoom to the full grid size, click View > Zoom > Fit to Window. 

Select Area 1. To zoom in to a specific area of the slice or GPR line, click View > Zoom > 

Select Area. 

2. Draw a box around the area you want to zoom in on. 

3. Click the magnifying glass (  ) icon. 

Out  To zoom out of the current image size, click View > Zoom > Out. 

In To zoom into the current image size, click View > Zoom > In. 
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After zooming into an image, scroll bars appear on the bottom and right edge of the image.  

 

Use the scroll bars to move around the image and view different areas. The scroll bar narrows 
each time the image is zoomed-in to indicate that a smaller percentage of the full image range is 
displayed. 

A zoomed-in image still displays X and Y scales. The image may show more data than defined 
by the box because the additional data will be added to the right or bottom of the image so it 
always retains the correct aspect ratio. 

5.2.4 Pan 

Click Pan to move images around a zoomed-in image; in Pan Mode the cursor displays a hand 

icon ( ). You can click and drag data images to a new location. As the image is dragged, a 
dashed box outlining the current viewed image is formed. The image will move to the location of 
this dashed box. 

To exit Pan mode, click View > Pan. 
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5.2.5 Show Collected Lines 

To superimpose lines onto the depth slice image to display where a grid’s data lines were 
collected, click Show Collected Lines. 

Use this feature when a partial grid or partial lines were collected in a survey to avoid having to 
interpret a target in an area where no data was collected. 

  

Show Collected Lines Disable Show Collected Lines 
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5.2.6 Show Scale Grid 
To superimpose a grid of dashed lines onto the depth slice or GPR Line view, in the Menu bar 
click View > Show Scale Grid.  

Horizontal and vertical grid lines appear at major positions and depths as indicated on the 
position and/or depth scales. 

In normal operation the scale grid is turned off to remove clutter from the image. Turn the grid 
scale on to display more detailed positioning information to assist with the interpretation. 

With Scale Grids: 

 

Without Scale Grids: 
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5.2.7 Show Flags/Fiducials 

Flags/Fiducials are markers and/or comments added during data acquisition at specific trace 
positions along the line. 

To enable Flags/ Fiducials, click View > Display Flags/Fiducials.  

The following image displays a number of fiducial markers highlighted red: 

 

If your older GPR system does not write fiducials to the GFP file created during grid data 
collection, use the GFP_Edit utility program to import fiducials separately into the GFP file. 

If the grid contains Flags/Fiducials on any data lines, they are automatically displayed on the 
image in the Depth Slice View when Show Collected Lines is enabled. The flags/fiducials 
appear as small squares on the line. 

To turn flags/fiducials on or off, click View > Display Flags/Fiducials. 

The following image displays flag/fiducial markers as little squares on the depth slice view 
image. 
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5.2.8 GPS Format 

If the GPR data file contains GPS data, GPS information is displayed on the Status Bar. The 
format of the GPS information displayed is controlled by the GPS the GPS Format dialog box. 

a. To open the GPS Format dialog box click View > GPS Format. 

 

5.2.8.1.1 Latitude/Longitude 

b. Select the Latitude/Longitude checkbox to enable the Latitude/Longitude pane. 

a. Select to display Latitude/Longitude in Degrees Minutes Seconds (D M” S”) or Decimal 
Degrees. 

b. In the Show Hemisphere Location at drop-down list, select one of the following 
options: 

• Do not show 

• Positive/Negative 

Displayed as a plus (+) sign when latitude is in the Northern hemisphere or 
Longitude is in the Eastern Hemisphere. 

Displayed as a minus (-) sign when latitude is in the Southern hemisphere or 
Longitude is in the Western Hemisphere. 

• Letter  

For latitude, “N” for North or “S” for South. For Longitude, “E” for East or “W” for 
West. 

• Word 

For latitude, “North” or “South”. For Longitude, “East” or “West” 

The current GPS output is displayed in the Sample GPS Output field. 
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5.2.8.1.2 UTM 

c. Select the UTM (Universal Transverse Mercator) checkbox to enable the UTM pane. 

From the Using Reference Ellipsoid dropdown list, select an option. The default is 
WGS-84. 

• Click the Show UTM Letter Designator option to display the letter designator. 

• Click the UTM Zone Number option to display the zone number. 

The current GPS output is displayed in the Sample GPS Output field. 

Click OK. 

5.3 Navigation 

 

5.3.1 Slice Up or Slice Down 

Stepping Up or Down through depth slices provides insight into the depth of various features in 
the three dimensional volume. 

• Click Slice Up ( ) to scroll up through the depth slice image by single depth slice 
increments. 

• Click Slice Down ( ) to scroll down through the depth slice image by single depth slice 
increments. 

When the highest or lowest depth slice is reached, the depth slice image does not change. 

If the GPR Line View is open, as you move through the slices in the depth slice view, the slice 
cursor lines on the GPR line image move up or down corresponding to the depth slice image. 

5.3.2 Line Up or Line Down 

If you collected X-lines to generate a depth slice image (see Lines in Depth Slice Image) and a 

GPR Line view is open, click Line Up ( ) or Line Down ( ) to move through the X-GPR line 
one image at a time.  

If the Show Collected Lines option is enabled, a horizontal cursor line corresponding to the 
grid position of the current X-line is displayed on the slice image on the depth slice view.  

As the X-line GPR line image changes, the grid cursor line on the depth slice image moves to a 
new position corresponding to the new X-line. 

You can switch the GPR Line View from X lines to Y lines by clicking an option under Line Left 
and Line Right. 
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These buttons are active when selecting an X line for Hyperbola Velocity Calibration. 

5.3.3 Line Left or Line Right 

If you collected Y-lines to generate the depth slice image (see Lines in Depth Slice Image) and 
a GPR Line View is open, you can move through the Y-lines one at a time using the Left Arrow (

) and Right Arrow ().  

If the Show Collected Lines option is enabled, a vertical Cursor Line (Figure 5) corresponding to 
the grid position of the current Y line will be displayed on the depth slice image. As the Y line 
image changes, the cursor line on the depth slice image moves to a new position corresponding 
to the new Y line. 

These buttons are active when selecting any Y line for Hyperbola Velocity Calibration. 
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5.4 Tool 

 

5.4.1 Data Processing 

Use the Data Processing dialog box to set the parameters for the processing depth slice 
images. 

To access Data Processing, in the menu bar click Tool > Data Processing. 

Alternatively, from the toolbar, click : 
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Slices produced in SliceView-Grid display GPR signal amplitude versus XY position. Amplitude 
value is the average amplitude value over the depth or time thickness. Data processing 
processes such as Dewow, Migration, Background Subtraction, and Envelope affect the original 
amplitude. 

5.4.1.1 Data Position Limits 

Data Position Limits define the positions at the edges of the depth slice image. This setting 
always defaults to the Outer positions, so a depth slice is generated that includes all the 
available data. You can select other settings such as Clipped, Inner, or User to define other grid 
dimensions. 

5.4.1.1.1 Outer 

Select this option to apply Outer data position limits to a grid when you want the longest lines in 
the X and/or Y direction to define the size of the grid, so the depth slice generated is the largest 
possible and uses all the available data in the grid.  

 

GPR lines that are shorter than the longest lines are padded with zero data so all lines are the 
same length. 

For example, if all the lines are 10m long except one in the X direction that is 10.5m and another 
in the Y direction that is 10.2m long, the grid size plotted in the depth slice will be 10.5 x 10.2m. 

5.4.1.1.2 Clipped 

It is common to collect GPR lines that are longer than the grid dimensions; this allows operators 
to overshoot the end of the grid without having to try and stop the line exactly at the end 
position. Each GPR line is typically a slightly different length.  

Select the Clipped data position limit to crop the grid using the first and last lines in X and Y 
directions; GPR lines that extend outside the defined grid are cut off.  . 

 

Clipped data limit is not available if you have only X-lines or Y-lines, (no Y-lines to clip the X-
lines and vice versa). 



SliceView User’s Guide Menu Bar 

 

 
67 

5.4.1.1.3 Inner 

Select the Inner data position limit for the grid when the shortest lines in the X and/or Y direction 
define the size of the grid so the grid contains solid data with no zero data padding. Use this 
option when one or more GPR lines exceed the desired size of the grid and you want to 
truncate those lines and display a grid with no zero data padding. 

 

For example, if all the lines are 10m long, except one in the X direction that is 10.5m long, and 
another in the Y direction that is 10.2m long, the grid size plotted in the depth slice will be 10 x 
10m. 

5.4.1.1.4 User 

Select the User data position limit when you can define the minimum X, maximum X, minimum 
Y, and maximum Y positions for the grid. GPR lines are truncated and/or padded with zero data 
to fit the defined grid size. 

5.4.1.2 Units 

Distance and depth units displayed on the axes around the depth slice and GPR line images 
can be displayed in meters or feet.  

Use this feature to convert and display the units default used during grid data collection from 
meters (m) to feet (ft.).  

5.4.1.3 Background Subtraction 

Horizontal events associated with direct air waves and the direct ground waves are displayed at 
the top of all GPR lines. These events are not reflections from within the ground and should be 
removed from the data before generating depth slice images.  

Use background subtraction to remove these events and other horizontal reflectors in the GPR 
lines. 

The background subtraction filter defaults to on, but can be turned off by unchecking this option. 
Turn off background subtraction when you are exporting geological data to 3D (Export Data). 
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5.4.1.3.1 Total Background 

Use Total Background to calculate the average trace for the entire grid survey and then subtract 
it from every trace in the survey. This process removes the direct air and ground waves on the 
top of the data to improve the very shallow depth slice images. 

  

Before Total Background Subtraction After Total Background Subtraction has been applied 

This filter is most effective when the air wave and/or ground wave events are fairly constant 
throughout the grid of GPR lines. If the surface varies in composition or water content, the 
ground wave event will vary in amplitude and time; using total background subtraction may not 
remove the events satisfactorily on all GPR lines. In this case, using a Local Background 
Subtraction filter may be more effective. 
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5.4.1.3.2 Local Background 

When using Local Background, an average trace in a user defined window width is calculated 
and subtracted from the trace in the center of the window. The window is then moved over one 
trace and the process is repeated. This type of filter is called a running average background 
subtraction filter. 

This background subtraction filter is effective for removing local flat-lying events in the data such 
as, varying wave events or localized banding on one GPR line in the grid. 

  

Before Local Background Subtraction After Local Background Subtraction 

To determine an appropriate window width for the local background subtraction filter, scroll 
through the GPR lines in your grid and determine the length of the shortest flat-lying reflection 
that you want removed from the data. Start with a value of 1 meter (3 feet) and modify up or 
down as necessary to improve the depth slice images. 

Caution: Be careful when using short distances for Local Background Subtraction as these 
can result in the removal of a significant amount of data. 
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5.4.1.4 Signal Velocity 

An accurate signal velocity is necessary for creating good depth slice images. A poor velocity 
value may result in fuzzy images that are difficult to interpret and result in inaccurate depth 
estimates. Velocity defaults to a typical average velocity of 0.10 m/ns or 0.328 ft./ns. 

You can enter a velocity into the Signal Velocity field in the units displayed (meters per 
nanosecond m/ns, or feet per nanosecond ft./ns). 

a. To display a list of typical signal velocities, in the Data Processing dialog box, beside Signal 

Velocity, click . 

 

Record the velocity for the material you are scanning. 

Click OK. 

In  the Data Processing dialog box, in the Signal Velocity field enter the material velocity 

Click OK. 
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5.4.1.5 Slice Processing 

Use Slice Processing to select the type of processing to apply to the current active slice before it 
is displayed. 

Slice Processing defaults to on. If you do not want to perform slice processing, de-select the 
Slice processing checkbox. Turn this option off when you want to display GPE lines from a grid. 
For example, trying to determine the best slice processing options for a large grid when you 
know that slice processing will take a substantial period of time. 

5.4.1.5.1 Slice Units 

The Slice Units setting determines which units of measurement will be used for the slice 
thickness parameter: depth in meters or feet, or time in nanoseconds.  

The Slice Units defaults to depth in the same units that the data were collected in, i.e. meters or 
feet, but these units can be changed (to learn more, see Units). 

5.4.1.5.2 Slice Resolution 

The smallest unit (box) of solid color in a depth slice image is called a pixel or a sample. Slice 
Resolution defines the physical size of the sample in a depth slice image. Decreasing the 
sample size increases the total number of samples and, as a result, the details of the images. 
However, Slice Resolution can also increase the time required to process and display the 
image. Increasing the sample size decreases the total number of samples and data processing 
time but results in increasingly fuzzier images. 

    

0.16ft (116x117 samples) 0.20ft (93x94 samples) 0.50ft (37x37 samples) 1.0ft (19x19 samples) 

Depth slices with a very small sample size are very detailed but take longer to process. 

Slice Resolution defaults to an appropriate value based on the step size (the distance between 
traces during data collection) and the screen resolution. Slice resolution can be changed but not 
made finer (smaller) than the smallest step size in the data. A coarser (larger) resolution value 
results in faster data processing. 

The Depth Slice View Legend displays the current slice resolution value and the total number of 
samples in the X and Y directions. To change the slice resolution value, enter a new value or 
use one of the four resolution values from the drop-down list (low, medium, high, and max).  

Changes in slice resolution have the most effect on large grid data sets. It is a good practice to 
set slice resolution to a coarse value at first and then make sure that the depth slices generated 
are what you expect before proceeding with a finer sample size that takes longer to process. 
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5.4.1.5.3 DME Processing 

DME (Dewow, Migration, and Enveloping) is a standard GPR data processing stream that is 
typically applied to the GPR lines before generating depth slice images. DME is generally for 
advanced users who understand these GPR data processing routines. 

The default setting (recommended for novice users) is all processes checked so that they are 
performed before generating the depth slice images. 

The processes selected in this option affect the number of processing streams available in the 
GPR Processing in the GPR Line Settings drop-down list. For example, if the Migration process 
is not selected, then the GPR processing streams listed will not include Migration. 

Turn off DME (uncheck) when you have processed grid data in some other program (such as 
EKKO_Project) and just want to use SliceView-Grid to display the data. In this case, Turn off 
Background Subtraction as well as. If grid data was gained you should also turn off Amplitude 
Equalization Gain. 

Review the DME settings when exporting geological data to 3D. It may look better in 3D without 
the Migration and Enveloping processes (see Export Data). 

Dewow 

Depending on the proximity of the transmitter and receiver, as well as the electrical properties of 
the ground, the transmit signal may induce a slowly decaying low frequency (wow) on the trace 
which is superimposed on the high frequency reflections. 

The Dewow process (also called the Signal Saturation Correction) removes this unwanted low 
frequency while preserving the high frequency.  

  

Raw data line containing the low frequency wow 

component - before Dewow 

The same data line after Dewow removes the low frequency 

wow component 

Wow is removed from the data by running a high pass average filter on each trace. A window 
with a width the same as that of one pulse width at the nominal frequency is set on the trace. 
The average value of all the points in this window is calculated and subtracted from the central 
point. The window is then moved along the trace by one point and the process is repeated. 

While any filter produces unwanted artifacts in the data to which it is applied, Dewow has been 
optimized after many experiments over many years to reach a satisfactory compromise filter. 
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The Dewow process is highly recommended when data processing GPR lines and depth slices. 

Migration 

Targets in the subsurface often generate hyperbolic responses on a GPR line. A hyperbola is 
the result of the wide beam-width inherent in most GPR systems. 

The target is located at the apex, or top of, the hyperbola. Migration focuses the energy spread 
over the hyperbolic shape back to the apex of the hyperbola— the actual location of the object. 
This is an essential and highly recommended part of the data processing when generating 
depth slices. Migration allows linear targets viewed on depth slice images to appear as linear 
objects rather than hyperbolic shapes that make interpretation difficult. 

  

Before migration After migration 

Migration requires an accurate Signal Velocity value. If the velocity value is too low or too high, 
hyperbolic reflectors will not be focussed back to a point and the target will have fuzzy edges in 
the depth slice.  

Migration defaults to on and is highly recommended for most grid data sets, but the user can 
turn the migration process off by unchecking the checkbox. 

There are two types of migration available in SliceView: F-K Migration and Kirchhoff Migration. 

The F–K migration applies a synthetic aperture image reconstruction process to the GPR line. 
The GPR data are Fourier-transformed into plane waves at a monochromatic frequency. The 
waves are then processed individually to superimpose the energy at source point. This 
transformation was devise by R.H. Stolt (Geophysics, Vol 43 1978, p 23-48) and is often called 
Stolt migration. 

The Kirchhoff migration processes the data in its original space and travel time form and is 
more intuitive. The Kirchhoff migration sums along a hyperbolic trajectory for a given velocity 
and places that energy at the apex of the hyperbola. This concept is readily understood from 
examining GPR records with localized point targets. The point target response results in energy 
lying on hyperbolic trajectory in space-time cross sections. The Kirchhoff summation approach 
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essentially takes all the energy along a given hyperbola, sums it up and places it at the apex of 
the hyperbola which is the location of the source.  

There are two parameters available for the Kirchhoff Migration: 

Width: Window width used for summing along the hyperbolic trajectory. Default value is 
calculated based on the GPR line parameters and used during the migration processing. 

If not using the default, the value is in feet or meters, depending on the units the GPR line was 
collected in. 

Target Type: Type of target being imaged to optimize the gain for amplitude normalization.  The 
options are: 0=All Targets, 1=Point Targets, 2=Rod/Cylinder-targets, and 3=Planar Targets.  
The default is 0=All Targets. 

 

Envelope 

Enveloping a trace converts it from a signal with both positive and negative components to a 
signal with all positives. The process removes the oscillatory nature of the radar wavelet and 
shows the data in its true resolution. 

In the following graphic, the top image shows the original trace made up of positive and 
negative components. The middle image shows enveloping process turning negative 
components into positive. The bottom image shows a smooth wavelet outline. 

 

At a single time or depth value, the amplitude value will be similar to the raw amplitude value but 
is always positive. Average enveloped amplitude is calculated by averaging the amplitude 
values over a depth or time thickness.  

Original trace 

Trace undergoing 

Enveloping 

Final Trace  
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The following graphic shows how the enveloping process replaces the negative signal 
amplitudes in the raw data with positive values  

  

Raw data with positive and negative values Raw data with positive values 

Enveloping is highly recommended when displaying depth slices. Depth slices are generated by 
averaging all amplitude values in the thickness range. If enveloping is not done, the positive and 
negative amplitudes would cancel each other out, resulting in slice images with values close to 
zero. 

If enveloping is turned off, the data retains the negative amplitude values and the color palette 
becomes bipolar, which means that the colors display positive, negative, or zero amplitude data 
values. 

5.4.1.5.4 Slice - Thickness 

Slice Thickness defines the thickness of the depth slices and is indicated by the slice cursor 
lines on the slice image (Figure 4) in the GPR Line View. 

Depth slices plot the average signal amplitude between two depths or two times. For example, a 
depth slice with a thickness of 0.5 feet uses the signal amplitudes in 0.5-foot-thick 3D slabs and 
averages those into 2D plan images. 

Conceptually, SliceView-Grid divides the data volume into slabs of equal thickness and then 
displays depth slice images of the average amplitude in each slab: 
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The default thickness value is based on the antenna frequency used for the grid survey. In 
general, as antenna frequency decreases and wavelength increases, the default depth slice 
thickness is increased. 

The default value in feet is (1000/frequency) / 12.  

The default value in meters is (1000/frequency) * 0.025. 

Frequency is in MHz. For example, the default thickness for 250 MHz data is 0.33 feet or 0.10 
meters. 

Events with a large depth extent will be seen over several depth slices. In this case it may be 
possible to increase the thickness of the depth slice and still see the target. Be careful not to 
make the slice thickness too large, as the averaging process will reduce the amplitude of even 
very strong reflectors if they are averaged over too large a thickness interval. 

5.4.1.5.5 Slice - Overlap 

Overlap defines the percentage of overlap between depth slices. For example, an overlap of 
50% means that each depth slice will overlap the depth slices above and below it by 50%. If the 
depth slice thickness is one foot, depth slice depth ranges would be 0.0-1.0, 0.5-1.5, 1.0-2.0, 
and so on. 

The default setting is 0% which means there is no overlap between depth slices. 

Overlap is useful for seeing a feature gradually appear and disappear as you step through 
several depth slices. 

5.4.1.5.6 Slice Depth Limit 

Depth Limit specifies the maximum depth of the data used to generate depth slice images. The 
depth slice depth limit is automatically set to Auto and defaults to the maximum depth in the 
GPR line data. 
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a. To change depth limit, select the User option. 

b. In the text box, enter a new value that is less than or equal to the maximum depth value.  

If you set depth limit higher than the maximum depth, the system ignores it and uses the 
maximum depth value. 

Reducing the depth limit decreases the number of depth slice images. This is useful when the 
GPR signal depth is significantly less than the maximum depth of the GPR line data. You can 
set depth limit to the depth of penetration so the depth slice images of the background noise 
signals toward the bottom of the GPR lines are not generated and displayed. 

5.4.1.5.7 Slice - Interpolation Limit 

SliceView-Grid generates depth slice images by interpolating data into the gaps between GPR 
linens. As line separation or the distance between GPR lines increases, interpolating data into 
the gap is less desirable as artifacts may be created in the depth slice. 

The following image displays how SliceView-Grid interpolates data between GPR lines to 
generate a solid data set that is then displayed as depth slices. 

  

The Interpolation Limit defines the maximum distance (in meters or feet) that data will be 
interpolated. If the distance between two GPR lines exceeds this limit, a gap of zero data will be 
left between them. The following image displays a depth slice image from a Y line data grid 
showing a gap with zero data where the line separation exceeded the Interpolation Limit. 



SliceView User’s Guide Menu Bar 

 

 
78 

 

This value defaults according to the data set and can usually be left as Auto. The default setting 
is 1.5 times the average survey line separation. 

The User setting allows you to define the interpolation distance. 

5.4.1.5.8 Amplitude Equalization Gain 

Amplitude Equalization Gain applies a gain to depth slice data to compensate for weaker 
signals at depth. Use this feature to compare the relative signal strengths of targets in different 
depth slices. 

To add Gain to GPR Processing, in the Settings dialog box, ensure the Amplitude 
Equalization Gain checkbox is checked. 

 

Select the Auto, Level or User option. 

Auto uses the average decay curve of the GPR signal strength over time to calculate an 
appropriate gain parameter values for attenuation, maximum gain and start gain. If the GPR 
depth slice images are properly gained using the Auto gain setting, use it. 

If an Auto gain does not gain the GPR line properly, try using the gain Levels.   

 

Level uses 12 pre-defined settings for Start Gain, Attenuation and Maximum Gain (see 
details below) that increase from a low gain at 1 to a high gain value at 12.  Typically, one of 



SliceView User’s Guide Menu Bar 

 

 
79 

these 12 settings applies a suitable gain to the GPR line.  If not, select a gain level that is close 
and then switch to a User and modify the gain parameters (see below) until the gain is the best.  

 

The gain level is changed in this dialog but can also be changed using the Gain Level dropdown 
list and the Gain Level increase or decrease buttons on the Toolbar.  

 

 

 

This makes it easy to quickly scroll through several pre-set gain levels and find one that makes 
the GPR depth slices look the best. 
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The User Amplitude Equalization Gain requires three parameters: Attenuation, Start Gain, and 
Maximum Gain. 

The strongest GPR signals come from shallow targets while deeper targets have weaker signal 
strength.  

The gain applied to GPR data increases with increasing depth.  

The following images display applying Amplitude Equalization Gain to grid data. The gain at the 
shallowest depth slice is set by the Start Gain. The gain increases for deeper slices set by 
attenuation. If the attenuation value is low, the gain increases slowly with depth. If the 
attenuation value is high, the gain increases quickly with depth. Gain increases until it reaches 
the max gain value which is the highest gain applied to the deepest slices. 

 

 

The Amplitude Equalization Gain setting is only applied to the depth slice image display. 
Changing the gain setting has no effect on GPR line images. 

The current Amplitude Equalization Gain value is displayed in the SliceView-Grid Legend. 

To turn off Amplitude Equalization Gain, de-select the Amplitude Equalization Gain checkbox. 
Turning off Amplitude Equalization Gain generates slice images using the raw data amplitudes 
with no gain applied. It is not advisable to compare the signal amplitudes of targets in different 
slices. 

To set the Amplitude Equalization Gain parameters manually, select the User option.  

To set the Amplitude Equalization Gain parameters automatically, select Auto. Auto mode uses 
the average decay curve of the GPR signal strength over time to calculate appropriate gain 
parameter values for Attenuation, Maximum Gain, and Start Gain. If the resulting depth slices 
are not over-gained or under-gained, using Auto Amplitude Equalization Gain is acceptable. 

However, Auto does not always gain data properly, especially if the data has strong, high 
amplitude signals deep in the section. This may result in the attenuation value being too high, 
resulting in over-gained data and depth slices with too many high amplitude signals which can 
be confusing for data interpretation. When this occurs with your data, use Auto to set the initial 
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values for the gain parameters and then switch the gain to User and experiment using different 
values. 

Attenuation 

The Attenuation value defines the steepness of the gain function. Lower values result in a more 
gradual slope, while higher values produce steeper slopes. The value slope begins at the Start 
Gain value and increases up to the Maximum Gain value. 

Low attenuation values are typically used, but higher values may improve the imaging of deeper 
targets. Use the lowest value possible because data can be over-gained making it more difficult 
to understand. 

The following images show how Amplitude Equalization applies a gain to the weaker signals at 
depth. If the Auto value is too low or too high, select the User option and experiment with 
different values that generate images with a good balance of colors. 

   

Auto value too low Good color balance Auto value too high 

Typical attenuation values fall between 0.0 and 20.0, but you can enter any values by selecting 
the User option and then entering the value into the text box. 

The Amplitude Equalization Gain value applies gain to slices in the same way that Attenuation 
applies gain to GPR lines. Once you find an attenuation value that produces clear GPR lines 
images that aren’t over-gained, you can use it as the attenuation value to produce quality depth 
slice images. 

Start Gain 

Start Gain is the gain value at zero depth at the top of the GPR line. Typical Start Gain values 
are 0 or 1; 1 is the default value. 

Maximum Gain 

Maximum Gain is the highest multiplication factor for the GPR line data. The slope defined by 
the attenuation stops increasing once it has reached the maximum gain value. Typically values 
for the Maximum Gain are between 20 and 1000 with 500 being the default value. 

5.4.1.5.9 PCD Scale 

PCD Scale is the setting for the maximum value on the Power Cable Detection (PCD) scale for 
the PCD slice image. This option is only accessible for Conquest grid data. 
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Auto automatically sets the PCD scale to the maximum value found in the Conquest grid data.  
This value is displayed in the Slice Legend (see table in View).  

User allows the user to manually set the maximum PCD scale value.  This is useful for 
increasing or decreasing the strength of the response in the PCD slice.  This option is also 
useful to set a single maximum value when displaying PCD slices from multiple Conquest grids 
in MapView. 

 

5.4.1.6 Defaults 

Click Defaults to return the Data Processing settings to their default values. 

5.4.1.7 Preview 

Click Preview to display the effect of changes made to the Data Processing Settings before 
implementing those changes. 

5.4.1.8 OK 

Click OK to close the dialog box and implement any changes made to the Data Processing 
settings processing the grid survey data and generating slice images. Depending on the 
changes, processing time may change. 

5.4.1.9 Cancel 

Click Cancel to close the Data Processing dialog box ignoring any changes. 

5.4.1.10 Un-processed Data 

Select the Always open this dialog when loading un-processed data checkbox to 
automatically open a dialog box so you can confirm that all the data processing settings, 
especially velocity and the slice thickness, are correct before processing the data.  

5.4.2 Hyperbola Velocity Calibration 

An accurate target velocity is necessary for generating the clearest depth slice images and 
accurately determining the depth of an object from the GPR line images. 

Hyperbola Velocity Calibration allows you to calculate a velocity value using hyperbola fitting. In 
hyperbola fitting you fit a typical response curve (hyperbola) to the raw data to in order to extract 
velocity. 

It is important that you only perform hyperbola fitting on target responses where the GPR 
system has crossed the target perpendicularly. Hyperbola-fitting on a target that was crossed at 
an angle produces poor velocity values, fuzzy depth slice images, and inaccurate depth 
measurements. 

To access velocity calibration, in the menu bar click Tool > Hyperbola Velocity Calibration. 

Alternatively, in the toolbar click . 

Note: this feature toggles the Hyperbola Velocity Calibration window on and off so it must be 
clicked again after calibration is completed. If the velocity value has changed, a Yes/No 
message box appears to confirm that you want to change the velocity value. 



SliceView User’s Guide Menu Bar 

 

 
83 

5.4.2.1 Velocity Calibration Window 

Selecting Hyperbola Velocity Calibration prompts a hyperbola to appear on the GPR line image. 
If no PR line window is opened, a new one is automatically opened. 

The window first displays the current GPR line.  

Press Line Up and Line Down and Line Left and Line Right to move through the GPR lines and 
display one with a good hyperbola for the velocity calibration. 

 

If necessary, you can change the value to make the hyperbola more visible. 

5.4.2.2 Hyperbola Fitting 

The objective for hyperbola fitting is to superimpose the hyperbola over the data on top of a 
hyperbola in the GPR line image and then match the shape by dragging the handles on the end 
of the hyperbola tails. 

To determine velocity, the superimposed hyperbola does not need to be placed at the very top 
of hyperbola in the image.  

a. Select the colored band on the most visible hyperbola that has the longest tails. 

b. To move the superimposed hyperbola, click the position on the GPR line image where you 
want to set the apex (top) of the hyperbola.  

The hyperbola automatically jumps to the new position. 

  

After the hyperbola has been positioned at the apex of the hyperbola in the GPR line image, 
match the shape of the hyperbola.  

To change the shape of the hyperbola, click the diamond shaped handle on the ends of the 
hyperbola tails and then drag it to the position that best matches the shape of the image 
hyperbola. 
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Once the hyperbolas are matched, click Hyperbola Velocity Calibration again to exit velocity 
calibration mode. 

If the velocity value has changed, in the message box click Yes to accept the new velocity 
value, or No to discard the changes. 

When you accept a new velocity, the grid data is automatically processed using the new 
velocity. The depth slice images and depth axis in the GPR line window will automatically 
update. 

During the hyperbola velocity calibration, the Status Bar along the bottom of the SliceView-Grid 
window displays information including the velocity, depth, and time of the hyperbola. As the 
hyperbola shape changes, the velocity and depth also change. The depth value is always for 
the apex (top) of the superimposed hyperbola. 

5.4.2.2.1 Target of Known Depth 

You can also use Hyperbola Velocity Calibration to determine velocity using a target at a known 
depth. 

a. For a target at a known depth, such as the one in the following image, the known thickness 
of a concrete slab, place the apex of the hyperbola on the reflection of the target. 

Adjust the velocity by dragging the hyperbola handles until the depth value listed at the bottom 
of the screen matches the known depth.  

 

For example, if the reflection from the bottom of concrete is visible in the GPR line  image, and 
the depth of the concrete is known, the apex of the hyperbola can be positioned on that 
reflection and the velocity changed until the depth value displayed on the bottom of the window 
matches the known depth. 
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5.4.2.3 Measure 

Use the measure tool to measure the straight-line distance between any two points on a depth 
slice or GPR line image. 

a. To access the Measure tool, in the menu bar, click Tool > Measure.  

To measure the distance between two points, click the start position. 

Drag and drop the cursor at the end position.  

The distance between the two points (in the current units) is displayed on the Status Bar at 
the bottom of the screen. 

 

It is important to understand that measurements made on GPR lines are based on the velocity 
so an accurate velocity is critical for an accurate measurement. 

To exit from the Measure tool, click Toggle Measure Tool. 
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5.5 Window 

5.5.1 New Plan View Window 

In the menu bar, click Window > New Window to open another instance (window) of the 
current Depth Slice View window. 

This is useful when looking at different slice views at the same time. 

Windows display a green number on the left side of the title banner to indicate which data set 
they belong to. For example, all the windows associated with the first GFP file opened will have 
a number 1 in the banner, and all windows associated with the second GFP file opened will 
have a number 2 in the banner, and so on. 

 

When multiple plan view windows open, only one can be active at one time. However, changing 
some variables, such as data processing parameters, velocity, slice thickness, and color palette, 
change the value for all plan view window instances. Other variables, such as Show Collected 
Lines, Show Scale, Show Scale Grid, Show Legend, and Show Slice only apply to the active 
window. 

5.5.2 New GPR Line Window 

Use this feature when you are looking to display different GPR line images at the same time. 

Click Window > New GPR line Window to open a GPR line window for the current grid survey. 

Windows display a green number on the left side of the title banner to indicate which data set 
they belong to.  
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5.5.3 Cascade 

Click Window > Cascade to open windows to cascade on the screen, that is, the front section 
is completely visible and the title lines from the other sections are visible and accessible. 

 

5.5.4 Tile Horizontally 

In the menu bar click Window > Tile Horizontally to display all open windows so they are tiled 
horizontally. 

Alternatively, in the toolbar click . 
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5.5.5 Tile Vertically 

In the menu bar, click Window > Tile to display all open windows so they are tiled vertically. 

Alternatively, in the toolbar click . 

 

5.5.6 Arrange Icons 

Click Window > Arrange Icons to change the order of all icons (minimized windows). 
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5.5.7 Selecting an Open Window 

Click Window to display a list of all the currently open windows  

 

A checkmarks indicates the active window. To change the active window, in the list, click 
another window. 

5.6 Help 

5.6.1 Contents 

Click Help > Contents to open the SliceView User’s Guide. 

5.6.2 Sensors & Software Contact Information 

Displays contact information for Sensors & Software including mailing address, email 
addresses, phone, and fax numbers. 

5.6.3 About SliceView 

This option displays a description, version number, and product number of SliceView-Grid. 
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6 Opening SliceView-Lines 
SliceView is an optional module of the EKKO_Project software. To access SliceView-Lines, you 
must first open EKKO_Project.  

SliceView-Lines is only accessible when the project (gpz) file contains lines with 2D positioning, 
either through GPS or by manually adding Line Positioning to the GPR lines (see the Line 
Positioning routine in the EKKO_Project manual). 

a. To open EKKO_Project, click Start > All Programs > Sensors & Software GPR > 
EKKO_Project. 

 

The Getting Started dialog box automatically opens to assist you to select a project file 
containing the line(s) to process into depth slices. 

 

In the Getting Started dialog box, click  

Alternatively, click Add Lines or Add all Lines in a Folder to create a new project with 
lines. 

 

 

 

In the Open dialog box, navigate to and then select GPR lines, a folder containing GPR lines or 
project file.  
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Note: If you are opening a project only gpz files are listed.  If you are adding lines to a 
project file, only .hd files are listed. 

 

Click Open. The line(s) are displayed in the Project Explorer: 

 

 

 

In Project Explorer, select a GPR line or check one or more lines to process into depth slices.  

 

 

 

Select SliceView-Lines in one of these ways: 

 

a. In the EKKO_Project menu bar, click SliceView-Lines from the dropdown menu on 
the side of the SliceView button on the toolbar. 

 

 

b. Another method is to select the menu item Tools > SliceView-Lines. 

 

c. To process a single line, right-click on the line in the Project Explorer window and 
click SliceView-Lines. 
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The SliceView-Lines settings dialog opens.  
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6.1 SliceView-Lines Settings 

The first time the SliceView-Lines dialog opens, the settings are set to default values.   

 

 

 

6.1.1 Name 

Name is the name of the Line Slice generated.  This name is displayed in the Layer View 
window and can be checked to display the line slice data image in MapView or unchecked to 
hide it. 

The SliceView-Lines dialog always opens with a new default name.  Use the dropdown list to 
select previously processed Line Slice name; useful when reprocessing a Line Slice with 
modified settings. 
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6.1.2 List Affected Lines 
The List Affected Lines button displays a list of the GPR lines used to generate the current 
Line Slice.  This button is not accessible when generating a new Line Slice; it is only accessible 
if the selected Line Slice was generated previously and is now being edited. 

6.1.3 Process 
There are several processes that are usually applied to the GPR Lines before generating the 
depth slice.  These are listed in the Process box at the top of the dialog.   

When Auto is selected, the default settings for all the processes are applied before generating 
the depth slice. 

When Advanced is selected, the user can decide which processes to include and modify the 
parameters for that process. 

In general, it is best to run in Auto mode, so all the recommended processes are included in 
generating the depth slice.   

6.1.3.1 Velocity 

An accurate velocity is necessary for generating the clearest depth slice images and 
accurately determining the depth of an object from the GPR line images. 

The default velocity is 0.10 m/ns or 0.328 ft/ns but, if possible, the user should open the GPR 
line or lines in the LineView module and measure the velocity by using the hyperbola-fitting 
method (see the LineView manual).  If processing more than one line and the velocity varies 
between lines, the average velocity is used. 

6.1.3.2 Processes 
If Advanced is selected, the process checkboxes are enabled for the user to modify the 
processing applied to GPR line(s) before depth slices are generated. 
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Dewow is explained in DME Processing. 

Background Subtraction is explained in Background Subtraction 

The Background Subtraction Filter Length defaults to zero (0).  This uses the total length of the 
GPR line (see Total Background) which may not always create the best depth slices, especially 
if your GPR line data is very long, crosses different surface materials, has many horizontal 
bands in it or the terrain is rough.  In these cases, set Process to Advanced and experiment 
with a few different Filter Length values (see Local Background) and see which one works best. 
Remember that the shorter the Filter Length, the more horizontal signals are removed from the 
data so if your goal is to emphasize hyperbolic targets, use a shorter Filter Length but 
remember that a shorter filter length removes more data.  Three good Filter lengths to try are 
10m (30 ft), 2m (6 ft) and 1m (3 feet). 

Migration is explained in DME Processing. 

Envelope is explained in DME Processing. 

Gain is explained in Amplitude Equalization Gain.  If Gain is unchecked, the Gain options lower 
down in the dialog box are greyed out and not accessible: 
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6.1.3.3 Gain  

Gain applies a gain to depth slice data to compensate for weaker signals at depth. Use this 
feature to compare the relative signal strengths of targets in different depth slices. 

Select Auto, Level or Advanced.  These options are explained in Amplitude Equalization Gain. 

 

 

 

Note that Auto may not provide enough gain for depth slices.  If your depth slices are not 
showing the full range of the color palette (see below), change the Gain from Auto to Level and 
reprocess the depth slices with a gain level from 1 to 12, increasing the Level and reprocessing 
the depth slices until there is a full range of colors visible in the depth slices. 

 

 Gain = Auto  Gain Level = 6 

6.1.3.4 Slice 
 

The Slice settings include the Color Palette the depth slices are displayed with, the Slice 
Thickness, the percent of Overlap between slices and the Maximum Slice Depth.  If the Slice 
settings are set to Auto, default values are used.  Selecting Advanced allows the user to 
modify the settings.  
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Use the dropdown to select the Color Palette.  For more information, see Slice Color 
Palette. 

 

Thickness is explained in Slice - Thickness 

 

Overlap percentage is explained in Slice - Overlap 

 

Maximum Slice Depth is explained in Slice Depth Limit 

 

6.1.3.5 Interpolation 
 

After the GPR line data are processed, it is interpolated based on the Neighborhood Radius 
and the Pixel Width values.  From the dropdown, the options are Low, Medium, High and 
Advanced.   

The values for the Neighborhood Radius and Pixel Width are based on low, medium and 
high settings for the recommended line spacing for grid data collected with the antenna 
frequency.  The lower the frequency (and the longer the GPR antenna), the higher the 
values for the Neighborhood Radius and Pixel width (see table below). 

 

If the Interpolation is set to Advanced, the user can set the values for the Neighborhood 
Radius and Pixel Width. 

 

 

 

Neighborhood Radius 

The GPR signal amplitudes are interpolated over an area defined by the Neighborhood 
Radius.   



SliceView User’s Guide Opening SliceView-Lines 

 

 
99 

To generate a continuous depth slice with few or no gaps, the Neighborhood Radius should 
be set to the ½ the average distance between lines.  Use the Measure tool in EKKO_Project 
to measure this distance (see the EKKO_Project manual). 

If the Neighbourhood Radius is less than the ½ the actual line spacing, the depth slices will 
have gaps in them.  In the example below, the actual line spacing is about 0.5 to 1.2m and 
the Neighborhood Radius is 0.25m (diameter is 0.5m), so some areas of the depth slice 
show gaps up to 0.7m wide (1.2m actual – 0.5m interpolation = 0.7m). 

 

 

Beware of setting the radius too high; this interpolates the data over a larger area which 
reduces amplitudes, spreads responses over a larger area and may give a false sense of 
where data were actually collected. 

Pixel Width 

Pixel Width is the physical size of the smallest pixel of data in the depth slice.   

Smaller pixel widths will produce higher resolution depth slices but will take longer to 
generate.  

In general, the Pixel Width should be about 1/4 to 1/10th the Neighborhood Radius; the 
default value is 1/5th.   

Beware of making too small a pixel size as it may create a false sense of data resolution. 
For example, if the data traces are actually spaced 0.25 meter apart, it does not make a lot 
of sense to set a pixel size of 0.01 metres. 

 

The following table shows the default values for Neighborhood Radius and Pixel Width 
based on the antenna frequency and the level of interpolation (Low, Medium, High). 
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Centre 
Frequency 

(MHz) 

Low Interpolation Medium Interpolation High Interpolation 

Radius Pixel Width Radius Pixel Width Radius Pixel Width 

1000 0.2 0.04 0.1 0.02 0.05 0.01 

500 0.5 0.1 0.25 0.05 0.125 0.025 

250 1 0.2 0.50 0.1 0.25 0.05 

200 1 0.2 0.50 0.1 0.25 0.05 

100 2 0.4 1.00 0.2 0.50 0.1 

50 4 0.8 2.0 0.4 1.0 0.2 

25 8 1.6 4.0 0.8 2.0 0.4 

12.5 16 3.2 8.0 1.6 4.0 0.8 

 

For example, here is the same depth slice from the same GPR line plotted using Interpolation 
settings of low, medium and high: 

 

Low Medium High 
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6.2 Viewing Depth Slices in MapView 

 

After the depth slices are generated they are displayed as a layer in the MapView window.   

 

 

 

Note that the checkboxes in the Layer View window  control what is displayed in MapView so if 
you do not see the depth slice, it may be because the Line Slices checkbox is not checked. 

 

 

 

It is possible to display more than one Line Slice at the same time. The most recently generated image is 

on top. 
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Right-clicking on a Line Slice item opens a sub-menu.   

 

 

 

Selecting Settings opens the SliceView-Lines dialog to allow the Line Slice settings for that Line 
Slice to be modified. 

Selecting Delete deletes the Line Slice image. 

For more details about Layer View, see the EKKO_Project manual. 
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Appendix A  GFP_Edit 
Use GFP_Edit to edit a grid or change the relationship between project and global coordinates. 
To edit a grid, export it from EKKO_Project, and then edit it with GFP_Edit. Once editing is 
complete, import the edited grid back into the project. 

Before you can edit a grid, install GFP_Edit on your computer. 

Exporting Grids to GFP_Edit  

a. In the Project Explorer, select the grid you want to export. 

In the menu bar, click File > Export Line(s) > Line Data. 

In the Select folder to export to dialog box, navigate to the folder you want to export to. 

a. To create an export folder, right-click in the display pane and create a new folder. 

b. Select the folder 

c. Click Select Folder. 

Editing Grids in GFP_Edit 

a. In Windows Explorer, click the exported grid. 

b. In the folder, right-click the .gfp file  

c. In the drop-down list, click Open with. 

d. In the open with dialog box, click GFP_Edit. 

a. If GFP_Edit is not listed, click Browse.  

b. In the Open with dialog box, navigate to Sensors & Software folder. 

c. Click  

d. Click  

e. Click  
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Click OK. 

Edit the grid in GFP_Edit.  

 

Save your GFP file. 
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To Import the gfp file as a new grid to EKKO_Project, in EKKO_Project, click Add Grid. 

In the Open dialog box, select the edited gfp file. 

Click Open. 

The new grid is displayed in Project Explorer 

Right-click the new grid. 

In the drop-down list click SliceView.  

The new grid is displayed in SliceView-Grid. 
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Appendix B  Glossary  

Term or Phrase Definition 

3D View Displaying depth or time slices and selected cross sections through a volume. 

Enables 3D visualization of grid survey data. 

Amplitude Depth / 

Time Equalization 

Equalizing the average amplitudes in all depth/time slices so that equivalent 

features in slices from different depths/times appear to have the similar 

amplitude in the generated image. 

Attribute Characteristic derived from original data. For example, the average amplitude of 

the dominant frequency between two times or depths. 

Color Palette The color palette or color table that converts a data attribute like amplitude into 

color in the creation of depth or time slice images and section views. 

GPR line Image When profiling data is displayed as a computer generated image, showing 

signal amplitude varying in time or depth versus position along the line. Often 

shortened to GPR line or section. 

Cross Section 

Maximum Slice 

Depth Multiplier 

Multiplication factor used to set the maximum depth displayed on the GPR line 

view. Maximum depth displayed is this factor multiplied by the Max Depth Limit 

specified in the slice processing. Shortened to Max Slice Depth Multiplier, 

Depth Gain Depth Gain: is a display gain applied that varies with depth along a trace. 

Depth or Depth-

Section Image: 

Profiling data is displayed as a GPR line with the vertical depth scale. Often 

shortened to depth-section or section. 

Depth Slice Describes a data attribute derived from data between two depths - top of depth 

slice and bottom of depth slice. Most often a grid survey has the depth range 

from 0 to the maximum depth subdivided into a number of depth slices of equal 

thicknesses. 

Depth Slice Image Describes a depth slice when the slice attribute is displayed as a computer 

generated image. Normally be shortened to depth slice. 

Gain When displaying cross sections formed from traces, a display control is often 

needed to allow strong responses from shallow targets to be viewed at the same 

time as weaker responses from deep targets. Gain is applied to weak signals to 

make them larger. 

GFP File An XML format computer file which provides information on multiple files of data 

and enables a Sensors & Software program to automatically read and process 

the data to final form. 

Grid Describes a square or rectilinear set of straight lines covering an area. Acquiring 

data on a grid means acquiring data along each line forming the grid. Acquiring 

data on a grid is a pre-requisite for creating depth or time slice images. 

Conventional notation is to use a Cartesian coordinate system with X and Y 

axes. 

Grid Resolution  Describes the XY spatial resolution attained in a grid and is controlled by the 

largest line or trace spacing. 

Grid Size Describes the real extent of a grid (e.g. 5m x 10m, 20ft x 50ft.). 
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Term or Phrase Definition 

Grid Survey Describes the process of acquiring data on a grid over an area with the goal of 

creating depth or time slice images. 

Hyperbolic Fitting Fitting a hyperbolic shape to a local GPR response in the space-time domain. 

The fitting process yields a velocity above target and a depth estimate. 

Hyperbolic Velocity 

Estimate 

A point source GPR refection appears as a hyperbola in the GPR line Image. 

Hyperbolic fitting enables the media velocity and target depth to be estimated. 

Image Contrast  How much of image is at extremes of Color Palette. Effectively the Color Palette 

increases the area of extremes of data signal. Given as 0-100%, with default of 

0% (no added contrast). 

Image Sensitivity How sensitive the image is to small signal variations. Effectively the Color 

Palette widens around the zero signal level. Given as 0-100%, with default being 

100% (most sensitive) 

Interpolation Limit The maximum separation between lines when interpolating Slice data. Parallel 

Lines separated by more than the limit will result in an area on the Slice 

between the Lines with no GPR signal.(zero amplitude). 

Line Identifies the location of data acquisition. A line is normally straight and data are 

recorded from the start to the end of the line. 

Line Name/Number The identifier for a line of data saved when surveying along a line. (e.g. 

XL0010.DT1) 

Line Profiling Describes collecting data along one or more lines for immediate site 

assessment using PR line images. A series of lines can be used to help define 

site conditions prior to a grid survey. 

Line Spacing 

Conversion Factor 

Importing X or Y Lines, the position of the line on the grid area is determined 

using the Conversion Factor. If the Line name has a number N, the position is 

N* Factor. If the Line name does not have a number, a Line Spacing of Factor is 

used. I.e. XLine010, with a factor of 0.5 m, would be placed 10*0.5=2 meters 

from origin along Y axis. 

Maximum Depth Describes the maximum depth selected for viewing, processing, or data 

acquisition along a line. 

Maximum Time Describes the maximum time selected for viewing, processing or data 

acquisition along a line.  

MultiSlice or 

MultiSlice View 

Term used when displaying a number of contiguous depth or time slice images 

which, when viewed together, enable the user to view a complete volume 

described by the grid area and the maximum depth or maximum time. 

Plan View Window that displays a plan view of the surveyed area. The depth/time slices, 

line location map, and surface images (future development) are all displayed as 

layers, possibly overlaid, (e.g. line locations over depth slice image) within this 

window. 

Slice Image 

Resolution 

The spacing (m or ft.) between the regularized grid data points in the XY plane 

for the processed and interpolated slice attribute data. This is the parameter that 

determines the spatial resolution in the depth/time slice images. 

Slice Overlap Overlap (% of slice thickness) between the adjacent depth/time slices. 

Slice Thickness Thickness (m or ft.) of the time/depth slice. 
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Term or Phrase Definition 

Time Slice Describes the data acquired between two times - top of time slice and bottom of 

time slice. Most often a grid survey has the maximum time subdivided into a 

number of time slices of equal thicknesses. 

Time Slice Image Describes a time slice when the slice attribute is displayed as a computer 

generated image. This term will normally be shortened to time slice. 

Time or Time-

Section Image 

Term used when line profiling data are displayed as GPR line with the vertical 

time scale. Quite often the term is shortened to time-section or section. 

Time Window same as Maximum Time 

Velocity Term used to characterize the speed at which GPR signals travel. Velocity is a 

critical parameter when creating depth slice images and estimating depths of 

targets since velocity is used to convert travel-time to depth. 

X Line A line oriented in the X direction. (Y = constant while X position varies). 

X Line Spacing Refers to the spacing between X lines when a grid is covered by equi-spaced X 

lines. 

X Slice Time or depth slice image created from X lines in a grid. 

X Y Axes X and Y are the names given to the two orthogonal directions of a grid. When 

positioned at the specific corner of the grid which is selected to be the origin of 

the coordinate system and facing diagonally across the grid, the positive X 

direction runs to the right along the edge of the grid and the positive Y direction 

runs off to the left. 

X Y Slice Time or depth slice image created from combining both X and Y lines in a grid. 

Y Line A line oriented in the Y direction. (X = constant while Y position varies). 

Y Line Spacing Refers to the spacing between Y lines when a grid is covered by equi-spaced Y 

lines. 

Y Slice Time or depth slice image created from Y lines in a grid. 

 


