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Sensors & Software Inc. Product License, Copyright, Liability and 
Warranty Information 

Important 

Please read this document carefully before using the SOFTWARE PRODUCT or assembling the HARDWARE 

PRODUCT. By using the storage media or assembling the hardware, you are agreeing to be bound by the 
terms of this agreement. If you do not agree to the terms of this agreement, promptly contact Sensors & 
Software, Inc. at the address indicated at the end of this document. 

Definition 

The word PRODUCT as used herein defines any item sold by Sensors & Software, Inc. and may be 
comprised of HARDWARE PRODUCT which consists of physical objects and SOFTWARE PRODUCT which 
means computer programs, codes and related support materials. 

Software Product License Agreement 

In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. does not 
sell any rights to its Software products. Rather, Sensors & Software, Inc. I grant the right to use its 
software, CDs, memory sticks (or other storage media) and documentation (hereafter collectively called 
SOFTWARE PRODUCT) by means of a SOFTWARE PRODUCT license.  You acknowledge and agree that 
Sensors & Software, Inc. retains worldwide title and rights to all its software and that the SOFTWARE 

PRODUCT contains proprietary materials protected under copyright, trademark and trade secret laws. 

Grant of Software Product License 

In consideration of payment of the license fee which is the price you pay for the SOFTWARE PRODUCT and 
your agreement to abide by the terms and conditions of this License Agreement, Sensors & Software, Inc. 
grants to you, the Licensee, a non-exclusive right to use the SOFTWARE PRODUCT under the following 
conditions: 

You may: 

• use the SOFTWARE PRODUCT on a single workstation owned, leased or otherwise controlled by you; 

• copy the SOFTWARE PRODUCT for backup purposes in support of your use of the product on a single 
workstation. 

You may not: 

• copy, distribute or sell copies of the SOFTWARE PRODUCT or accompanying written materials, 
including modified or merged SOFTWARE PRODUCT to others; 

• sell, license, sublicense, assign or otherwise transfer this license to anyone without the prior written 
consent of Sensors & Software, Inc.; 

• modify, adapt, translate, decompile, disassemble, reverse engineer or create derivative works 
based on the SOFTWARE PRODUCT. 

Termination 

This license is effective until terminated. You may terminate the license at any time by returning the 
SOFTWARE PRODUCT and all copies to Sensors & Software, Inc.  The license will automatically terminate 
without notice by Sensors & Software, Inc. if you fail to comply with any terms or conditions of this 
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agreement.  Upon termination, you agree to return all copies of the SOFTWARE PRODUCT to Sensors & 
Software, Inc. 

Update Policy 

Sensors & Software, Inc. may create, from time to time, updated versions of its SOFTWARE PRODUCT.  At 
its option, Sensors & Software, Inc. will make such updates available to licensees who have paid the 
update fee. 

Product Warranty, Limited Remedy and Limited Liability  

Sensors & Software, Inc. warrants the PRODUCT to be free from defect in material and workmanship under 
normal use for a period of one year (365 days) from the date of shipment.  Any third-party computer 
systems or other items not manufactured directly by Sensors & Software, Inc. purchased with any  

PRODUCT or independently from Sensors & Software, Inc. are subject to the original manufacturer's 
warranty and are not the responsibility of Sensors & Software, Inc. 

Sensors & Software, Inc. makes no other warranties including, but not limited to, any implied warranty of 
merchantability or fitness for a particular purpose.  If the PRODUCT is defective within the warranty period 
stated above, your exclusive remedy shall be, at Sensors & Software, Inc.’s option to replace or repair the 
Sensors & Software, Inc. PRODUCT or refund the purchase price of the Sensors & Software, Inc. 
product.  Except where prohibited by law, Sensors & Software, Inc. will not be liable for any loss or 
damage arising from this Sensors & Software, Inc. product, whether direct, indirect, special, incidental or 
consequential regardless of the legal theory asserted. 

All statements, technical information, and recommendations related to any Sensors & Software, Inc. 
PRODUCT are based on information believed to be reliable, but the accuracy or completeness is not 
guaranteed.  Before using any PRODUCT, you must evaluate it and determine if it is suitable for your 
intended application.  You assume all risks and liability associated with such use.  Any statements related 
to the PRODUCT, which are not contained in Sensors & Software, Inc. current publications, or any 
contrary statements contained on your purchase order shall have no force or effect unless expressly 
agreed upon, in writing, by an authorized officer of Sensors & Software, Inc. 

Sensors & Software, Inc. warrants the CD, memory stick or other storage media on which the SOFTWARE 
PRODUCT is furnished to be free from defects in material and workmanship under normal use for a period 
of ninety (90) days from the date of purchase as evidenced by a copy of your invoice. 

Except as specified above, any SOFTWARE PRODUCT is provided "as is" without warranty of any kind, either 
expressed or implied, including, but not limited to, the use or result of use of the product in terms of 
correctness, accuracy, reliability, currentness or otherwise. The entire risk as to the results and 
performance of the PRODUCT is assumed by you. If the PRODUCT is defective or used improperly, you, and 
not Sensors & Software, Inc. or its dealers, distributors, agents, or employees, assume the entire cost of 
all necessary servicing, repair or correction. 

Sensors & Software, Inc.'s entire liability and your exclusive remedy for SOFTWARE PRODUCT shall be, at 
Sensors & Software, Inc.'s option, either: 

• the replacement of any storage media (CD, memory stick etc.) or hardware components which do 
not meet Sensors & Software, Inc.'s Limited Warranty and which are returned to Sensors & 
Software, Inc. postage prepaid with a copy of the receipt, or 

• if Sensors & Software, Inc. is unable to deliver a replacement storage media which is free of 
defects in material or workmanship, Licensee may terminate this agreement and have the license 
fee refunded by returning all copies of the SOFTWARE PRODUCT postage prepaid with a copy of the 
receipt. 
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If failure of any PRODUCT resulted from accident, abuse or misapplication, Sensors & Software, Inc. shall 
have no responsibility to replace the SOFTWARE PRODUCT, refund the license fee, or replace or repair the 
HARDWARE PRODUCT. 

Do not tamper with any PRODUCT.  PRODUCT contains no user serviceable parts.  If tampering is 
evident in Sensors & Software, Inc.’s opinion, warranty is void and null. 

No oral or written information or advice given by Sensors & Software, Inc., its dealers, 
distributors, agents or employees shall create a warranty or in any way increase the scope of this 
warranty and you may not rely on any such information or advice. 

Neither Sensors & Software, Inc. nor anyone else who has been involved in the creation, 
production or delivery of the PRODUCT shall be liable for any direct, indirect, special, exemplary, 
incidental or consequential damages, claims or actions including lost information, lost profits, or other 
damages arising out of the use or inability to use this PRODUCT even if Sensors & Software, Inc. has been 
advised of the possibility of such damages. 

This warranty gives you specific rights.  You may have other rights which vary from province to province, 
territory to territory and certain limitations contained in this limited warranty may not apply to you. 

General 

No right, license, or interest to any Sensors & Software, Inc. trademarks is granted hereunder with the 
purchase of the PRODUCT or the SOFTWARE PRODUCT license. 

Governing Law 

In the event of any conflict between any provision in this license agreement and limited warranty and any 
applicable provincial legislation, the applicable provincial legislation takes precedence over the 
contravening provision.  This agreement shall be governed and construed in accordance with the laws of 
the Province of Ontario, Canada. 

Serviceability 

Should any term of this agreement be declared void or not enforceable by any court of competent 
jurisdiction, the remaining terms shall remain in full effect. 

Waiver 

Failure of either party to enforce any of its rights in this agreement or take action against any other party 
in the event of a breach of this agreement shall not be considered a waiver of the right to subsequent 
enforcement of its rights or actions in the event of subsequent breaches by the other party. 

Acknowledgement 

You acknowledge that you have read this agreement, understand it and agree to be bound by its terms 
and conditions. You further agree that this agreement is the complete and exclusive statement of 
agreement between the parties and supersedes all proposals or prior agreements oral or written between 
the parties relating to the subject matter of this agreement. 

Should you have any questions concerning this agreement, please contact in writing: 
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Sensors & Software Inc. 

1040 Stacey Court 

Mississauga, Ontario 

Canada L4W 2X8 

Tel:(905) 624-8909 

Toll Free: 1-800-267-6013 

Fax:(905) 624-9365 

E-mail: customerservice@sensoft.ca 

Sensors & Software, Inc. trademarks are listed at: www.sensoft.ca/trademarks 

1999-00236-05 
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This product uses libkml, a google Inc. software library which is subject to the following conditions of use. 

Copyright 2008, Google Inc. All rights reserved.  

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer.  

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the 
following disclaimer in the documentation and/or other materials provided with the distribution.  

3. Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote 
products derived from this software without specific prior written permission.  

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO 
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER 
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING 
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGE.  
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1 Introduction 
EKKO_Project was designed to simplify the display, editing, processing, and 
interpretation of Ground Penetrating Radar (GPR) data.  

EKKO_Project increases productivity by giving you more time to view and interpret data 
and less time spent organizing it. 

Use EKKO_Project to display project (.gpz) files (compressed files containing GPR 
linesets and grid data) intuitively in the Project Explorer window. The Properties tabs 
display GPR line details such as acquisition parameters and attached files.   

The Line Preview window automatically displays the first line in the project with the view 
settings from the data acquisition software or default view settings.  The user can display 
other lines by clicking on the line name in Project Explorer or using the arrow keys. 

The MapView window displays the position of grids in the project space coordinate 
system.  If GPR data was collected with GPS or, if the relationship between the project 
coordinate system and the global coordinate system (Latitude-Longitude or UTM) is 
defined by the user, grids and the GPS path of GPR lines are displayed in MapView. 

Depth slices processed in the field using the data acquisition software or using the 
optional SliceView module (see below) are also displayed in the MapView window.  

The optional LineView module allows you to display one or more GPR lines and modify 
the view settings to use different color palettes, gains, fonts, axes, etc.  See the 
LineView Module User’s Guide for more details. 

The optional Interpretation module in LineView is used to create interpretations of 
Points, Polylines, Boxes, and Annotations, view them in GPR lines, and then output your 
interpretations as Reports. Interpretations are also displayed in MapView.  See the 
LineView Module User’s Guide for more details. 

The optional SliceView module allows GPR data with 2-dimensional positioning, such as 
GPS or XY, to be processed and display as a series of depth slices. SliceView-Grid is 
used to process grid data into depth slices while SliceView-Line processes or one or 
more GPR lines into depth slices.  Depth slices enhance interpretations at complex sites 
by providing a powerful way of visualizing the spatial relationships between targets seen 
in multiple GPR lines.  SliceView also allows grid data to be exported in a 3D format.  
See the SliceView manual for more details. 

The optional Processing module allows you to edit and process data, including cropping 
data, time filters, migration and gain. You can then save processing streams as Recipes 
that you can apply to other GPR projects. See the Processing Module User’s Guide for 
more details. 

The optional Bridge Deck Condition Report module allows you to process point 
interpretations on the rebar in a bridge deck or other concrete structure and output a 
PDF report with an amplitude map image and statistics about the rebar in the structure. 

The optional Pavement Structure Report module allows you to process polyline 
interpretations on subsurface layers and output a PDF report with cross-sections of and 
statistics about of the layers. 
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2 Getting Started 
EKKO_Project works with GPR project files called GPZ files. Each project file contains 
one or more GPR line data files and may contain information from other related files 
such as GPS files that were saved as the GPR data was collected.  

New generation Sensors & Software GPR devices automatically create Project files 
however, GPR data collected using older Sensors & Software GPR systems can easily 
be added to a new EKKO_Project project file following the Creating a New Project 
procedure. 

2.1 Project (GPZ) File Size Limits 

Project (GPZ) files are limited to a maximum size of 2 GB.  This includes the GPR data 
plus all the attachments (see Attachments Tab).  If you try to save a project file and get 
an error message that the project file is too large to save, consider deleting large 
attachments. 

2.2 Opening a Project 

When you open EKKO_Project, the Getting Started dialog box automatically opens to 
help you open or create a new project based on the data file format you select.  

 

Figure 1: The Getting Started dialog box 
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 Open a Recent EKKO_Project File 

1. In the Getting Started dialog box Open Existing Project pane, click the Recent 
Projects drop-down list. 
 

2. In the drop-down list, click the project file you want to open. 
 

 
 
 

 Open an Existing EKKO_Project File 

1. In the Getting Started dialog box Open Existing Project pane, click 

 
 

2. In the Open dialog, navigate to the folder and select the project file you want to work 
in.  

 

Figure 2: Open Dialog 

Only files with a .gpz extension are listed.  

3. Select the project you want to work with and then click Open. 

The project contents are displayed in the Project Explorer and, if positioning 
information is available, the GPR lines are displayed in MapView. 
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If the project file contains grids that don’t have a global position reference such as 
GPS, a message appears: 
 

 
 

Answering Yes will tile the grids so they are not all plotted at the origin of the project 
coordinate system in MapView. 
 
Grids can be manually repositioned using the Grid Position Relationship in the Tools 
menu.  

2.3 Creating a New Project 

To create a new EKKO_Project file (typically for older GPR systems that do not 
automatically generate project (.gpz) files), in the Create a New Project pane, select 
one of the following options: 

•   
•  
•  

A project file can contain multiple grids and line sets. 

 Adding a Grid 

1. In the Getting Started dialog box Create a New Project pane, click . 
2. In the Open dialog box, navigate to and then select a grid (.gfp) file.  

Only files with a .gfp extension are listed. For more details about GFP files, see Add 
Grid. 

3. Click Open. 
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The grid is displayed in the Project Explorer and indicated with the small green grid 
on the folder. 
 
 

 
 

 Adding all Lines in Folder 

1. In the Getting Started dialog box Create a New Project pane, click
.  

2. In the Select folder to import lines from dialog box, navigate to and then select a 
folder containing GPR lines. 

3. Click Select Folder. 

The new project folders will be displayed in the Project Explorer 

 Adding Line(s) 

1. Click . 

2. In the Open dialog box, navigate to and then select one or more GPR (.hd) Lines.  

Only GPR files with an .hd extension are listed. 

Note: although only .hd files are listed and selected, the folder must also contain the 
associated .dt1 file(s). 

3. Click Open. The Line(s) are displayed in the Project Explorer  
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3 EKKO_Project Interface Overview 
When a project file is open, EKKO_Project is populated with information about the GPR 
data in the Project file.  

 

 

Figure 3: The EKKO_Project interface  

The main EKKO_Project window consists of a Menu Bar, Toolbars, Project Explorer, 
Line Preview, MapView, Layer View, Status Bar and Properties tabs.  

All windows can be moved, resized, and modified. The tabs that make up the Properties 
window can be separated into individual windows (to learn more, see Window 
Operations). 

When a project file containing grid data is opened, the 3D Preview window is available to 
display the grid data in a 3D format with one depth slice and two GPR cross-sections 
(lines) visible at the same time.   

Menu Bar 

MapView 

Toolbars 

Project Explorer 

Properties Tabs 

Line Preview  

Layer View 

Status Bar 
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Figure 4: The EKKO_Project interface showing the 3D Preview window for grid data; in this example, a 
Conquest grid scan data. 

The GPR lines are oriented parallel to the cross-hair lines on the depth slice. 

For the details of the 3D Preview window, see 3D Preview. 

3.1 Active Window 

EKKO_Project typically displays several windows at a time including Line Preview, 
MapView and 3D Preview. Only one window can be active and accept changes at a 
time. The active window is the one that was last selected by clicking in it with the mouse 
cursor and is usually identified by its darker title banner.  

To make changes in a particular window, first ensure it is the active window. 

Trying to edit a window makes it the active window, for example, selecting a GPR line in 
the Project Explorer by clicking on it makes the Line Preview window the active window. 

3D Preview 
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4 Project Explorer 
Project, folders, and files are displayed in the Project Explorer which is similar to 
Windows Explorer. In Project Explorer, grids and linesets are used just like folders in 
Windows, and GPR lines are similar to files. 

To display all GPR Lines associated with a project folder, click the plus sign (+) beside 
the grid or lineset name  

 

Figure 5: Project Explorer pane displaying open data folders listing the GPR lines. 

The names of all the GPR data files in the grid and/or linesets are listed. The line icon (
) indicates which files are GPR lines. If other files associated with the line (photos, 

videos, field notes, etc.) have been attached, the line icon displays a paperclip icon 

 (to learn more, see Attach a File). 

Project Explorer 

Toolbar 

Lineset name 

Selected GPR line GPR Line icon 

Attachment icon 

t = topography data added 
i = Interpretations added 

g = collected with GPS  

p = processed 

Grid Name 

Pin window to frame 
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4.1 Data Collections Linesets vs. Grids 

Data collections in EKKO_Project are composed of either linesets or grids.  

Grids are, by definition, a complete collection of GPR lines related to one another 
spatially and run orthogonally (right angles) to one another; they cannot run at angles 
other than right angles.   

To edit a grid by adding, deleting, moving, or changing the direction of lines, use the 
Tools > Grid Tools > Grid Tools or by right-clicking on the grid name in Project Explorer 
and selecting Edit Selected Grid from the menu.  However, individual GPR lines in a grid 
can be copied from a grid and added to a lineset. 

Linesets are collections of GPR lines that may or may not relate to one another 
spatially. Linesets can be edited to add or delete GPR lines using the Right Click menu. 
GPR lines in linesets can also be cut and/or copied and pasted into other linesets.   

4.2 Selecting vs. Checking GPR Lines 

GPR lines, linesets, grids, and projects can be selected in two different ways: 

 Clicking the Item Name  

To select the name of a GPR line, lineset, grid, or project, click the item name.  

Once an item is selected, it is highlighted blue and you can only apply Right Click menu 
operations to the item. 

 

If the GPR line is displayed in MapView, it turns red to indicate it has been selected.  For 
example, if a single GPR line collected with GPS is selected, the GPS path in MapView 
turns red.  If a grid is selected, all the grid lines turn red. 

When a GPR line is selected in Project Explorer, it is displayed in the Line Preview 
window. 

 

  

Selected Line 
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 Clicking the Item Checkbox 

To access copy, cut, paste, delete, and process operations from the Standard Toolbar or 
the Edit Menu, click the checkbox beside the GPR Line, lineset, grid, or project name.   

Note: When a GPR Line is checked, the GPR collection (lineset or grid) and the 
project name are also checked. This feature enables you to identify when GPR Lines 
in the collection are checked even if the GPR collection is collapsed (click the minus 
sign [-]). 

 

4.3 Associated Data Files 

An icon is displayed next to the line name in Project Explorer to indicate whether any of 
the following file types are attached to the GPR line: 

 GPS 

If a GPS is connected to the GPR system during data collection, GPS files with the same 
name as the GPR line are saved to the Project file and/or data folder.  When the GPR 
data is opened in EKKO_Project, GPS positions are automatically integrated with the 
GPR lines.  This is indicated by the letter “g,” see the example in the Project Explorer.  

GPS integration means Latitude-Longitude and UTM coordinates are displayed on the 
Status Bar when viewing the GPR line in LineView and listed in Reports.   

The name of the GPS file is listed under the Attachments tab.  

 Topography 

When a topography (.top) file with elevation information is attached to a GPR line, it is 
indicated by the letter “t,” see the example in the Project Explorer. 

Integrating topography information means that the GPR line can be plotted with an 
elevation axis in LineView, rather than the default depth axis.  Elevations of 
interpretations and fiducial markers are also listed in Reports. 

The topography file name is listed in the Attachments tab.  

Topography files with the same name and in the same folder as the GPR line are 
automatically attached.  Topography files with a different name can be manually 
attached; see the Attachments tab.   

GPS files also contain elevation information; see GPS Files for more information about 
GPS elevations and how EKKO_Project decides whether to use Topography file or GPS 
file elevations.  

 Interpretations 

Interpretations added to the file using the optional Interpretation module in LineView are 
identified by the letter “i,” see the example in the Project Explorer. Interpretations are 
points of interest (points, polylines, boxes, and annotations) added to GPR lines. This is 
similar to adding a flag/fiducial during data collection. 

file:///C:/My%20Documents/Manuals/EKKO_Project%20V3%20R2-2011-00125-06/Source/Text/EKKO_Project%20manual.docx
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 Processing 

GPR data that has been processed using the optional Processing module is identified by 
the letter “p,” see the example in the Project Explorer.  See the Processing Module 
User’s Guide for more details. 
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5 Project Explorer Toolbar 
The Project Explorer toolbar displays four icons representing features that enable you to 
add GPR lines to the current project: 

 

5.1 Add a New Lineset 

1. To add a new lineset folder to the current project file, in the menu bar click .  

A  folder opens in the Project Explorer.  

2. To rename the new lineset, right-click New Lineset. 
3. In the drop-down list, click Rename.  

5.2 Add a Grid 

1. To add a grid (.gfp) file to the current project, in the menu bar click . 
2. In the Open dialog box, navigate to the folder and click the grid file you want to open.  

Only files with a .gfp extension are listed. 

3. Click Open. 

The new grid is displayed in the Project Explorer: 

 

5.3 Add Lines to Lineset 

1. To add lines to the selected lineset, in the menu bar, click . 
2. In the Open File dialog box, navigate the file folder and then select one or more 

GPR (.hd) Lines.  

The GPR lines are added to the current Lineset. If the highlighted item is not 
contained in a lineset, a new lineset will be created in the project.   

Note: GPR lines cannot be added to a grid. 
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3. Click Open. 

The lines are displayed in the Project Explorer: 

 

5.4 Attach a File 

The Attach File feature enables you to attach any file to the selected GPR line, lineset, 
grid, or project.  

Note: any item with the same name as the line is automatically attached when the 
line is added to the project (for example, a picture of the site could be renamed as 
LineX0.jpg so it is automatically attached to the project when the LineX0 data is 
added). 

1. To add an attachment to a file, in the menu bar click Attach File . 
2. In the Open File dialog box, navigate to the folder and then select the file you want 

to attach.  
3. Click Open. 

The files are displayed in the Attachments pane: 

 

Note: if you attach multiple topography (.top) or GPS (.gps or .gp2) files, the last file 
attached is the one that is used. 

5.5 LineView Module (Optional) 

Double-clicking on a GPR Line name in Project Explorer displays it in the optional 
LineView module.  For more details, see LineView or the LineView module User’s Guide. 

5.6 SliceView Module (Optional)  

The SliceView module processes grids or lines into a series of depth slices.   

SliceView-Grid processes a grid into depth slices.   

SliceView-Lines processes one or more lines with 2D positioning (such as GPS or 
project XY) into depth slices. 

 SliceView-Grid 

Use one of the following methods to process a grid in SliceView-Grid: 

1) Double-click on a GPR grid name in Project Explorer.   
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2) Select or check the grid name in Project Explorer and then select Tools > 
SliceView-Grid. 

3) Select or check the grid name in Project Explorer and then click the SliceView 

button  on the toolbar. 

4) Select or check the grid name in Project Explorer and then click the dropdown 
button beside the SliceView button on the toolbar and select SliceView-Grid. 

 

5) Right click on the grid name in Project Explorer and select SliceView from the 
sub-menu. 

 SliceView-Lines 

Use one of the following methods to process a single GPR line in SliceView-Lines: 

1) Select or check the line(s) in Project Explorer and then select Tools > SliceView-
Lines. 

2) Select or check the line(s) in Project Explorer and then click the SliceView button 
on the toolbar and select SliceView-Lines from the dropdown. 

For more details, see SliceView or the SliceView module User’s Guide. 

5.7 Right Click Menu 

When you right-click in Project Explorer, a context-sensitive menu opens.  Menu items 
vary depending on whether the project name, a grid, lineset, or GPR line was right-
clicked on. 

Menu items in the right-click menu only operate on the item that was selected. The 
checked items in the Project Explorer are ignored. 



EKKO_Project User’s Guide Project Explorer Toolbar 

 

 
16 

 

Use the following table as a guide to working with the Project Explorer Right Click menu 
features: 

Menu Option Description 

LineView  Click LineView to open and display project GPR lines in the optional 

LineView module. 

To learn more, see the LineView User’s Guide. 

The LineView button is only visible if the LineView module was 

purchased. 

SliceView-Grid Click SliceView-Grid to process and display the grid as a series of depth 

slices in the optional SliceView module. 

To learn more, see the SliceView User’s Guide. 

The SliceView button is only visible if the SliceView module was 

purchased. 

SliceView-Lines Click SliceView-Lines to process and display the checked lines with 2D 

positioning as a series of depth slices in the optional SliceView module. 

To learn more, see the SliceView User’s Guide. 

The SliceView button is only visible if the SliceView module was 

purchased. 

3D Preview  With a Conquest grid selected in the Project Explorer, click  to open 

and display the grid as a depth slice flanked with an X and Y line.  To 

learn more, see 3D Preview. 

 

Rename Change the name of the project, grid, lineset, or GPR line in a lineset. 

Note: A GPR line name in a grid cannot be renamed. 

Edit Selected Grid  Edit the selected grid. See Edit Selected Grid. 
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Menu Option Description 

Create Grid from 

Checked Lines 

Create a new grid using the checked lines in Project Explorer. See 

Create Grid from Checked Lines. 

Attach File To attach any file to the currently selected GPR data line, lineset, grid, 

or project, click   Attach File.  

The file is then displayed in the Attachments tab. 

Zoom To Zoom to the currently selected GPR line or grid in MapView.  The GPR 

line or grid must be plotted in MapView so only grid lines or lines with 

GPS are eligible or this option is greyed out and not accessible. 

Grid Position 

Relationship 

If a grid is selected, the grid-to-project position relationship is edited 

(see Grid Wizard) – useful for moving a grid in the project XY coordinate 

system.   

Line Positioning If a line is selected, the line-to-project position relationship is edited (see 

Line Positioning) – useful for defining or placing a line in the Project, 

Latitude/Longitude or UTM coordinate system.  

Note: the position of individual grid lines cannot be edited with this 

option; the options are greyed out and not accessible. The positions of 

grid lines are edited using the Edit Selected Grid tool. 

Process 
To open the Processing dialog box, click  Process.  

This feature enables you to edit and process selected GPR line using 

repositioning, temporal and spatial filters, and migration features.  

See the Processing module User’s Guide for more details. 

Undo Process To reset the selected GPR line to its original format before processing 

was applied, click  For more details, see the Processing module. 

Undo Process.  

Copied GPR lines are reset to the any processing they had at the point 

they were copied.   

When processing is undone to an item, the small letter “p” beside the file 

name indicating that it was a processed file disappears.   

See the Processing module User’s Guide for more details. 

Average Trace 

Amplitude (ATA) 

Plot 

Average Trace Amplitude (ATA) plots display the average signal 
amplitudes (in millivolts) for the selected GPR line.  

ATA plots display how quickly signal amplitude decays from the peak 
value of the transmit pulse to the background noise level, providing an 
indication of the maximum penetration in the survey area. See Average 
Trace Amplitude. 

Average Frequency 

Spectrum (AFS) 

Plot  

Average Frequency Spectrum (AFS) plots the average frequency 
spectrum of the selected GPR line.  

Select AFS to determine the frequency content and bandwidth of the 
GPR line to decide if filtering is required. See Average Frequency 
Spectrum. 
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Menu Option Description 

Trace Plot Trace Plot is used to display individual traces from the selected GPR 
line; this allows the user to check the first break is correct, see subtle 
signals on traces or view the effect of different editing and processing 
types on individual traces. See Trace Plot. 

Cut 
Use the  Cut feature to remove the selected GPR line, lineset or grid 

from the project. 

This enables you to remove a GPR line from a lineset and paste it into a 

different lineset. 

Note: a GPR line cannot be cut from a grid. 

Copy 
Use the  Copy feature to: 

• Copy the selected GPR line so it can be pasted into the same or a 
different lineset in the project  

• Copy the selected lineset or grid so it can be pasted back into the 
project 

Note: You can copy GPR lines from a grid and paste then into a lineset, 

but you cannot be paste them into a grid. 

Paste 
Use the  Paste feature to: 

• Paste a copied or cut GPR line into the same or a different lineset 
in the project  

• Paste a copied or cut lineset or grid back into the project 

Note: You can copy GPR lines from a grid and paste them into a lineset, 

but you cannot paste them into a grid. 

Delete To Delete the selected grid or lineset from a project, click   Delete. 

You can also delete a GPR line from the Lineset in the project. 

Note: GPR lines cannot be deleted from a grid.  . 
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6 Line Preview 
The Line Preview window displays the GPR line currently selected in Project Explorer.  
When EKKO_Project first opens, Line Preview automatically displays the first GPR line 
listed in the project. 
 

 
 
If the GPR line is a Conquest line that includes PCD data, the PCD response is plotted 
as a red graph under the line image.  The maximum value of the PCD scale is displayed 
in the Line Preview Legend. 
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The user can change the Line Preview display to another GPR line in the project by: 
 

1) Clicking on another line name in Project Explorer, or 
 

2) After clicking in the Project Explorer window to make it the Active Window, using 
the up and down arrow keys on the keyboard to move to a new GPR line name. 

 
Both options provide fast switching between lines to quickly review all the lines in a 
project.   
 
Any Flags or Field Interpretations added to the GPR line during data collection or 
interpretations added to the GPR line using the optional Interpretation module are visible 
in the Line Preview plot. Clicking on a multi-media flag (one with a media icon such as a 
photo, audio or video) opens the file attached to the flag. 
 

 
 
On the bottom of the GPR line is a simple legend listing the file path and line name, the 
velocity used to calculate the depth axis and the View Settings (gain and filter). 
 
After selecting the Line Preview window, use the zoom options to zoom in, out or to a 
user-specified zoom window using the buttons on the View Control Toolbar or the View 
> Zoom menu options.  
 
After zooming in, plot the whole GPR line to the Line Preview window by selecting the 
Fit to Window button on the View Control Toolbar or the View > Zoom menu option. 
 
GPR lines plotted in Line Preview use the View Settings (gain, color table, filter, etc.) 
from the GPR system’s data logger (DVL or Display Unit).  If these settings are not 
available, default settings that include Auto gain, the “Bone” color palette and no 
background subtraction filter applied. 

Multi-media flag 
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The View Settings can be changed by plotting the GPR line(s) in the optional LineView 
module and changing the View Settings there.  After exiting LineView, the Line Preview 
settings for that GPR line are updated.   
 
Use Measure to measure distances between objects on a GPR images displayed in 
LineView.  The Measure tool includes the vertical component of the distance so be 
careful of the vertical exaggeration that is often a part of GPR data displays. 
 
If LineView module is not enabled, change the View Settings for the GPR line on the 
system’s data logger (DVL or Display Unit) and transfer the data, along with the new 
View Settings, to the PC and open the updated project file in EKKO_Project. 
 
Line Preview will not plot GPR traces in wiggle mode and GPR lines cannot be plotted 
with an elevation axis with the traces shifted for topography – these advanced display 
options are available in the LineView module. 
 
If the Line Preview window is closed, open it by selecting Window > Open Line 
Preview. 
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7 MapView 
The MapView window shows a plan map image of GPR lines and grids.  It also displays 
flags/fiducials, field interpretations, interpretations and depth slices added to the GPR 
data in the field or by using EKKO_Project.  The Layer View window controls which 
items are visible in MapView. 

 

 

 

 

Figure 6: MapView Window New image  
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If the GPR project does not contain any grids and none of the GPR lines were collected 
with GPS or positioned using Line Positioning, then the MapView window will not be 
open as there is nothing to plot. 

When one or more GPR lines are selected in the Project Explorer, they appear in red in 
MapView. If the file has an associated GPS file, the GPS path also appears in red. 

Flags always appear as a flag icon with text nearby.  Flags that have had a photo, audio 
or video file attached to them, called multi-media flags, appear with an appropriate icon 
with text nearby.  Clicking on the icon opens the attached file. 

 

Figure 7: Clicking on a multi-media flag in MapView, opens the file attached to the flag. 

 

Interpretations appear in the color and shape they were defined with. 

Depth slices can be plotted in MapView.  For more information, see below. 

7.1 Project (XY) Coordinates 

MapView displays GPR data in project (XY) coordinates.  The horizontal axis is the 
project X position, and the vertical axis is the Project Y position.  The units are either 
meters or feet, determined by the selected Units. 

GPR lines are displayed in MapView as black lines with arrows.  Lines collected as part 
of a grid are automatically displayed in MapView.  Individual GPR lines are displayed in 
MapView if they have project (XY) positioning added to them (see Line Positioning). 

Move the mouse cursor over the MapView image to display the project (XY) coordinates 
the Status Bar along the bottom of the EKKO_Project screen. 
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7.2 Global Coordinates 

To show GPR data in global coordinates, such as Latitude-Longitude or UTM, the 
relationship between the project (XY) and global coordinates must be defined.  If GPR 
data were collected with GPS, this relationship is automatically defined. 

If a grid was collected with GPS, the grid lines are displayed as black arrowed lines and 
the GPS paths are displayed as dark green lines (see Figure 6). Due to the variable 
accuracy of GPS units, the GPS lines will not typically correspond exactly with the GPR 
grid lines.  MapView calculates the best fit of the grid to the GPS to position the grid and 
establish the project – global relationship.   

To manually define the Project to Global relationship, use the Tools > Project Position 
Relationship > Wizard (see Wizard). 

Once the Project to Global relationship has been defined, move the mouse cursor over 
the MapView image to display the Latitude-Longitude and UTM coordinates in the Status 
Bar along the bottom of the EKKO_Project screen. 

A compass icon  pointing to geographic North is displayed if the World-Project 
relationship is defined. This relationship is calculated automatically if the GPR data were 
collected with GPS.  If this relationship is not defined, the Status Bar displays “GPS 
relationship not defined”. 

Global coordinates are also used in output reports (see Project Report (CSV)). 

If the GPS and grid lines are out by 45 degrees it may indicate a problem with the grid 
definition of “X” and “Y” lines when the grid was collected in the field.  To correct, see 
Editing Grid Line Orientation. 
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Use the following table as a guide to working with MapView: 

Item Description 

Cross-hair position As you move the cursor over an area in the Grid Map, the position of 

the mouse cross-hair is displayed in XY and global coordinates GPS (if 

present) at the bottom right of the screen. 

Flags/Fiducials Flags/Fiducials are markers added during data collection at specific 

trace positions along the line.   

Flags/Fiducials can be repositioned and the labels edited if the 

Interpretation module was purchased (see the LineView User’s Guide 

for more details). 

Interpretations Interpretations added to the file using the optional Interpretation module 

in LineView. 

Interpretations represent points of interest (points, polylines, boxes, 

and annotations) added to the line. To learn more, see Interpretations. . 

Field Interpretations Some GPR systems such as the LMX200 have the capability of adding 

point interpretations in the field.  These are just like the interpretations 

added with the Interpretation module and are displayed in MapView. 

Selected Line The line selected in the Project Explorer is highlighted red in the plan 

Map. The details of the selected line are displayed in the Properties 

Pane. 

Compass When the project-global position relationship is defined, a North arrow 

is displayed in MapView.  North is not necessarily vertically upwards; if 

a grid is opened, MapView displays it with the Y-axis pointing vertically, 

which may not be North so the North arrow will then point in another 

direction.  To rotate the MapView display so North is up, use the Reset 

to North function. 

7.3 Depth Slices in MapView 

Depth slice images can be plotted to MapView.  Depth slices are generated in two ways: 

1) Using the optional SliceView module or 

2) For some, generally more recent GPR systems, depth slices can be generated 
on the Display Unit or DVL during data collection out in the field.  For example, 
when using recent Noggin, LMX200 or Conquest systems, depth slices from grid 
data can be generated on the DVL.   
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Depth Slice generated and displayed on a Digital Video Logger.  These images are saved to the GPZ file 
when the data is copied to a USB-memory stick and available to display in EKKO_Project. 

Depth slices generated in the field are saved when the data is transferred from 
the DVL to the GPZ file on the USB-memory stick.  These depth slices are 
available to plot in MapView when the GPZ file is opened in EKKO_Project. 

The SliceView module can generate depth slices from: 

1. grid data (SliceView-Grid) 

2. GPR line data (SliceView-Lines) collected with GPS 

3. GPR line data (SliceView-Lines) that has XY positioning added each line in post-
processing using Line Positioning.   

4. GPR Lines made into a grid (Create Grid from Checked Lines). 

Depth slices are only displayed in MapView if they have been checked in the Layer 
View.  
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Depth Slice at 0.85 m generated from a grid and displayed in MapView. 

 

 

Depth Slice generated from one or more GPR lines and displayed in MapView. 

 

Slider bar 
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Use the depth slice slider bar on the top right of the MapView window, to scroll through 

the depth slices.  You can also use the mouse-wheel to smoothly scroll through the 

depth slices, after selecting the MapView window to make it the Active Window. 

The current slice depth is displayed next to the slider bar, the window title and the 

MapView legend in the top left corner. 

For multiple grids, slice through all of them simultaneously, even if: 

• they are at different angles to one another,  

• they were collected with different GPR systems with different center antenna 

frequencies,  

• they were collected with different depth slice processing (slice thickness, 

amplitude equalization gain, background subtraction filter, resolution, etc.).  

For example, if depth slices were processed using a different slice thickness value, the 

depth slices shown in MapView are the depth slices closest to the current depth value. 

 

 

7.4 Saving MapView Depth Slices as GIF 

Animation Files 

If the MapView window is the Active Window, select View > Export Animation to the 
depth slices to a GIF animation file.  The Export Animation dialog box allows the user to 
set the frame speed of the animation.  For more details, see Export Animation. 
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7.5 Displaying Multiple Grids with GPS 

Many GPR surveys are made up of multiple grids. EKKO_Project can display more than 
one grid to confirm targets within the grids. 

Multiple grids collected using GPS are automatically arranged within the MapView 
window.  

 

 

7.6 Repositioning Grids 

Multiple grids collected without GPS all have their X=0, Y=0 corner corresponding with 
the X=0, Y=0 of the Project coordinate system.  When a project file containing more than 
one grid without GPS is opened, the user is asked if they would like the grids arranged 
so they are spread out and do not overlap. 

Answering “No” will leave all the grids “stacked” at the X=0, Y=0 position (see figure 
below below).   
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Answering “Yes” automatically shifts the grids so there is a gap between each one.    In 
other words, the origin of all grids after the first grid is set to a value other than X=0, Y=0.   

Regardless of the position of a grid in MapView, it can move to a new position. To move 
a grid within the project coordinate system, select the grid in Project Explorer and then: 

1) right-click to open the menu and select Position Relationship > Wizard or, 

2) select Tools > Grid Position Relationship > Wizard 

and follow the directions (see Grid Position Wizard). 

For example, the image below shows grids after each one was repositioned within the 
Project coordinate system. 

 

7.7 Editing and Merging Multiple Grids 

Use the Tools > Grid Tools to create grids from lines, edit grids, add lines to a grid or 
merge two grids together to create one large grid.   

The key advantage of using the Grid Tools to merge multiple grids together is that then 
all grid data are processed together in SliceView, so filters such as Background 
Subtraction use all the data in their calculations. 

Merging grids in Grid Tools requires the grid lines for all grids to be parallel or orthogonal 
(90 degrees) to one another.  You cannot merge grids if grid lines are oriented at other 
angles, for example, 45 degrees. 

As well, all the grids being merged must have consistent settings such as antenna 
frequency, temporal sampling interval, antenna separation, etc.  If any key settings differ 
between grids, they cannot be merged.  In this case where there are differences, it is 
better to plot the grids separately as shown in the sections above. 

For more details, see Adding a Grid to a Grid. 
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7.8 Background Images 

A powerful way to visualize and present data is by adding a background image to 
MapView.   

 

 

For details, see Add Background Image to MapView. 



EKKO_Project User’s Guide Layer View 

 

 
33 

8 Layer View 
The Layer View window allows the user to specify which items to display in MapView 
and Line Preview windows.   

 
 

Checked items are displayed in MapView and Line Preview.  

The checked status of Line Slices, Grid Slices, Lines, GPS, Flags/Fiducials and 
Interpretations are used to determine which elements to include in the Google Earth 
Report KMZ file (Google Earth (KMZ)).   

 

Use the following table as a guide when working with the Layer View window: 
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Layer Description 

Background Image Display the background image in MapView.  It is possible to display 

more than one background image, so they can be stacked on top of 

one another or spread out to different areas of MapView.  Individual 

images can be turned off or on using the checkbox.  When multiple 

images are displayed, the first image loaded is on the bottom and later 

images are displayed above.  If the image has a percentage of 

transparency, images underneath it will be partially visible. 

Right-clicking on a background image item opens a sub-menu.  

 

Selecting Settings opens the Add Background Image dialog (Add 

Background Images to MapView) 

Selecting Edit puts handles on the image to resize or rotate it and 

selecting Delete deletes the background image. 
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Line Slices Plot depth slices generated with the SliceView module using the 

SliceView-Lines program.  It is possible to display more than one Line 

Slice at the same time. If Line Slices overlap, they are displayed in 

alphabetical order with ones that start with, say “z”, on top of ones that 

start with, say “a”. 

Right-clicking on a Line Slice item opens a sub-menu.   

 

Selecting Settings opens the SliceView-Lines dialog to allow the 

settings for that Line Slice to be modified and the depth slices 

regenerated. 

Selecting Rename opens a dialog to rename the Line Slice. 

Selecting Delete deletes the Line Slice image. 

Grid Slices Plot depth slices generated with the SliceView module.  Depth slices 

generated with the SliceView-Grid program or, for some GPR 

systems, in the field with the data acquisition program. For example, 

the Conquest, LMX200 and Noggin systems generate depth slices in 

the field. 

For Conquest users, the PDC image is always plotted on top of depth 

slices so ensure Grid Slices is not checked when viewing grid slices.  

It is possible to display more than one Grid Slice at the same time. If 

Grid Slices overlap, they are displayed in alphabetical order with ones 

that start with, say “z”, on top of ones that start with, say “a”.. 

PCD Slice Plot Power Cable Detector (PCD) image in MapView. Only available 

for grid data collected with a Conquest GPR system. 

The PCD image is always plotted on top of depth slices so ensure 

PCD Slice is not checked when viewing the grid slices. 

Lines Plot GPR grid lines and GPR lines with project (XY) positioning in the 

MapView window. Grid lines plot on top of depth slices so turning the 

grid lines off makes the depth slices more visible. 

GPS GPS paths for lines and grids collected with a GPS in the MapView 

window. 
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Flags/Fiducials Markers added to GPR lines in the field during data collection.   

When selected, Flags/Fiducials are displayed in both the Line Preview 

and MapView windows.   

Flags/Fiducials are indicated by a flag icon and a label such as F1, F2 

etc.   

If the flag had a media file attached to it, it appears as a multi-media 

flag (see Line Preview and MapView).   

Flags/Fiducials can be repositioned, and the labels edited if the 

optional Interpretation module was purchased (see the LineView 

User’s Guide for more details).  

Interpretations Display interpretations in MapView and Line Preview.  Interpretations 

are added to GPR lines while analyzing the data using the optional 

Interpretation module in LineView.  

Interpretations are points of interest (points, polylines, boxes, and 

annotations) added to GPR lines. 

GPR systems with the DVL 500 data logger, such as the LMX200, 

newer Noggins and pulseEKKOs have the capability of adding point 

interpretations in the field.  These are just like the interpretations 

added with the Interpretation module. 

Legend Display the Legend in the MapView window, defining the Flags and 

interpretations added to the data in the field or while analyzing the 

GPR data in EKKO_Project using the Interpretation module in 

LineView.  The legend also displays the current depth of depth slices.   

If the Legend is covering data, it can be moved by clicking and 

dragging it to a new location in the MapView window. 
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9 3D Preview for Grid Data 
The 3D Preview window shows a depth slice image from a grid on the upper left, a GPR 
X line on the bottom left and a GPR Y line on the upper right.   

1. To display a grid in 3D Preview check or select a grid in Project Explorer. 

 

2. Click Window > Open 3D Preview. 
3. 3D Preview can also be opened from the Project Explorer right click menu  
 
Here is an example of a 4x4 foot grid on concrete floor collected with a Conquest 
system.   
 

.  

 

Images of the 3D Preview window can be saved to the project and used in the GPR 
Summary Report or exported to the clipboard or an image file.  They can also be saved 
as a GIF animation files (Export Animation)  

 

Y GPR Line 

X GPR Line 
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Depth Slice 

Slider bar 
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PCD Response 

Depth Slice Cursor Lines 
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Here is an example of a 12x30-meter archaeological grid collected with a Noggin 250 
system. 

 

 

For help with interpreting concrete, utility and geological data displayed in 3D Preview 
see Interpreting Grids in 3D Preview. 

 

The 3D Preview window is only available if the grid data has been processed into depth 
slices.  The depth slice processing is typically done using the SliceView-Grid function in 
the SliceView module.  However, GPR systems with the DVL 500 data logger can 
process depth slices right on the display unit out in the field, specifically the Conquest 
100, LMX200, Noggin and pulseEKKO have this capability.  These depth slices are 
saved with the GPZ file when it is transferred from the display unit and copied to a 
computer. 

9.1 Depth Slices 

The depth slice image displayed is controlled by the vertical slider bar beside the 
window, mouse wheel or Page Up and Page Down keys, and is locked to the same 
slice displayed in the MapView window.   

The red Depth Slice Cursor Lines indicate the depth slice thickness and the depth range 
of data used to calculate the current depth slice. 

Clicking in the depth slice image moves the crosshairs to the nearest X and Y lines. 

The Depth Slice images can be modified with different gains and color palettes by: 

X GPR Line 

Y GPR Line 

Legend 

Depth 
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Hairs 

Depth Slice Cursor Lines 

Depth Slice 

Slider bar 
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1) Reprocessing the grid data in SliceView-Grids after changing the slice gain, data 
processing and/or the slice settings. 

2) Changing the settings and reprocessing the grid data on the Conquest 100, 
LMX200, Noggin or pulseEKKO Display Unit, exporting the new project file to a 
PC and opening it again in EKKO_Project, 

9.2 GPR Lines 

The GPR lines are displayed parallel to the crosshairs on the depth slice.  The Y line is 
rotated so it is parallel to the vertical crosshair. 

Change the current X line by pressing the Up Arrow and Down Arrow on the keyboard. 
Change the current Y line by pressing the Left Arrow and Right Arrow on the 
keyboard.  

As you move the cursor over the GPR Line images, the position and depth of the mouse 
crosshair is displayed at the bottom right of the screen. 

The GPR Line images can be modified with different gains, color palettes, depth, etc. by: 

1) Changing the Line settings in SliceView-Grids, saving the new settings and 
exiting. 

2) Changing the View Settings in the Conquest 100, LMX200, Noggin or 
pulseEKKO Display Unit, exporting the new project file to a PC and opening it 
again in EKKO_Project, 

9.3 PCD 

If displaying Conquest 100 data in 3D Preview, the PCD image replaces the current 
depth slice in 3D Preview by selecting it in the Layer View window: 
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9.4 Drill Locator 

The Drill Locator is displayed on the depth slice by selecting the Drill Locator button from 
the View > Drill Locator menu option or right-clicking on the 3D preview depth slice and 
selecting it from the menu.   

The Drill Locator is a set of movable crosshairs and a resizable circle displayed on the 
depth slice to determine the XY coordinates of a suitable location to drill.   

The diameter of the circle is set by the user with the View > Edit Drill Diameter menu 
option or by right-clicking on the 3D preview depth slice and selecting it from the sub-
menu:   

 

Enter a custom size of the drill diameter up to 36 inches or 1000mm. 

PCD 

Image 

PCD Response 
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9.5 Legend 

The Legend is in the lower right of the 3D Preview window.  It displays the depth of the 
displayed depth slice, the names of the displayed X and Y lines and drill locator XY 
position and diameter (if displayed). 

9.6 Saving GIF Animation 

If the 3D Preview window is the Active Window, select View > Export Animation to 
save it to a GIF animation file.  The Export Animation dialog box allows the user to select 
whether the depth, X lines or Y lines will animate while the other two are fixed on the 
currently selected image.  For more details, see Export Animation. 

9.7 Interpreting Grids in 3D Preview 

When interpreting data in 3D Preview it helps to remember that the images are 3 sides 
of a cube of data.  The conceptual grid image displays the relationship between depth 
slice images and X and Y GPR lines.  
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Use the following tips to help interpret grid data shown in 3D Preview for Grid Data: 

1) If the grid was collected with only lines in one direction, only one set of X or Y 
GPR lines will appear. 

2) The position of the Y line within the grid is indicated by the vertical cross-hair on 
the depth slice.  

3) The position of the X line within the grid is indicated by the horizontal cross-hair 
on the depth slice. 

4) The depth slice image shows an average of all the GPR signals between the two 
red depth slice cursor lines displayed in both the X GPR line and Y GPR line.  
Stronger colors usually indicate a stronger reflection and therefore, a higher 
contrast between the host material and the object. 

5) To change the depth slice to a shallower or deeper one, use the Depth Slice 
Slider bar on the right side of the window.  Notice how the Depth Slice Cursor 
Lines on the X and Y GPR lines move together. 

6) Use the Measure tool to measure the distance between objects in the depth slice 
or the GPR lines. 

 Concrete 3D Preview Example 

For the concrete grid shown in and below, the following observations can be made: 

1) The current depth slice shows a rebar or wire mesh at a depth of about 0.3 feet 
(using the depth scale on the X and Y Lines). 

2) The rebar is at a spacing of 6 inches (using Measure). 

3) A conduit with current flowing in it is visible in the depth slice, the X GPR Line 
and the PCD response. 
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 Utility 3D Preview Example 

For the utility grid shown in and below, the following observations can be made: 

1) The current depth slice shows two obvious utilities at a depth of about 0.5 meters 
(using the depth scale on the Y Line). 

2) The orientation of the utilities can be seen in the depth slice. 

3) Slicing through the depth slices shows other utilities at other depths and 
orientations. 
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10 Properties Tabs 
The Properties pane is a series of tabs that display information about the selected GPR 
line. The Properties pane can usually be found on the right side of the EKKO_Project 
screen; the tabs are displayed at the bottom of the pane. 

 

10.1 Acquisition Tab 

The Acquisition tab displays information about how the GPR line was acquired. It lists 
the survey parameters under four headings: General, Positioning, Advanced, and 
Additional Info. You may need to click the plus (+) sign to view the details under a 
heading.  
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To quickly open or close all the headings, click . 

 

 

 

Use the following tables to guide you through working with the Acquisition tab. 

The General pane displays the following basic survey parameters: 

Field Description 

Original Line Name The name of the GPR line when first opened in EKKO_Project. 

Comment Comment about the system used to acquire the data. 

Date Collected The date of data collection. 

Survey Type GPR survey type: reflection, CMP/WARR, or transillumination. 

Frequency (MHz) The antenna center frequency 

Time Window (ns) The length of the time window in nanoseconds (ns). 
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The Positioning pane displays the following parameters related to the positioning of the 
GPR line:  

Field Description 

Units Meters or feet 

Start Position The initial position of the GPR system along the line, generally will be 

zero, but could be different if an offset was used, or if the line was 

collected as part of a forward/reverse grid. 

End Position The ending position of the GPR system along the line 

Step Size The distance interval along the surface between GPR data traces 

Odometer Cal. The calibration value of the odometer wheel (if applicable) 

 

The Advanced pane displays the following advanced survey parameters:  

Field Description 

Number of Traces Total number of traces 

Points per Trace The number of sample points per trace 

Antenna Separation Spacing between transmitting and receiving antennas 

Stacking Type • DynaQ ON: indicates automatic stacking 

• P: number of point stacks 

• S: number of trace stacks 

• A: maximum number of stacks 

Stacks Number of repeated measurements averaged to get resulting 

measurements 

Time Sample Interval 

(ps) 

The time period in picoseconds at which the GPR signal is sampled. 

Often set automatically by the system based on GPR frequency. 

First Break Offset (ns) The number of nanoseconds from the start of the trace to the first 

break 

Transmitter Voltage The voltage of the transmitter 

Pulse Width (ns) The width of the GPR pulse in nanoseconds. Varies with antenna 

center frequency. 

GPS Latency (s) The GPS latency in seconds (only listed if a non-zero value applied) 

GPS X Offset X direction offset between GPR and GPS (only listed if non-zero value 

applied) 

GPS Y Offset Y direction offset between GPR and GPS (only listed if non-zero value 

applied) 

GPS Z Offset Z direction offset between GPR and GPS (only listed if non-zero value 

applied) 

The Additional Information pane may include the serial numbers of the GPR system 
and the Digital Video Logger (DVL), as well as any processing done prior to importing 
the data. 
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10.2 Attachments Tab 

The Attachment tab lists all files attached to the current GPR line, project, grid, or lineset 
such as GPS files, topography files, photos, documents, videos or voice recordings of 
information relevant to the GPR line. 

 

 

 

 

 Attachments Toolbar 

Use the following table as a guide to working with the Attachments pane toolbar:  

Item Description 

 

Click to display or hide the list of attached files. 

 

This feature enables you to attach a file to the GPR line. 

1 Click Attach File. 

2 In the Attach File(s) dialog box, navigate to and select the file 

you want to attach. 

3 Click Open. 

Toolbar 
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1 In the Attachments tab, select the item you want to delete. 

2 Click Delete File. 

3 In the message box, click Yes. 

Note: Positioning files (GPS, Topography) cannot be deleted. 

 

1 In the Attachments tab, select the item you want to open. 

2 Click Open.   

Note: if there is no application associated with the selected file 

type, Windows will prompt you to select one from a list. 

 

 Positioning Files  

GPS and Topography files are special files called “Positioning Files”; they are always 
listed first in the Attachments list.  When attached, either automatically or manually, they 
cannot be deleted, only replaced by another GPS or topography file. 

If another GPS or topography file is attached, the user is prompted whether or not to 
replace the current file.  If they answer “Yes”, the new file is added to the list and the old 
GPS or topography file is appended with the extension .BAK and kept as an attachment 
for record-keeping but is not used for positioning. 

GPS and topography files both contain elevation information, but the topography file 
takes precedence.  Therefore, if both a GPS and topography file are attached, the 
topography file elevations are used when plotting the data. 

The GPS and topography file names must always match the name of the GPR line. If a 
GPS or topography file with a different name is manually attached to a GPR line, the 
name is changed to match the name of the GPR line.  Further, these attached files will 
be automatically renamed when the GPR line name is changed. Other attachments do 
not follow this requirement. 

10.2.2.1 GPS Files 

Attaching a GPS file adds Latitude, Longitude, UTM coordinates, and GPS elevation to 
every trace in the GPR line.   

A GPS file is created by attaching a GPS system to the GPR system during data 
collection. GPS files contain lines of standard GPS positional output text (called NMEA 
strings) and the associated GPR trace number. When the GPS (or GP2) file is attached 
to a GPR line, latitude, longitude, and GPS elevations for every GPR trace are 
calculated and saved into the GPR line. 

Some later GPR systems also save GP2 files, which contain GPS data in a different 
format than the GPS file.   

Note: EKKO_Project automatically creates a GP2 file from an existing GPS file. 

GPS and GP2 files formats are defined in Appendix B – File Formats.  

When GPS information is available, GPR lines plotted in LineView display the GPS 
position of the current mouse cursor location on the Status Bar along the bottom of the 
screen.  
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When a GPS file is created with the same name as a GPR line in the project folder, the 
GPS file is automatically attached to the GPR line.  GPS files, even those with different 
names, can also be attached manually.  In this case the GPS file is copied, renamed to 
the same name as the GPR line and attached. 

A GPR line with integrated GPS is indicated by a small letter “g” beside the GPR line 
name in Project Explorer. 

10.2.2.2 GPS Elevations 

GPS data contains an elevation value that is integrated with the GPR line. However, be 
aware that if you are using a lower-end GPS system the elevation data may not be very 
accurate; plotting the GPR line with an elevation axis in LineView usually provides poor 
results with large vertical shifts in the data image. High-end GPS systems can provide 
accurate elevation values that work well when the GPR line is plotted with an elevation 
axis in LineView.  

10.2.2.3 Topography Files 

A topography file is a text file containing GPR line positions and the elevations at those 
positions. When a topography file is attached to a GPR line, elevations for every GPR 
trace are saved into the elevation field of the GPR trace header.  

When elevation information is available, GPR lines can be plotted in the LineView 
module with an elevation axis. This type of display can be invaluable for understanding 
the proper spatial positioning of GPR reflections. 

• Each line of text must contain a pair of numbers representing position and elevation. 

Topography file example: 

0.0 935.8 

10.1 933.9 

22.7 930.3 

30.5 932.7 

34.6 936.5 

The Topography file format is defined in Appendix B – File Formats. 

Note: Topographic files (.top) are stored in the same units that the data was collected 
in (meters or feet); however, the file could be viewed in a different unit. The units 
used during collection are displayed in the Acquisition tab Positioning Pane.  

1 
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When a topography (.top) file is available with the same name as a GPR line in the 
folder, it is automatically attached to the GPR line.  Topography files, even those with 
different names, can also be attached manually.  In this case the topography file is 
copied, renamed to the same name as the GPR line and attached. 

A GPR line with integrated topography is indicated by a small letter “t” beside the GPR 
line name in Project Explorer. 

If a topography file is attached after a GPS file is attached, the user is prompted to 
confirm whether or not they would like to replace the GPS elevations with the elevations 
from the topography file.  If the answer is “Yes”, the topography file is attached.  If the 
answer is “No”, the topography file is not attached.  In other words, if a Topography file 
has been attached, it is used for elevations.  
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10.3 Processing Tab 

If GPR lines have been processed using the optional Processing module, the processing 
details, including the name of the processes, the order the processes were applied, and 
the details of the process parameters are listed in the Processes tab. 

Only processed GPR lines are identified by a small letter “p” in the Project Explorer will 
list processing information in the Processes tab.  

To learn more, see the Processing Module User’s Guide. 

 

 

Note: Distance units (m/ft.) listed in the processes tab are always displayed in the 
format the GPR line was collected in, even if the Units have been changed in 
EKKO_Project. 
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11 Toolbars 
To manage how toolbars are displayed ion EKKO_Project, in the menu bar, click the 
View Menu. 

11.1 Standard Toolbar 

The EKKO_Project Standard toolbar displays icons or text that represents features that 
allow you to work with GPR data. 

 

Use the following table as guide to work with the Standard Toolbar: 

Toolbar Option Description 

New 

Click to create a New project. 

Open 

Click  to Open an existing project. 

Save 

Click  to Save the current project 

LineView 

Select an item(s) in Project Explorer and then click  to display the 

items in the optional LineView.module.   

The LineView button is only visible if a license for the LineView module was 

purchased.  

SliceView 

Select a grid or Line(s) in Project Explorer and then click  to 

display the grid as depth slices using the optional SliceView module.  

The SliceView button defaults to the SliceView-Grids.  To generate depth 

slices on GPR Lines, use the dropdown menu (small down arrow) on the 

side of the SliceView button:  

 

and select SliceView-Lines. 

3D Preview 

Select a grid in Project Explorer and then click  to display the grid 

as a depth slice flanked with an X and Y line in 3D Preview. 
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Toolbar Option Description 

PhotoSlicer 

Click the PhotoSlicer button  to open a photo and select the depth 

slices to superimpose onto the photo. See PhotoSlicer. 

Report Button to generate a report.  The Report button defaults to the GPR 

Summary Report but changes; remembering the last type of report 

selected.  To generate a different report than the one indicated by the 

button, use the dropdown menu (small down arrow) on the side of the 

button. 

 

The reporting options are:  

GPR Summary Report 

Google Earth (KMZ) 

Project Report (CSV) 

CAD (DXF) 

 

Bridge Deck Condition Report 

Pavement Structure Report. 

Process 

Click to open the Processing dialog box.   

The Process button is only visible if a license for the Processing module 

was purchased. See the Processing module User’s Guide for more details. 

Undo Process 

Click  to Undo Processing applied to the checked GPR lines. 

The Undo Process button is only visible if a license for the Processing 

module was purchased. See the Processing module User’s Guide for more 

details. 

Cut 

Click  to Cut the selected or checked item(s) and place them on the 

clipboard. 

This enables you to remove a GPR line from a lineset and paste it into a 

different lineset. 

Note: a GPR line cannot be cut from a grid. 
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Toolbar Option Description 

Copy 

Click  to Copy the selected or checked GPR line(s), lineset, or grid, 

and place them on the clipboard. 

Paste 

Click  to Paste the cut or copied GPR line(s), lineset, or grid from the 

clipboard into the project. 

Delete 

Click  to Delete the selected GPR line, lineset, or grid from the 

project. 

Add or Remove 

Buttons 
Click the drop-down arrow beside the Delete icon  to add or remove 

buttons from the Standard toolbar. 

To learn more, see Add or Remove Buttons. 

To display a brief description of the icon’s function, hold your mouse cursor over the icon 
on the toolbar. 

If a keyboard shortcut is associated with the toolbar item, it is displayed with the tool tip  

 

A description also appears on the Status Bar at the bottom of the screen: 

 

 

11.2 View Control Toolbar 

The EKKO_Project View Control toolbar allows you to manage how to display images 
in MapView and Line Preview.  

 

 

Use the following table as a guide to working with the View Control toolbar: 

Field Description  

Zoom Out 

Click  to display 1.5 times more of the MapView image. 

For Line Preview, Zoom out shows more horizontal data in the window.  

To learn more, see Zoom Out. 
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Field Description  

Zoom In 

Click  to magnify the MapView image by 1.5 times. 

For Line Preview, Zoom in shows less horizontal data in the window.  

To learn more, see Zoom In. 

Zoom Window 

Click  to magnify a selected area within MapView or Line 

Preview.  

To learn more, see Zoom Window. 

Fit to Window 

Click  to automatically zoom to fit all data in the MapView or Line 

Preview windows. 

To learn more, see Fit to Window. 

Pan View 

Click  to pan the Display area (drag and drop) in MapView. 

Not available for Line Preview. 

To learn more, see Pan View. 

Measure 

Click  to measure distance in the MapView, Line Preview and 

3D Preview windows. 

To learn more, see Measure. 

View(s) Buttons to Save, Copy or Export the current image (see below).   

The View(s) button visible on the toolbar defaults to Save View(s) but 

changes; remembering the last type of View(s) selected.   

To select a View(s) option other than the one indicated by the button, 

use the dropdown menu (small down arrow) on the side of the button. 

 

Save View 

Click  to save the Active Window or all open windows as an 

image file and attach it to the project file.  This image can be included in 

the GPR Summary Report. To learn more, see Save View. 

Copy View 

Click  to copy the Active Window or both the MapView and 

Line Preview windows to the clipboard. 

To learn more, see Copy View. 
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Field Description  

Export View  

Click  to export the Active Window or both the MapView and 

Line Preview windows as a graphics image file (jpg, bmp, png etc.) 

To learn more, see.Export View. 

Add or Remove 

Button 

Click the drop-down arrow beside the View(s) button to add or remove 

buttons from the View Control toolbar. 

 

To learn more, see Add or Remove Buttons. 

 Measure 

To measure distance within the MapView, Line Preview or 3D preview windows, click 

. 

Click and drag the ruler icon ( ) to span two points within the MapView that you 
want to measure. 

The measured distance is displayed in the Status Bar on the bottom left: 

 

The first value indicates the straight-line distance between the two points. The values 
displayed in brackets represent the distance along the X-axis and Y-axis respectively. 
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12 Status Bar 
The Status Bar is displayed along the bottom edge of the EKKO_Project window: 

 

 

As the mouse cursor moves around the various windows and toolbars, relevant 
information is constantly displayed on the Status Bar including: 

Toolbars 

• Description of the function of the button 

• Measurement distance when the Measure button is selected (see Measure) 

Line Preview window: 

• Position along the GPR line 

• Depth 

• Trace number 

• Time 

MapView window: 

• Positional information in Project X,Y coordinates 

• Latitude/Longitude and UTM positions (see GPS Format) providing a Project-to-
Global position relationship has been defined (see Project Position Relationship) 
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13 Menu Bar Overview 
The EKKO_Project menu bar displays several options that allow you to create, save, 
manipulate, and export GPR data. 

 

Use the following table as a guide to working with the EKKO_Project menu bar: 

Field Description 

File Create a New project, or Open, Close, Save, Report, Export, or Exit 

existing projects. 

To learn more, see the File menu. 

Edit  Update your project - add lines, linesets, or grids, rename files, or attach 

files. 

To learn more, see the Edit menu. 

View Display units in meters or feet, view data in Average Amplitude 

Spectrum, Average Trace Amplitude or Trace Plot graphs, or define how 

the toolbars are displayed.  Perform CMP/WARR Analysis. 

To learn more, see the View menu. 

Tools Access LineView (optional), SliceView-Grid and SliceView-Lines (optional), 

modify Project or Grid Position Relationships, Add Positioning to Lines, 

Processing (optional) and GPS routines. Add background image to 

MapView and Edit grids with the X and Y lines mixed up. 

To learn more, see the Tools menu. 

Window To open the Line Preview or MapView windows or tile the Line Preview and 

MapView windows horizontally or vertically. 

To learn more, see the Window menu. 

Help Display information about EKKO_Project, a PDF version of this manual, the 

About dialog, and the EKKO_Project Registration.  See Help. 
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14 File Menu 
Use the File menu to create a New project, Open, or Save files, create Reports, Export 
lines, or Exit the EKKO_Project.  

To open the file menu drop-down list, click File: 

 

The following sections describe the File menu features: 

14.1 New 

1. To create a new project file, In the EKKO_Project menu bar, click File > New. 

Alternatively, in the Standard Toolbar, click .  

2. In the Getting Started dialog box (Figure 1), in the Create a New Project pane 
select one of the three data type options to add GPR data to a new project file:  

•   
•  
•  

Note: Project files can contain multiple grids and linesets. 

To learn how to add more data to the current project file, see the Edit menu.  
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14.2 Open 

1. To open an existing project (.gpz) file in EKKO_Project, click File > Open.  

Alternatively, in the Standard Toolbar, click .  

2. In the Open dialog (Figure 2), navigate to and then select the project you want to 
open. 

3. Click Open. 

14.3 Close 

1. To close the current project click File > Close  
2. In the message box, to close the project and save your changes, click Yes. 

To close the project without saving your changes, click No. 
 

 

Figure 8: Save As dialog box 

3. In the Save As dialog box, navigate to the folder you want to save the project to. 
4. Click Save. 

14.4 Save 

1. To save the current project to a .gpz file, click File > Save. 

Alternatively, in the Standard Toolbar, click . 

2. In the Save As dialog box, navigate to the folder you want to save the project to. 
3. Click Save.  

When a new project is saved, the .dt1, .hd, and all other ancillary files such as GPS 
and topographic files are saved to a compressed .gpz project file. 
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14.5 Save As 

1. To save the current project to a different folder and/or name, click File > Save As.  
2. In the Save As dialog box, navigate to the folder you want to the project to. 

To save the project with a different file name, in the File name field enter the new 
project name.  

3. Click Save. 
 

14.6 Import GPZ 

 
1. To merge the data from an existing project (GPZ) file with the current project in 

EKKO_Project (if a project file is already open), click File > Import GPZ.  

2. In the Open dialog (Figure 2), navigate to and then select one or more projects (GPZ 
files) you want to import and merge into the current project. 

3. Click Open. 

4. Data folders and grids in the imported project files are added to the current project 
file.   

Note that no interpretations are imported from the project file into the current 
project. It is best to import and merge all the project files before adding interpretations 
or processing data.   
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14.7 Export 

Select Export to extract data files from a project and save them as GPR Line(s).   

If the optional Processing module is available, Export also allows GPR lines to be 
exported as Slices, Average Trace Amplitude (ATA) plots, and Average Frequency 
Spectrum (AFS) plots. 

1. To export data files, click Export. 

 

2. In the drop-down list, click the format you want to save the file as. 

 Lines 

Select Line(s) to extract data from a project file and save them to a separate folder as 
Line Data, CSV, or Text.  

1. Click the Line(s) drop-down list to select the format you want to export line data to: 
 

 
 

2. In the drop-down list, click the format you want to save the file in. 
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14.7.1.1 Line Data 

Select Line Data to export selected GPR lines (.dt1 or .hd) and any files attached to that 
data (such as GPS, topography, photos, etc.).  

1. To export GPR lines from the project (.gpz) file to a different folder location click File 
> Export > Line(s) >Line Data. 

 

2. In the Select folder to export to dialog box, navigate to and then select the folder 
you want to export the files to. 

3. Click Select Folder. 

A dialog box opens displaying the exported lines.  

\ 

Note: Interpretations are not saved when GPR lines are exported. 

The DT1 and HD file formats are defined in Appendix B – File Formats.  
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14.7.1.2 SEG-Y 

Select SEG-Y to export GPR lines to a SEG-Y, a format commonly used for seismic 
data.  Selected GPR lines are converted to a file with the same name as the original 
file(s) appended with a .sgy extension, 

1. Click File > Export > Line(s) > SEG-Y. 
2. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
3. Click Select Folder. 

A dialog box opens to display the folder that the .sgy lines were saved to. 
 

The SEG-Y format is defined in Appendix B – File Formats.  

 

14.7.1.3 CSV 

Select CSV to export GPR lines to a comma separated value (CSV) file. This feature 
converts selected GPR lines to a single file with the same name as the original file(s) 
appended with a .csv extension, 

4. Click File > Export > Line(s) > CSV. 
5. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
6. Click Select Folder. 

A dialog box opens to display the folder that the .csv lines were saved to. 
 

 

7. To open a .csv file, navigate to the folder you saved the lines in and then click the 
.csv file. 

The CSV files can be read by spreadsheet software such as Microsoft Excel and GIS 
packages. 
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The new file lists the data in a table that displays point amplitudes from each trace in 
separate columns with trace numbers and position values at the top of each column 
and point numbers and time values at the beginning of each row.  

 

Amplitude values are expressed as 2-byte integers ranging from -32767 to +32767 and 
can be converted to millivolts by multiplying by 50/32767 = 0.0015259. 

 

14.7.1.4 Text 

Select Text to export GPR lines to a text file. This feature converts GPR lines to a single 
text file with the same name as the original file(s) appended with a .txt extension. 

1. Click File > Export > Line(s) > Text  
2. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
3. Click Select Folder. 

A dialog box opens to display the folder that the .txt lines were saved to. 
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4. To open a .txt file, navigate to the folder you saved the lines in and then click the .txt 
file.  

This format can be read by spreadsheet software, Microsoft Notepad, and WordPad. 
The text file lists data in a table that displays point amplitudes from each trace in 
separate columns with position values at the top of each column and time values at 
the beginning of each row.   

 

The first value in this file is a placeholder and is always set to -999. 

Amplitude values are expressed as 2-byte integers ranging from -32767 to +32767 and 
can be converted to millivolts by multiplying by 50/32767 = 0.0015259. 
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14.7.1.5 Trace Headers 

Every time a GPR data trace is collected, as well as saving the trace amplitude 
information, other parameters associated with that trace are saved to the “trace header” 
in the data file.  

The trace header consists of 25 floating point numbers. Parameters such as the trace 
number, trace position, elevation data, Transmitter X, Y and Z positions, Receiver X, Y 
and Z positions, GPS X, Y and Z positions and the time of day in seconds past midnight 
when the trace data were collected, are saved to the trace header. 

If the GPR line was collected with a pulseEKKO system with a DVL-500, the 3-
dimensional orientation of the transmitter and receiver (Yaw, Pitch and Roll) are also 
listed.   

Exporting the trace headers allows the user to see the values of these parameters from 
every trace header in the GPR line.  

Select Trace Headers to export the GPR tracer header information to a CSV.  The 
selected GPR lines are converted to a file with the same name as the original file(s) 
appended with a .csv extension, 

1. Click File > Export > Line(s) > Trace Headers. 
2. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
3. Click Select Folder. 

A dialog box opens to display the folder that the .csv lines were saved to. The CSV file 
format allows the trace header information to be exported to programs like Microsoft 
Excel. 
 

 

  



EKKO_Project User’s Guide File Menu 

 

 
72 

 

14.7.1.6 Parameters 

Select Parameters to export the GPR Acquisition parameters for all the checked GPR 
lines to a CSV file.  The CSV file defaults to the name Line Parameters.  

1. Click File > Export > Line(s) > Parameters. 
2. In the Save As dialog box, navigate to the folder you want to save the CSV file of 

parameter data to. 
3. Modify the default file name if desired. 
4. Click Save. 

A dialog box opens to display the folder that the .csv lines were saved to. The CSV file 
format allows the data acquisition parameters to be exported to programs like Microsoft 
Excel. 
 

 
 

14.7.1.7 Point Cloud 

Third-party point-cloud software can be used for plotting very large scientific data sets.  
Originally developed for LiDAR, 3D Laser scans and photogrammetry, point cloud 
visualization software can be a useful tool for visualizing GPR data collected with GPS.   

Select Point Cloud to export the all the checked GPR lines to a point cloud CSV file.  
The CSV file defaults to the name Line Parameters.  

1. Click File > Export > Line(s) > Point Cloud 
2. In the Save As dialog box, navigate to the folder you want to save the CSV file of 

parameter data to. 
3. Modify the default file name if desired. 
4. Click Save. 

A dialog box opens to display the folder that the .CSV lines were saved to.  
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The CSV file format allows the GPR data to be imported into point cloud software such 
as CloudCompare and Voxler.  For example, the figure below shows a GPR line 
zigzagging over two utilities (indicated by hyperbolas) plotted in CloudCompare, free 3D 
point cloud processing software.   

 

 

 

GPR line data plotted in third-party point cloud software called CloudCompare.   
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 Slices 

This option requires the optional Processing module. 

Use the Slices feature to export Average Trace Amplitudes for one or more intervals 
from all the traces in the selected lines to a comma separated (.csv) file. Slices are 
compatible with 2D plotting software applications such as Golden Software’s Surfer. 

For more details, see the Processing Module User’s Guide. 

 Average Trace Amplitude 

Select Average Trace Amplitude (ATA) plot to display the average rectified signal 
amplitudes (in microvolts) for one or more GPR lines.  

For more details, see Export Average Trace Amplitude Values. 

 Average Frequency Spectrum 

This option requires the optional Processing module. 

Select Average Frequency Spectrum (AFS) to display the average frequency 
spectrum of the selected GPR line(s).  

For more details, see Export Average Frequency Spectrum Values. 

 Attachments 

Select Attachments to export all the files attached to the project (GPZ) file.   

1. Click File > Export > Attachments. 
2. In the Select folder to export dialog box, navigate to and select the folder you want 

to export the file to. 
3. Click Select Folder. 
4. A dialog box opens to display the folder that the attachments were saved to. 

14.8 Recent Files 

1. To re-open a project (.gpz) file that you recently worked with, click File. 
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2. In the drop-down list, click one of the projects listed in the recent files area. 

14.9 Exit 

1. Click File > Exit to close all windows that are open as part of the current 
EKKO_Project session and exit the application. 

2. In the message box, click Yes to save the project file. 
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15 Edit Menu 
The EKKO_Project menu bar Edit menu contains many features that allow you to add 
and update GPR project files. 

To open the edit menu drop-down list, click Edit: 

 

 

 

The following sections describe the Edit menu features: 

15.1 Add Grid 

1. To add a grid to the current project file, click Edit > Add Grid.  
2. In the Open dialog box, navigate to and then click the grid file you want to add. 
3. Click Open.  

The project file grid name defaults to the same name as the .gfp file.  

15.2 Add Lineset 

A Lineset represents a number of GPR lines grouped into a single folder. Select Add 
Lineset to create and then populate a lineset folder.  

1. Click Edit > Add Lineset. 
2. In the Select folder to import Lines From dialog box, navigate to and then select 

the folder you want to add.  
3. Click Select Folder. 

The lineset and lines are displayed in Project Explorer. 
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15.3 New Lineset 

Select New Lineset to create a New Lineset folder in the current project file. 

1. Click Edit > New Lineset.  

The lineset name appears in the Project Explorer window.  

 

15.4 Add Line(s) to Lineset 

Select Add Line(s) to Lineset to add lines to a Lineset in a project. 

1. Click Edit > Add Lines to Lineset.  

2. In the Open dialog, navigate to and then select one or more GPR (.hd) lines.  

3. Click Open. 

The data files are added to the Lineset and are displayed in the Project Explorer. 

15.5 Rename 

Select Rename to change the name of the project, grid, lineset, or GPR line in a lineset. 

Note: A GPR line name in a grid cannot be renamed. 

1. To rename an item, in Project Explorer, select the item you want to rename.  

 

2. In the menu bar, click Edit > Rename.  

 
A box appears around the item name signifying that the name is now editable. 

3. Type the new item name and then press Enter. 

Note: Certain characters, such as periods and slashes are not valid in names. If you 
enter one of these characters, it will be automatically replaced with an underscore. 

15.6 Attach File 

Select Attach File to attach GPS files, topography files, photos of the line location, 
videos of the area, or voice recordings of information relevant to the GPR project, grid, 
lineset, or line.  

1. To attach a file to the selected GPR data line, lineset, grid, or project, click Edit > 
Attach File. 

2. In the Attach Files dialog box, to navigate to and then select the file you want to 
attach. 

The file is listed in the Attachments tab. To learn more, see Attachments Tab.  
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15.7 Remove 

Use Remove > Interpretation Observations to remove interpretations from MapView 
and LinePreview. For example, since interpretations are included when a GPR line is 
copied, you may want to remove interpretations from the copied line.  

1. To remove interpretations from GPR line, lineset, or grid, click Edit > Remove > 
interpretation Observations.  

 
 
 

 

2. To remove the observation, in the message box, click Yes. 

15.8 Cut 

To remove the selected GPR line, lineset or grid from the project, click Edit > Cut. 

This enables you to remove a GPR line from a lineset and paste it into a different lineset. 

Note: a GPR line cannot be cut from a grid. 

15.9 Copy 

To copy an item, click Edit > Copy.   

Use the Copy feature to: 

• Copy a GPR line, lineset, or grid and display it in LineView or Process the item 
differently than the original. 

• Copy and then paste the selected lineset or grid back into the project. 

Note: GPR lines in a grid can be copied, but they must be pasted into a lineset; they 
cannot be pasted into a grid. 

15.10 Paste 

Select Paste to add a GPR line from one lineset to a different lineset.  

To paste an item, click Edit > Paste  

Use the Paste feature to: 
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• Paste a copy of a GPR line, lineset, or grid into LineView, or Process the item 
differently than the original. 

• Paste a copied or cut lineset or grid back into the project. 

Note: copied GPR lines must be pasted into a lineset; they cannot be pasted into a 
grid. 

15.11 Delete 

To remove a grid or lineset from a project, or delete a GPR line from the lineset in the 
project, click Edit > Delete. 

Note: GPR lines cannot be deleted from a grid.  

To delete a line or lines from a grid, use the GFP_Edit utility program that accompanies 
SliceView. 

Caution: Removing a GPR line from the project file may result in the total loss of the 
GPR data line, interpretations, and associated files (.gps, .top, and .ini) unless a 
separate copy of the original data files exists.  

The original data files may exist if the GPR lines were added to the project file rather 
than being embedded in the project (.gpz) file.  

If the project (.gpz) file was generated by the Sensors & Software GPR system, a copy 
of the GPR line(s) can be made clicking File > Export > Lines; this saves the original 
.dt1 and .hd files, and not the interpretations.  
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16 View Menu 
The EKKO_Project View menu contains many features that allow you to change the way 
information is displayed in EKKO_Project. 

To open the view menu, click View: 

 

 

The following sections describe how to work with the View menu features: 

16.1 Units 

1. To display units of measurement in EKKO_Project in meters or feet, click Units. 
2. In the drop-down list, click m (metric) or ft. (US standard).  

 

 

Changes in units of measurement affects the following EKKO_Project features: 

• Line Preview 

• MapView 

• LineView 

• Reports (including Bridge Deck Condition and Pavement Structure Reports) 

• Processing  
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16.2 Average Trace Amplitude  

Average Trace Amplitude (ATA) plots display the average signal amplitudes (in 
millivolts) for one or more selected GPR lines.  

ATA plots display how quickly signal amplitude decays from the peak value of the 
transmit pulse to the background noise level, providing an indication of the maximum 
penetration in the survey area. 

3. Data is Dewowed and Rectified before being displayed but Dewow can be turned off 
(see   
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Filter).   
 
1. One GPR Line: To display the ONE currently selected GPR line in Project Explorer, 

right click with the mouse cursor on the Project Explorer window and then, from the 
right click menu, select Average Trace Amplitude Plot (ATA). 

 

 
 

2. Multiple GPR Lines: To display ALL the GPR lines currently CHECKED in Project 
Explorer, click View > Average Trace Amplitude Plot (ATA). 
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The ATA plot is greyed out if no lines are selected in the Project Explorer window. 
 

 
Figure 9: Average Trace Amplitude Plot 

Use the following table as a guide to working with the Average Trace Amplitude Plot: 
 

Item Description  

Resize Window Drag and drop a corner or edge of the window to resize it.  The 

Window can also be maximized using the Maximize button  in 

the top right. 

Pan View Hold the right-click button and drag the mouse in the direction you 

want to move the image. 

Copy Image to 

Clipboard 

Click the Copy Image to Clipboard to copy the image to paste it in 

another document. 

Default View Limits  Click Zoom - Fit to Window button to return to the original plot 

display. 

Zoom Click the image to define the top left corner of the zoom box 

1 Hold the left-click button and drag the mouse to the bottom 

right corner of the zoom box. 

2 Release the mouse button and the image zooms to the box 
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Item Description  

Amplitude (mV) – Y 

Axis 

The GPR signal amplitude in millivolts (mV).  

Move the mouse cursor along the time axis to display the time and 

GPR signal amplitude on the status bar at the bottom of the window.   

The signal amplitude typically starts at the background noise level on 

the left.  At zero time, a strong amplitude signal occurs when the 

GPR system fires its transmitter. At later times, the GPR signal 

slowly decays back to the background noise level (providing the 

recording time window is long enough).  The steepness of the slope 

depends on the material being surveyed. 

Time (ns) – X Axis The time in nanoseconds from the start of the recording window.  

Time before zero time is displayed as a negative value.   

The time at which the signal level drops back to the background 

noise level is the maximum penetration time. This can be converted 

to the average maximum depth of penetration if the GPR velocity for 

the material is known. 

 File 

Click the File menu to see the following sub-menu: 
 

 
 
 

Use the following table as a guide to working with the File menu: 
 

Item Description 

Print To print the ATA plot, click Print. 

Save Image as File To save the ATA plot as an image, click Save Image as File. 

1 In the Save As dialog box, use the dropdown at the bottom 

to select the type of graphics image file (jpg, bmp, gif or 

png). 

2 Navigate to the folder to save the file to. 

3 Click Save. 

Copy Image to 

Clipboard 

To copy an ATA plot image to paste to a document, click Copy 

Image to Clipboard.  

Save Image to 

Project 

To attach the ATA image to the project so it is included in GPR 

Summary Reports, click Save Image to Project.  



EKKO_Project User’s Guide View Menu 

 

 
86 

Item Description 

Close To close the ATA plot, click Close. 

 Display 

Click the Display menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the Display menu: 
 

Item Description 

Legend Location To define the location of the legend on the ATA plot, click Legend 

Location. 

In the drop-down list click Top, Bottom, Left, Right, or Hide. 

Legend Select the items to include on the Legend: Filters and GPR Line 

names. 

Font Size Choose a font size of Small, Medium or Large. 

Linear Amplitude 

Axis 

Check this option to change the Amplitude Axis from the default 

Logarithmic scale to a linear scale. 

Custom Zoom Allows the user to specify Min and Max Times in nanoseconds 

(ns) and Min and Max Amplitudes in millivolts (mV) to display. 
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 Filter 

Click the Filter menu to see the following sub-menu: 
 

 
 

Check Background Average Subtraction to apply an Average background subtraction 
filter with a filter length equal to the length of the GPR line before plotting the ATA plot.  
Defaults to OFF.   

 
Check Dewow to apply a high pass temporal filter called Dewow to the GPR line before 
plotting the ATA plot.  Defaults to ON. 

 
For more information on Filtering, see Dewow and Background Average Subtraction in 
the Processing Module User’s Guide. 

 Export Average Trace Amplitude Values 

Exporting the Average Trace Amplitude values requires the optional Processing module. 

To export the average rectified trace amplitudes for all the traces in the selected GPR 
line(s) to comma separated value (.csv) files: 

1. Click File > Export > Average Trace Amplitude (ATA). 

2. In the Select target folder for the ATA report dialog box, navigate to and then 
select a target folder. 

3. Click Select Folder  
A dialog box opens to display the folder containing the reports in Windows Explorer. 
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Note that the exported ATA data has the Dewow filter applied. 

16.3 Average Frequency Spectrum 

Average Frequency Spectrum (AFS) plots the average frequency spectrum of the 
selected GPR line(s).  

Plot the AFS to determine the frequency content of GPR lines to decide if filtering is 
required to remove unwanted frequencies like high frequency noise. If so, lowpass, 
highpass, or bandpass filtering can be applied (see Filters – Time in the Processing 
Module User’s Guide). 

Data is Dewowed and Rectified before being displayed but Dewow can be turned off 
(see   
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Filter).   

1. One GPR Line: To display the ONE currently selected GPR line in Project 
Explorer, right click with the mouse cursor on the Project Explorer window and 
then, from the right click menu, select Average Frequency Spectrum (AFS) 
Plot. 

 

2. Multiple GPR Lines: To display ALL the GPR lines currently CHECKED in 
Project Explorer click View > Average Frequency Spectrum Plot (AFS). 
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The AFS plot is greyed out if no lines are selected. 
 

 
Figure 10: Average Frequency Spectrum Plot 

 

Use the following table as a guide to working with the Average Frequency Spectrum 
Plot: 

Item Description  

Resize Window Drag and drop a corner or edge of the window to resize it.  The 

Window can also be maximized using the Maximize button  in 

the top right. 

Pan View Hold the right-click button and drag the mouse in the direction you 

want to move the image. 

Copy Image to 

Clipboard 

Click the Copy Image to Clipboard to copy the image to paste it in 

another document. 

Default View Limits  Click Zoom - Fit to Window button to return to the original plot 

display. 

Zoom Click the image to define the top left corner of the zoom box 

1 Hold the left-click button and drag the mouse to the bottom 

right corner of the zoom box. 

2 Release the mouse button and the image zooms to the box 

Amplitude (mV) – Y 

Axis 

The GPR signal amplitude in millivolts (mV).  

Move the mouse cursor along the time axis to display the time and 

GPR signal amplitude on the status bar at the bottom of the window.   
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Frequency (MHz) – 

X Axis 

The Frequency in megahertz (MHz).  

The displayed frequency range defaults to zero to the Nyquist 

frequency (calculated from the temporal sampling interval for the GPR 

line).    

 

Note: Sensors & Software antennas center frequency is measured in air. For 
example, 100 MHz antennas produce a center frequency of about 100 MHz when 
data is collected in air. The center frequency of data from antennas placed on the 
ground will be lower in frequency than the stated frequency of the antenna. For 
example, the center frequency of data collected with 100 MHz antennas is often 60 to 
70 MHz. 

 File 

4. Click the File menu to see the following sub-menu: 
 

 
 
 

Use the following table as a guide to working with the File menu: 
 

Item Description 

Print To print the AFS plot, click Print. 

Save Image as File To save the AFS plot as an image, click Save Image as File. 

1 In the Save As dialog box, use the dropdown at the bottom to 

select the type of graphics image file (jpg, bmp, gif or png). 

2 Navigate to the folder to save the file to. 

3 Click Save. 

Copy Image to 

Clipboard 

To copy an AFS plot image to paste to a document, click Copy 

Image to Clipboard.  

Save Image to 

Project 

To attach the AFS image to the project so it is included in GPR 

Summary Reports, click Save Image to Project.  

Close To close the AFS plot, click Close. 
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 Display 

5. Click the Display menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the Display menu: 
 

Item Description 

Legend Location To define the location of the legend on the AFS plot, click Legend 

Location. 

In the drop-down list click Top, Bottom, Left, Right, or Hide. 

Legend Select the items to include on the Legend: Filters and GPR Line 

names. 

Font Size Choose a font size of Small, Medium or Large. 

Linear Amplitude 

Axis 

Uncheck this option to change the Amplitude Axis from the default 

Linear scale to a logarithmic scale. 

Custom Zoom Allows the user to specify Min and Max Frequency in megahertz 

(MHz) and Min and Max Amplitudes in millivolts (mV) to display. 

 

 Filter 

Click the Filter menu to see the following sub-menu: 
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Check Background Average Subtraction to apply an Average background subtraction 
filter with a filter length equal to the length of the GPR line before plotting the AFS plot.  
Defaults to OFF.   
 
Check Dewow to apply a high pass temporal filter called Dewow to the GPR line before 
plotting the AFS plot.  Defaults to ON. 

 
For more information, see Dewow and Background Average Subtraction in the 
Processing Module User’s Guide. 

 Export Average Frequency Spectrum Values 

Exporting the Average Frequency Spectrum values requires the optional Processing 
module. 

To export the average frequency spectrum for all the traces in the selected GPR line(s) 
to comma separated value (.csv) files: 

1. Click File > Export > Average Frequency Spectrum (AFS). 

2. In the Select target folder for the AFS report dialog box, navigate to and then 
select a target folder. 

3. Click Select Folder  
A dialog box opens to display the folder containing the reports in Windows Explorer.  
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16.4 Trace Plot 

Trace Plot is used to display individual traces from one or more GPR lines; this allows 
the user to see subtle signals on traces or view the effect of different editing and 
processing types on individual traces. 

Viewing traces can also help you determine if the first break offset needs to be edited. 
Normally the first break should occur at the first large deflection in the signal. If not, time 
scales and depth scales on section plots will be inaccurate. 

1. One GPR Line: To display the traces of the ONE currently selected GPR line in 
Project Explorer, right click with the mouse cursor on the Project Explorer window 
and then, from the right click menu, select Trace Plot. 

 
 

2. Multiple GPR Lines: To display the traces of ALL the GPR lines currently 
CHECKED in Project Explorer, click View > Trace Plot. 
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The Trace plot is greyed out if no GPR lines are selected. 
 

 

Figure 11: View Traces Plot 

Use the following table as a guide to working with the Trace Plot: 
 

Item Description  

Resize Window Drag and drop a corner or edge of the window to resize it.  The 

Window can also be maximized using the Maximize button  in 

the top right. 

Pan View Hold the right-click button and drag the mouse in the direction you 

want to move the image. 

Copy Image to 

Clipboard 

Click the Copy Image to Clipboard to copy the image to paste it in 

another document. 

Default View Limits  Click Zoom - Fit to Window button to return to the original plot 

display. 

Zoom 1 Click the image to define the top left corner of the zoom box 

2 Hold the left-click button and drag the mouse to the bottom 

right corner of the zoom box. 

3 Release the mouse button and the image zooms to the box 

Amplitude (mV) – Y 

Axis 

The GPR signal amplitude in millivolts (mV).  

Move the mouse cursor along the time axis to display the time and 

GPR signal amplitude on the status bar at the bottom of the window.   

Time (ns) The time in nanoseconds from the start of the recording window.  

Time before zero time is displayed as a negative value.    
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Trace The displayed trace.   

Click the up and down arrows to display other traces. 

Position The position of the displayed trace on the GPR line.  The position is 

based on the trace number and the step size 

 File 

3. Click the File menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the File menu: 
 

Item Description 

Print To print the Trace plot, click Print. 

Save Image as File To save the Trace plot as an image, click Save Image as File. 

1 In the Save As dialog box, use the dropdown at the bottom to 

select the type of graphics image file (jpg, bmp, gif or png). 

2 Navigate to the folder to save the file to. 

3 Click Save. 

Copy Image to 

Clipboard 

To copy a Trace plot image to paste into a document, click Copy 

Image to Clipboard.  

Save Image to 

Project 

To attach the Trace image to the project so it is included in GPR 

Summary Reports, click Save Image to Project.  

Close To close the Trace plot, click Close. 
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 Display 

4. Click the Display menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the Display menu: 
 

Item Description 

Legend Location To define the location of the legend on the Trace plot, click Legend 

Location. 

In the drop-down list click Top, Bottom, Left, Right, or Hide. 

Legend Select the items to include on the Legend: Filters and GPR Line 

names. 

Font Size Choose a font size of Small, Medium, or Large. 

Linear Amplitude 

Axis 

Not available. 

Custom Zoom Allows the user to specify Min and Max Time in nanoseconds (ns) 

and Min and Max Amplitudes in millivolts (mV) to display. 

 

 Filter 

Click the Filter menu to see the following sub-menu: 
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Check Background Average Subtraction to apply an Average background subtraction 
filter with a filter length equal to the length of the GPR line before plotting the Trace plot.  
Defaults to OFF.   
 
Check Dewow to apply a high pass temporal filter called Dewow to the GPR line before 
plotting the Trace plot.  Defaults to ON. 

 
For more information, see Dewow and Background Average Subtraction in the 
Processing Module User’s Guide. 

16.5 CMP/WARR Analysis 

This option requires the optional Processing module. 

Analyze Common Mid-Point (CMP) or Wide-Angle Reflection and Refraction (WARR) 
survey data (left) and analyze it using semblance analysis to extract velocity information 
(right): 

 

For more details, see the Processing Module User’s Guide. 

16.6 Zoom 

 Zoom Out 

To decrease the magnification of the MapView or Line Preview image by a factor of 1.5 
times, click View > Zoom > Out. 

 Zoom In 

To increase the magnification of the MapView or Line Preview image by a factor of 1.5 
times, click View > Zoom > In. 
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When you zoom in to display a portion of the project data, an icon appears in the lower 
left corner of MapView to indicate that data exists outside the current view (see Pan). 

 Zoom Window 

To magnify a selected area of MapView or Line Preview windows, click View > Zoom > 
Zoom Window and then click and drag a rectangle in the area of interest. 

 Fit to Window 

To adjust the zoom to fit all the data in the MapView or Line Preview windows, click 
View > Zoom > Fit to Window. 

16.7 Pan 

To reposition the MapView or the Line Preview, click View > Pan.  

Click and drag the cursor ( ) to move the MapView or Line Preview within the 
window.  

 

 

Panning or zooming images within MapView may prompt the following icons to be 
displayed in the bottom left corner: 

Indicates that some of the data is outside the current window.   

Indicates that all of the data is outside the current window.  Click View > Zoom > 
Fit to Window to see all the data in the project in the MapView window. 
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16.8 Export Animation 

If the MapView or 3D Preview window is currently the Active Window, it can be saved to 
a GIF animation file by selecting View > Export Animation.  The following dialog box 
opens: 

 

 

 

Window displays the name of the window to be animated (MapView or 3D Preview). 

Cycle Through displays what images will animate.  If Window is MapView, it is only 
possible to animate the Depth Slices.  If the Window is 3D Preview, the user can select 
either the X Lines, Y Lines, or depth slices to animate. 

Speed determines the speed of the animation; the number of frames per second (fps).  
Slow is 1 fps, Normal is 2 fps and Fast is 3 fps. 

After pressing OK, the user is prompted to navigate to the folder to save the GIF file into 
and can edit the default name for the GIF file. 

After exporting the GIF animation file, the folder opens, to see the GIF file and play it, if 
desired. 

 



EKKO_Project User’s Guide View Menu 

 

 
101 

16.9 Save View 

To save the MapView or Line Preview window image to the GPR Summary Report 
(PDF), select that window so it is the Active Window and then select View > Save View. 
 
1. A message opens, asking if you would like to save the currently selected window or 

all open windows. 
2. A dialog for naming the image. The default name is based on what window is being 

saved (Line Preview or MapView).  

• For Line Preview images, the default image name includes the Line name. 

• For 3D preview, the default name includes the grid name and depth slice. 

• For MapView images, the default image name will include: 
➢ the depth of the slice being shown (if Slices are turned on in Layer View).  
➢ PCD, (if PCD is turned on in Layer View). 
 

3. Click Save. 

When the GPR Summary Report is selected, the user can select from the images 
attached to project to appear in the report. 

To see a list of the images currently saved and available for the GPR Summary Report, 
select the project item in Project Explorer and then open the Attachments Tab. 

Images saved to the Project (GPZ) file can be exported using the File > Export > 
Attachments menu option. 

16.10 Copy View 

To copy the MapView or Line Preview window image to the clipboard, select that window 
so it is the Active Window and then select View > Copy View. 

A message opens, asking if you would like to save the currently selected window or all 
open windows. 

This feature enables you to copy and paste the image to a document or image editor. 

16.11 Export View 

To export the MapView or Line Preview image to a graphics image file, select that 
window so it is the  Active Window and then select View > Export View.  
 
1. A message opens, asking if you would like to save the currently selected window or 

all open windows. 
2. In the Save As dialog box, navigate to, and select the folder you want to save this 

image in. 
3. Use the Save as Type dropdown to select the file format (jpg, bmp, gif, png or tiff) 
4. Click Save. 

16.12 Use Getting Started dialog 

When a new project is created, the Getting Started dialog (Figure 1) automatically opens 
to guide you through creating a project file.   
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To disable this feature, click View and then uncheck Use Getting Started dialog.   

16.13 Toolbar Text 

EKKO_Project enables you to display/hide the text that appears below each toolbar icon. 

Select View > Toolbar Text to display text below each icon: 

 

To display the toolbar icons without text, reducing the size of the toolbar, select View 
and then uncheck Toolbar Text. 
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16.14 Toolbars and Docking Windows 

Select View > Toolbars and Docking Windows to view or hide the following features: 

 

 

• Standard Toolbar 

• View Control Toolbar 

• Acquisition Tab 

• Processing Tab 

• Attachments Tab 

• Project Explorer 

• Layer View 

 Customize 

Customize is standard Microsoft functionality; for more details see Microsoft 
documentation. 

To modify the Commands, Toolbars, Keyboard, Menus, and other Options in 
EKKO_Project, click View > Toolbars and Docking Windows > Customize. 

16.14.1.1 The Commands Tab 

Use the Commands tab to display all commands available to add to a toolbar.   

1. The Commands tab lets you see all the commands available to add to a custom or 
existing toolbar.  To determine which commands will be displayed in the menu bar, 
click the item in the Categories pane. 
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2. To display a description of the command, click a menu item in the Commands pane. 

 

3. To exit the Customize window, click Close or click another tab to view more 
information. 
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16.14.1.2 Toolbars Tab 

1. To display the available Toolbar options, click the Toolbars tab.  

 

2. Use the following table as a guide to working in the Toolbars tab: 

Field Description 

Toolbars The Toolbars field displays the available menu bars. 

To display or hide a toolbar in EKKO_Project, select/deselect the checkbox 

next to the toolbar name. 

Reset In the Toolbars field, select the menu bar(s) that you want to return to the 

default setting and then click Reset. 

Reset All To return all toolbars to their default view, click Reset All. 

New 1 To add a new toolbar to EKKO_Project, click New. 

2 In the Toolbar Name field, type the name of the new toolbar. 

The new toolbar is displayed in the Toolbars field. 

Rename To Rename a toolbar that you have added to EKKO_Project: 

3 In the Toolbars pane, select the toolbar you want to rename. 

4 Click Rename. 

5 In the Toolbar Name dialog box, type the new toolbar name. 

6 Click OK. 

Delete To Delete a toolbar that you have added to EKKO_Project: 

1 In the Toolbars pane, select the toolbar you want to rename. 

2 Click Delete. 

3 In the confirmation dialog box, click Yes. 

Show text 

labels 

To display text descriptions with the toolbar icons, click the Show text 

labels checkbox 
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16.14.1.3 Keyboard 

To manage how your keyboard interacts with EKKO_Project, click the Keyboard tab. 

Use the Keyboard tab to assign keyboard shortcuts to any feature in the File, Edit, 
View, Tools, Help, or All Commands.  

 

1. To create a new keyboard shortcut, in the Category drop-down list, click one of the 
following options: 

 

Note: Each Category displays a different list of commands. 

2. In the Commands pane, click the command that you want to apply a hotkey shortcut 
to. 

A brief description of the command is displayed in the Description area. 
Any existing shortcuts associated with the selected command are displayed in the 
Current Keys pane. 

 

3. In the Set Accelerator for drop-down list, click an option. 
4. To create a new hotkey shortcut, select the Press New Shortcut Key field and then 

press a shortcut combination on your keyboard. 

The shortcut is displayed in the Press New Shortcut Key field. 
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5. Click Assign to assign the shortcut to the selected command. 

Press Remove to remove a shortcut from a command. 
Press Reset All to remove all shortcuts.  

16.14.1.4 Menu  

1. To change the items displayed in the menu bar, click the Menu tab. 

 

2. In the Application Frame Menus pane, click the Show Menus for drop-down list. 
3. Click one of the following options: 

  
Click Reset to abandon your changes. 

4. To apply animations to the menu, click the Menu animations drop-down list and 
select one of the following options: 

 

5. To apply shadows to the menu items, select the Menu shadows option. 
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6. To allow context menus to be displayed, in the Context Menus pane, click the Select 
context menu drop-down list to select one of the following: 

 
Click Reset to abandon all your changes. 

7. Click Close to close the window. 

16.14.1.5 Options 

1. To define your toolbar and menu options, click the Options tab. 

 

2. Use the following table as a guide to working with the Options tab: 

Field  Description 

Toolbar 

Show Screen Tips on 

toolbars 

Select this option to display text screen tips when you hold your 

mouse over the toolbar icon. 

Show shortcut keys 

in Screen Tips 

Select this option to display text keyboard shortcuts when you hold 

your mouse over the toolbar icon. 

Large Icons Select this option to display the large toolbar icons. 

Personalized Menus and Toolbars 

Menus show recently 

used commands first 

Select this option to place the commands you most recently used 

at the top of the drop-down list. 

Click the arrow (>) to display other menu options,  
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Field  Description 

Show full menus 

after a short delay 

Select this option to first display only the most recent commands 

and then display the full menu after a few seconds. 

Reset my usage data Select this option to reset the recently used order.  

3. Click Close to close the window. 

16.15 Status Bar 

To display information in the Status Bar at the bottom of the EKKO_Project window 
(Status Bar) in the menu bar, click View > Status Bar. 

 

To not display information in the status bar, de-select the Status Bar option.   

16.16 GPS Format 

To modify the format of the GPS information in the Status Bar at the bottom of the 
EKKO_Project window, in the menu bar click View > GPS Format. 

 

 

 Latitude/Longitude 

If Latitude/Longitude is selected with the checkbox, the display options are: 

1) Degrees Minutes Seconds 

2) Decimal Degrees 

The options for the Hemisphere are: 

1) Do not show 



EKKO_Project User’s Guide View Menu 

 

 
110 

2) Show as a Positive (+) or Negative (-) sign. A plus (+) sign if Latitude is in the 
Northern hemisphere or Longitude is in the Eastern Hemisphere and a minus (-) 
sign if Latitude is in the Southern hemisphere or Longitude is in the Western 
Hemisphere.  

3) Letter: For latitude, “N” for North or “S” for South. For Longitude, “E” for East or 
“W” for West. 

4) Word: For latitude, “North” or “South”. For Longitude, “East” or “West”. 

A sample of the current GPS output is shown at the bottom of the dialog box. 

 UTM 

If UTM is selected with the checkbox, the Reference Ellipsoid can be selected from the 
drop-down list. The default is WGS-84. 

To display the UTM Zone Number and/or the UTM Letter Designator, select those 
options. 

A sample of the current GPS output is shown at the bottom of the dialog box. 

16.17 Scale Lines 

Scale lines are dashed lines that correspond to the X and Y axes label increment.  They 
can assist in determining an accurate XY position within the project data. 

 

 

 

 

 

 

 

 

 

 

 

16.18 Drill Locator 

See Drill Locator. 

16.19 Edit Drill Diameter 

See Drill Locator. 

Scale lines 
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17 Tools Menu 
The EKKO_Project Tools menu contains many features that allow you work in 3D 
Preview and the optional LineView, SliceView, and Process modules within 
EKKO_Project.  The Tools menu is also used to add or modify positioning, add 
background images to MapView and produce various reports from the GPR data and 
images in the project. 

To open the tools menu drop-down list, click Tools: 

 

 

The following sections describe how to work with the Tool menu features: 
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17.1 LineView 

The optional LineView module displays cross-sectional views of GPR lines; you can 
change the display settings such as color table, gain, and axes. 

1. To display a GPR Line name in the LineView module, in Project Explorer, select a 

line.  
2. Click Tools > LineView. 

 

 

If the optional Interpretation module is enabled, use LineView to add interpretations such 
as, Points, Polylines, Boxes, Annotations and Flags  

 

 

to the GPR Line which can be displayed in MapView and listed in the Project Report 
(CSV). 
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Only the selected GPR Line or those checked in to Project Explorer are displayed in 
LineView, however all GPR Lines in the project can be displayed using the LineView 
toolbar Project List drop-down. 

To learn more about using LineView to display GPR lines and add Interpretations, see 
the LineView Module User’s Guide. 

 

17.2 SliceView 

Ground Penetrating Radar (GPR) data is usually displayed as cross-sections of the 
subsurface called GPR lines; interpreting data from multiple GPR lines can be confusing 
and labor intensive. 

The SliceView module is used to process a grid or line of GPR data collected in an area 
into a series of map view images called depth slices.   Depth slices provide highly 
detailed subsurface information that can enhance GPR data interpretation and 
presentation. Users can see the spatial correlation of targets, making interpretation 
easier as they can differentiate real targets from targets of no interest. For example, 
responses from utilities tend to produce linear targets while local targets, such as rocks, 
appear as point targets. This type of display is especially useful for interpreting large 
data volumes. 

Depth Slices can be generated two ways: 

1) SliceView-Grid 

2) SliceView-Lines  

These are described in more detail below.   
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 SliceView-Grid  

SliceView-Grid is used to process GPR data collected in a grid into depth slices.   

The SliceView module contains a function called SliceView-Grids to generate depth 
slices of GPR data collected in a grid.   

1. To display a grid in SliceView, in Project Explorer, select a grid in Project Explorer. 

 

2. Click Tools > SliceView-Grid. This opens the SliceView-Grid function, processes 
the grid data into depth slices and displays them along with the GPR grid lines like 
the example below. 

 

 
 

Use SliceView-Grid to: 

• Analyze grid data by viewing depth slices at increasing depths  

• Reprocess grid data using different velocities 

• Save depth slices as images 

• Display depth slices generated from grid data collected with a GPS on Google Earth. 

• Export grid data to 3D data files and 3D visualization software (available from 
Sensors & Software) 

To learn more about using SliceView-Grid to display depth slices, see the SliceView 
User’s Guide. 

 

mailto:radar@sensoft.ca
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 SliceView-Lines 

SliceView-Lines is used to process GPR data collected in one or more lines with 2D 
project (XY) positioning(see Line Positioning).  It can also be used for lines collected with 
GPS or added afterwards (see Line Positioning).  

1. To process GPR line data using SliceView-Lines, in Project Explorer, select one or 
more lines. 
 

 
 

2. Click Tools > SliceView-Lines. This opens the SliceView-Lines function, processes 
the grid data into depth slices and displays them in the MapView window like the 
example below. 

 

Use SliceView-Lines to: 

• Process GPR lines collected with a high accuracy GPS when it is not possible to 
collect a grid. 

• Analyze GPR line data by viewing depth slices at increasing depths  

• Reprocess grid data using different velocities 

• Save depth slices as part of MapView images 

To learn more about using SliceView-Lines to display depth slices, see the SliceView 
User’s Guide. 
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17.3 PhotoSlicer 

PhotoSlicer allows the user to overlay GPR depth slices onto a photograph.  Depth 
slices generated on the Display Unit in the field or from EKKO_Project’s SliceView 
module are added to a photo and can be stretched or squeezed to fit onto the photo in 
the proper position and with the proper perspective.  Photos with depth slices are an 
excellent way to convey the position of objects found with GPR in the context of the 
survey site. 

PhotoSlicer images can be saved for external reports and presentations.  They can also 
be attached to the project file so they can appear in the GPR Summary Report.   

Select PhotoSlicer from the Toolbar button or by selecting the Tools > PhotoSlicer 
menu option.  The following dialog box opens: 

 

 

 

Slice Set is the name of the depth slices to overlay on the photo.   

The user selects the depth slice from the dropdown that lists all the depth slices 
available in the project; depth slices generated by SliceView-Grid and SliceView-Lines.   

Image is the image the slice will be overlayed on. While a photograph of the surveyed 
area is typically used, any image file is can be selected. 

If the desired photo has already been attached to the GPR project (GPZ) file or any 
Lineset, Grid or GPR line in the project (see Attachments Tab), the user clicks on the 
Attachments button and then uses the dropdown list to select the name of the image. 

PhotoSlicer supports the following image formats: BMP, JPEG, JPG, PNG, TIF and 
TIFF. 

If the desired photo is elsewhere on the computer, select the Files button and then use 
the Browse button to navigate to the folder and select the name of the image. 

Once the Slice Set and Image are selected, press OK. 
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A new window opens with the image in the background and the top depth slice 
overlayed on the image.  The Info tab on the left lists the name of the Slice Set, name of 
the image.   

 

If necessary, the photo can be rotated 90 degrees clockwise using the View > Rotate 
Image menu option.   

The depth of the current depth slice is displayed in the bottom left corner of the image.  
Use the mouse scroll wheel or the scroll bar on the right to scroll through the depth 
slices and select the desired one.   

 

Info tab 

Scroll bar 



EKKO_Project User’s Guide Tools Menu 

 

 
118 

The depth slice has a frame and red corners that cab be clicked and dragged to stretch, 
squeeze, rotate and change the shape to place it at the desired location on the photo.  
The X=0, Y=0 corner of the depth slice is indicated by the black zero (0) on one of the 
red corners.   

If the photo is of the grid collected with GPR, position the depth slice by placing the four 
corners of the depth slice onto the four corners of the grid in the photo. 

 

It is possible to move the corners of the depth slice off the edges of the photograph.  
This is sometimes necessary to position the depth slice in the correct position but be 
aware that once you “drop” the corner, you will no longer have access to it to move it 
again.  In this situation and if the depth slice image gets twisted and distorted, it may be 
necessary to reset the depth slice image to the original starting point and try again.  Do 
this by selecting View > Reset Frame. 

 

X=0, Y=0 corner 

Corner 

Corner 

Corner 
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Once the depth slice has been placed, the red corners, frame and depth slices can be 
turned off using the option in the View menu or by selecting the Options tab in the 
bottom left corner and unchecking the appropriate boxes.  The depth slice can still be 
moved without the corners or frame. 

 

Options tab 
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Once the photo and depth slice are positioned correctly, you can save images: 

1) Save the image to the clipboard by going to Edit > Copy to Clipboard.  The 
image can then be pasted into another document such as a Word document. 

2) Save the image to a JPG graphics image file by going to File > Export 
PhotoSlice 

3) Save all the images to JPG graphics image files by going to File > Export All 
PhotoSlices 

When you save a JPG graphics file image, the Save As dialog opens allowing you to 
navigate to the desired folder and name the JPG file.  Once the file has been saved, the 
folder opens to show the saved file.   

To exit from PhotoSlicer, go to File > Close or click on the X in the top-right corner. 

17.4 Grid Tools 

 Grid Conventions 

By convention, grids are always supposed to be collected in the “First Quadrant” with the 
X axis increasing from left to the right and the Y axis increasing upwards.   
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As well, “X Lines” are defined as the grid lines collected in the X direction of the grid and 
“Y Lines” are defined as grid lines in the Y direction of the grid.   

Grid Tools are used to create grids from GPR lines and edit grids, so the grid lines are 
positioned as if they were collected in the first quadrant.  This ensures that depth slices 
or 3D volumes created from the data are correctly oriented and not mirror image or off at 
right angles.   

 Create Grid from Checked Lines 

Sometimes GPR Line Scans are collected in a grid pattern (either parallel lines or lines 
in the both the X and Y directions) and the user wants to add them to a grid so it can be 
processed into depth slices using the SliceView-Grid module.  This is done by using the 
GFP_Edit utility program to create a GFP file for that group of lines, which is the file that 
defines the position, direction, and length of every GPR line in the grid. 

Note that grid line names must be unique, so it is not possible to create a grid with more 
than one line named Line1 or Line2, etc.  This could happen by checking lines with the 
same name but in different linesets in Project Explorer, for example, \Lineset1\Line1 and 
Lineset2\Line1 

17.4.2.1 Creating a Grid with All GPR Lines in One 
Direction 

From Project Explorer, check all the GPR lines.  

 

Select Create Grid from Checked Lines, either by: 

1) right- clicking on the Lineset name in Project Explorer and selecting it from the 
menu or  

2) clicking on the Lineset name in Project Explorer and selecting it from the Tools > 
Grid Tools menu.   

The GFP_Edit utility program opens: 
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Import Lines as: Select X Lines or Y Lines (see Grid Conventions). 

Reverse Line Direction:  Leave unchecked unless you want all the lines to be reversed.   

Grid Name: Defined as the Lineset Name in Project Explorer.  The name is not editable 
in this dialog.  

Line Spacing: Enter the distance between lines. 

Offset from Current Origin: To set this value properly, understand that GFP_Edit uses 
the number at the end of the line name and the Line Spacing value to calculate the 
position of each line in the grid.   

For example, if lines are in the X direction, spaced 0.5 meters apart and the first line 
name ends with “1”, for example Line1, it is positioned at: 

Y Position = Line number * Line Spacing = 1 x 0.5 = 0.5 meters 

It is usually desired that the first grid line is positioned at zero (0).  There are two ways to 
position the first line at position zero (0): 

1) Set the Offset from Current Origin value in the other direction to the line 
direction to: 

Y = -(First Line Number x Line Spacing)  

In the example above, Y = -(1 x 0.5) = -0.5. 

2) Exit from GFP_Edit and follow the directions below in Creating a Grid with GPR 
Lines in Both X and Y Directions to rename the lines, but only for the one line 
direction.   
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Once the fields are filled in, press OK.  This opens a map view showing the position of 
all the lines in the grid: 

 

 

 

From this screen, if necessary, modify the grid line positions and directions by using the 
editing tools described in Edit Selected Grid.  When finished exit from GFP_Edit using 
the X in the corner or from the File menu. 
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17.4.2.2 Creating a Grid with GPR Lines in Both X and 
Y Directions 

If you want to create a grid from GPR lines that go in both the X and Y directions, the 
easiest way is, before selecting the Create Grid from Checked Lines option, to rename 
the lines in Project Explorer adding an X and an incrementing number starting at 0 to the 
lines in the X direction and a Y and an incrementing number starting at 0 to the lines in 
the Y direction.   

For example: if there are 10 GPR lines, and Lines 1-5 were collected in the X direction 
and Lines 6-10 were collected in the Y direction, rename them as follows:” 

Original Line 
Name 

Renamed Line 
to Create Grid 

Line1 Line1-X0 

Line2 Line2-X1 

Line3 Line3-X2 

Line4 Line4-X3 

Line5 Line5-X4 

Line6 Line6-Y0 

Line7 Line7-Y1 

Line8 Line8-Y2 

Line9 Line9-Y3 

Line10 Line10-Y4 

If your grid is large an contains so many lines that renaming them all is not feasible, see 
Creating Large Grids with GPR Lines in Both X and Y Directions.  

After renaming the GPR lines in Project Explorer, check all the lines to include in the 
grid.  Select Create Grid from Checked Lines, either by  

1) right-clicking on the Lineset name in Project Explorer and selecting it from the 
menu or 

2) clicking on the Lineset name in Project Explorer and selecting it from the Tools > 
Grid Tools menu.   

The GFP_Edit utility program opens with a dialog with the following settings: 

Import Lines as:  Leave it set the default value of X & Y Lines. 

Reverse Line Direction: Leave unchecked unless you want all the lines to be reversed.   

Grid Name: Defined as the checked Lineset Name in Project Explorer.  The name is not 
editable in this dialog.  
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Line Spacing: Enter the distance between lines. 

Offset from Current Origin:  Leave values at the default values of X=0 and Y=0.   

 

 

Once the fields are filled in, press OK.  This opens a map view showing the position of 
all the lines in the grid: 

 

From this screen, if necessary, modify the grid line positions and directions by using the 
editing tools described in Edit Selected Grid.  When finished exit from GFP_Edit using 
the X in the corner or from the file menu. 

 

17.4.2.3 Creating Large Grids with GPR Lines in Both 
X and Y Directions 

If you have too many lines that renaming is infeasible, we recommend creating a grid 
with only the X Lines, then adding the Y Lines. Here is an example of this method. 
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Adding X Lines to a Large Grid 

From Project Explorer, check all the GPR lines that go in the X direction, in this example 
Line1= 1 to Line 11.  

 

Select Create Grid from Checked Lines, either by: 

1) right-clicking on the Lineset name in Project Explorer and selecting it from the 
menu or  

2) clicking the Lineset name in Project Explorer and then selecting it from the Tools 
> Grid Tools menu.    

The GFP_Edit utility program opens with a dialog with the following settings: 

Import Lines as: Set to X Lines (see Grid Conventions). 

Reverse Line Direction:  Leave unchecked unless you want all the lines to be reversed.   

Grid Name: Defined as the checked Lineset Name in Project Explorer.  The name is not 
editable in this dialog.  

Line Spacing: Enter the distance between the X grid lines. 

Offset from Current Origin: To set this value properly, it is important to understand that 
GFP_Edit uses the number at the end of the line name and the Line Spacing value to 
calculate the position of each line in the grid.   

For example, if lines are spaced 0.5 meters apart and the first line name ends with “1”, 
for example Line1, it is positioned at: 

Y Position = Line number * Line Spacing  

Y Position = 1 x 0.5 = 0.5 meters 
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Since it is usually desired that the first line in the grid is positioned at zero (0).  To do 
this, set the Offset from Current Origin value in the Y direction to: 

-(Line Number x Line Spacing)   

In the example above, Y = -0.5. 

 

 

Once the fields are filled in, press OK.  This opens a map view showing the position of 
all the lines in the grid: 

 

 

To save the new grid with the X lines, exit from GFP_Edit by clicking the X in the top 
right corner or using the File menu. 
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Adding Y Lines to a Large Grid 

From Project Explorer, notice the new grid folder containing the X lines.   

 

To add the Y Lines to the new grid, go back to the original Lineset and check all the 
GPR lines that go in the Y direction, in this example, Line 12 to Line 22.  

 

Select Add Checked Lines to Selected Grid, either by: 

1) right-clicking on the new Grid name in Project Explorer and selecting it from the 
menu or  

2) clicking on the new grid name and then selecting it from the Tools > Grid Tools 
menu.    
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The GFP_Edit utility program opens with a dialog with the following settings: 

Import Lines as: Select Y direction (see Grid Conventions). 

Reverse Line Direction:  Leave unchecked unless you want all the lines to be reversed.   

Grid Name: Defined as the selected Lineset Name in Project Explorer.  The name is not 
editable in this dialog.  

Line Spacing: Enter the distance between Y grid lines. 

To set the Offset from Current Origin, it is important to understand that GFP_Edit uses 
the number at the end of the line name and the Line Spacing value to calculate the 
position of each line in the grid.   

For example, if Y lines are spaced 0.5 meters apart and the first line name ends with 
“12”, for example Line12, it is positioned at: 

Y Position = Line number * Line Spacing  

Y Position = 12 x 0.5 = 6.0 meters 

It is usually desired that the grid first line is positioned at zero (0).  To do this, set the 
Offset from Current Origin value in the X direction to: 

-(Line Number x Line Spacing)   

In the example above, X = -6.0. 

 

 

 

Once the fields are filled in, press OK.  This opens a map view showing the position of 
the Y lines added to the grid: 
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Exit from GFP_Edit to save the new grid with the both the X and Y lines into Project 
Explorer.  You will see a grid folder in Project Explorer similar to this one: 
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 Edit Selected Grid 

To edit a grid, select it in Project Explorer and then select Edit Selected Grid by: 

1) right-clicking on the grid name in Project Explorer and selecting it from the menu, 
or  

2) clicking the grid name in Project Explorer and then selecting it from the Tools > 
Grid Tools menu.    

The GFP_Edit utility program opens: 

After making the desired modifications to the grid, close GFP_Edit using the X in the top 
right corner or from the file menu. EKKO_Project will show the modified grid. 

 

 

 

17.4.3.1 Selecting Grid Lines 

The grid lines to edit must be selected.  Grid lines are selected in the following ways: 

1) Select a single grid line by clicking on it in the table on the left or the map on the 
right. 
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2) Select multiple grid lines by: 

a.  Clicking on the first line name you want to select in the table and then 
pressing and holding the Shift key on your keyboard and clicking on the 
last line name you want to select in the table.  All the lines between the 
first and last are selected. 

 

b. Clicking a grid line name in the table (or the line on the map), and then 
pressing and holding the Ctrl key on your keyboard as you click on other 
lines names.  This allows you to, for example, select every second line in 
the grid. 
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c. Drawing a box in the map window by dragging and dropping the mouse 
cursor.  Any grid lines touched by the box are selected and appear in red. 

 

 

3) Select all Grid Lines using Edit > Select All Lines menu option or pressing the 
Ctrl-A. 

 

 

Grids can be edited in various ways described in the sections below: 

17.4.3.2 Deleting Grid Lines 

1) Select the grid lines to delete (see Selecting Grid Lines). 

2) Press the Delete key on the keyboard or select Edit > Delete Line(s) menu 
option. 

Note there is no warning message before the lines are deleted and there is no undo. 

17.4.3.3 Reversing Line Direction 

The option to reverse the line direction is used when grid lines were collected in a zigzag 
but either the user collected them as Line Scans, or they collected them as a Grid Scan 
but forgot to set the data collection pattern to Forward/Reverse. 
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Viewing the grid as a depth slice or a 3D view displays the lines in incorrect spatial 
positions, resulting in erroneous and un-interpretable data views. 

To remedy this situation: 

1) Select the grid lines collected in the reverse line direction (see Selecting Grid 
Lines).    

2) Select Edit > Edit GFP File or the Edit Selected Lines button on the 
Toolbar and go to the Orientation tab click the Start<->End button: 

 

 

Do not use Reverse Line Direction when grid lines were collected with a Noggin 
system in Grid mode with the Survey Format set to Forward/Reverse; the line 
positioning is correct without any editing of the line direction. 

17.4.3.4 Moving Grid Lines 
 

1. Select the line to reposition in the grid (see Selecting Grid Lines). 

2. Select:  

a. Edit > Edit GFP File or  
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b. the Edit Selected Lines button on the Toolbar  

c. Right -click on the line 

and go to the Position tab.    

3. Input the new XY position for the start of the line and press OK. 

 

It is possible to move multiple grid lines at once.  When multiple lines are selected, Xmin 
and Ymin define the minimum X and Y values. If a rectangle was drawn from all selected 
lines, Xmin and Ymin define the position of the lower left corner. In the example below, 6 
lines were moved +1.25m in the X direction and +0.5m in the Y direction. 

 
 
Lines can be moved to negative X or Y values but afterward, it may be necessary to 

redraw the map using the Fit to Window button  or by going to the View > Zoom > 
Fit to Window menu option. 
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17.4.3.5 Changing Grid Line Length 
 

The most common reason for changing the length of lines in a grid is to make all the 
lines in one direction of a rectangular grid or the all the lines in a square grid the same 
length.  Although grid lines may have been stopped at the same position at the far side 
of the grid, especially if the terrain is rough, the odometer wheel can skip and slide, 
resulting in lines that differ slightly in length.  Another reason is if the odometer 
calibration is off. 

1) Select the grid line(s) to change the length of (see Selecting Grid Lines).    

2) Select  

a. Edit > Edit GFP File or  

b. the Edit Selected Lines button on the Toolbar  

c. Right -click on the line 

and go to the Length tab.    

3) If more than one line is selected, the length of the longest line is displayed.  

4) Enter the new length for the line(s) and press OK.   

In the following example, the length of all the lines in the square grid are edited to be 5m 
long: 
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The line length is changed by recalculating the Step Size (the distance between traces). 
No traces are added to or deleted from the data file, only the position of each trace 
changes. 

17.4.3.6 Editing Grid Line Spacing 

If the distance between grid lines is incorrect, it can be edited, and the lines repositioned.   

1) Select the grid lines to change the Line Spacing between (see Selecting Grid 
Lines).    

2) Select  

a. Edit > Edit GFP File or  

b. the Edit Selected Lines button on the Toolbar  

and go to the Line Spacing tab.    

3) Enter the new Line Spacing for the line(s) and press OK.   

The following 5x5m grid was collected with the incorrect line spacing (1m instead of the 
correct 0.5m).   

 

Same, after correcting the Line Spacing to 0.5m. 
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17.4.3.7 Editing Grid Line Orientation 

A common mistake is to collect with the X and Y lines swapped or in a different 
quadrant.   

The Orientation tab is used to correct these sorts of mistakes, so the grid lines are 
positioned as if they were collected in the first quadrant.  This ensures that depth slices 
or 3D volumes created from the data are correctly oriented and not mirror image or off at 
right angles.   

Flip X and Flip Y tools are most commonly used to re-orient lines collected in a different 
quadrant than the first quadrant.  

Swapping X and Y Lines 

1) Select all the grid lines (see Selecting Grid Lines).    

2) Select Edit > Edit GFP File or the Edit Selected Lines button on the 
Toolbar and go to the Orientation tab.   

3) Click the X<->Y button to change the X lines to Y lines and the Y lines to X lines.  
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Flipping Y Lines 

1) Select all the Y lines (see Selecting Grid Lines).    

2) Select Edit > Edit GFP File or the Edit Selected Lines button on the 
Toolbar and go to the Orientation tab.   
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3) Click the Flip Y button to reverse the order of the Y lines. For example, if Y lines 
are numbered 0 to 9 from left to right on the map image, clicking Flip Y changes 
the order to 9 to 0 from left to right. 

 

 

Flipping X Lines 

1) Select all the X lines (see Selecting Grid Lines).    

2) Select Edit > Edit GFP File or the Edit Selected Lines button on the 
Toolbar and go to the Orientation tab.   

3) Click the Flip X button to reverse the order of the X lines. For example, if X lines 
are numbered 0 to 9 from bottom to top on the map image, clicking Flip Y 
changes the order to 9 to 0 from bottom to top. 

17.4.3.8 Changing the Step Size 

Changing the Step Size, the distance between traces, is another way of changing the 
length of the grid lines. 

1) Select the grid line(s) to change the step size of (see Selecting Grid Lines).    

2) Select Edit > Edit GFP File or the Edit Selected Lines button on the 
Toolbar and go to the Step Size tab.   

3) Enter the new step size for the line(s) and press OK.   

 Add Checked Lines to Selected Grid 

17.4.4.1 Adding One Line to a Grid 

From Project Explorer, check the GPR line to add to a grid.  
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In Project Explorer, select the grid to add the checked GPR line to.   

Select Add Checked Lines to Selected Grid by: 

1) right-clicking on the Grid name in Project Explorer and selecting it from the menu 
or  

2) Clicking on the Grid name in Project Explorer and then selecting it from the 
Tools > Grid Tools menu.    

The GFP_Edit utility program opens with a dialog with the following settings: 

 

Import Lines as: Set to X Lines or Y Lines depending on the line direction of the line 
being added to the grid. 

Reverse Line Direction:  Leave unchecked unless you want all the lines to be reversed.   

Grid Name: Defined as “selected Grid Name - Lineset Name of checked lines” in Project 
Explorer.  The name is not editable in this dialog.  

Offset from Current Origin: Set the X and Y values to the starting position of the line to 
add to the grid.   
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For example, if the line being added to the grid is a Y line that continues at the same line 
spacing as the grid (0.5m in this case), the last Y line is at X = 5.0, so the desired X 
position of the new line is X = 5.5. 

 

 

Once the fields are filled in, press OK.  This opens a map view showing the position of 
the new line added to the grid in red: 

 

 

Note that previous Grid name/lineset name is added to the beginning of the line name.  

After making the desired modifications to the grid, close GFP_Edit using the X in the top 
right corner or from the file menu. EKKO_Project will show the modified grid with the 
new Y line. 
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17.4.4.2 Adding Multiple Lines to a Grid 

From Project Explorer, check all the GPR lines to add to a grid.  

 

In Project Explorer, select the grid to add the checked GPR lines to.   

Select Add Checked Lines to Selected Grid, either by: 

1) right- clicking on the Grid name in Project Explorer and selecting it from the menu 
or  

2) clicking on the Grid name in Project Explorer and selecting it from the Tools > 
Grid Tools menu.    

The GFP_Edit utility program opens with a dialog with the following settings: 

 

Import Lines as: Set to X Lines or Y Lines depending on the line direction of the lines 
being added to the grid (see Grid Conventions).  

Reverse Line Direction:  Leave unchecked unless you want all the lines to be reversed.   

Line Spacing: Enter the distance between the new grid lines. 
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Offset from Current Origin: To set this value properly, it is important to understand that 
GFP_Edit uses the number at the end of the line name and the Line Spacing value to 
calculate the position of each line in the grid.   

For example, if lines are spaced 0.5 meters apart and the first line to add to the grid has 
a name that ends with “5”, for example Line5, as above, the calculated position is: 

Y Position = Line number * Line Spacing = 5 x 0.5 = 2.5 meters 

This calculated distance is in addition to the X or Y offset set in this field.   

In the example above, the last Y line is at X=5.0m.  If the lines being added to the grid 
are Y lines that continue at the same line spacing as the grid (0.5m in this case), the 
desired X position of each line is: 

Line5 at 5.5m 

Line6 at 6.0m 

Line7 at 6.5m 

Line8 at 7.0m 

Line9 at 7.5m 

Line5 at 8.0m 

The achieve this, the X value for the Offset from Current Origin must be set to: 

X = ((Desired X Position of first numbered line / Line Spacing) – First numbered Line 
Number) X Line Spacing 

In this example: 

X = ((5.5 / 0.5) - 5) X 0.5  

X = (11 – 5) X 0.5 

X = 3.0m 
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Once the fields are filled in, press OK.  This opens a map view showing the position of 
all the lines in the grid: 

 

After making the desired modifications to the grid, close GFP_Edit using the X in the top 
right corner or from the file menu. EKKO_Project will show the modified grid with the Y 
lines. 

 

17.4.4.3 Adding a Grid to a Grid 

From Project Explorer, check the GPR grid to add to a grid.  
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In Project Explorer, select the grid to add the checked GPR lines to.   

Select Add Checked Lines to Selected Grid, either by: 

1) right- clicking on the Grid name in Project Explorer and selecting it from the menu 
or  

2) clicking on the Grid name in Project Explorer and selecting it from the Tools > 
Grid Tools menu.    

The GFP_Edit utility program opens with a dialog with the following settings: 

 

Import Lines as: Leave it at the default X Lines & Y Lines setting. 

Reverse Line Direction:  Leave unchecked unless you want all the lines to be reversed.   

Line Spacing: Enter the distance between the grid in the checked grid. 

Offset from Current Origin: Set the X and Y values to the X=0, Y=0 corner of the 
checked grid to add to the selected grid.   

For example, to add the checked grid to X=5, Y=5, set these values in the Offset from 
current origin fields: 

 

Once the fields are filled in, press OK.  This opens a map view showing the position of 
all the lines in the grid: 
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Exit from GFP_Edit by clicking the X in the top right corner or from the File menu to save 
the new grid that combines both grids. 
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17.5 Report 

EKKO_Project can generate several reports from data at fiducial markers and 
interpretations added to the project data.  Reports are output in several formats including 
Adobe Acrobat (.pdf), Google Earth (.kmz), Comma Separated Values (.csv), and 
AutoCAD (.dxf) files.   

1. Click Tools > Report.  
 

 

  

2. In the drop-down list, select a report format:  

• GPR Summary Report (PDF) 

• Google Earth (KMZ) 

• Project Report (CSV) 

• CAD (DXF) 

• Bridge Deck Condition Report (PDF) 

• Pavement Structure Report (PDF) 
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 GPR Summary Report (PDF) 

The GPR Summary Report allows users to take data images saved of EKKO_Project 
windows, their own photographs and images and include them in a PDF report.   

Images saved from EKKO_Project windows include the Line Preview and MapView 
windows (see Save View) as well as images of windows from the optional LineView and 
SliceView modules.    

As well, for some newer GPR systems, such as the LMX200 Enhanced, screen captures 
saved in the field (by pressing the camera button) are also saved in the project file and 
are available for inclusion in the GPR Summary Report. 

To see a list of window images currently saved and available for the GPR Summary 
Report, select the project item in Project Explorer and then open the Attachments Tab. 

Photographs and other images attached to the project file, grid folder, lineset folder or 
individual GPR line in the project are available to include in the report. For details on 
attaching a file, see Attachments Tab. 

1. To generate a GPR Summary Report (pdf) click Tools > Report > GPR Summary 
Report. 
 

2. A dialog opens, displaying all the data images available to include in the report.  
Click on the images to include or click on the Select All checkbox in the bottom left 
corner to quickly include all the images. 
 

 
 

3. Once the desired images are selected, they appear in the bottom of the dialog.  
Change the order of the images by dragging and dropping them in the desired order 
for the report.  
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4. Select Generate Report button.  A preview of the report appears. 
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5. The Report preview is editable, with several fields automatically filled-in. Users can 
modify or add to the text fields.  The Site Description and Additional Comments 
fields allow pages of text to be added.  The title of each image can be edited from the 
default name and caption text added.  The caption text can multiple pages long. 
 

6. To add a Title Page to the report, select the Title Page checkbox. 
 

7. The report defaults to displaying one image per page.  If you’d like to display 2 
images per page, select 2 under Image Per Page. 
 

8. To add space for a Signature at the end of the report, check the Signature 
checkbox.  To add more than one signature, press the + button next to the Signature 
checkbox.   
 

9. If you want to make changes to the images in the report, select the Back button to 
move back to the previous screen.  Text entered in text boxes before pressing Back 
is saved. 
 

10. To save the current report and come back later to modify and finish it, press the 
Save Progress button. 
 

11. Scroll down to the end of the document to add text to the Conclusions section that 
appears on a separate page at the end.  If the Conclusion field is left blank, the PDF 
document will not include a conclusion page. 
 

12. The user can add their own logo to the top left-hand corner of the report by clicking 
on the “Click here to add logo” link and selecting an image file. 
 

 
 
The logo image is automatically remembered for that installation of EKKO_Project, 
so the logo file only must be selected once. 
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To clear the current logo image, select the Clear Logo button.   
13. When the editing of the report is complete, save the report as a PDF document by 

clicking the Generate PDF button.  Providing the computer has PDF reader software 
installed (it may be necessary to install Adobe Acrobat Reader from 
www.adobe.com), the PDF file opens. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Google Earth (KMZ) 

Projects containing GPR lines and grids collected using GPS can be written to a Google 
Earth (.kmz) report file and displayed in Google Earth. The following items can be written 
to the kmz file and displayed in Google Earth: 

• GPS path of GPR lines,  

• grids lines,  

• depth slices (both Line Slices and Grid Slices),  

• flags/fiducial markers added during data collection 

• field interpretations added during data collection,  

• Interpretations added in post-processing using the optional Interpretations 
Module in LineView).  

The elements written to the kmz file are determined by the items checked in Layer View.  

The items included in the Google Earth kmz file can enabled or disabled using the 
check-boxes in the Google Earth Places window. 

1. To generate a Google Earth (.kmz) report file for GPR lines in the project (.gpz) file 
with GPS, click Tools > Report > Google Earth. 
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2. A dialog opens to define the color and thickness of the GPS path when plotted on 
Google Earth: 
 

 

Use the dropdowns to select a new color or width. 

3. In the Save As folder, navigate to the folder you want to save the file to. 
4. Click Save. 

Google Earth opens to display a satellite image of the data collection site. 
 

 
 

Figure 12: Google Earth image of the data collection site with the GPR line survey path in red and utility 
point interpretations as pink and light blue dots. 

 Project Report (CSV) 

Flags/Fiducial markers and Field Interpretations are added to the data during data 
collection and Interpretations are added during post-processing using the optional 
Interpretation module in LineView.   
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Exporting the flags/fiducial markers and interpretations to spreadsheet-type files (.csv) 
allows you to transfer the information to third-party software applications such as Excel 
and Geographical Information Systems (GIS). 

Before adding interpretations, decide whether to plot data with a depth axis or an 
elevation axis.  

To include observation values in the report by elevation rather than depth, add the 
Interpretations after one of the following: 

• the GPR line has topographic data added that will not be changed 

• the GPR line is plotted with an elevation axis using a velocity value that will not be 
changed 

Note: Changing either of these conditions after adding interpretations shifts the 
vertical positions of the interpretations and is not recommended. 

Changing the depth or elevation axis velocity in LineView changes the depth and 
elevation values. 

 

1. To generate a Project Report, click Tools > Report > Project Report. 

Alternatively, from the Standard Toolbar, click . 
 

 

Figure 13: Select target folder for export 

2. In the Select target folder for the report dialog box, navigate to and then click the 
folder to save the report files to 

3. Click Select Folder. 
4. In the Report dialog box, enter the Polyline Output Interval (the horizontal distance 

between points on any polylines in the project).  Be realistic for the Polyline Output 
Interval.  For example, if you GPR line is 10,000 meters long, setting the Polyline 
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Output Interval to 0.01 meters will result in 1,000,000 sample points to analyze, 
probably exceeding the limits of most software programs. 

 
 
The Project Report Options dialog box opens whether polyline interpretations were 
added or not, if you do not have any polyline interpretations click OK to ignore the 
dialog. 

5. Click OK. 

A dialog box opens to display the folder that the .csv lines were saved to. 
 

 
 
The types of .csv files generated are: 

• .csv files for each interpretation 

• .csv files for each GPR line 

• A .csv file containing all interpretations sorted by interpretations 

• A .csv file containing all interpretations sorted by GPR line 

• A .csv file for all fiducial markers 
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Figure 14: Example of Project Report 

 

 CAD (DXF) 

Projects can be written to a CAD report (dxf) file. The path of the GPR grid lines, the 
GPS path for GPR lines collected with GPS, fiducial markers added during data 
collection, and post-processing point interpretations (using the Interpretation Module) are 
saved as layers in the DXF file.   

Exporting this information to a .dxf file allows you to transfer the information to third-party 
CAD programs.  The Voxler software, if available, reads .dxf files.  If necessary, free 
CAD (.dxf) file viewers can be found on-line. 

1. To generate a CAD (dxf) report file, click Tools > Report > CAD (DXF). 
2. Use the dropdown box in the dialog box to select the coordinate system to save with 

the DXF file: 
 

 
 
The options are Project (Local X, Y), or, if a local-global coordinate relationship has 
been established (usually by GPS data), UTM and Latitude-Longitude options are 
also available.   
 
UTM is usually selected to open the GPR report in AutoCAD programs while 
Latitude-Longitude is the choice for GIS programs.  When UTM or Latitude-
Longitude is selected, a projection file (.prj) is generated that lists the projection 
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details.  It is important to keep this file with the .dxf file when importing the data into 
third-party programs such as ArcGIS. 
 
The projection file always uses the WGS84 reference ellipsoid for UTM and 
latitude/longitude outputs. 
 

3. In the Save As folder, navigate to the folder you want to save the file to. 
 

4. Click Save. 
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 Bridge Deck Condition Report (PDF) 

If the optional Bridge Deck Condition Report module is enabled, projects containing GPR 
lines collected using GPS or grids where point interpretations have been added to rebar 
responses are processed to generate a Bridge Deck Condition Report.   

See the Bridge Deck Condition Report module User’s Guide for more details. 
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 Pavement Structure Report (PDF) 

If the optional Pavement Structure Report module is enabled, Projects containing GPR 
lines where polyline interpretations have been added are processed to generate a 
Pavement Structure Report.   

See the Pavement Structure Report module User’s Guide for more details. 
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17.6 Project Position Relationship 

The Project Position Relationship defines the relationship between the project 
coordinates and a global coordinate system. 

The Project Position Relationship menu has several options: 

 

 

This menu is also available in the Project Explorer Right Click menu. 

The Wizard takes the user step by step through manually adding global coordinates to a 
GPR project data.   

Note: The position of individual GPR lines or grid lines within the project cannot be 
modified by this Wizard.  For positioning individual GPR lines, use the Line Positioning 
routine.   

Auto (GPS based) defines the project-to-global relationship using the GPS files 
generated during data collection or manually created and attached.  

Undefine removes any previously-defined project-to-global relationship.  

Reset to North rotates the image so the North Arrow points up in MapView. 

 Wizard 

Use the Wizard option to manually define the relationship between the project (X, Y) 
coordinates and the global coordinates (Latitude-Longitude or UTM) of the GPR project 
data. 

Use the Wizard if: 

• GPS data were not collected for a GPR data grid but one or two GPS positions in 
the grid area are known; GPS positions for the entire grid can be calculated. 

• The automatic positioning of the grid using GPS files generated during data 
collection does not provide an accurate fit to the GPR data grid so you would like 
to manually enter GPS positions reference points to provide better positioning of 
the grid. 
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Step 1- Global Position Units 

 

Global Position Units are defined as Latitude-Longitude or UTM (Universal Transverse 
Mercator).  

1. Select Latitude-Longitude or UTM. UTM is the default. 

2. If UTM is selected, update the Zone Number field.  

3. If UTM is selected, in the Hemisphere drop-down list, click Northern or Southern. 

4. Select Next. 
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Step 2 – Project to Global Transformation – Primary Point 

Define a primary X, Y position in the Project coordinate system with a known global 
position in UTM or Latitude-Longitude. 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. In the Primary Point fields, enter the project X, Y coordinates for the point where 
the global position is known.   

The first time you select this option, the Project X, Y position defaults to the 
center of all the GPR grid data; this could be the center of one grid or several 
grids. If the user manually defines the project X, Y position, the wizard 
remembers these values the next time the Wizard is run.  Any X, Y point in the 
project coordinate system can be entered; X=0, Y=0 is popular.   

2. In the Global East or Long field enter the Easting or Longitude Global 
coordinates.  

In the Global North or Lat field enter the Northing or Latitude Global 
coordinates. 

UTM Northing and Easting values are always entered in meters and can be positive or 
negative.  

For example, the UTM values above position the X=0, Y=0 project coordinate point at 
Easting = 400567.058 meters and Northing = 3701368.032 in Zone 12 in the Northern 
hemisphere. 

Latitude and Longitude values are always entered in decimal degrees.  Latitudes north 
of the Equator are positive (+) values and south are negative (-) values. Longitudes east 
of the Prime Meridian (Greenwich) are positive (+) and west are negative (-).  
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Step 3 – Rotation Method 

The orientation of the project-to-global coordinate relationship can be set in two ways: 
 

1. Rotating using a Y-Axis heading, or  
2. Defining the global position of a second point in the project.  

 

 
 

Note: if you are simply moving the Primary Point to a new location and not changing the 
orientation, select the Finish but before selecting either of the rotation methods 
listed.   
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Step 4a – Y-Axis Heading 

Enter the Y-Axis Heading in degrees from 0 (zero) to 360 degrees. Angles are defined 
positive in the clockwise direction, for example, East is 90, South is 180, and West is 
270 degrees. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If the project-to-global coordinate relationship is acceptable, click Finish to save the new 
settings and exit the dialog.  

 

 

(x=0,y=0) 

North=0º 
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Step 4b – Secondary Point 

Define a secondary X, Y position in the Project coordinate system with a known global 
position in UTM or Latitude-Longitude. 

 

1. In the Secondary Point fields, enter the project X, Y coordinates for a second 
point where the global position is known.   

The first time you select this option, the Project position defaults to X=0, Y=0 but 
any X, Y point in the project coordinate system can be entered.   

2. In the Global East or Long field enter the Easting or Longitude Global 
coordinates.  

In the Global North or Lat field enter the Northing or Latitude Global 
coordinates. 

UTM Northing and Easting values are always entered in meters and can be positive or 
negative.  
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For example, the UTM values above position the X=0, Y=0 project coordinate point at 
Easting = 400570.150 meters and Northing = 3701376.755 in Zone 12 in the Northern 
hemisphere. 

 
 

Latitude and Longitude values are always entered in decimal degrees.  Latitudes north 
of the Equator are positive (+) values and south are negative (-) values. Longitudes east 
of the Prime Meridian (Greenwich) are positive (+) and west are negative (-).  

Note: The Primary and Secondary points are used to determine the heading only; the 
GPR data does not expand or contract to fit the data from the project coordinates to the 
global coordinates. The Primary Point, the heading from Primary to Secondary Point and 
the local positioning method used for the survey, typically an odometer, are used to 
position the grid in global coordinates.   

The Secondary point method is commonly used when GPS positions using a handheld 
GPS for two corners of the grid are collected out in the field.   

 

17.6.1.1 Using GPS Positions from Third-Party 
Sources 

Google Earth is a third-party source to obtain Global positions for the Primary and/or 
Secondary Points in the area of your grid.  Find the location of the GPR grid in Google 
Earth and then use the mouse cursor to find the GPS position for a particular point near 
or within the grid.  As the mouse cursor is moved around on the image, the global 
position is listed on bottom edge. 

To obtain better accuracy for points, use the Ruler option in Google Earth to change the 
mouse cursor from the default hand to cross-hairs. 

(x=0m,y=0m) = (609799.14 m Easting, 4831930.85m Northing) 

(x=10m,y=7m) = (609801.22 m Easting, 4831943.11m Northing) 

Secondary Point 

Primary Point 
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Global positions are entered as UTM or Latitude-Longitude in decimal degrees.  Google 
Earth usually displays in degrees-minutes-seconds but you can change the Google 
Earth display to decimal degrees or UTM under Tools > Options > 3D View Tab > 
Show Lat/Long.  

Extracting global positions from Google Earth is useful when a GPR grid was collected 
along a visible feature such as the edge of a sidewalk, building or road.   

Note: while this method ensures the data align with features visible in Google Earth, the 
absolute accuracy of the GPS coordinates is only as good as the Google Earth imagery 
placement, which can be several meters in some places. 

The Google Earth Ruler can also be used to help determine the Y Axis Heading.  If the 
Ruler function is set to degrees, it displays the Heading in degrees that the Heading 
dialog requires.   
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 Auto (GPS-based) 

Auto calculates the Project-to-Global coordinate relationship using GPS files in the 
project file. 

The Auto menu option is most commonly used to restore the original Project-to-Global 
relationship after altering it using the Wizard. 

Note: it is not recommended to have data in a project widely separated in space.  A 
warning is displayed if GPS files from different UTM zones are found because the 
positional accuracy decreases with increasing separation. 

Grids 

If a grid of GPR lines were collected with GPS, the Project-to-Global coordinate 
relationship is calculated by finding the “best fit” between the known positions of the grid 
lines and the GPS positions for those lines.  This calculation was automatically done 
when the project was opened or the grid was imported into EKKO_Project.   

The best-fit calculation minimizes the error between the grid lines and GPS but 
depending on the GPS accuracy and the correlation with the grid lines, a manual 
adjustment may be necessary in some cases.  Use the Wizard option to do this. 

GPR Lines 

When individual GPR lines in a Lineset are collected with GPS, the raw GPS positions 
are used to calculate the Project-to-Global coordinate relationship.   

 Undefine 

Undefine removes any previously-defined Project-to-Global coordinate relationship.  
When the Project-to-Global relationship is undefined, GPS coordinates are not displayed 
on the MapView Status Bar and you cannot generate Google Earth (KMZ) export slice 
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images to KMZ files for display in Google Earth (to learn more, see the SliceView User’s 
Guide). 

 Reset to North 

If the Compass Arrow in MapView (see MapView) is not set to North pointing upwards, 
selecting Reset to North rotates the data items in the MapView window so that North is 
upwards.   
 

 

17.7 Grid Position Relationship 

The Grid Position Relationship defines the relationship between the project coordinates 
and grids in the project. 

The Project Position Relationship menu has 2 options: 
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This menu is also available in the Project Explorer Right Click menu. 

The Wizard takes the user step by step through manually defining the relationship 
between the project coordinate and the grid coordinate systems.   

Note: The position of Linesets, individual GPR lines or grid lines within the project cannot 
be modified by this Wizard.  For individual GPR lines, use the Line Positioning routine 
(see Line Positioning). 

Auto (GPS based) defines the grid-to-project relationship using the GPS files generated 
during data collection or manually created and attached.  It is not accessible if there is 
no Project-to-Global relationship defined. 

 Wizard 

Use the Wizard option to manually position a grid in the project coordinate system.   

Step 1 – Primary Point 

Define a primary X, Y position in the grid coordinate system to define in the Project 
coordinate system. 

 

1. In the Primary Point fields, enter the project X, Y coordinates for the grid point.  
Select a grid point with the realization that any possible rotation of the grid is 
about this point.   

The Project position defaults to the XY position of the center of the grid if a 
Project-to-Global relationship has been defined by GPS files; otherwise, it 
defaults to X=0, Y=0.  Any X, Y point in the grid coordinate system can be 
entered.   

2. In the Project Points field, enter the project X, Y coordinates for the primary point.   

For example, the values above position the X=0, Y=0 grid coordinate point at project 
coordinate X=10, Y=10.   

Step 2 – Rotation Method 

The orientation of the grid can be set in two ways: 
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1. Rotating using a Y-Axis heading, or  
2. Defining the project position of a second point in the grid. 

 

 
 

Note: if you are simply moving the Primary Point to a new location and not changing the 
orientation, select the Finish but before selecting either of the rotation methods 
listed.   

Step 3a – Y-Axis Heading 

Enter the Y-Axis Heading in degrees from 0 (zero) to 360 degrees. Angles are defined 
positive in the clockwise direction, for example, East is 90, South is 180, and West is 
270 degrees. 

 

 

Enter the rotation angle and click Finish to save the new settings and exit the dialog.  
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For example, the two steps above moves the x=0, y=0 point of the grid to project 
position x=10, y=10 and the grid is rotated 45 degrees clockwise around the x=10, y=10 
point. 

 

 

 

 

 

 

 

 

 

Step 3b – Secondary Point 

Another way of rotating the grid is by defining the project position of a second point in 
the grid. . 

 

 

 

1. In the Secondary Point fields, enter the project X, Y coordinates for the grid point.  
Select a point with the realization that the grid will rotate based on the direction 
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from the first point to the second point.  Any X, Y point in the grid coordinate 
system can be entered.   

2. In the Project Points field, enter the project X, Y coordinates for the secondary 
point.   

Click Finish to save the new settings and exit the dialog.  

For example, the two steps above moves the x=0, y=0 point of the grid to project 
position x=10, y=10 and the grid is rotated based on secondary grid point x=5, y=5 
moving in the direction of project position x=20, y=10. 
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Note: The Primary and Secondary points are used to determine the heading only; the 
GPR grid does not expand or contract to fit the data from the grid coordinates to the 
project coordinates. The Primary Point, the heading from Primary to Secondary Point 
and the local positioning method used for the survey, typically an odometer, are used to 
position the grid in project coordinates.   

Positioning Multiple Grids 

The grid positioning methods shown above can be used to place more than one grid into 
the correct spatial location in the project space. 

 

 Auto (GPS-based) 

Auto calculates the Grid-to- Project coordinate relationship using GPS files in the project 
file. 

The Auto menu option is most commonly used to restore the original Grid-to- Project 
relationship after altering it using the Wizard. 

Auto is only accessible if a Project-to-Global relationship has been defined by GPS files. 

Note: it is not recommended to have data in a project widely separated in space.  A 
warning is displayed if GPS files from different UTM zones are found because the 
positional accuracy decreases with increasing separation. 

Grids 

If a grid of GPR lines were collected with GPS, the Grid-to- Project coordinate 
relationship is calculated by finding the “best fit” between the known positions of the grid 
lines and the GPS positions for those lines.  This calculation was automatically done 
when the project was opened or the grid was imported into EKKO_Project.   
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The best-fit calculation minimizes the error between the grid lines and GPS but 
depending on the GPS accuracy and the correlation with the grid lines, a manual 
adjustment may be necessary in some cases.  Use the Grid Position Relationship 
Wizard option to do this. 

17.8 Line Positioning 

Line Positioning defines the relationship between the project XY, Latitude/Longitude or 
UTM coordinates and a GPR line in the project. 

This menu is also available in the Project Explorer Right Click menu under Position 
Relationship. 

The Line Positioning menu has 3 options: 

 

 

Add opens a dialog to enter the position and direction of the selected GPR line.  The 
user can select to position the GPR line using project (XY), Latitude/Longitude or UTM 
coordinates.   
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The Settings option is available for a GPR line that has previously had Line Positioning 
added to it and allows the position to be modified. 

The Undefine option is available for GPR lines that have had Line Positioning added to 
them. 

Using GPS Positions from Third-Party Sources 

Google Earth is a third-party source to obtain Global positions for the Primary and/or 
Secondary Points for GPR lines.  See Using GPS Positions from Third-Party Sources for 
more information about Google Earth positions for Line Positioning. 

 

17.9 Process 

Requires the optional Processing module. 

Use the optional Processing module to edit and process GPR lines using various 
functions including repositioning, temporal and spatial filters, and migration.    

For more details, see the Processing module. 

17.10 Undo Process 

Requires the optional Processing module. 

Undo Process resets processed GPR lines to their original state before processing was 
applied to them. For more details, see the Processing module. 

17.11 Merge Lines 

Sometimes during data acquisition, a long, continuous GPR survey line is broken up into 
two or more pieces and saved as separate lines. Merge Lines is used to combine the 
data from two or more GPR lines into a single, separate line.  
 
In Project Explorer, check the GPR lines to be merged and then select Tools > Merge 
Lines. 
 
A dialog allows the merge order of the lines to be changed by selecting the line name 
and pressing the Up or Down buttons to move the line in the list.   
 
The name of the merged line defaults but can be edited. 
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Press OK to create the new merged line.  If all the lines came from the same folder, the 
new, merged line is saved to that folder.  If the lines came from different folders, the 
new, merged line is saved in a new lineset folder.   
 
If the merged line name conflicts with a line name already in the project, the new line is 
automatically appended with (2), (3) etc. 
 
Some of the restrictions/features of Merge Lines are: 
 

1. Lines cannot be merged together if any of the following survey parameters differ: 
a. Survey Type 
b. Frequency 
c. Time Sampling Interval 
d. Step Size 
e. Antenna Separation 

2. If the lines differ in Time Window length the merges the lines using the longest 
time window, padding data onto the bottom of lines with shorter time windows so 
no data is ever lost.   

3. If lines have a different First Break point number the largest first break point 
number from all the lines is used and other lines are padded at the top so that no 
data is lost during the merge operation. 

4. Traces are not shifted for differences in the First Break values between lines. It is 
best to run repick the First Break after merging the lines together so the first 
break is consistent.   

5. The Start Position of the new merged line is the same as the Start Position of the 
first line in the merge list.   

6. The number of Stacks of the new merged line is the same as the number of 
Stacks of the first line in the merge list. 

7. Lines with interpretations can be merged. 
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A list of lines used to create a merged line can be seen by selecting the line in the 
Project Explorer, and then selecting the Acquisition tab and expanding Additional 
Info. 

17.12 GPS 

The GPS menu has 3 options: 

 

 

The Survey Line offset and Latency time are used to determine which trace of the GPR 
line correlates to a given GPS position. 

 GPS Latency 

The GPS latency time is the time difference between when the GPS receiver obtains its 
position and when it logged by the DVL. If GPS latency time is not corrected for, the 
GPS position of targets and features of interest in the GPR line is less accurate. 

GPS latency is not a large problem when GPR data are collected on slow-moving 
platforms such as the SmartCart or SmartTow; it has the largest effect when trying to 
determine the true position of a fast-moving platform such as the SmartChariot. 

For example, at 25 kph, you are moving 6.94m per second. If the GPS has 1.00 second 
latency, your data position would be off by 6.94m.  Further, if you also collect data in 
opposite direction (i.e. north and south adjacent lanes) the positional offset on a linear 
target such as a buried utility that spans both lanes would be off by 6.94 x 2 = almost 
14m. 
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The latency time will vary by GPS, and data logger hardware/software and can be 
calculated and input in this dialog.  

See Appendix C: GPS Latency Procedure for calculating the GPS latency time for your 
system. 

 GPS Offset 

Offset defines the X, Y and Z offset distances between the center of the GPR system (or 
antennas, if using a low frequency) and the GPS. These distances are necessary to 
correct the position of the GPS if it is offset from the GPR. 

 

 

This option displays a diagram that defines the co-ordinate system for the GPS X, Y and 
Z offset values.  
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Lateral (X) 

X (or Lateral) is the distance, left or right of the survey line direction, from the GPR to the 
GPS Antenna. Looking in the survey line direction, the distance is positive if the GPS 
receiver is to the right of the GPR and negative if it is to the left of the GPR. 

Survey Line (Y) 

Y (or Survey Line) is the distance from the GPR to the GPS receiver in the survey line 
direction. The distance is positive if the GPS receiver is ahead of the GPR and negative 
if it is behind the GPR. 

Height (Z) 

Z (or Height) is the height of the GPS receiver above the GPR. 

Example 

When a GPR system collects data using a SmartChariot, the GPS is offset +0.50 meters 
in the Survey Line (Y) direction and +0.50 meters in height (Z).   
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17.13 Add Background Images to MapView 

To add a background image to MapView, select Tools > Add background image to 
MapView.  The dialog below appears. 

 /  

The simplest way to add a background image to MapView is to navigate to and select 
the image and press OK.  The image appears in MapView with a handle in the top left 
corner to rotate it, a handle on the bottom right corner to move it, handles in the bottom 
left and top right corners to resize it and handles along the four sides to stretch it in any 
direction. 

 

Rotate 
Resize 

Resize 

Move 

Stretch
te 

Stretch
ate 

Stretch
te 

Stretch
te 
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There are also more advanced ways to add the background image.  Check the 
Advanced checkbox to add the image using Project, Latitude/Longitude or UTM 
coordinates.  

After selecting the type of coordinates (Project, Latitude/Longitude or UTM), input the 
values for the lower left and upper right corners of the image: 
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Note that more than one background image can be added.  This allows images to be 

stacked on top of one another or spread out to different areas of MapView.  Use the 

checkboxes in the Layer View window to select which images to display in MapView.  

When multiple images are displayed, the images are ordered alphabetically with the last 

image plotted on top.  In other words, if an image called “zoo” plots on top of an image 

called “apple”.  Use the Layer View > Background Image right-click menu (Layer View) 

to edit the image names to plot them in a particular order.  

 

 

If the image has a percentage of transparency, images underneath it will be partially 

visible. 
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18 Window Menu 
To open the Window menu drop-down list, click Window: 

18.1 Open Line Preview 

If the Line Preview window was closed, it can be opened by selecting Window > Open 
Line Preview. 

18.2 Open MapView 

If the MapView window was closed, it can be opened by selecting Window > Open 
MapView. 

18.3 3D Preview 

If the 3D Preview window was closed, select a grid in Project Explorer and then select 
Window > Open 3D Preview. 

18.4 Tile Horizontally 

Selecting Window > Tile Horizontally will arrange the Line Preview and MapView 
windows (and the 3D Preview window, if displaying Conquest grid data) so they are tiled 
horizontally in the space between the other windows open on the screen.   
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18.5 Tile Vertically 

Selecting Window > Tile Vertically will arrange the Line Preview and MapView 
windows (and the 3D Preview window, if displaying Conquest grid data) so they are tiled 
horizontally in the space between the other windows open on the screen. 
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19  Help Menu 
To open the Help menu drop-down list, click Help: 

 

 

19.1 About EKKO_Project 

This option displays the EKKO_Project version number, a description, and ownership 
information. 

19.2 User’s Guides 

Select this option to open the PDF document for EKKO_Project or one of the 
EKKO_Project Modules.  

 

 

Adobe Acrobat Reader must be installed on your PC to open this document. If not, you 
can download it from the Adobe website. 

All user’s guides can be opened, even if the optional module was not purchased. 

19.3 Restore Factory Defaults 

Click Restore Factory Defaults to reset all the windows, dockable windows, menus, 
and toolbars to their default values.   

Note: Restoring automatically closes EKKO_Project, so you must save your project 
first, and then re-open EP for the restoration to take effect 
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19.4 Product Improvement Program 

You can help us improve EKKO_Project by participating in our Product Improvement 
Program.  To help us understand how our customers use our products we collect 
statistics on which features are used. Any information collected is completely 
anonymous - no information that could identify the user is collected.   

To help our development team improve our software programs, we collect usage data, 
and that data is stored within our private and secure databases. 

The data we collect provides statistics on which features are used (or not used). This 
helps us better understand the needs of our users so we can build better applications. 

The information is completely anonymous – it is not traceable to any individual, project 
or organization, and does not contain any personal information. Participation is 
voluntary, and you can enable or disable this at any time under the Help menu in 
EKKO_Project.  

If you have additional questions about our Product Improvement Program or have any 
feedback on our products, please email us at customerservice@sensoft.ca 

19.5 EKKO_Project and Module Registration 

The Product Registration dialog allows you to enter a License Key, request a License 
Key, request a trial License Key or transfer a License to a different computer. 

 For more details see the System Documentation and Software Installation 
document. 

19.6 Contact Us 

Displays contact information for Sensors & Software including mailing address, email 
addresses, website, and phone and fax numbers. 
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20 Window Operations 
EKKO_Project can display multiple panes on the main screen, but only one pane can be 
active and accept changes at one time.  

20.1 Resizing the EKKO_Project Window 

If an EKKO_Project pane is not maximized (full screen), you can resize it by clicking and 
dragging any frame or corner to the size you require.  

 

Figure 15: Click and drag a Project Explorer or Properties window to change its dimensions. 

Note: As the size of the window changes, the information in the window will distort to 
fit the window size. If the window is made too small, the pane may close completely; 
click and drag the frame to re-open it. 

20.2 Undocking and Docking Windows 

1. To undock the Project Explorer and Properties  panes from the edge of the screen, 
click and drag the window’s title banner.  

2. Drop the window at any location, or dock it on any edge of EKKO_Project. 

Arrow icons ( ) appear on the screen to indicate where (top, bottom, left, or right 
edge) the pane can be docked.  

3. Drag the title banner to the icon and drop the window to dock it in the indicated 
position.  
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Note: It is a best practice to dock windows. 

 

Figure 16: Example of moving the Project Explorer. Note the docking arrows. 

20.3 Pinning Windows 

To pin a docked Project Explorer or Properties pane to the side of EKKO_Project, in the 
pane’s title bar, click the Pin icon ( ).  

 

Figure 17: Example of pinning a window 

• To expand these panes to their original size, click the pane and then click the pin 
icon to pin the window back into position. 
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20.4 Closing a Window 

• To close a window, press close ( )  

• To reopen a closed window, in the menu bar, click View > Toolbars and Docking 
Windows 

20.5 Adding or Removing Buttons from 

Toolbars 

Use the Add and Remove buttons to edit the toolbars.  

 Standard Toolbar 

1. To manage what appears in the Standard toolbar, click the drop-down arrow beside 

the Help icon . 

 

2. Click Add or Remove Buttons > Standard. 

 

3. To display an icon in the Standard toolbar, click beside the button to display 
checkmark icon. 

• To restore the Standard toolbar to the factory default settings, click Reset Toolbar. 
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• To tailor the Standard toolbar to better suit your need, click Customize > Toolbars 
tab. 

 View Control Toolbar 

1. To manage what appears in the View Control toolbar, click the drop-down arrow 

beside the Export View to File icon . 
 

 
 

2. Click Add or Remove Buttons > View Control. 

 

3. To display an icon in the View Control toolbar, click beside the button to display 
checkmark icon. 

• To restore the View Control toolbar to the factory default settings, click Reset 
Toolbar. 

• To tailor the View Control toolbar to better suit your need, click Customize > > 
Toolbars tab. 
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 File Formats 

1. Interpretation Reports 

The following information is written to the Interpretation Report: 

• Header: lists the Interpretation Names and count of observations for each 
interpretation 

• Drawing Tool 

• Interpretation Name 

• GPR Line Name 

• Position along Line (m or ft.) 

• X Position (m or ft.) 

• Y Position (if grid data) 

• Depth (m or ft.) 

• Time (ns) 

• Elevation (if available, m or ft.) 

• Signal Amplitude (millivolts) 

• Velocity (ft/ns or m/ns): Velocity is used to calculate depth and elevation. 

• UTM Easting with Zone 

• UTM Northing with Zone 

• Latitude (degrees and decimal degrees; + = North, - = South) 

• Longitude (degrees and decimal degrees; + = East, - = West) 

• GPS Elevation of the GPS receiver 

• Comments 

 

In a box interpretation, the positions of the upper-left and bottom-right corners are listed.  
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2. Global Positioning Files 

The Global Positioning System (GPS) uses special satellites around the Earth to 
determine the position of a GPS receiver located at any position on the surface of the 
Earth. GPS receivers can be purchased from a number of manufacturers. 
 
Sensors & Software GPR systems have a serial port for attaching a GPS receiver to 
record the position of the GPR unit. This port will accommodate any GPS receiver that 
has a standard serial port output.  
 
The GPS receiver sends one or more types of data strings to the GPR. These strings, 
called NMEA-0183 strings, contain positional and other information in specific formats. 
Each type of string is specified by a 5-character prefix. There are numerous NMEA 
strings but to integrate the GPS data into the GPR data, the GPS receiver must be 
sending the GPGGA string.  This may require reprogramming the GPS receiver; most 
systems come with PC-based utility software. 

3. GPS 

The .GPS file format consists of a line listing the GPR trace number and the position 
based on the odometer and the step size, followed by one or more NMEA strings.  The 
GPGGA string must be included in this list. 
Depending on the version of the embedded data acquisition software, the trace number 
lines may have every trace, every nth trace or a somewhat random interval between 
trace numbers.   
 
Trace #2 at position 0.050000 
$GPGGA,185721.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-35.1,M,,138*68 
$GPGSA,A,3,15,05,18,21,26,29,51,02,08,,,,2.3,1.2,1.9*32 
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D 
Trace #3 at position 0.100000 
$GPGGA,185731.00,4337.9926,N,07938.2534,W,2,09,1.2,110.3,M,-35.1,M,,138*6F 
$GPGSA,A,3,26,18,05,21,15,29,08,02,51,,,,2.3,1.2,1.9*32 
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D 
Trace #4 at position 0.150000 
$GPGGA,185732.00,4337.9926,N,07938.2534,W,2,09,1.2,110.4,M,-35.1,M,,138*6B 
$GPGSA,A,3,21,15,26,29,18,05,51,02,08,,,,2.3,1.2,1.9*32 
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D 
Trace #5 at position 0.200000 
$GPGGA,185733.00,4337.9926,N,07938.2534,W,2,09,1.2,110.4,M,-35.1,M,,138*6A 
$GPGSA,A,3,21,51,26,29,15,18,05,02,08,,,,2.3,1.2,1.9*32 
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D 
Trace #8 at position 0.350000 
$GPGGA,185734.00,4337.9926,N,07938.2534,W,2,09,1.2,110.4,M,-35.1,M,1,138*5C 
$GPGSA,A,3,21,15,26,29,51,18,05,02,08,,,,2.3,1.2,1.9*32 
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D 
Trace #12 at position 0.550000 
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4. GP2 

The .GP2 file format consists of 5 header lines, then a line that defines the parameters 
listed on each line for the rest of the file: 
 
Trace number 
Number of odometer ticks 
GPR line position (based on odometer ticks, odometer calibration value and step size) 
Time elapsed in seconds since the start of the data collection 
GPS NMEA string in quotes 
 
Any NMEA strings output by the GPS receiver are listed.  The GPGGA string is required 
to be in the list. 
 
;GPS@@@ 
;Ver=1.1.0 
;DIP=2009-00152-00 
;Date=2012-Jan-09 13:56:16.0 
;--------------------------------------------- 
traces,odo_tick,pos(m),time_elapsed(s),GPS 
1,0,0.000,0.00,"$GPGGA,185713.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,,138*69" 
1,0,0.000,0.00,"$GPGSA,A,3,15,21,29,51,26,18,08,02,05,,,,2.3,1.2,1.9*32" 
1,0,0.000,0.00,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,1,0.001,0.60,"$GPGGA,185714.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,,138*6E" 
1,1,0.001,0.60,"$GPGSA,A,3,15,29,21,26,18,05,08,02,51,,,,2.3,1.2,1.9*32" 
1,1,0.001,0.60,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,3,0.003,1.59,"$GPGGA,185715.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,,138*6F" 
1,3,0.003,1.59,"$GPGSA,A,3,18,21,05,26,29,15,08,02,51,,,,2.3,1.2,1.9*32" 
1,3,0.003,1.59,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,2,0.002,2.58,"$GPGGA,185716.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,1,138*5D" 
1,2,0.002,2.58,"$GPGSA,A,3,05,21,15,18,26,29,08,02,51,,,,2.3,1.2,1.9*32" 
1,2,0.002,2.58,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,3,0.003,3.63,"$GPGGA,185717.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,2,138*5F" 
1,3,0.003,3.63,"$GPGSA,A,3,21,26,15,29,18,05,08,02,51,,,,2.3,1.2,1.9*32" 
1,3,0.003,3.63,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,5,0.005,4.61,"$GPGGA,185718.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,3,138*51" 
1,5,0.005,4.61,"$GPGSA,A,3,18,21,26,29,05,15,08,02,51,,,,2.3,1.2,1.9*32" 
1,5,0.005,4.61,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,6,0.006,5.60,"$GPGGA,185719.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,,138*63" 
1,6,0.006,5.60,"$GPGSA,A,3,21,18,15,05,29,26,08,02,51,,,,2.3,1.2,1.9*32" 
1,6,0.006,5.60,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,10,0.009,6.59,"$GPGGA,185720.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,,138*69" 
1,10,0.009,6.59,"$GPGSA,A,3,18,21,15,05,26,29,08,02,51,,,,2.3,1.2,1.9*32" 
1,10,0.009,6.59,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
1,20,0.019,7.58,"$GPGGA,185721.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-
35.1,M,,138*68" 
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1,20,0.019,7.58,"$GPGSA,A,3,15,05,18,21,26,29,51,02,08,,,,2.3,1.2,1.9*32" 
1,20,0.019,7.58,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D" 
 

The last characters (before the quote symbol) in the NMEA string is the checksum.  The 
checksum is the xor of each byte between the $ and *.  NMEA lines with a failed 
checksum are assumed to be corrupt and not recorded. 

5. DT1 and HD 

Sensors & Software GPR data lines consist of two files, a Header file and a Data file.  
The files have the same name but different extensions.  The format details of these files 
are given below. 
 
Header (.HD) File: 
 
The header file, identified by the file extension .HD, is an ASCII file. An example is 
shown below.  The heading identifies what each piece of information represents. 
 
1234 

 

Data Collected with Noggin Plus 

12/10/2000  

NUMBER OF TRACES   = 220  

NUMBER OF PTS/TRC  = 156  

TIMEZERO AT POINT  = 31  

TOTAL TIME WINDOW  = 62  

STARTING POSITION  = 0.0000  

FINAL POSITION     = 10.9500  

STEP SIZE USED     = 0.0500  

POSITION UNITS     = m  

NOMINAL FREQUENCY  = 250.00  

ANTENNA SEPARATION = 0.3048  

PULSER VOLTAGE (V) = 100  

NUMBER OF STACKS   = 4  

SURVEY MODE        = Reflection  

 

This file can be read and/or printed using any Word Processor. 
 
Data (.DT1) File: 
 
The data file contains as many records as there are traces. Each record in turn consists 
of a header section and a data section. The header section consists of an array of 25 
real*4 numbers and a string of 28 characters which is used for annotation. The 25-
element real array contains the following information: 
 
 Item # Description 
 
 1 Trace number 
 2 Position 
 3 Number of points per trace 
 4 Topographic data, if available 
 5 (not used) 
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 6 # bytes/point (always 2 for Rev 3 firmware) 
 7 Time Window 

8 # of stacks 
 

9-10 reserved for GPS X position (double*8 number) 
11-12 reserved for GPS Y position (double*8 number) 
13-14 reserved for GPS Z position (double*8 number) 

 
 15 reserved for receiver x position 
 16 reserved for receiver y position 
 17 reserved for receiver z position 
 18 reserved for transmitter x position 
 19 reserved for transmitter y position 
 20 reserved for transmitter z position 
 21 timezero adjustment 
  where:point(x)= point(x+adjustment) 
 22 Zero flag: 0 = data okay, 1=zero data 
 23 (not used) 
 24 Time of day data collected in seconds past midnight. 
 25 Comment flag: 1 = comment attached. 
 26 - 32 Comment 
 
The data section consists of an array of two-byte integers, one value for every data 
point. 

 

6. SEG-Y 

The following describes in detail which variables are loaded in the SEG-Y conversion 
program. 
 
Reel Identification Header - ASCII Portion 
 
The reel identification header is first loaded with the GPR header file (*.HD). 
This file is copied directly into the ASCII portion. 
 
Reel Identification Header - Binary Portion 
 
The following lists the variables used in the binary portion. 
 
Bytes Description 
3201-3204 Set to zero. 
3205-3208 Set to zero. 
3209-3212 Set to zero. 
3213-3214 Set to one for REFLECTION data. 
Set to # of  offsets for CDP data. 
3215-3216 Set to zero. 
3217-3218 Sample interval down trace in psec. 
3219-3220 Sample interval down trace in psec. 
3221-3222 Number of points in trace. 
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3223-3224 Number of points in trace. 
3225-3226 Set to three (fixed point 2 bytes). 
3227-3228 CDP fold. Set to zero for REFLECTION data. Set to # offsets for 

CDP data. 
3229-3230 Trace Sorting Code. Set to three for single fold data. Set to one for 

multifold data. 
3231-3250 Not used. 
3251-3252 Set to two (no binary gain recovery). 
3253-3254 Set to one (no amplitude recovery method). 
3255-3256 Set to 1 or 2 depending on units used. 
3257-3258 Not used. 
3259-3260 Not used. 
3261-3600 Not used or NON STANDARD (see the following). 
 
Non-Standard 
 
Bytes Description 
3261-3262  Number of traces (I*2) 
3401-3410  Job number (CHAR*10) 
3411-3480  Title 1 (CHAR*70) 
3481-3550  Title 2 (CHAR*70) 
3551-3570  Date (CHAR*20) 
3571-3572  Number of stacks (I*2) 
3573-3574  Pulser voltage (I*2) 
3575-3594  Survey mode (CHAR*20) 
3595-3598  Frequency (R*4) 
3599-3600  Dewow (I*2) (0-NOT DONE 1-DONE) 
 
The following lists the variables used in the binary portion. 
 
Bytes Description 
 
1-4  Trace number from 1 to number of traces. 
5-8  Trace number from 1 to number of traces. 
9-12  Tape record number 1 to number of traces. 
13-16  Set to one. 
17-20  Not used. 
21-24  CDP ensemble number. 
25-28  Trace # within CDP. (one for REFLECTION data) 
29-30  Set to one. 
31-32  Set to one. 
33-34  Set to one. 
35-36  Set to one. 
37-40  Antenna sep. times 1000. (Not official SEG-Y format) 
41-44  Receiver Elevation data times 1000. 
45-48  Transmitter Elevation data times 1000. 
49-68  Set to zero. 
69-70  Set to -1000. 
71-72  Set to -1000. 
73-76  Transmitter x-coord times 1000. 
77-80  Transmitter y-coord (set to zero). 
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81-84  Receiver x-coord times 1000. 
85-88  Receiver y-coord (set to zero). 
89-104  Not used. 
105-106  Timezero in ns. 
107-114  Not used. 
115-116  Number of points in trace. 
117-118  Sample interval in psec. 
119-120  Set to one. 
121-240  Not used. 
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7. Topography Files 

• Each line of text must contain a pair of numbers representing position along the GPR 
line and elevation. 

• These numbers can be separated by a space or a tab. 

• The range of topographic information does not have to correspond exactly to the 
range of positions in the GPR line. Positions lying outside the range of available 
topographic data will be assigned to the elevation of the nearest endpoint. 

• Since linear interpolation is used to obtain the elevation at each trace position it is 
not necessary to have an elevation for every trace in the file. Topographic data can 
be added to a GPR line with as little as two position and elevation pairs (in the case 
of a constant slope). The more data points entered, the more detail there will be in 
the topographic correction. 

• Topographic files must have a .top extension. 

0.0 935.8 

10.1 933.9 

22.7 930.3 

30.5 932.7 

34.6 936.5 

Topography files are text files that are easily created using Windows Notepad, which 
defaults to a .txt file extension  

To change the Notepad default to a .top extension: 

1. In Notepad click File > Save As. 
2. In the Save as dialog box in the Save as type drop-down list, click All Files. 
3. In the File name text box, typing file name and append it with the .top extension.  

For example, Line87.top. 
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 Calculating GPS Latency 
 

1. Choose a large outdoor area with a clear view of the sky, like a parking lot. 

2. In the center of the area, place a metallic disk, roughly 1 ft in diameter. You can 

use a foil covered piece of cardboard. It is advised that the disk be taped down 

so that it does not move. 

3. Set up your GPR to collect GPS data as well. Make sure that the GPS is 

centered directly over top of the GPR unit (as shown below). 

4. Set GPR recording Depth to 0.50m (10.1ns) so that data can be collected quickly 

without skipping traces. 

5. Start a new line and collect data running over the disk in a flower pattern (see 

figure below). Try to run over the disk in as many different directions and as 

many different speeds as you can. The faster the data are collected over the 

plate, the more accurate the latency value will be. 

*Make sure no traces are skipped. 
 

 
 

6. Export the GPZ data from the flash memory card and open it in the 

EKKO_Project software. MapView should display your GPS path like this: 
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7. Double click the line name in the Project Explorer to open in LineView. Each time 

you ran over the disk you should see a disturbance in the direct wave like this: 
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8. Create a new Point type interpretation. 

Note: If the Interpretation module is not enabled, use the mouse cursor and 

the F8 key for steps 8 to 13.  Pressing the F8 key with the mouse cursor on 

the disk response in the GPR line saves the position information to the 

Clipboard.  Copy the position information of each disturbance to a csv file. 

 
 

9. Scroll through the line and enter and add an observation at the center of each of 

the disturbances. The vertical placement of the observation is not important. 
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10. Close LineView.  Now you should see all of the observations clustered near the 

center of the flower pattern in MapView. 

 
 

11. Run the Project Report under File > Report > Project Report, make a new 

folder called 0s_latency and save the report inside. 

12. Go to Tools > GPS > Latency and set it to 1 second, click OK. 

13. Run the Project Report again under File > Report > Project Report, make a 

new folder called 1s_latency and save the report inside. 
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14. Open a new spreadsheet in Excel. Copy and paste the UTM coordinates from 

the two project reports into the columns of the new spreadsheet. 

0s Latency Set 1s Latency Set 

Easting Northing Easting Northing 

609895.67 4831925.06 609895.1 4831924.38 

609895.55 4831924.67 609895.69 4831926.31 

609895.36 4831925.25 609897.68 4831923.17 

609896.07 4831924.94 609892.26 4831924.66 

609895.51 4831924.85 609896.8 4831925.95 

609895.65 4831925.42 609896.04 4831922.3 

609895.77 4831924.83 609894.77 4831925.44 

609895.1 4831925.07 609899.3 4831925.17 

 

15. In the column to the right, calculate the speed in each axis by differencing the 

Eastings and the Northings. So Speed in Easting is Easting at 0s latency – 

Easting at 1s latency 

0s Latency Set 1s Latency Set Speed  

Easting Northing Easting Northing Easting Northing 

609895.67 4831925.06 609895.1 4831924.38 0.57 0.68 

609895.55 4831924.67 609895.69 4831926.31 -0.14 -1.64 

609895.36 4831925.25 609897.68 4831923.17 -2.32 2.08 

609896.07 4831924.94 609892.26 4831924.66 3.81 0.28 

609895.51 4831924.85 609896.8 4831925.95 -1.29 -1.1 

609895.65 4831925.42 609896.04 4831922.3 -0.39 3.12 

609895.77 4831924.83 609894.77 4831925.44 1 -0.61 

609895.1 4831925.07 609899.3 4831925.17 -4.2 -0.1 

 
16. In the next two columns calculate a corrected Easting and Northing based on 

some defined latency value. So the Corrected Easting is Easting at 0s latency – 

Speed_Easting * Latency_s (0s,1s) 
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17. Calculate the standard deviation of each of the corrected axes (Easting and 

Northing) and then calculate the average standard deviation: 

0s Latency Set 1s Latency Set Speed  Latency 0 

Easting Northing Easting Northing Easting Northing Corrected Easting 
Corrected 
Northing 

609895.67 4831925.06 609895.1 4831924.38 0.57 0.68 609895.67 4831925.06 

609895.55 4831924.67 609895.69 4831926.31 -0.14 -1.64 609895.55 4831924.67 

609895.36 4831925.25 609897.68 4831923.17 -2.32 2.08 609895.36 4831925.25 

609896.07 4831924.94 609892.26 4831924.66 3.81 0.28 609896.07 4831924.94 

609895.51 4831924.85 609896.8 4831925.95 -1.29 -1.1 609895.51 4831924.85 

609895.65 4831925.42 609896.04 4831922.3 -0.39 3.12 609895.65 4831925.42 

609895.77 4831924.83 609894.77 4831925.44 1 -0.61 609895.77 4831924.83 

609895.1 4831925.07 609899.3 4831925.17 -4.2 -0.1 609895.1 4831925.07 

    Standard Deviation: 0.286256628 0.242100186 

    Avg Standard Deviation: 0.264178407  

 
18. Now adjust the Latency value (in red) to minimize the Avg Standard Deviation 

0s Latency Set 1s Latency Set Speed  Latency 0.125 

Easting Northing Easting Northing Easting Northing 
Corrected 
Easting 

Corrected 
Northing 

609895.67 4831925.06 609895.1 4831924.38 0.57 0.68 609895.5988 4831924.975 

609895.55 4831924.67 609895.69 4831926.31 -0.14 -1.64 609895.5675 4831924.875 

609895.36 4831925.25 609897.68 4831923.17 -2.32 2.08 609895.65 4831924.99 

609896.07 4831924.94 609892.26 4831924.66 3.81 0.28 609895.5938 4831924.905 

609895.51 4831924.85 609896.8 4831925.95 -1.29 -1.1 609895.6713 4831924.988 

609895.65 4831925.42 609896.04 4831922.3 -0.39 3.12 609895.6988 4831925.03 

609895.77 4831924.83 609894.77 4831925.44 1 -0.61 609895.645 4831924.906 

609895.1 4831925.07 609899.3 4831925.17 -4.2 -0.1 609895.625 4831925.083 

    Standard Deviation: 0.043527495 0.069991828 
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    Avg Standard Deviation: 0.056759662  

 

19. Once you have found the minimum Average Standard Deviation, this is the 

latency value to use for this GPS unit. 

 

  



EKKO_Project User’s Guide Window Operations 

 

 
208 
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 Glossary 

1. Definitions 

Term Description 

Attenuation Represents the radar wave attenuation given in decibels/meter. 

The higher the attenuation value, the faster the exponential function 

rises the more gain applied at earlier times on the GPR Line. 

Attributes Characteristics derived from original data. Examples are the average 

amplitude of the dominant frequency between two times or depths. 

Automatic Gain Control 

(AGC) 

The Automatic Gain Control (AGC) gain attempts to equalize the 

amplitudes of all GPR signals by applying a gain which is inversely 

proportional to the signal strength. 

This type of gain is most useful for defining continuity of reflecting 

events. 

Average Frequency 

Spectrum (AFS) 

Use AFS plots to determine the frequency of a signal on which to 

base processing and filtering, similar to band-pass.  

Average Trace 

Amplitude (ATA) 

The Average Trace Amplitude (ATA) plot displays the average signal 

amplitudes (in microvolts) for an entire data file. 

This plot is a good way to display how rapidly the signal amplitude 

decays to the background level, giving you an idea of the maximum 

penetration for the data file. 

Background Average 

Subtraction (BAS) 

Use BAS to subtract the average trace of the entire GPR line from 

every trace in the line. 

This process enhances dipping events (such as hyperbolas from 

point targets) and removes horizontal responses common to all 

traces in the line. It is also used to remove the direct air and direct 

ground waves (transmit pulse) visible at the top of the line. BAS also 

removes horizontal bands in the data present throughout the length 

of the line.  

Background Subtraction Use Background Subtraction to apply a running-average background 

subtraction to the data set. This process enhances dipping events 

(such as hyperbolas from point targets) and suppresses or 

completely removes horizontal responses. This can be very useful 

for removing localized flat-lying events. 

Bandpass Filter Use bandpass filtering when the GPR signal is contained in a 

defined band of frequencies and there is "noise" energy in the 

remainder of the spectrum. Applying bandpass filtering enhances 

the desired signals at the expense of the out-of-band noise 

(Dewow). 

Bandpass is based on Fourier transform filtering concepts. 

Dewow  The process of removing a very low frequency component from GPR 

data. These low frequency data components are associated with 

either inductive phenomena or possible instrumentation dynamic 

range limitations. 
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Term Description 

DynaQ DynaQ is an advanced, patented technology that dynamically 

adjusts stacking as system speed varies. In most situations, moving 

the system at a comfortable speed stacks enough to generate good 

quality data. 

Enveloping Enveloping converts a trace from a wavelet with both positive and 

negative components to a monopulse wavelet with all positive 

components.  

The process removes the oscillatory nature of the radar wavelet and 

shows the data in its true resolution. Enveloping can also simplify 

radar section display making it easier to interpret. 

Filter Type Dictates the weighting the traces on the edges of the Filter Width 

have on the average trace calculation. 

First Break Offset The number of nanoseconds from the start of the trace to the first 

break. 

GPS Files Attaching a GPS file adds Latitude and Longitude, UTM coordinates, 

and GPS elevation to every trace in the GPR line.   

A GPS file is created by attaching a GPS system to the GPR system 

during data collection. GPS files contain lines of standard GPS 

positional output text (called NMEA strings) and the associated GPR 

trace number. When the GPS file is attached, latitude, longitude, and 

GPS elevations for every GPR trace are saved into the GPR file. 

GPZ Files Compressed files containing GPR lineset and grid data 

Grid A square or rectilinear set of straight lines which cover an area. 

Acquiring data on a grid means acquiring data along each line 

forming the grid.  

Acquiring data on a grid is a pre-requisite for creating depth or time 

slice images. Conventional notation is to use a Cartesian coordinate 

system with X and Y axes. 

Highpass Filter Removes frequencies below a cut-off frequency. Used for removing 

low frequency content in the GPR data; sometimes used instead of 

the Dewow filter. 

High Pass is a recursive filter designed for filtering GPR lines in the 

time domain. It is an infinite impulse response zero phase filter.   

Interpretation Module Interpretation module in LineView to create interpretations of Points, 

Polylines, Boxes, and Annotations, view them in GPR lines, and 

then output the interpretational information in reports. 

KMZ Files The KMZ files generated by a Noggin contain GPS information 

describing the path travelled during line collection.  

These files can be configured to display depth measurements along 

the line, making the data easier to interpret. Noggin enables you to 

export KMZ files which can be opened in Google Earth. 

Lineset All GPR lines in a project contained in one folder; collections of GPR 

lines that may or may not be related to one another.  

Linesets can be edited to add or delete GPR lines. GPR lines in 

linesets can also be cut and/or copied and pasted into other linesets.   
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Term Description 

LineView Shows GPR line data cross sections. Uses EKKO_View/Interp 

application modified to work with and get launched from 

EKKO_Project. 

Lowpass Filter Removes frequencies above a cut-off frequency - useful for 

removing high frequency noise in GPR data.   

Low pass is a recursive filter designed for filtering GPR lines in the 

time domain. It is an infinite impulse response zero phase filter. 

Migration The migration process applies a synthetic aperture image 

reconstruction process to the GPR line. 

nanosecond A nanosecond is 10-9 seconds (one billionth of a second). 

Overlap Overlap (% of slice thickness) between the adjacent depth/time 

slices. 

picosecond A picosecond is 10−12 seconds (one trillionth of a second). 

Polylines A polyline is a list of points, where line segments are drawn between 

consecutive points. 

Polyline Output Interval The horizontal distance (meters or feet) between points on any 

polylines in the project. To interpolate and list more points than just 

the input observation points, enter them text box. A common interval 

is the step size for the GPR line 

Project Explorer The Project Explorer is similar to Windows Explorer, which lists 

folders and files. In Project Explorer, grids and linesets are used just 

like folders in Windows, and GPR lines are similar to Window 

Explorer files. 

Processing Module The optional Processing module allows you to edit and process 

data, including cropping data, time filters, migration and gain. 

Popular processing streams can be saved as Recipes and applied to 

other GPR projects. 

Properties Window Displays details of each GPR line including acquisition parameters 

and associated files 

Slice Describes the GPR data in a depth slice when the data is displayed 

as a computer generated image. Normally shortened to slice. 

SliceView 

(EKKO_Mapper) 

SliceView creates and displays GPR depth slice maps quickly and 

easily. Using the systematic grid data acquisition process common 

to pulseEKKO PRO, Noggin, or Conquest systems, images at 

multiple depths are generated in minutes. 

Spatial Filter Spatial filters act on radar data in the spatial (or positional) direction. 

These filters use adjacent traces during the filtering procedure and 

alter the shape of the trace through various mathematical 

manipulations designed to enhance or eliminate certain features. 

Spreading & 

Exponential Calibrated 

Compensation (SEC2) 

SEC2 gain is a composite of a linear time gain and an exponential 

time gain which attempts to compensate for the spherical spreading 

losses and the exponential ohmic dissipation of energy in the GPR 

Line. 
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Term Description 

Time Window The maximum time selected for viewing, processing or data 

acquisition along a line. The length of the time window in 

nanoseconds (ns). 

Time Sampling Interval The time in picoseconds at which the GPR signal is sampled. Often 

set automatically by the system based on GPR frequency. 

Topography Files A topography file is a text file containing GPR line positions and the 

elevations at those positions. When a topography file is attached to 

a GPR line, elevations for every GPR position are saved into the 

elevation field of the GPR trace header. 

Trace Plot View Traces when you want to display subtle features in the data file 

or view the effect of different editing and processing types have on 

individual traces. 

Viewing traces can help you determine whether time-zero point 

needs to be edited. Normally the time-zero point should occur at the 

first large deflection in the signal. If not, time scales and depth 

scales on section plots will be inaccurate. 

Universal Transverse 

Mercator (UTM) 

UTM is a geographic coordinate system that uses a 2-dimensional 

Cartesian coordinate system to give locations on the surface of the 

Earth. It is a horizontal position representation, i.e. it is used to 

identify locations on the Earth independently of vertical position, but 

differs from the traditional method of latitude and longitude in several 

respects. 

UTM Zone  The UTM system divides the Earth between 80°S and 84°N latitude 

into 60 zones, each 6° of longitude in width.  

UTM Zone Number Zone 1 covers longitude 180° to 174° W; zone numbering increases 

eastward to zone 60 that covers longitude 174 to 180 East. 

UTM Letter Each zone is segmented into 20 latitude bands. Each latitude band 

is 8 degrees high, and is lettered starting from "C" at 80°S, 

increasing up the English alphabet until "X", omitting the letters "I" 

and "O" (because of their similarity to the numerals one and zero). 

The last latitude band, "X", is extended an extra 4 degrees, so it 

ends at 84°N latitude, thus covering the northernmost land on Earth. 

Latitude bands "A" and "B" do exist, as do bands "Y" and "Z". They 

cover the western and eastern sides of the Antarctic and Arctic 

regions respectively. 

Velocity Speed at which GPR signals travel. Velocity is a critical parameter 

when creating depth slice images and estimating target depth since 

velocity is used to convert travel-time to depth. 

Vertical Filter Applies a running average filter vertically (down the trace) to a GPR 

line. The signal is averaged by replacing the data value at a given 

point by the average data value over a window centered about that 

point. Its primary purpose is to reduce random or high frequency 

noise by acting as a low pass temporal filter. 
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2. Abbreviations 

Abbreviation Full Phrase 

AFS Average Frequency Spectrum 

ATA Average Trace Amplitude  

AGC Automatic Gain Control 

BAS Background Average Subtraction 

GPR Ground Penetrating Radar 

GPZ GPR Project Zip file 

MAPI Messaging Application Programming Interface 

MHz Megahertz 

ns nanoseconds  

ps picoseconds 

SEC2 Spreading & Exponential Calibrated Compensation  

UTM Universal Transverse Mercator 

 

 


