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Sensors & Software Inc. Product License, Copyright, Liability and  

Warranty Information 

Important 

Please read this document carefully before using the SOFTWARE PRODUCT or assembling the 

HARDWARE PRODUCT. By using the storage media or assembling the hardware, you are agreeing to 

be bound by the terms of this agreement. If you do not agree to the terms of this agreement, promptly 

contact Sensors & Software, Inc. at the address indicated at the end of this document. 

Definition 

The word product as used herein defines any item sold by Sensors & Software, Inc. and may be 

comprised of hardware product which consists of physical objects and software product which means 

computer programs, codes and related support materials. 

Software Product License Agreement 

In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. (hereafter 

SSI) does not sell any rights to its Software products. Rather, SSI grants the right to use its software, 

diskettes (or other storage media) and documentation (hereafter collectively called software product) by 

means of a software product license.  You acknowledge and agree that SSI retains worldwide title and 

rights to all its software and that the software product contains proprietary materials protected under 

copyright, trademark and trade secret laws. 

Grant of Software Product License 

In consideration of payment of the license fee which is the price you pay for the software product and 

your agreement to abide by the terms and conditions of this License Agreement, SSI grants to you, the 

Licensee, a non-exclusive right to use the software product under the following conditions: 

You may: 

use the software product on a single workstation owned, leased or otherwise controlled by you; 

copy the software product for backup purposes in support of your use of the product on a single 

workstation. 

You may not: 

copy, distribute or sell copies of the software product or accompanying written materials, including 

modified or merged software product to others; 

sell, license, sublicense, assign or otherwise transfer this license to anyone without the prior written 

consent of SSI; 

Modify, adapt, translate, decompile, disassemble or create derivative works based on the software 

product. 

Termination 

This license is effective until terminated. You may terminate the license at any time by returning the 

software product and all copies to SSI.  The license will automatically terminate without notice by SSI if 

you fail to comply with any terms or conditions of this agreement.  Upon termination, you agree to return 

all copies of the software product to SSI. 

Update Policy 

SSI may create, from time to time, updated versions of its software product.  At its option, SSI will make 

such updates available to licensees who have paid the update fee. 
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Product Warranty, Limited Remedy and Limited Liability  

SSI warrants the product to be free from defect in material and workmanship under normal use for a 

period of one year (365 days) from the date of shipment.  Any third party computer systems or other items 

not manufactured directly by SSI purchased with any product or independently from SSI are subject to the 

original manufacturer's warranty and are not the responsibility of SSI. 

SSI makes no other warranties including, but not limited to, any implied warranty of merchantability or 

fitness for a particular purpose.  If this product is defective within the warranty period stated above, your 

exclusive remedy shall be, at SSI’s option to replace or repair the SSI product or refund the purchase 

price of the SSI product.  Except where prohibited by law, SSI will not be liable for any loss or damage 

arising from this SSI product, whether direct, indirect, special, incidental or consequential regardless of 

the legal theory asserted. 

All statements, technical information, and recommendations related to SSI products are based on 

information believed to be reliable, but the accuracy or completeness is not guaranteed.  Before using this 

product, you must evaluate it and determine if it is suitable for your intended application.  You assume all 

risks and liability associated with such use.  Any statements related to the product, which are not 

contained in SSI current publications, or any contrary statements contained on your purchase order shall 

have no force or effect unless expressly agreed upon, in writing, by an authorized officer of SSI. 

SSI warrants the diskettes or other storage media on which the software product is furnished to be free 

from defects in material and workmanship under normal use for a period of ninety (90) days from the date 

of purchase as evidenced by a copy of your invoice. 

Except as specified above, any software product is provided "as is" without warranty of any kind, either 

expressed or implied, including, but not limited to, the use or result of use of the product in terms of 

correctness, accuracy, reliability, currentness or otherwise. The entire risk as to the results and 

performance of the product is assumed by you. If the product is defective or used improperly, you, and 

not SSI or its dealers, distributors, agents, or employees, assume the entire cost of all necessary 

servicing, repair or correction. 

SSI's entire liability and your exclusive remedy for software product shall be, at SSI's option, either: 

the replacement of any diskette or hardware components which do not meet SSI's Limited Warranty and 

which are returned to SSI postage prepaid with a copy of the receipt, or 

if SSI is unable to deliver a replacement diskette which is free of defects in material or workmanship, 

Licensee may terminate this agreement and have the license fee refunded by returning all copies of the 

software product postage prepaid with a copy of the receipt. 

If failure of any product resulted from accident, abuse or misapplication, SSI shall have no responsibility 

to replace the software product, refund the license fee, or replace or repair the hardware product. 

Do not tamper with any PRODUCT.  PRODUCT contains no user serviceable parts.  If tampering is 

evident in SSI’s opinion, warranty is void and null. 

No oral or written information or advice given by SSI, its dealers, distributors, agents or employees shall 

create a warranty or in any way increase the scope of this warranty and you may not rely on any such 

information or advice. 

Neither SSI nor anyone else who has been involved in the creation, production or delivery of the 

PRODUCT shall be liable for any direct, indirect, special, exemplary, incidental or consequential 

damages, claims or actions including lost information, lost profits, or other damages arising out of the use 

or inability to use this PRODUCT even if SSI has been advised of the possibility of such damages. 
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This warranty gives you specific rights.  You may have other rights which vary from province to province, 

territory to territory and certain limitations contained in this limited warranty may not apply to you. 

General 

No right, license, or interest to any SSI trademarks is granted hereunder with the purchase of the product 

or the software product license. 

Governing Law 

In the event of any conflict between any provision in this license agreement and limited warranty and any 

applicable provincial legislation, the applicable provincial legislation takes precedence over the 

contravening provision.  This agreement shall be governed and construed in accordance with the laws of 

the Province of Ontario, Canada. 

Serviceability 

Should any term of this agreement be declared void or not enforceable by any court of competent 

jurisdiction, the remaining terms shall remain in full effect. 

Waiver 

Failure of either party to enforce any of its rights in this agreement or take action against any other party 

in the event of a breach of this agreement shall not be considered a waiver of the right to subsequent 

enforcement of its rights or actions in the event of subsequent breaches by the other party. 

Acknowledgement 

You acknowledge that you have read this agreement, understand it and agree to be bound by its terms 

and conditions. You further agree that this agreement is the complete and exclusive statement of 

agreement between the parties and supersedes all proposals or prior agreements oral or written between 

the parties relating to the subject matter of this agreement. 
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Introduction 

GFP_Edit is designed to create, view, and edit GFP (GPR Files and Parameters) files.  

A GFP file contains information about groups of GPR lines. Typically, these are GPR lines that 
are related to one another in some manner, for example, lines collected over a grid to cover an 
area. The GFP file contains the names of the GPR lines, information about the position and 
direction of the GPR lines within the grid, and any data processing to be applied to the GPR 
lines. 

When GPR lines are organized under a GFP file, the data can be quickly read into Sensors & 
Software programs such as EKKO_Project, processed, and visualized.  
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Opening GFP_Edit 
1. To open GFP_Edit click Start > All Programs > Sensors & Software GPR > . 

 

 

Figure 1: GFP_Edit main screen 

2. Use the following table as a guide to working with the GFP_Edit main screen. 

Item Description 

Cross-hair Position As you move the cursor over an area in the Grid Map, the position of the 

mouse cross-hair is displayed in XY coordinates and GPS (if present) at the 

bottom right of the screen. 

Grid Table The Grid Table displays the names, positions, and other parameters of 

each GPR line in the grid. 

To learn more see Grid Table. 

Grid Map The Grid Map displays the relative position, length, and direction of each 

GPR line in the grid. 

To learn more see Grid Map. 

Grid Table 

Status Bar 

Cross-hair 

position 

Grid Map 

Toolbar 

Menu Bar 
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Item Description 

Menu The menu bar contains links to a number of features that help you to 

navigate through, and work with, GFP_Edit. 

To learn more see Menu Bar. 

Status Bar As you move the cursor over buttons on the Toolbar, the status bar at the 

bottom left of the screen displays a description of the selected button. 

Toolbar Most GFP_Edit operations can be performed through the toolbar. If the 

Toolbar is not visible, in the Menu Bar, click View > Toolbar. 

To learn more see Tool Bar. 

Grid Table 
The Grid Table displays the names, positions, and other information about each GPR line in the 
grid. 

 

Use the following table as a guide to working with the GFP_Edit Grid Table. 

Item Description 

Grid Name Use the grid name to organize GPR lines from the same grid. 

Line Name The name of the GPR line 

Orientation The line direction, either X or Y. By convention, X lines are parallel to the X 

(horizontal) axis and Y lines parallel to the Y (vertical axis). 
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Item Description 

Xmin The minimum X value on the GPR line 

Xmax The maximum X value on the GPR line 

Ymin The minimum Y value on the GPR line 

Ymax The maximum Y value on the GPR line 

Length The total length of the GPR line 

Step The step size between traces on the GPR line 

The Step value can be negative if the PR line was collected in reverse starting 

at a positive value and then stepping in a negative direction toward the zero 

position. This is common when grid data are collected with a forward/reverse 

survey format. 

Edit The Edit column indicates whether the GPR line has been edited from the 

original data file while being imported into the GFP file.  

The options are: No, Yes and RLD (Reverse Line Direction).  

RLD means that the only editing done to the original GPR line was to reverse its 

direction (Reverse Line Direction).  

Yes means that more substantial editing was done to the data. 

GPR Data The path and file name of the GPR (DT1) line. 

When the DT1 name is followed by a plus (+) sign, it indicates that other files 

associated with the DT1 file have been added to the GFP file; for example, a 

GPS file. 

GPS If the GPS field is a check-mark, the GPS file associated with the GPR line is 

used to compute the Local-Global Coordinates Relationship calculation to add 

GPS to the GFP file. 

If the GPS field is not checked, the GPS file associated with the GPR data is not 
used in the calculation to add GPS to the GFP file. Click Edit > GPS Data > 

Error! Reference source not found. to remove one or more GPS files from the 

GFP file. 

If the GPS field is blank, no GPS files were found for the GPR lines. 

If the GPS column contains a zero (0), a GPS file is present but does not 

contain valid GPS data, either no data or less than two GPS points. 

If the GPS column contains a question mark (?), no GPS file is present but there 

is GPS information in the DT1 file trace headers. In this situation, the GPS files 
can be recovered by clicking Edit > GPS Data > Error! Reference source not 

found.. 

If the GPS column contains an X, the GPS file is present but it could not be 

opened. For example, another application could be using it. 
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Opening a GFP File 
1. To open a GFP file, in GFP_Edit, click File > Open. 

 

2. In the Open dialog box, select a .gfp file. 

3. Click Open. 
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If GPS files were collected during data collection and added to the GFP file (Add GPS), the raw 
GPS lines can also be displayed in the Grid Map (Figure 2).  

The color of the GPR (and GPS) Lines is selected in the View > Line Settings menu option. 

Selecting one or more GPR lines files in the Grid Table will highlight the row(s) and the 
corresponding line(s) will change color on the Grid Map (Figure 2).  

Creating a GFP File 
1. To create a GFP file, in the GFP_Edit menu bar, click File > Create New GFP for Grid 

Lines. 

2. In the Please select new GFP file name and location dialog box, select a location for the 
new file. 

3. In the File name field, enter the new GFP file name. 

4. Click Save. 

• To import GPR lines into the GFP file, click Edit > Import Line(s). 

If the GPR lines were collected with GPS, the Import Lines option allows you to add GPS to 
the GFP file. 

You can also add GPS data manually (to learn more, see Add GPS Manually). 

• To delete GPR lines from the GFP file, click Edit > Delete Line(s). 

• To edit a GFP file, click Edit > Edit GFP File. 

Grid Map  

Selecting Lines 
• To highlight GPR lines in the Grid Map, on the Grid Table, click the line you want to 

highlight. 

• To display consecutive multiple GPR lines, click the first line you want to display, press Shift 
and then click the range of lines. 

• To display multiple lines that are not consecutive, click the first line you want to display, 
press Ctrl and then click the other lines you want to show in the Grid Map. 

• To select GPR Lines on the Grid Map, click the GPR line or click and drag a box across 
several lines. Any GPR line that intersects the box will be selected - the line color changes 
on the Grid Map and the name is highlighted in the Grid Table. 
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• If the selected line(s) do not appear in the Grid Map they may be turned off. To enable or 
change the color of displayed lines, in the menu bar, click View > Line Settings. To learn 
more, see Line Settings. 

 

Figure 2: Grid Table and Grid Map displaying selected lines.
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Toolbar 

Most GFP_Edit operations can be performed using the toolbar. If the Toolbar is not visible, in 
the menu bar, click View > Toolbar. 

 

To display a brief description of a toolbar button, hold your cursor over the button for at least 
one second. The description will appear in the Status Bar on the bottom left of the GFP_Edit 
main screen: 

 

Use the following table as a guide to working with the GFP_Edit toolbar. 

Item Description 

 Open Open an existing GFP file. 

To learn more, see Opening a GFP file. 

New Create a GFP file. 

To learn more, see Creating a GFP File. 

Save Save the active GFP file. 

To learn more, see Save GFP. 

Import Import Lines into GFP. 

To learn more, see Import Lines. 

 Delete Delete the selected line(s) from the GFP file. 

 Edit Edit the selected line. 

To learn more, see Edit GFP File. 

 Define 

Relationship  

Define local (XY)—Global (GPS) coordinate relationship. 

To learn more, see Local-Global Coordinates Relationship.  

meters Display in meters 

feet Display in feet 

Edit Display Edit GRP and GPS lines display  

 Display FID & 

Text 

Display FID & Text. 

To learn more, see Display Fiducials. 
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Item Description 

Zoom Out Display more of the image. 

To learn more, see Zoom. 

 Zoom In Magnify the image. 

To learn more, see Zoom. 

 Select Zoom 

Area 

Select area to zoom in on.  

To learn more, see Zoom. 

 Zoom Active 

Window 

Zoom active window to fit all data. 

To learn more, see Zoom. 

Pan View Pan the view area (drag and drop). 

 Help Display the GFP_Edit User’s Guide. 
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Menu Bar 
The GFP_Edit menu bar contains links to a number of features that help you to navigate 
through, and work with GFP_Edit. 

 

The following sections describe the GFP_Edit menu bar features. 

File 

 

Open GFP 
1. To open an existing project (.gfp) click File > Open.  

2. In the Open dialog, navigate to and then select the .gfp you want to open. 

3. Click Open. 

To learn more, see Opening a GFP file. 

Automatically Add GPS 

When a GFP file is opened, if GFP_Edit detects GPS files in the GPR line folder that have not 
been added, the program automatically prompts you to add the GPS files to the GFP file. 
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1. If GPS files are not automatically added: 

2. In the Grid Table, select one or more GPR lines. 

3. Click Edit > GPS Data > Add GPS. 

If GPR data were not collected with GPS you can still add GPS to the GFP file by defining the 
relationship between the Local XY grid and the Global coordinates (to learn more, see Manually 
Entering Global Coordinates). 

Close GFP 
1. To close the current GFP file, click File > Close.  

2. In the message box, to close the project and save your changes, click Yes. 

i. In the Save As dialog box, navigate to the folder you want to save the project to. 

ii. Click Save. 

• To close the project without saving your changes, click No. 

• To close the message box and return to working with the GFP file, click Cancel.  

Save GFP 

To save the current GFP file, click File > Save. 

Your work is automatically saved to the previously defined folder. 

Save GFP As 

1. To save the GFP current project to a different folder and/or name, click File > Save As.  

2. In the Save As dialog box, navigate to the folder that you want to the project to. 

To save the project with a different file name, in the File Name field enter the new project 
name.  

3. Click Save. 

Create New GFP for Grid Lines  

Not all GPR grid surveys have an associated GFP file. Earlier grid data acquisition software on 
a PC or the DVL (Digital Video Logger) did not automatically generate a GFP file when a grid 
was collected. To use software that requires GFP files for input, such as EKKO_Project, you 
need to create a GFP file for the grid survey. 

1. To create a GFP file, in the GFP_Edit menu bar, click File > Create New GFP for Grid 
Lines. 

2. In the Please select new GFP file name and location dialog box select a location for the 
new file. 

3. In the File name field, enter the new file name. 

4. Click Save. 

To learn more, see Creating a GFP File. 
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Recent Files 
1. To re-open a GFP file that you recently worked with, click File. 

 

2. In the drop-down list, click one of the GFP files listed in the recent files area. 

Exit 

To close all windows associated with the current GFP_Edit session and exit the application, 
click File > Exit. 

Edit 
To open the Edit menu, in the menu bar click Edit. 

 

Use the following table as a guide to working with the Edit menu. 
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Item Description  

Edit GFP File Edit GFP File is enabled when one or more GPR lines have been highlighted on 

the Grid Table or the Grid Map Selecting Lines. 

Use this feature to reposition or reorient lines within the grid. 

To reposition or reorient lines within the grid, in the menu bar, click Edit > Edit 

GFP File. 

To learn more, see Edit GFP File. 

Import Line(s) Click Import Lines to add GPR lines to a new or existing GFP file.  

You can also use this option to combine multiple grids to cover a larger area. 

To learn more, see Import Line(s). 

Delete Line(s) After GPR lines have been imported into a GFP file and one or more GPR lines 

have been highlighted on the Grid Table or the Grid Map, the Delete Line(s) 

option becomes available. 

1. To remove GPR lines from the GFP file, in GFP_Edit select the line(s) you 

want to delete. 

2. In the menu bar, click Edit > Delete Line(s).  

Note: no warning message will appear before the lines are deleted 

Select All Lines To select all the lines in a Grid Table, in the menu bar click Edit > Select All 

Lines. 

Deselect All Lines To deselect all selected lines in the Grid Table, in the menu bar click Edit > 

Deselect All Lines. 

GPS Data Use the GPS Data menu to add GPS data into the GFP file. You can also 

remove GPS data from the GFP file and export GPS positions from the trace 

headers for use with other software. 

To learn more, see GPS Data. 

GPS Format Click GPS Format to modify the GPS format displayed in the status bar: 

Latitude/Longitude in Degrees Minutes Seconds or Decimal Degrees alongside 

UTM coordinates. 

Local-Global 

Coordinates 

Relationship 

Use this feature to define the relationship between local grid coordinates and a 

global coordinate system such as GPS. 

Re-import Fiducials Click Re-import Fiducials to read fiducials from the trace headers into the GFP 

file. This can be useful if the fiducials were not read when the GPR lines were 

imported. 

Edit GFP File 

Edit GFP File is enabled when one or more GPR lines have been highlighted on the Grid Table 
or the Grid Map Selecting Lines). Use this feature to reposition or reorient lines within the grid. 

To edit a GFP file, in the menu bar, click Edit > Edit GFP File. 

The Editing dialog box opens. 

Editing—Name 

1. Click the Name tab to edit the lines name.  
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2. In the Editing dialog box Name tab, change the file name. 

 

This option is not available when more than one file is selected. 

3. Click OK. 

• Press Cancel to exit without making the change. 

• Press Undo to revert back to the original name. 

Clicking Undo will undo the last operation performed, even if you are on a different tab. 

• Press Preview to see how the name change affects the Grid Table. 

Clicking a different tab implements the change; changes can be undone by clicking Undo. 
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Editing Orientation 

Click the Orientation tab to change the orientation of the selected line(s). 

 

Start <-> End 

Click Start<->End to reverse the direction of the selected line 
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This option performs the same function as the Reverse Line Direction option when importing 
lines. 
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X <-> Y 

Click X<->Y to change the lines from X lines to Y lines or Y lines to X lines. 

 

 



GFP_Edit User’s Guide Menu Bar 

 

 

19 

Flip Y 

Click Flip Y  to reverse the order of the Y lines. For example, if Y lines are numbered 
0 to 9 from left to right, clicking Flip Y changes the order to 9 to 0 from left to right. 
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Flip X 

Click Flip X  to reverse the order of the X lines. For example, if X lines are numbered 
0 to 9 from bottom to top, clicking Flip X change the order to 9 to 0 from bottom to top. 

Flip X and Flip Y are most commonly used to re-orient lines collected in a different quadrant 
than the first quadrant. Two-dimensional plan map software like SliceView and 3D software 
expect data from the first quadrant. 

The following image shows grid data are expected to be collected in the first quadrant with the 
origin (X=0, Y=0) in the bottom left corner and X line names incrementing up and Y lines 
incrementing to the right. If data were collected in a different quadrant, use Flip X and Flip Y to 
edit the line positions so the grid data displays properly. 
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Editing - Position 

1. Click the Position tab to move the selected line(s) to a new position within the grid. 

 

2. Click OK to displays the selected lines Minimum X (XMin) and Minimum Y (YMin) positions.  

 

To edit the position of lines in the grid 

1. Change the XMin and/or YMin values. 

Lines are moved as a group to a new position. 
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2. Click OK. 

 

• Click Cancel to exit without making the changes. 

• Click Undo to revert to the original positions. 

• Click Preview to display the effect in the Grid Table and Grid Map. 

Editing - Length 

1. Click the Length tab to change the length of the selected line(s). 

 

2. Click OK to displays the length of the selected line.  

If more than one line is selected, the length of the longest line is displayed. The line length is 
changed by recalculating the Step Size (the distance between traces). No traces are added to 
or deleted from the data file; only the position of each trace changes. 
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In the following example, lines Y5 to Y9 were lengthened to 22 feet by changing the step size. 

 

The selected lines are set to the same length. To change the length of lines but keep their step 
size and relative lengths consistent, use the Step Size routine. 

3. Click OK, 

 

• Click Cancel to exit without making the changes. 

• Click Undo to revert to the original positions. 

• Click Preview to display the effect in the Grid Table and Grid Map. 
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Editing – Step Size 

1. Click the Step Size tab to change the distance between traces on the selected line(s). 

The Editing – Step Size displays the current step size. If more than one line is selected, the 
largest step size is displayed. Changing the step size affects the length of the line. 

 

2. Click OK to display the Step Size. 
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In the following example, the step size for lines Y5 to Y9 was changed from 0.16 to 0.25 feet. 
This change lengthened the lines. 

 

3. After changing the step size, click OK. 

• Click Cancel to exit without making the changes. 

• Click Undo to revert to the original positions. 

• Click Preview to display the effect in the Grid Table and Grid Map. 

Editing – Line Spacing 

Click the Line Spacing tab to change the distance between the selected lines. 

Clicking the Editing – Line Spacing tab displays the current line. If multiple lines are selected 
and the line spacing varies, the average spacing is displayed. 

 

In the following example, the spacing between lines Y7 to Y9 was changed from 2 to 5 feet. 
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After changing the line spacing, click OK.  

 

• Click Cancel to exit without making the changes. 

• Click Undo to revert to the original positions. 

• Click Preview to display the effect in the Grid Table and Grid Map. 
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Import Line(s) 

GFP_Edit allows you to create or edit a GFP file to group GPR lines collected by different 
systems with different hardware settings.  

1. In GFP_Edit, select the GPR line(s) to be imported.  

GPR lines must be in the same folder as the GFP file or in a sub-folder. 

2. Click Edit > Import Line(s). 

3. In the Open dialog box, select a DT1 file. 

The default file type is GPR line (DT1) files with an X or Y as part of the GPR line file name. 

 

4. To change the DT1 file to X & Y Line files, X Line Files, Y Line Files, or All Files click the 
option from the drop-down list. 

 

5. Click Open.  

Grids of GPR lines collected using Sensors & Software GPR systems automatically embed 
an X or a Y into the line name to indicate the line direction, for example, LINEX0, LINEX1, 
LINEX2, etc.  

• If the grid GPR lines being imported are in both the X and Y direction, use the X and Y 
Line Files file type. 

• If the grid GPR lines being imported are in the X direction only, use the X Line Files file 
type. 

• If the grid GPR lines being imported are in the Y direction only, use the Y Line Files file 
type. 
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• If the grid GPR lines were collected as a Noggin Line or a Conquest Line Scan or with 
an older pulseEKKO system on a PC, the names may have no indication of the line 
direction. In this case, to import the lines into the GFP file, use the All Files file type.   

Importing a Grid of GPR lines 

1. To import multiple GPR lines, press Shift or Ctrl to select the lines you want to import. 

2. Click Open. 

 

3. Use the following table as a guide to working with the Import Line Parameters dialog box. 

Item Description 

Import Lines as This option defaults to the file type selected in the Import Line(s) 
dialog.  

Select one of the X & Y Lines, X lines, or Y Lines options to change 
the file type. 

Reverse Line 

Direction 
Select the Reverse Line Direction check box to reverse the line 
direction. 

To learn more, see Reverse Line Direction. 

Grid name  From the drop-down list, click a Grid name. 

All the data files imported into a GFP file under one Grid Name are 
associated and are processed, displayed, and analyzed together in 
software, such as EKKO_Project, that opens GFP files. 

GFP files can contain information for more than one set of data (to 
learn more, see Importing Multiple Grids). 
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Item Description 

Line Spacing 

Conversion Factor 
Use Line Spacing Conversion Factor tries to import GPR lines to their 
correct positions in the grid by using the number part of the GPR line 
name as a multiplication factor. 

To learn more, see Line Spacing Conversion Factor. 

Offset from Current 

Origin 
Set the X and Y offset values to move the imported GPR lines away 
from the absolute origin at X position = 0 and Y position = 0.  

To learn more, see Offset from Current Origin. 

Add GPS if Found If GPS files were created during data collection, select the Add GPS 
if found check box to add GPS to the GFP file when the lines are 
imported.  

The GPS files must reside in the same folder as the GPR lines and 
must have the same name as the GPR line but with a .GPS 
extension. 

4. Click OK. 

Reverse Line Direction 

Use this option only when pulseEKKO grid data were collected in a zigzag (Forward/Reverse 
pattern), but the start position and step size direction were not updated for every file. For 
example, a grid was collected in the following way but the start of every line was set to zero no 
matter which direction it was actually collected in. 

 

Collecting data in this manner results in every second line being reversed compared to its 
adjacent lines. Viewing the grid lines in a plan or 3D view displays the reversed lines in incorrect 
spatial positions resulting in erroneous and un-interpretable data views. 

To remedy this situation, Import every second GPR line in the reverse line direction so all GPR 
lines are running in the same direction.  
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1. Import GPR lines in two groups: 

i. Import standard lines with the Reverse Line Direction option un-checked. 

ii. Import reversed lines with the Reverse Line Direction option checked.  

2. To verify the lines were imported correctly, check that that the line directions on the Grid 
Map match the directions of the grid survey. 

Note: Do not use Reverse Line Direction when data were collected with a Noggin system in 
Grid mode with the Survey Format set to Forward/Reverse because the data acquisition 
software automatically sets the Start Position to ensure the position of every line is correct. 

Line Spacing Conversion Factor 

Line Spacing Conversion Factor tries to import GPR lines to their correct positions in the grid by 
using the number part of the GPR line name as a multiplication factor.  

Example, when importing X GPR lines, LINEX0, LINEX1, LINEX2 with a line spacing of 2 feet, 
set the Conversion Factor to 2 feet. Y positions of the GPR lines will be calculated in the 
following manner: 

LINEX0: 0 x 2 feet = 0 feet 

LINEX1: 1 X 2 feet = 2 feet 

LINEX2: 2 X 2 feet = 4 feet 

The following image displays how the Line Spacing Conversion Factor is used to quickly import 
and position GPR lines with incrementing numbers in of the GPR line name. 

 

This assumes an origin of X=0 and Y=0. If X and Y are offset from the origin, this offset will be 
added to the final position values (see Offset from Current Origin).  

Importing Conquest Lines: When importing Conquest lines into a GFP file it is important to 
remember that Conquest line names contain have numbers that indicate the line spacing in 
centimeters, i.e. XL0000, XL0005, XL0010 etc. To determine the correct the line spacing for 
each GPR line, set the Line Spacing Conversion Factor to 0.01 m or 0.0328 feet. 
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Different Line Spacing: If GPR lines in the X direction have different line spacing than GPR 
lines in the Y direction, import the X lines first with one Line Spacing Conversion Factor and the 
Y lines second with a different Line Spacing Conversion Factor. 

 

GPR lines without Numbers in the Name: If the imported GPR line names do not contain 
numbers the following warning message is displayed when importing the files: 

 

When GPR lines are imported without numbers in their names, they are arranged alphabetically 
and the first file position is set to zero.  

 

If the GPR lines positions are still not set correctly, import each GPR line individually and set the 
position set using the offset from the origin option (to learn more, see Importing a Single GPR 
line). 
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Offset from Current Origin 

Set the X and Y offset values to move the imported GPR lines away from the absolute origin at 
X position = 0 and Y position = 0.  

Example, GPR lines can be imported with the origin set to X = 100 and Y = 55. 

Importing the line position from the Line Spacing Conversion Factor example above, will result 
in the following offsets from the origin and position: 

LINEX0: X Position = 100 Y Position = 55 + (0 x 2) feet = 55 feet 

LINEX1: X Position = 100 Y Position = 55 + (1 x 2) feet = 57 feet 

LINEX2: X Position = 100 Y Position = 55 + (2 x 2) feet = 59 feet 

The following image displays GPR lines offset from the X=0, Y=0 origin. 

 

Importing a Single GPR line 

It is common to import a single GPR line when: 

• The second part of a GPR line has a gap 

• Lines do not have numbers in the name 

• A grid of GPR lines has non-equal line spacing 

1. In GFP_Edit, select the GPR line to be imported.  

2. Click Edit > Import Line(s). 

3. In the Open dialog box, select a DT1 file. 

4. In the Import Line Parameters dialog box click the Grid name drop-down list. 

5. Click the Grid name. 

Make sure that the grid name is the same as the rest of the grid. For a single GPR line, the 
Line Spacing Conversion Factor is not accessible and the position of the line is determined 
using the Offset from Current Origin option. 

6. Click OK. 
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Importing a Broken Line into a Grid 

1. To import the second part of a GPR line that was separated due to an obstruction, import 
the GPR lines into the grid by selecting Import the Grid of GPR lines. 

2. Import the single GPR line that occurs after the gap in the data. 

3. In the Input Lines Parameters dialog box, the Import Lines as option select a Line 
Direction. 

i. In the Grid name drop-down list, check that the name is the same as the rest of the grid. 

ii. Set the X and Y Offset from Current Origin fields to position the GPR line. 

The following image displays an imported line on the other side of a gap in the grid survey. 

 

Importing GPR lines without Numbers 

GPR lines with names that do not include numbers are placed in alphabetical order when 
imported as multiple files (Importing a Grid of GPR lines). If alphabetical order is not the correct 
order of the files in the grid, you can rename the files by appending appropriate numbers and 
then import them. 

A second option is to import them as single files:  

1. Import the single GPR line. 

2. In the Input Lines Parameters dialog box, in the Import Lines as pane, select the Line 
Direction. 

3. Click the Grid Name drop-down list to check that the name is the same as the rest of the 
grid. 

4. In the Offset from Current Origin, position the GPR line. 

5. Repeat steps 1 to 5 until all the files have been imported. 
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6. Click OK. 

 

Importing Lines with Variable Line Spacing 

It is easier to import equally spaced GPR lines into a GFP file, but GFP_Edit allows you to 
import variable spaced line GPR lines individually. 

1. Import a single GPR line. 

2. In the Input Lines Parameters dialog box, in the Import Lines as pane, select a line 
direction option. 

3. Click the Grid name drop-down list to make sure that the grid name is the same as the rest 
of the grid. 

4. In the Offset from Current Origin, position the GPR line. 

5. Repeat steps 1 to 5 until all the files have been imported. 

6. Click OK. 
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Importing Multiple Grids  

A GFP file can contain more than one grid. The GPR lines for the other grid(s) can either be in 
the same folder as the first grid or in a folder at the same level as the first grid.  

Example: if the GFP file is in folder C:\data, GPR lines from the first grid could be in the sub-
folder C:\data\grid1 and the GPR lines for the second grid could be in the sub-folder 
C:\data\grid2.  

To import a second grid, follow the instructions from Importing a Grid of GPR lines. 

In the Offset from Current Origin pane enter X and Y positions to offset the second grid from the 
first.  

To process both grids at the once, give them the same grid name. The second grid name can 
use a new name, but if the two grids have different grid names, SliceView can only process the 
GPR lines under one grid name at a time.  

 

Using the method described above, multiple small grids can be merged together in a GFP file to 
make one large grid to process in SliceView; you just need to know the relative positions of 
each grid.  
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To process multiple grids together, they must have the same frequency and temporal sampling 
interval.  

GPS Data 

Use the GPS Data menu to add GPS data into the GFP file. You can also remove GPS data 
from the GFP file and export GPS positions into the trace headers for use with other software. 

In the Menu bar, click Edit > GPS Data. 
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Add GPS 

Click Edit > GPS Data > Add to add GPS data to a GFP file. 

 

Adding GPS Automatically 

When GFP_Edit detects GPS files in a GFP file that is in the same folder as the GPR line data 
files, and the GPS files have not already been added, the program automatically prompts you to 
add the GPS files into the GFP file (to learn more, see Automatically Add GPS). 

Adding GPS Manually 

1. To add GPS data after you have chosen to not to add it automatically, in the Grid Table 
highlight one or more file names. 

2. In the menu bar, click Edit > GPS Data > Add.  

Typically, all GPS files would be selected to add to the GFP file but any GPS data files known to 
be corrupt or inaccurate should not be selected.  

GPS Fitting and Accuracy 

The GPS positions for the added GPS files are processed to calculate the best fit of the GPS 
data to the GPR lines in the grid. The accuracy of the raw GPS data affects the accuracy of 
GPS position of the grid and consequently the target GPS positions interpreted in the data when 
viewed in the SliceView and LineView.   

Viewing GPS Positions 

Once you have added GPS positions, the GPS lines, relative to the GPR grid lines are viewed 
by enabling the Raw GPS in the View > Line Settings dialog (see Figure 4). 

GPS information is displayed in the Status Bar when 
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• Edit > Local-Global Coordinates Relationship > Use Global Positions is enabled. GPS 
is displayed in the GPS Format as the mouse cursor is moved around the Grid Map in 
GFP_Edit (Figure 4). GPS positions are also displayed in SliceView and LineView. 

• Edit > Local-Global Coordinates Relationship > Use Global Positions is disabled and 
no GPS files are present, “GPS: N/A” 

• Edit > Local-Global Coordinates Relationship > Use Global Positions is disabled and 
there are GPS files present, “GPS: Disabled” 

• The GPS point translates to an invalid point, “GPS: Invalid, Out of Bounds.” This can 
happen at the poles. 

GPS in Trace Headers 

GPR lines are saved in two files: a data (.DT1) file and a header (.HD) file. The GPR signal 
amplitude values for every trace and trace header are saved in the .DT1 file and the survey 
parameters to the .HD file.  For more details about the DT1 and HD files, see the GPR System 
User's Guide. 

If GPS data have been added to the GFP file, the Add GPS option writes a unique GPS position 
for every trace to the trace headers. Writing GPS positions to the trace headers is necessary for 
viewing the GPS positions in LineView, used for plotting cross-sectional GPR line data. 

Note: there may be a difference between GPS positions on GPR Lines displayed in 
GFP_Edit/SliceView and LineView. 

In LineView, which plots GPR cross-sectional lines, the GPS position is based interpolating 
the GPS positions saved to the GPS file during data collection. 

In GFP_Edit/SliceView, which use many GPR lines combined into a grid, GPS positions are 
determined by using the defined Local-Global Coordinates Relationship and grid line 
positions.  

The GPS positions for any individual line in the grid will differ slightly from the GPS file 
collected with that line. 

Remove GPS 

1. To remove the selected GPS file(s) from the GFP file, in the Grid Table select one or more 
file names. 

2. Click Edit > GPS Data > Remove.  

Remove inaccurate GPS files to increase the accuracy of the best fit calculation of the GPS 
position of the GPR lines and grid.  

3. After removing GPS files, run the Compute from GPS to ensure the best possible fit 
between the Local and Global Coordinates. 

Note: Remove GPS does not remove GPS positions from the trace headers (GPS in Trace 
Headers) so GPS positions are displayed in LineView. 

Recover GPS Files 

Use Recover GPS Files when the original file has been lost or when GPS positions were added 
to the trace headers method other than Edit > GPS Data > Add GPS.  

Recover is only available in when the GPS positions are saved in the trace headers of the DT1 
file and there are no GPS files in the GPR lines folder. The Grid Table displays a question mark 
(?) in the GPS column. 
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Recover generates a GPS file with the same name as the GPR line but with a .GPS extension. 

To recover a GPS File, in the Grid Table) highlight a GPR line or lines. 

In the menu bar, click Edit > GPS Data > Recover.  

Note: The Recover operation will never overwrite an existing GPS file. 

GPS Format 

If GPS data were added to the GFP file, you can change the format of the GPS display on the 
Status Bar.  

The GPS format selected is used for the GPS display on the Status Bar in SliceView (to learn 
more, see the SliceView User’s Guide). 

1. To Configure GPS Format, in the menu bar, click Edit > GPS Format. 

 

2. Use the following table as a guide to working with the Configure GPS Format dialog box. 

Item Description 

Latitude/Longitude Click the Latitude/Longitude check box to enable the Decimal Minutes 

Seconds (D°°°°M’S”), Decimal Degree, and Show Hemisphere options.  

D°°°°M’S” Select D°M’S” to display Latitude-Longitude values in Degrees-Minutes-

Seconds.  

Decimal Degree Select Decimal Degree to display Latitude-Longitude values in decimal-

degree.  
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Item Description 

Show Hemisphere 

Location as 
From the Show Hemisphere drop-down list, click one of the following 

options: 

• Do not show 

• Positive or Negative: A plus (+) sign indicates latitude in the Northern 

Hemisphere or longitude is in the Eastern Hemisphere.  

A minus (-) sign indicates latitude is in the Southern hemisphere or 

longitude is in the Western Hemisphere. 

• A Letter: For latitude N represents North and S represents South.  

For longitude, E represents East and W represents West. 

• Word: For latitude, use North or South. 

For longitude, use East or West. 

The selected option is displayed in the Sample GPS Output field. 

UTM Click the UTM check box, to enable the Reference Ellipsoid, Show UTM 

Letter Designator, and Show UTM Zone Number options. 

The selected option is displayed in the Sample GPS Output field. 

Using Reference 

Ellipsoid 

From the drop-down list, click a Reference Ellipsoid option. The default is 

WGS-84. 

Show UTM Letter 

Designator 

Select the UTM Letter Designator option to display UTM Letter 

Designator. 

Show UTM Zone 

Number 

Select the UTM Zone Number option to display UTM Zone Number. 
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Local-Global Coordinates Relationship 

Local-Global Coordinates Relationships enable you to define the relationship between the Local 
XY (GPR grid) coordinates and the Global coordinates (Latitude-Longitude or UTM). If the GPR 
data were collected with GPS, this relationship is best calculated using Compute from GPS. It 
can also be established by defining two points or one point and a heading in both the XY and 
Global coordinates. 

1. To define the relationship between Local XY and Global Coordinates, in the menu bar, click 
Edit > Local-Global Coordinates Relationship. 

 

2. Use the following table as a guide to working with the Local-Global Coordinates Relationship 
dialog box: 
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Item Description 

Use Global Position Select the Use Global Positions check box to enable the Local-Global 

Coordinates Relationships dialog box features. 

When disabled, GPS coordinates are not displayed on the SliceView Status 

Bar. You will not be able to export slice images to KMZ files for display in 

Google Earth (to learn more, see the SliceView User’s Guide). 

Compute from GPS If GPR lines were collected with GPS, the most common method for 

determining the relationship between the Local XY grid and the GPS 

positions is by calculating the best-fit. 

To learn more, see Compute from GPS.  

Global Coordinates 

Expressed As 
Global Coordinates are defined as Latitude-Longitude or UTM (Universal 

Transverse Mercator). 

To learn more, see Global Coordinates.  

Manually Entering 

Global Coordinates 
If GPS data were not collected for the entire GPR data grid but one or two 

GPS positions in the grid area are known, GPS positions for the entire grid 

can be calculated. 

To learn more, see Manually entering Global Coordinates. 

Define using two 

reference points 

Select this option to enable the 1
st
 and 2

nd
 Reference Point panes. 

Define using one 

reference point and 

heading  

Select this option to enable the 1
st
 Reference Point and the Y-Axis Heading 

panes. 

1
st
 Reference Point Enter the first point X and Y positions and the Latitude and Longitude, or 

UTM Northing and Easting points. 

To learn more, see 1
st
 Reference Point. 

2
nd
 Reference Point To enter two reference points to define the Local-Global Coordinates 

Relationship, depending on whether Longitude-Latitude or UTME are 

selected, enter the X, Y, Latitude, Longitude, or Northing and Easting 

values. 

To learn more 2
nd
 Reference Point.  

Y Axis Heading  If entering a point and a heading to define the Local-Global Coordinates 

relationship, enter the Y-Axis Heading in degrees from 0 (zero) to 360.  

To learn more, see Y Axis Heading. 

GPS Display Format Sometimes even though GPR data were collected with GPS and added into 

the GFP file, you may want to set the Local-Global Coordinates 

Relationship to a different GPS location than the position calculated from 
the Compute from GPS option. 

To learn more, see GPS Format. 
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Compute from GPS 

If GPR lines were collected with GPS, the most common method of determining the relationship 
between the Local XY grid and the GPS positions is by calculating the best-fit. This calculation 
may have been done when the GPS was added to the GFP file (see Automatically Add GPS). If 
so, the results of the best-fit calculation are displayed when the Local-Global Coordinates 
Relationship dialog is first opened. The best-fit calculation minimizes the length of the GPS 
Whiskers but depending on the GPS accuracy and visual correlation with the grid lines, a 
manual adjustment may be necessary in some cases. 

Best-fit calculation is affected when the XY line positions edited (see Edit GFP File). 

Specifically, changing the position, orientation, length, step size, or line spacing of one or more 
GPR lines will affect the best-fit calculation. 

Only run Compute from GPS to define the Local-Global Coordinates Relationship after the 
GPR lines have been edited or GPS files have been removed. 

1. Click Compute from GPS.  

If GPS data have not been added to the GFP file, this button will be greyed out and not 
accessible. 

GFP_Edit calculates the best-fit in UTM coordinates for the Local XY origin (0,0) and the 
corresponding Northing and Easting are displayed in the 1st Reference Point fields. The 
calculated UTM zone and hemisphere are displayed in the Global Coordinates - UTM fields. 

The Latitude and Longitude of the best-fit calculated position for the Local XY origin (0,0) 
are displayed in the 1st Reference Point field by changing the Global Coordinates to 
Latitude-Longitude (see Global Coordinates). 

Be careful clicking Compute from GPS and then greatly changing any of the editable fields 
in the Local-Global Coordinates Relationship dialog. In some cases, small changes to the 
Local XY Point, Y-Axis Heading, Latitude, Longitude, UTM Northing, and Easting may 
provide a better visual fit of the Local and Global coordinates. However, large changes in 
these values or changing the Zone and/or Hemisphere may result in the Local XY grid being 
widely separated from the Raw GPS Lines. If the Raw GPS Lines do become greatly 
separated, a warning message will appear. The Raw GPS settings can always be recovered 
by pressing the Compute from GPS button again. 

2. Click OK. 

Global Coordinates 

Global Coordinates are defined as Latitude-Longitude or UTM (Universal Transverse Mercator).  

1. Select Latitude-Longitude or UTM. 

UTM is the default. 

2. If UTM is selected, update the Zone field.  

3. In the Hemisphere drop-down list click Northern or Southern. 

Note: Editing these values after pressing Compute from GPS may result in errors. These 
fields are primarily designed to be edited when manually entering Global Coordinates (see 
Manual Entering Global Coordinates). 
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Manually Entering Global Coordinates 

If GPS data were not collected for the entire GPR data grid but one or two GPS positions in the 
grid area are known, GPS positions for the entire grid can be calculated. 

Or if the Compute from GPS does not provide an acceptable fit to the GPR data grid, manually 
entering the reference points may provide better results. 

In the Local-Global Coordinates Relationship dialog box, select one of the following options: 

• Define using two reference points 

• Define using one reference point and heading 

1st Reference Point 

These values will be different depending on whether Latitude-Longitude or UTM is selected in 
the Global Coordinates Expressed As pane. 

1. Selecting the Define using two reference points option enables both the 1st and 2nd 
Reference Points panes. 

2. In the Local X field, enter the local X coordinates. 

3. In the Local Y field, enter the local Y coordinates. 

4. You can click Select in View and then click a point in the grid to represent the X and Y 
positions. 

5. In the Global East/Long field enter the East/ Longitude Global coordinates.  

6. In the Global North/Lat field enter the North/Latitude Global coordinates. 

UTM Northing and Easting values are always entered in meters and can be positive or 
negative.  

Latitudes north of the Equator are positive values and south are negative values. Longitudes 
east of the Prime Meridian (Greenwich) are positive and west are negative. Latitude and 
Longitude values are always entered in decimal degrees. 

7. Click Preview to display the Local-Global Coordinates Relationship. You can move the 
mouse cursor over the grid image and see the proposed GPS values displayed on the 
Status Bar.  

8. If the Local-Global Coordinates Relationship is acceptable, click OK to save the settings and 
exit the dialog.  

If unacceptable, change the definition or click Cancel. 

2nd Reference Point 

If entering 2 reference points to define the Local-Global Coordinates Relationship, depending on 
whether Longitude-Latitude or UTME are selected, enter the X, Y, Latitude, Longitude, or 
Northing and Easting values. 
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Use for Heading Only 

To enter the heading reference point only, to determine whether to use local or global 
positioning, select the Use for Heading Only checkbox. 

The Local XY positions and the heading between the first and second reference point 
determines the Local-Global Coordinate Relationship. When a GPR depth slice is plotted in 
global coordinates, for example in Google Earth, the size of the grid is determined by the GPR 
odometer positions used during data collection. In general, having Use for Heading Only 
enabled is more accurate so having it enabled is the default setting. 

The Use for Heading Only option is commonly used when determining a heading using two 
points from third-party sources such as Google Earth; for example, using Google Earth to line 
up the GPR grid to the edge of a building or road that you know defined the edge of the GPR 
grid. 

 



GFP_Edit User’s Guide Menu Bar 

 

 

46 

Entering Two Reference Points  

The following images show how to set the Local-Global Coordinates relationship by entering the 
Latitude-Longitude positions of two XY positions in the grid. With the Use for Heading Only 
option selected, the heading of Point 1 to Point 2 is used; not the absolute position of Point 2. 
This method uses the local GPR odometer positioning saved during data collection when plotted 
with Global coordinates, for example in Google Earth. 
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Entering One Reference Point and the Y Axis Heading 

The following images show how to set the Local-Global Coordinate Relationship by entering the 
Local XY and Global Latitude/Longitude (or UTM) coordinates for one reference point in the grid 
area and the Y-Axis Heading. 

This method uses the local GPR odometer positioning saved during data collection when 
plotting data slices in Global coordinates, for example in Google Earth. 

Enter the first reference point as described above.  
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Using GPS Positions from Third-Party Sources 

Global positions in Latitude/Longitude or UTM can be obtained from an independent GPS that 
calculates the GPS position for two known XY points in the GPR grid, for example, two corners. 
These positions can be recorded before, during, or after the GPR data survey and then you can 
Manually Enter Global Coordinates. 

Another place to obtain Global positions for reference points in the area of your grid is from 
Google Earth. Find the location of the GPR grid in Google Earth and then use the mouse cursor 
to find the GPS position for a particular point near or within the grid. 

To obtain better accuracy for points, use the Ruler option in Google Earth to change the mouse 
cursor from a hand to cross-hairs. 

  

GFP_Edit expects Latitude-Longitude values expressed in decimal degrees or UTM. Google 
Earth usually displays in degrees-minutes-seconds. You can change the Google Earth display 
to decimal degrees or UTM under Tools > Options > 3D View Tab > Show Lat/Long.  

Y-Axis Heading 

If entering a point and a heading to define the Local-Global Coordinates relationship, enter the 
Y-Axis Heading by selecting the radio button to enable it and then entering the heading in 
degrees from 0 (zero) to 360. North is 0 (zero) and 360. Angles are defined positive in the 
clockwise direction and negative counter-clockwise direction. For example, East is +90 or -270, 
South is +180 or -180, and West is +270 or -90 degrees. 
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Re-import Fiducials 

Fiducials are markers added during data collection at specific trace positions along the line (see 
Display Fiducials). 

In the following image, fiducial markers (bottom of image) are added at significant positions 
during data collection. Fiducials usually consist of a letter “f” followed by an incrementing value. 

 

Figure 3: Fiducial markers displayed in a cross-section 

Fiducials contained in the grid GPR lines (DT1 files) are automatically imported into the GFP file 
when the lines are imported.  
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View 
1. To open the View menu, in the menu bar click View. 

 

2. Use the following table as a guide to working with the View menu. 

Item Description  

Line Settings Click Line Settings to define which lines you want to display in the Grid Map 

(GPR and/or GPS). 

To lean more, see Line Settings. 

Display Fiducials Click Display Fiducials to show the markers added during data acquisition 

at specific trace positions along the line. 

To learn more, see Display Fiducials. 

Fiducial with Text Click Fiducial with Text to display the text associated with the fiducial 

markers. 

To learn more, see Fiducials with Text. 

Display Units You can display distance units on the Grid Table and the axes around the 

Grid Map in meters or feet. The units default to those used during the original 

grid data collection but can be converted and displayed in either meters (m) 

or feet (ft). 

Zoom Click Zoom to magnify or reduce the size of the Grid Map image. 

To learn more, see Zoom. 

Pan Click Pan to move around a zoomed in image. In Pan mode, the mouse 

cursor becomes a hand ( ) that you can use to click and drag the data 

image to a new location. As the image is dragged, a dashed box outlining the 

current viewed image is formed. 

Click Pan again to exit Pan mode,  

Toolbar Click Toolbar to display the toolbar in the GFP_Edit interface below the 

menu bar. 

You can drag the Toolbar to other areas in the interface or remove it as a 

standalone bar on your computer screen. 

Status Bar Click Status Bar to display the Status Bar along the bottom of the GFP_Edit 

interface. 
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Line Settings 

Line Settings enables you to define which lines you want to display in the Grid Map (GPR 
and/or GPS). 

 

Figure 4: Types of lines displayed in the Grid Map. 

In the menu bar, click View > Line Settings. 

 

Figure 5: Line Display Settings dialog box 
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The following sections describe how you can use the Line Display Settings dialog box to edit 
color, style, and weight. You can also edit GPR and GPS points can also be edited for color, 
marker shape, and size. 

GPR Lines 

1. In the Line Settings (Figure 5) dialog box, click the GPR Line (Local XY coordinates) 
check box to display GPR Lines in the Grid Map (Figure 4). 

GPR lines can have different properties when they are Active (selected) than when they are 
Inactive (not selected). To learn more, see Selecting Lines. 

2. To change the properties of GPR Lines select the Active or Inactive option. 

 

The word Edit->- is displayed beside the selected option. 

3. In the Line or Marker pane, edit the line settings.  

Leave the GPR line marker style blank because the GPR traces that the markers represent 
are usually so close together that individual markers are not visible until zoomed in very 
close. 

Raw GPS 

1. In the Line Settings (Figure 5) dialog box, click the Raw GPS check box to display GPR 
lines collected with GPS in the Grid Map (Figure 4). 

Raw GPS lines can have different properties when they are Active (selected) than when 
they are Inactive (not selected). To learn more, see Selecting Lines. 

2. To change the properties of Raw GPS lines select the Active or Inactive option. 

 

The word Edit->- is displayed beside the selected option. 

3. In the Line or Marker pane, edit the line settings.  

Markers represent points where GPS data were collected. Display raw GPS lines in the Grid 
Map by adding straight lines between the markers. 

The number of raw GPS points collected along a GPR line depends on the GPS settings 
during GPR data collection (to learn more, see the GPS section in the GPR System User's 
Guide). 
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GPS Whiskers 

GPS Whiskers connect the raw GPS position marker to the corresponding GPR trace. 

Displaying GPS Whiskers helps display GPR lines that may have been accidentally reversed 
because the whiskers will connect the Raw GPS to the opposite ends of the GPR line than 
expected. 

1. In the Line Settings (Figure 5) dialog box, click the GPS Whiskers check box to display 
GPS Whiskers from GPS Lines collected with GPS in the Grid Map (Figure 4). 

2. To change the properties of Raw GPS lines select the Active or Inactive option. 

 

The word Edit->- is displayed beside the selected option. 

3. In the Line or Marker pane, edit the line settings.  

Leave the Line and Marker style for Inactive GPS Whiskers blank to avoid cluttering the Grid 
Map. 

GPS Accuracy 

The difference in linearity and the distance between the Raw GPS line and the GPR line 
indicates the accuracy of the GPS used for data collection. Non-linear Raw GPS lines indicate 
poor GPS accuracy; be careful when using the extracted GPS positions of targets interpreted in 
the GPR data when viewed in the SliceView and LineView. 

Line 

The features in the Line pane enable you to modify the line color, style, or weight. 

 

Style 

1. Click the Style drop-down list. 

 

2. Select the line style to display the GPR Lines.  
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Color 

1. Click the Color button. 

 

2. Select a color to highlight the GPR Lines. 

3. Click OK. 

Weight 

1. Click the Weight drop-down list. 

 

2. Select a line weight to highlight the GPR Lines. 
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Marker 

Markers represent points where GPS data were collected. 

 

Style 

1. Click the Style drop-down list 

 

2. Select a marker style to display the GPR Marker. 

Color 

1. Click the Color button. 

 

2. Select a color to highlight the GPR Markers. 

3. Click OK. 
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Size 

Click the Size buttons to increase or decrease the marker point size. 

 

Display Fiducials 

To enable/disable Fiducials, in the menu bar, click View > Display Fiducials. 

Fiducials are markers added during data acquisition at specific trace positions along the line 
(Figure 3).  

Fiducials are automatically displayed on the Grid Map image if they have been imported into the 
GFP file (Re-import Fiducials). The fiducials appear as small squares on the line. 

 

If the grid survey data does not contain any fiducials, this option is greyed out and not 
accessible. 

Fiducials with Text 

If Display Fiducials is enabled, Show Fiducial Text is also available. Click Show Fiducial 
Text to display the text associated with the fiducials.  

If the grid survey data does not contain any fiducials, Show Fiducial Text is not enabled. 
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Zoom 

Click Zoom to magnify or reduce the size of the Grid Map image. 

 

In the Zoom drop-down list select one of the following options: 

Fit to Window 

Click View > Zoom > Fit to Window to display the full grid size within the screen. Click Fit to 
Window to return to the full image view after zooming in. 

Select Area 

Click View > Zoom > Select Area to zoom in on a specific area of the grid.  

Out 

Click View > Zoom > Out to Zoom out of the image size.  

In  

Click View > Zoom > In to magnify the image. 

When you zoom into an image, scroll bars are displayed on the edge of the image. Use the 
scroll bars to move around on the image and view different areas. The scroll bar narrows each 
time the image is zoomed in to indicate that a smaller percentage of the full image range is 
displayed. 
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A zoomed in image will still display the X and Y scales. 

 

Figure 6: Example of a Zoomed image with scroll bars. 

The zoomed in image may show more data than defined by the box because the additional data 
will be added to the right or bottom of the image so it always retains the correct aspect ratio. 
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Window  
To open the Window menu, in the menu bar click Window. 

 

Cascade 

Click Cascade to arrange open windows so they cascade on the screen; the front window is 
completely visible and the title lines from the other windows are visible and accessible. 
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Tile 

Click Tile to arrange all open windows so they are tiled on the screen; all windows are resized 
so they are all visible and accessible. 

 

Arrange Icons 

Click Arrange Icons to order all the icons (minimized windows). 
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Selecting an Open GFP Window 

The Windows menu lists all open GFP windows. A checkmark identifies the active window.  

To change the active window, click another window in the list. 

Help 
To open the Help menu, in the menu bar click Help. 

 

Help Topics 

Click Help Topics to open the GFP_Edit User’s Manuals in PDF. 

Adobe Acrobat Reader must be installed on the PC to open this document. If not, you will be 
prompted to download it from the Adobe website. 

Sensors & Software contact information 

Click Sensors & Software contact information to display Sensors & Software contact 
information: mailing address, e-mail addresses, phone, and fax numbers. 
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Diagnostic Mode 

Diagnostic Mode is designed to help resolve GFP_Edit issues.  

1. If some GPR lines consistently cause GFP_Edit to crash or freeze, restart GFP_Edit. 

2. Click Help > Diagnostic Mode.  

3. Open the GFP file for the grid survey. 

4. Re-run the steps that caused the crash.  

Diagnostic Mode causes the program to run much slower than usual, because it is logging 
all the data processing steps. 

  

. 
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