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SENSORS & SOFTWARE INC. PRODUCT LICENCE, COPYRIGHT, LIABILITY AND WARRANTY INFORMATION

Important
Please read this document carefully before removing the SOFTWARE PRODUCT storage media from their protective cover 
or assembling the HARDWARE PRODUCT. By removing the storage media or assembling the hardware, you are agreeing 
to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, promptly contact Sen-
sors & Software, Inc. at the address indicated at the end of this document.

Definition
The word PRODUCT as used herein defines any tangible item sold by Sensors & Software, Inc. and may be comprised 
of HARDWARE PRODUCT which consists of physical objects and SOFTWARE PRODUCT which means computer programs, 
codes and related support materials.

Software Product Licence Agreement

In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. (hereafter SSI) does not 
sell any rights to its Software product. Rather, SSI grants the right to use its software, diskettes (or other storage 
media) and documentation (hereafter collectively called SOFTWARE PRODUCT) by means of a SOFTWARE PRODUCT 
licence. You acknowledge and agree that SSI retains worldwide title and rights to all its software and that the SOFTWARE 
PRODUCT contains proprietary materials protected under copyright, trademark and trade secret laws.

Grant of Software Product Licence
In consideration of payment of the licence fee which is the price you pay for the SOFTWARE PRODUCT and your agree-
ment to abide by the terms and conditions of this Licence Agreement, SSI grants to you, the Licensee, a non-exclusive 
right to use the SOFTWARE PRODUCT under the following conditions:

You may:
• use the SOFTWARE PRODUCT on a single workstation owned, leased or otherwise controlled by you
• copy the SOFTWARE PRODUCT for backup purposes in support of  your use of the product on a single workstation

You may not:
• copy, distribute or sell copies of the SOFTWARE PRODUCT or accompanying written materials, including modified or 

merged SOFTWARE PRODUCT to others
• sell, licence, sublicence, assign or otherwise transfer this licence to anyone without the prior written consent of 

SSI
• modify, adapt, translate, decompile, disassemble or create derivative works based on the SOFTWARE PRODUCT

Termination
This licence is effective until terminated. You may terminate the licence at any time by returning the SOFTWARE PROD-
UCT and all copies to SSI. The licence will automatically terminate without notice by SSI if you fail to comply with any 
terms or conditions of this agreement. Upon termination, you agree to return all copies of the SOFTWARE PRODUCT to 
SSI.

Update Policy
SSI may create, from time to time, updated versions of its SOFTWARE PRODUCT. At its option, SSI will make such 
updates available to licencees who have paid the update fee.

Product Warranty, Limited Remedy and Limited Liability 
SSI warrants the PRODUCT to be free from defect in material and workmanship under normal use for a period of one 
year (365 days) from the date of shipment. Any third party computer systems or other items not manufactured directly 
by SSI purchased with any PRODUCT or independently from SSI are subject to the original manufacturer's warranty and 
are not the responsibility of SSI.

SSI makes no other warranties including, but not limited to, any implied warranty of merchantability or fitness for a par-
ticular purpose.  If this product is defective within the warranty period stated above, your exclusive remedy shall be, at 
SSI’s option to replace or repair the SSI product or refund the purchase price of the SSI product.  Except where prohib-
ited by law, SSI will not be liable for any loss or damage arising from this SSI product, whether direct, indirect, special, 
incidental or consequential regardless of the legal theory asserted.



All statements, technical information, and recommendations related to SSI products are based on information believed 
to be reliable, but the accuracy or completeness is not guaranteed. Before using this product, you must evaluate it and 
determine if it is suitable for your intended application.  You assume all risks and liability associated with such use.  Any 
statements related to the product which are not contained in SSI current publications, or any contrary statements con-
tained on your purchase order shall have not force or effect unless expressly agreed upon, in writing, by an authorized 
officer of SSI.

SSI warrants the diskettes or other storage media on which the SOFTWARE PRODUCT is furnished to be free from defects 
in material and workmanship under normal use for a period of ninety (90) days from the date of purchase as evidenced 
by a copy of your invoice.

Except as specified above, any SOFTWARE PRODUCT is provided "as is" without warranty of any kind, either expressed 
or implied, including, but not limited to, the use or result of use of the product in terms of correctness, accuracy, reliabil-
ity, currentness or otherwise. The entire risk as to the results and performance of the PRODUCT is assumed by you. If 
the PRODUCT is defective or used improperly, you, and not SSI or its dealers, distributors, agents, or employees, 
assume the entire cost of all necessary servicing, repair or correction.

SSI's entire liability and your exclusive remedy for SOFTWARE PRODUCT shall be, at SSI's option, either

• the replacement of any diskette or hardware components which do not meet SSI's Limited Warranty and which are 
returned to SSI postage prepaid with a copy of the receipt, or

• if SSI is unable to deliver a replacement diskette which is free of defects in material or workmanship, Licensee 
may terminate this agreement and have the licence fee refunded by returning all copies of the SOFTWARE PRODUCT 
postage prepaid with a copy of the receipt.

If failure of any PRODUCT resulted from accident, abuse or misapplication, SSI shall have no responsibility to replace 
the SOFTWARE PRODUCT, refund the licence fee, or replace or repair the HARDWARE PRODUCT.

Do not tamper with any PRODUCT.  PRODUCT contains no user serviceable parts.  If tampering is evident in SSI’s 
opinion, warranty is void and null.

No oral or written information or advice given by SSI, its dealers, distributors, agents or employees shall create a war-
ranty or in any way increase the scope of this warranty and you may not rely on any such information or advice.

Neither SSI nor anyone else who has been involved in the creation, production or delivery of the PRODUCT shall be lia-
ble for any direct, indirect, special, exemplary, incidental or consequential damages, claims or actions including lost 
information, lost profits, or other damages arising out of the use or inability to use this PRODUCT even if SSI has been 
advised of the possibility of such damages.

This warranty gives you specific rights.  You may have other rights which vary from province to province, territory to ter-
ritory and certain limitations contained in this limited warranty may not apply to you.

General

pulseEKKO®, Noggin®, SpiView®, Conquest® and SnowScan® are registered trademarks of SSI. No right, licence, or 
interest to such trademarks is granted hereunder with the purchase of the PRODUCT or the SOFTWARE PRODUCT licence.

Governing Law
In the event of any conflict between any provision in this licence agreement and limited warranty and any applicable 
provincial legislation, the applicable provincial legislation takes precedence over the contravening provision. This 
agreement shall be governed and construed in accordance with the laws of the Province of Ontario, Canada.

Serviceability
Should any term of this agreement be declared void or not enforceable by any court of competent jurisdiction, the 
remaining terms shall remain in full effect.

Waiver
Failure of either party to enforce any of its rights in this agreement or take action against any other party in the event of 
a breach of this agreement shall not be considered a waiver of the right to subsequent enforcement of its rights or 
actions in the event of subsequent breaches by the other party.



Acknowledgement
You acknowledge that you have read this agreement, understand it and agree to be bound by its terms and conditions. 
You further agree that this agreement is the complete and exclusive statement of agreement between the parties and 
supersedes all proposals or prior agreements oral or written between the parties relating to the subject matter of this 
agreement.

Should you have any questions concerning this agreement, please contact in writing:

Sensors & Software Inc.
1040 Stacey Court

Mississauga, Ontario
Canada L4W 2X8
Tel:(905) 624-8909
Fax:(905) 624-9365

E-mail: radar@sensoft.ca

pulseEKKO, Noggin, SpiView, SnowScan, Conquest, SmartCart, SmartHandle, Conquest for Windows, Win_EKKO, EKKO_Mapper, 
EKKO_3D and EKKO_Pointer are Trademarks of Sensors & Software Inc
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1 Introduction
Ground Penetrating Radar (GPR) data are usually collected as two dimensional cross-sections of the
subsurface. The EKKO_View 2 software is designed to plot cross-sectional GPR data images on a PC. 

EKKO_View 2 features:

1) Display data images in a variety of color palettes or as wiggle traces.

2) Display of data files with up to hundreds of thousands of traces.

3) Optimize the image by adjusting the color palette Contrast and Sensitivity.

4) Display multiple data images at once.

5) Plot data images with customizable position, time and depth axes and grid lines.

6) Apply same Gain and View Settings to all open data images at once.

7) Plot data images corrected for topography (if elevations integrated). 

8) Zoom in/out and pan around the data images.

9) Print the data images.

10) Save data images to graphics image files like BMP, JPG and TIF.

11) Save data images to the clipboard and paste into reports.

12) Apply Default, Auto or User Gains to the data.

13) Use cursor to display individual raw data traces, processed traces and Gain. 

14) Simultaneous scrolling of linked data images.

15) Use Hyperbola-fitting to extract velocity information from the data.

16) Hyperbola-fitting can also extract velocities from CMP (Common Mid Point) data.

17) Plot the depth axis based on an average velocity value.

18) Quickly change units from meters to feet or feet to meters.

19) Reverse the line direction to easily compare lines collected in a zig-zag pattern.

20) Use the mouse cursor to determine the position, depth and signal amplitude of any point in 
the data image.

21) For data integrated with GPS, use the mouse cursor to determine the GPS position of any 
point in the data image.

22) F8 hotkey to save the position, depth, signal amplitude, etc. at the mouse cursor to the 
Clipboard and Paste into other documents.
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23) Display data images with a legend with customizable GPR survey and processing 
parameters.

24) The program retains the display settings from the last time that cross-section was plotted.

 Figure 1-1:  Typical GPR cross-sectional image plotted with EKKO_View 2. 
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2 Overview

2.1 Using EKKO_View 2
The EKKO_View 2 main screen displays one or more data images in separate windows. 

A GPR data file (.DT1) is opened by selecting File > Open.

The window opens to display the cross-sectional data image (Figure 2-1).

 Figure 2-1:  The EKKO_View 2 main screen. 

The data image can be displayed in a Color Scale, Wiggle Trace or both.

The Legend under the image provides details of the current cross-section image. The information
specified in the Legend can be edited using the option under View > Settings > Legend Tab.

The Menus and buttons on the Toolbar allow the user to further modify and customize the images, and
when satisfied with the results, select File > Print Image to print a hard copy output, File > Copy Image to
Clipboard to copy the image to the clipboard or File > Export Image to File to save the image to a
graphics file.
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The Color Palette can be changed under the View > Settings > Color Palette Tab options from the menu
or by selecting the Settings button from the Toolbar: 

and then selecting the Color Palette Tab.

Gain is the amplification applied to the cross-sectional images. The Gain Type can be changed by
selecting View > Settings > Processing Tab> Gain Type. The Gain Level can be changed in the View >
Settings > Processing Tab. 

The Gain Level can also be changed using the Gain dropdown on the Toolbar:

If the Gain Level is set to a Numbered Level, the Gain Increase and Gain Decrease buttons on the
Toolbar:

can be used to quickly change the Gain Level.

Grid Lines corresponding to the major positions and depth labels can be superimposed on the cross-
sections. Grid Lines are displayed by selecting View > Show Grid Lines. The specific grid lines are
selected under View > Settings > Axes Tab. If no grid lines are selected under View > Settings > Axes
Tab, the View > Show Grid Lines menu option is greyed out and not accessible. 

The colors of the grid lines, fiducial markers and wiggle traces can be changed under View > Settings >
General Tab. 

The font for the axes and legend can be changed under View > Font or View > Settings > General Tab. 

The Depth scale is based on the velocity set under View > Settings > Axes Tab > Depth Axis. The best
way to determine this value is through the Tool > Hyperbola Velocity Calibration method. 

If the data file has elevation data integrated with it, the data image can be plotted with topography by
selecting View > Settings > Axes > Elevation Axis.
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As the mouse cursor is moved over the data image, cross-hairs appear and information about the current
position, depth, etc. of the cross-hairs in the data image are displayed on the Status Bar on the bottom of
the main window.
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2.2 Window Operations

2.2.1 Active Window

The EKKO_View 2 screen may have two or more cross-section windows open. However, only one window
at a time is “active” and can have changes made to it, for example, changing the Contrast value or
enabling the Show Legend option. The Active Window is always indicated by its dark (usually) blue title
banner. 

 Figure 2-2:  The Active Window is indicated by the darkly-colored title banner.

The current active window is also checked in the list under the Window menu.

2.2.2 Resizing Windows

To change the size of a window, click and drag any frame or corner. 

As the size of the cross-section window changes, the cross-section will distort to fill the maximum size
within the window. 

The windows can also be resized and closed using the buttons located in the upper right corner:
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Any window can be maximized to take up the full screen by pressing the maximize button:

A maximized window can be restored by pressing the restore down button in the upper right corner of the
window:

Any window can be minimized by pressing the minimize button: 

2.2.3 Tiling Windows

Use the menu option Window > Tile Horizontally or the following Toolbar button to arrange the windows
horizontally:

When tiling horizontally the current Active Window will always appear on top.

Use the menu option Window > Tile Vertically or the following Toolbar button to arrange the windows
vertically:

When tiling vertically the current Active Window will always appear on the left.

2.2.4 Opening a New Window

A second view into an already open cross-section window can be made by selecting Window > New
Window. 
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2.2.5 Closing a Window

Any window can be closed by pressing the close button in the upper right corner of the window: 

2.3 Legend
The data image has a legend that displays information about the cross-section (Figure 2-1).

The display of the legends can be enabled and disabled under the menu option View > Show Legend or
pressing or depressing the Toggle Legend Viewing button on the Toolbar:

2.4 Toolbar
Most operations can be performed using the Toolbar. The Toolbar is made visible by checking it under
View > Toolbar.

A brief description of the function of a button is displayed by holding the mouse cursor on the button for
about 1 second.

There is also a longer description of the button on the Status Bar on the bottom of the screen.

2.5 Status Bar
The status bar is visible on the bottom of the screen when the View > Status Bar option is checked
(Figure 2-1).

As the mouse cursor is moved over buttons on the toolbar, the status bar, at the bottom of the screen,
provides helpful descriptions of the purpose of the particular button. For example, holding the mouse over
the Legend button will display the following on the Status Bar:
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When the mouse cursor is located on the cross-section image, the right side of the status bar displays
information about the data at that location: 

2.5.1 GPS

If the GPR data file has GPS information integrated in (using the EKKO_View Deluxe or IcePicker
software), the GPS position in Latitude-Longitude and/or UTM coordinates are also displayed on the
Status Bar:

The format of the GPS information can be changed under View > Settings > Legend Tab > GPS
Configuration.

2.5.2 Exporting Status Bar Information to Other Documents

The data information text on the Status Bar can be copied to the Clipboard by pressing the F8 key. The
text can then be Pasted into another document like a Word or Excel file. 

Pressing the “Shift” key while pressing F8 will also save the text for the column headings.

To create a file like the one above, press Shift F8 and paste the first line into the document. Then press F8
for all the subsequent lines.

This feature is handy for extracting significant positions from the data image and writing them to other
documents.
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3 Menus
The following sections describe the EKKO_View 2 menus.

Menu options can be accessed by clicking on them with the mouse cursor or by pressing the Alt key
followed by the underlined letter.

Alt+F = File

Alt+V = View

Alt+W = Window

Alt+T = Tool

Alt+H = Help

Sub-menus can then be accessed by pressing the next underlined letter. For example, to select the Open
sub-menu under the File menu, press Alt+F and then O.

Sensitivity can be increased by pressing the ] key and decreased by pressing the [ key. Pressing the Shift
or Ctrl key at the same time changes the increment. For more details see Sensitivity.

Contrast can be increased by pressing the / key and decreased by pressing the . key. Pressing the Shift or
Ctrl key at the same time changes the increment. For more details see Contrast.

Gain Level can be increased by pressing the + key and decreased by pressing the - key.
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4 File Menu

4.1 Open
The File > Open option allows the user to select a GPR data file to be displayed. 

The Open dialog allows the user to select a file with a .DT1 extension. 

The File > Open option can also be accessed by pressing Ctrl-O on the keyboard or by clicking on the
Open button on the Toolbar:

More than one DT1 file can be opened at the same time resulting in multiple windows open on the screen. 

Data files can also be opened in EKKO_View 2 by:

1) Double-clicking the DT1 or HD file,

2) Dragging and dropping the DT1 or the HD files onto the EKKO_View 2 application, either the 
main screen or the icon on the desktop. 

3) Selecting View > Section from the EKKO_View Deluxe or EKKO_View Enhanced programs.

Opening the HD file will open both the cross-section and the HD (header) file for viewing (see HD File
Information).

4.2 Close
The File > Close option closes the window associated with the currently active DT1 file.

4.3 Copy Image to Clipboard
The File > Copy Image to Clipboard option copies the image in the current Active Window to the
Clipboard so it can be pasted into other documents like a Word document or an email message. 

See View Settings Menu for details on modifying the image by changing the processing, turning on or off
the axes, grid lines, legend, fiducial markers and fiducial text. These options are useful if you want to add
your own scales or annotations using a graphics program or if you want to tile several individual images
together into one larger image.

This option can also be accessed from the Toolbar by pressing the Ctrl+C keys or by clicking on the Copy
Screen to Clipboard button on the Toolbar.
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The resolution of the image sent to clipboard is controlled by the size of the image on the screen. The
bigger the image on the screen, the higher the resolution of the image sent to the clipboard.

4.4 Export Image to File
The File > Export Image to File option allows the user to save an electronic copy of the image in the
current Active Window. The plot can be saved in BMP, JPG, PNG, TIFF or GIF graphics file formats. 

Select the graphics format file type from the drop-down list. Then input a filename and folder to save the
image to. 

In general, the BMP file is the largest while the JPG image is quite small and good for emailing.

See View Settings Menu for details on modifying the image.

This option can also be accessed from the Toolbar by clicking on the Export Image to File button:

See View Settings Menu for details on modifying the image by turning on or off the scales, grid lines,
legend, fiducial markers and fiducial text. These options are useful if you want to add your own scales or
annotations using a graphics program or if you want to tile several individual images together into one
larger image.

To obtain the best resolution in the exported image, stretch your display window to the largest size possible
with the desired aspect ratio. The image can also be stretched to extend outside of application window to
obtain even better resolution for the exported image. Even though part of the image is not visible in the
application window, it will still be preserved in the exported image.
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4.5 Print Image
The File > Print Image option allows the user to produce hard copies of the image in the current Active
Window. After selecting this option, a standard print dialog opens which allows the user to select the
printer they wish to print to as well as customize other printing parameters. For example, the user can
select to print the data image to a Landscape rather than a Portrait orientation.

The image can be sent directly to the default printer by pressing the Ctrl-P keys or by clicking the Print
button from the Toolbar:

See View Settings Menu for details on modifying the image by changing the processing, turning on or off
the scales, grid lines, legend, fiducial markers and fiducial text. 

To obtain the best resolution in the printed image, stretch your display window to the largest size possible
with the desired aspect ratio. The image can also be stretched to extend outside of application window to
obtain even better resolution for very large printed images. Even though part of the image is not visible in
the application window, it will still be preserved in the printed image.

4.6 Recent Files
If the desired DT1 file is one of the last four (4) files opened, it can be opened by selecting it from the
recent files list under File.

4.7 Exit
Selecting this option will close all windows that are open as part of the current EKKO_View 2 session and
exit the application.
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5 View Settings Menu
The View > Settings option allows the user to change various aspects of the images including processing,
color palettes, axes, data limits, legend, contrast and sensitivity values.

The Settings option can also be accessed from the Toolbar by clicking on the Settings button:

The settings are displayed in various tabs in the dialog (Figure 5-1). 

 Figure 5-1:  The View Settings dialog has 6 tabs for setting various parameters of the image display.

5.1 Preview
Clicking on the Preview button allows the user to see the effect of changes they have made to the View
Settings before permanently applying those changes by clicking on the OK button.

For example, to interactively experiment with a variety of gain methods and settings, select the Gain Type
and appropriate parameters and then select Preview to update the display. 
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5.2 OK
Clicking the OK button applies any changes to the settings for the current slice image and closes the
Settings dialog box.

5.3 Cancel
Clicking the Cancel button closes the Settings dialog box ignoring any changes that may have been made
to the settings, including any changes made using the Preview button (Preview).

5.4 Apply to All 
The Apply to All checkbox is used to apply all the current settings (on ALL the View Settings tabs) to all
open cross-section windows. Check the Apply to All checkbox and then press OK.

Be cautious when using this option because there is no “undo” available once the settings have been
changed by pressing OK. 

If you press Preview but then decide to abandon the changes, pressing Cancel will “undo” all the
changes. 

If the Apply to All option is not selected, any changed settings only apply to the current Active Window. 
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5.5 Basic / Advanced
The Basic View Settings screen is shown in Figure 5-1. 

Selecting the Advanced button adds five buttons for saving and loading View Settings Configuration files,
loading and saving the Default settings as well as loading the Factory Defaults.

The Advanced View Settings screen is shown in Figure 5-2. 

 Figure 5-2:  The Advanced View Settings dialog adds 5 buttons on the side for configuration files.

Every GPR data file opened in EKKO_View 2 has a configuration file saved with it that saves all the display
settings specified in the View Settings dialog box. The configuration file has the same name as the data
file but has an .ini extension. Any settings changed in the View Settings dialog are automatically saved to
the configuration file so that the next time the GPR data file is opened in EKKO_View 2, it is displayed
exactly the same as the last time. 

The current View Settings can be saved to a configuration file by selecting the Save As button. 

The current View Settings can be changed to previously-saved View Settings by selecting the Load button
and selecting a configuration file.

The first time a GPR data file is opened in EKKO_View 2, it uses the Default Settings. The very first time
that EKKO_View 2 is run, the Default Settings are set to the same values as the Factory Settings. 

The user can define their own Default Settings, to be used with every GPR data file opened for the first
time in EKKO_View 2, by selecting the desired View Settings and then pressing the Save As Defaults
button.
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5.5.1 Load...

The Load button loads a previously-saved View Settings configuration (.ini) file and applies it to the current
View Settings.

5.5.2 Save As...

The Save As button saves all the current View Settings to a configuration (.ini) file. Use this option to save
the current View Settings to an .ini file to load and use in the future.

The user can specify the name and location of this configuration file but it is commonly kept in the same
folder as the GPR data file(s).

5.5.3 Load Defaults

Pressing the Load Defaults button overwrites the current View Settings with the Default settings.

5.5.4 Save As Defaults

The Save As Defaults button saves the current View Settings and makes them the Default settings. The
Default View Settings are used with all GPR data files opened for the first time in EKKO_View 2. 

5.5.5 Factory Defaults

The Factory Defaults button resets the current and default View Settings to the default “factory” settings. 
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5.6 General Tab
The General tab under View Settings allows the user to edit the image title, display type, color of various
features and the font for all the axes, titles and the legend.

 Figure 5-3:  General tab.

5.6.1 Title

The Title option allows the user to change the title displayed in the Legend. Note that the Title must be
selected in the Legend Tab.

The default title is the file name. Other options are: User Title, File Name only or Path & File Name. 

The title will appear in the font specified under Font. 

5.6.2 Color Scale

When selected, the GPR data will be displayed as a color scale image. This means that the GPR signal
amplitude, which typically varies from negative to positive values, is displayed as different colors
depending on the amplitude. A variety of color palettes can be chosen for the display (see View > Settings
> Color Palette Tab).

The data traces can be displayed interpolated (smoothed) or uninterpolated (see Interpolation below). 
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5.6.3 Interpolation

When Color Scale display is selected, the data image may appear “blocky” or pixellated when zoomed in
or if the traces were collected with a long step size between them. Selecting the Interpolation option
smooths the appearance of the GPR data image (see Figure 5-4). 

 Figure 5-4:  Interpolation is used to smooth the raw data image on the left to the one on the right.

Interpolation of large files can be a computer resource intensive process.

Interpolation is not available when only Wiggle traces are displayed.

5.6.4 Wiggle Trace

When Wiggle Trace is selected, the GPR data are displayed in wiggle trace format. The GPR signal
amplitudes of each trace are plotted in overlapping vertical columns with the center of the column
representing zero signal amplitudes, the left of the column representing negative amplitudes and the right
of the column representing positive amplitudes. The trace is plotted as a line that oscillates with the
direction and amount of deflection dependent on with the amplitude of the signal at that point (see Figure
5-5).

Depending on the size of the display window, the total number of traces in the file and the current Zoom
setting, not all traces will necessarily be displayed in Wiggle format. The number of wiggle traces displayed
is optimized depending on the space available to avoid a crowded-looking image.

If only wiggle traces are displayed, interpolation is not enabled (see Interpolation above). 
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 Figure 5-5:  Wiggle Trace format with shading on the right.

Note that both Wiggle Trace and Color Scale can be displayed at the same time. 

Wiggle trace requires a finite pixel width in order to display the trace amplitudes whereas color scale only
needs a single pixel width to display a trace. Therefore, more data can be viewed in a narrow image in
color scale than in wiggle trace. 

5.6.4.1 Wiggle Trace Properties

When the Wiggle Trace display is selected, the Wiggle Trace Properties can be edited so that the right
side (positive amplitude peaks) or the left side (negative amplitude troughs) of the traces are shaded with
color. No shading is also an option. Figure 5-5 shows a wiggle trace display with shading on the right.

The color of the wiggle traces can also be changed using the Wiggle Trace Color option.   

5.6.5 Marker Color

The Marker color sets the color of fiducial markers (see Show Fiducials), skipped trace flags (see Show
Skipped Traces), the Hyperbola Velocity Calibration tool and the Measure tool. 

Fiducial Markers are markers or comments added during data acquisition at specific trace positions along
the survey line. Fiducial Markers appear as triangles at the bottom of the data image (Figure 2-1). They
are displayed if the View > Show Fiducials option is enabled. 
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Skipped Trace Flags displayed if there is skipped traces in the data and if the View > Show Skipped
Traces option is enabled. Skipped Trace Flags appear as rectangles at the bottom of the data image
(Figure 2-1). 

The color of the various markers can be changed by clicking the Marker button and selecting a color from
the standard Windows dialog. It is recommended to choose a color that provides high visibility on the
cross-sectional image.

5.6.6 Grid Color

Grid Lines corresponding to the major positions and/or depth or time labels can be superimposed on the
cross-sectional image (Figure 2-1). This option is available by selecting Grid Lines in the Axes Tab. 

The color of the Grid Lines can be changed by clicking the Grid button and selecting a color from the
standard Windows dialog. It is recommended to choose a color that provides high visibility on the cross-
sectional image.

5.6.7 Wiggle Trace Color

Wiggle Trace display is described above (Wiggle Trace).

The color of the Wiggle Traces can be changed by clicking the Wiggle Trace button and selecting a color
from the standard Windows dialog. 

5.6.8 Font

The Font option determines the font used for the position, depth and time axes as well as the text in the
legend (see Legend Tab). When selected, the standard Windows font dialog opens allowing the user to
select the Font, Font Style and Size. Increasing the font type and size decreases the data image size but
will improve the readability of printed images or graphics image files.
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5.7 Color Palette Tab
The Color Palette tab under View Settings allows the user to change the color palette and edit the
Sensitivity and Contrast values for the image.

 Figure 5-6:  Color palette tab.
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5.7.1 Color Palette

The default color palette for cross-sections is bone. This option allows the user to choose from a number of
pre-defined color palettes for the cross-section image(s). Quite often one color palette may bring out
features in a data set better than others so some experimentation may be required to determine the
optimal color palette for a particular data set. Most users find that “bone” allows for the easiest
interpretation of a wide range of data.

 Figure 5-7:  Data displayed with different color palettes.
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5.7.2 Sensitivity

The Sensitivity setting controls how sensitive the image is to small signal variations. The sensitivity value is
from 0 to 100%, least sensitive to most sensitive. The default setting is 100% (most sensitive). Pressing
the Normal button (see Figure 5-6) sets the Sensitivity to 100%.

Decreasing the Sensitivity from 100% widens the color palette around the zero signal level, removing the
weaker signals in the image so only the strongest signals are visible.

Cross-section signals vary from extreme negative values to extreme positive values with the zero signal in
the middle. As the Sensitivity setting decreases, the color associated with the zero signal level in the
middle of the color palette widens, resulting in the weaker signals being removed from the image. 

 Figure 5-8:  The Sensitivity value defaults to 100% (left) meaning the image is most sensitive to weak signals. As Sensitivity is 
decreased, the color in the middle of the color bar associated with weaker signals around zero, widens, removing weaker signals 

from the image (right, Sensitivity=80). 

The Sensitivity is changed using the appropriate slider bar in the dialog box. 

The Sensitivity setting for the image can also be modified by clicking on the slider bar and then using the
right and left arrows on the keyboard to increase or decrease the value respectively. If you select the Auto
Preview checkbox beforehand, the changes made to the Sensitivity setting will be instantly visible on the
image.

The Sensitivity is increased by five percent (5%) by selecting View > Contrast & Sensitivity > Sensitivity
Increase or clicking the following button on the Toolbar: 
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The Sensitivity is decreased by five percent (5%) by selecting View > Contrast & Sensitivity >
Sensitivity Decrease or clicking the following button on the Toolbar: 

Pressing the “Shift” key while increasing or decreasing the sensitivity will cause the value to increase or
decrease by 10% rather than 5%.

Pressing the “Ctrl” key while increasing or decreasing the sensitivity will cause the value to increase or
decrease by 1% rather than 5%.

Sensitivity can also be increased by 5% by pressing the “]” key and decreased by 5% by pressing the “[”
key on the keyboard. 

5.7.3 Contrast

The Contrast setting controls how much of the image area is at the extremes of the color palette. The
contrast ranges from 0 to 100%, less contrast to more contrast. The default setting is 0% (no added
contrast). Pressing the Normal button (see Figure 5-6) sets the Contrast to 0%.

As Contrast increases, more and more of the data is displayed at the extreme value of the color palette.
Contrast can be useful for making weak targets more visible in the image.

Cross-section signals vary from extreme negative values to extreme positive values with the zero signal in
the middle. As the Contrast setting increases, the colors associated with the high positive and negative
signal levels at the ends of the color palette widen, resulting in the weaker signals looking stronger in the
image. 

 Figure 5-9:  The Contrast value defaults to 0% meaning no contrast is added to the image (left, Contrast=0). As Contrast is 
increased, the colors on the left and right of the color bar associated with the strongest signals, widen into the middle, resulting in 

weaker signals looking stronger in the image (right, Contrast=50). 
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The Contrast is changed using the appropriate slider bar in the dialog box. 

The Contrast setting for the image can also be modified by clicking on the slider bar and then using the left
and right arrows on the keyboard to increase or decrease the value respectively. If you select the Auto
Preview checkbox beforehand, the changes made to the Contrast setting will be instantly visible on the
image.

The Contrast is increased by five percent (5%) by selecting View > Contrast & Sensitivity > Contrast
Increase or clicking the following button on the Toolbar: 

The Contrast is decreased by five percent (5%) by selecting View > Contrast & Sensitivity > Contrast
Decrease or clicking the following button on the Toolbar: 

Pressing the “Shift” key while increasing or decreasing the contrast will cause the value to increase or
decrease by 10% rather than 5%.

Pressing the “Ctrl” key while increasing or decreasing the contrast will cause the value to increase or
decrease by 1% rather than 5%.

Contrast can also be increased by 5% by pressing the “/” key and decreased by 5% by pressing the “.” key
on the keyboard. 

5.7.4 Auto Preview

Selecting Auto Preview allows the user to instantly see the effect of changes made to the settings in the
Color Palette tab, including Sensitivity, Contrast and the color palette. This is much faster than changing
the settings and then clicking on the Preview button. However, it may be undesirable for large data files
especially with Interpolation turned on because the screen update may be sluggish.



5-View Settings Menu EKKO_View 2 Help

30

5.7.5 Bipolar Color Palette

A bipolar color palette has colors for both positive and negative values with zero in the middle. Since GPR
cross-section images are normally displayed with amplitude values varying from negative to positive
values, a bipolar color palette is the default and is not normally changed. 

When the Bipolar Color Palette option is unchecked, the color palette becomes monopolar, meaning that
zero amplitude moves from the middle of the color palette to the extreme left. The color palette only applies
to the positive values of the signal amplitude; negative amplitudes are all colored the same color as zero
amplitude data.

 Figure 5-10:  Bipolar color palettes (left) are typically used for displaying GPR data images. Both negative and positive signal 
amplitudes are displayed using the color palette. If a monopolar color palette is used (right), only positive signal amplitudes are 
plotted using the color palette. Any negative signal amplitudes in the data are all plotted with the color corresponding to zero (0) 

signal amplitude.

Processes available in the EKKO_View Deluxe software like rectifying and enveloping GPR data as well
as CMP Analysis, result in data with all positive amplitude values. In this case, unchecking the Bipolar
Color Palette option when viewing data allows the full color palette to be used for the positive values.

-50 mV +50 mV 0 mV +50 mV

Bipolar Monopolar
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5.8 Processing Tab
The Processing Tab under View Settings is used to set the parameters for the processing of the GPR
cross-section image, specifically, Dewow and Gain.

 Figure 5-11:  Processing Tab for setting the Processing for the data file including Dewow and Gain. The Trace View on the right 
displays the Raw and Processed trace and the Gain.

A description of each parameter is displayed by holding the mouse cursor on the parameter input field.
These descriptions are disabled by selecting the Disable Tips checkbox.

5.8.1 Trace View

The Trace View is displayed on the right side of the dialog. It is a wiggle trace plot of the current trace at
the mouse cursor position. A wiggle trace plot depicts the signal amplitude as a positive or negative
deflection from zero (indicated by the + and - signs on the top corners).

After editing the Dewow or Gain parameters, the Preview and OK buttons become accessible. Pressing
the Preview button re-displays the cross-section image and the Processed trace in the Trace View using
the new processing parameters (Dewow, Gain etc.). 

Moving the mouse cursor horizontally to a different trace in the cross-section image will display that trace
in the Trace View. 
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 Figure 5-12:  Moving the mouse cursor horizontally in the cross-section image behind the Processing Tab will display the trace 
corresponding to the mouse cursor in the Trace View. Moving the mouse cursor vertically in the cross-section image moves the 
Trace View cross-hair along the current trace. The raw and processed amplitudes are displayed to the left of the Trace View (if 

selected).

5.8.1.1 Trace Amplitudes

Using the checkboxes beside the Trace View, the user can select to display the Raw trace (in black), the
Processed trace (in red) and the Gain (in blue). 

Moving the mouse cursor vertically along a trace in the cross-section image moves the corresponding
horizontal cross-hair in the Trace View. The cross-hair makes it easy to see the signal amplitude at any
point on the trace. The raw (in black) and/or processed (in red) signal amplitudes are displayed to the left
of the Trace View (if checked).

5.8.1.2 Min and Max Trace Amplitude

Below the Trace View, the current trace number and amplitude information is displayed. The minimum and
maximum amplitude values in millivolts (mV) for the trace at the current mouse cursor position is shown. 

If the Raw checkbox is checked, the minimum and maximum amplitude values correspond to the raw trace
and are displayed in black. 

If the Processed checkbox is checked, the minimum and maximum amplitude values correspond to the
processed trace and are displayed in red. 
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If both the Raw and Processed checkboxes are checked, the minimum and maximum trace amplitudes
displayed are for the Processed trace (in red).

Change the scale of the Trace View plot by editing the Scale value to any number between 1 and 50 mV.
The default scale is 50 mV. 

5.8.1.3 Gain

The current Gain is displayed as a blue line in the Trace View by selecting the Gain checkbox (see Figure
5-11). The shape of the gain will change depending on the Gain Type and the gain parameters.

Gain values are always positive with zero on the left of the Trace View plot. The zero (0) and + in blue on
the lower corners of the Trace View refer to the gain plot.

The Gain value at any point along the trace is displayed by moving the mouse cursor vertically along a
trace in the cross-section image and following the corresponding cross-hair in the Trace View. The cross-
hair makes it easy to see the gain value at any point on the trace. 

The Gain value is displayed in blue to the left of the Trace View.

The minimum and maximum values for the Gain function can only be displayed (in blue) under the Trace
View if the Gain checkbox is checked and the both the Raw and Processed checkboxes are not checked. 

When displaying the Gain function only, the Scale can be changed to any value up to 32767.
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5.8.2 Recommended Processing

Pressing the Recommended Processing button will automatically set the processing for the current GPR
data file; Dewow is always selected and the Gain Type is set to SEC2 with a Level of Auto. Values for
Attenuation, Maximum Gain and Start Gain parameters are calculated from the data and displayed.

To modify the Recommended Processing values slightly, change the Level from Auto to User and then
adjust the individual parameter values (see SEC2).

5.8.3 Dewow

Depending on the proximity of the transmitter and receiver as well as the electrical properties of the
ground, the transmit signal may induce a slowly decaying low frequency “wow” on the trace which is
superimposed on the high frequency reflections.

The Dewow process is designed to remove this unwanted low frequency signal while preserving the high
frequency signal. The removal of this wow in the data is also called the “signal saturation correction”.

 Figure 5-13:  Data line showing raw data with the low frequency “wow” component (left) and after the Dewow process removes 
the low frequency component (right). The Dewow process is highly recommended when data processing cross-sections and slices.

The wow is removed from the data by applying a running average filter on each trace. A window with a
width the same as that of one pulsewidth at the nominal frequency is set on the trace. The average value
of all the points in this window is calculated and subtracted from the central point. The window is then
moved along the trace by one point and the process is repeated. 

While any filter produces unwanted artifacts in the data to which it is applied, Dewow has been optimized
after many experiments over many years to reach a satisfactory compromise filter. 

The Dewow process is highly recommended when data processing cross-sections.
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5.8.4 Gain Type

In general, GPR signals decrease rapidly with depth and in most cases it is necessary to amplify the signal
using a "gain" function. Gain is used to amplify the strength of the GPR data signals in the cross-section
images. Applying gain to GPR data is similar to adjusting the volume knob on a music stereo. 

There are 5 Gain Types that can be applied to the GPR data:

1) None

2) SEC2

3) AGC

4) DVL

5) Constant

The current Gain Level is displayed in the Gain dropdown list on the Toolbar. This dropdown list can be
used to change the Level. The Gain Type is changed in the Processing Tab.

The current Gain Type and parameter values can be displayed in the Legend (see Legend Tab). 

The shape of the current Gain is displayed in the Trace View by selecting the Gain checkbox (see Figure
5-11). 

Some data may have had a permanent gain applied in other software, like the EKKO_View Deluxe
program. If the data file is opened in EKKO_View 2, a warning message will appear. 

Typically, data that has already been gained should be plotted with the EKKO_View 2 gain set to None. 
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5.8.4.1 Level

With the exception of No Gain (None), each Gain Type has one or more parameters that must be set. The
Level option is used to set the gain parameter values. 

Level options are: Default, Numbered Levels, User and, in the case of the SEC2 gain, Auto.

The Level is changed in this dialog but can also changed using the Gain Level dropdown list on the
Toolbar:

Default: Sets the gain parameters to defined values that will work for most typical data sets but may not be
optimized for the particular data being displayed.

When the Default Level is selected, the Gain buttons on the Toolbar are disabled (see Gain Increase /
Decrease).

Numbered Levels: Each gain also has up to 10 Numbered Levels. These are pre-defined gain parameter
values that gradually increase the gain from Level 1 to the last level. 

When the Level is set to a numbered level, it can be changed using the Gain buttons or the Gain dropdown
list on the Toolbar (see Gain Increase / Decrease). This makes it easy to quickly scroll through several
pre-set gains and find one that makes the data look the best.

User: Allows the user to input values for the gain parameters. 

The best way to set the User gain parameters for the SEC2 gain type is to use the Recommended
Processing button or the Default, Auto or Numbered Levels to determine the gain parameters close to
the gain you want. Then, simply select and edit the gain parameter you want to change and press Preview
or OK. The Level automatically changes to User with the changes to the parameter you edited.

When the User Level is selected, the Gain buttons on the Toolbar are disabled (see Gain Increase /
Decrease).

Auto: The SEC2 gain also has the Auto Level available. Using the GPR data file, Auto uses the average
decay curve of the GPR signal strength over time to calculate an appropriate gain parameter values for
Attenuation, Maximum Gain and Start Gain. 
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Implement those values by pressing Preview or OK.

When the Auto Level is selected, the Gain buttons on the Toolbar are disabled (see Gain Increase /
Decrease).

5.8.4.2 None (No Gain)

Selecting a Gain Type of None means that no gain will be applied to the GPR data before it is displayed.
The “raw” data will be displayed. 

This gain is not normally selected unless the material has very low attenuation and/or the targets of interest
are shallow, for example, in ice profiling, snow and perhaps concrete.

As well, if the data has already had a gain permanently applied to the data (for example in EKKO_View
Enhanced or Deluxe), the Gain menu item should be set to None by the user or else the data will be gained
a second time and may appear over-gained.

When a Gain Type of None is selected, the Gain buttons and dropdown list on the Toolbar are disabled
(see Gain Increase / Decrease).

5.8.4.3 SEC2

The Spherical Exponential Calibrated Compensation (SEC2) gain attempts to boost weaker signals by
compensating for spherical spreading losses and exponential ohmic dissipation of energy in the radar
data. 

SEC Gain = Start Gain * Exponential

Since radar wave signal strength decays exponentially in the ground, the SEC gain represents the gain
function closest to physical reality. The advantage of the SEC2 gain is that after it is applied, relative signal
strengths at different depths can be compared. This is not the case with other gains like AGC and
Constant.

There are 3 input parameters for the SEC gain: Start Gain, Attenuation and Maximum Gain. 

The strongest GPR signals come from shallow targets at the top of the GPR cross-section while deeper
targets lower in the cross-section have weaker signal strength. Therefore, the gain applied to the GPR
cross-section increases with increasing depth. The gain is a ramp that starts off at the Start Gain value at
the top of the cross-section, ramps up on a slope with the steepness depending on the Start Gain and
Attenuation value and levels off to a constant multiplier when the Maximum Gain value is reached.
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 Figure 5-14:  Cross-section image with the gain function shape and parameters on the right. In general, the Start Value is usually 
1 or 0, attenuation (a), which controls the steepness of the slope is usually 0.0 to 20 and the Maximum Gain, which cuts off the 
exponential rise is usually 20 to 1000. Try to avoid over-gaining the data. Start with low values for Attenuation and Maximum 

Gain and increase as necessary.

Attenuation

The Attenuation represents the radar wave attenuation (in dB/m) and this determines the steepness of the
ramp created for the SEC2 function. Lower values mean a more gradual slope while higher values are
steeper. The ramp starts at the Start Gain value and ramps up to the Maximum Gain value. 

Changing the attenuation usually has the biggest effect on the data display as compared to the Start Gain
and Maximum Gain values. 

 Figure 5-15:  A low value for Media Attenuation makes the cross-section image look good (left) while a high value overgains the 
data, in this case (right). 
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Typical values for the Attenuation are 0 to 20 (selected from the drop-down list) but any value can be input
by typing it directly into the field. Attenuation values over 20 may be necessary for materials with very high
attenuation. The default value is 5.

Low values for Attenuation are typically used but higher values may help to improve the imaging of deeper
targets. Try to use the lowest value possible as the data can be "over-gained" making it more difficult to
understand.

Start Gain

The Start Gain is the gain value at zero depth at the top of the GPR cross-section. 

A Start Gain less than 1 can be used to reduce signal amplitudes prior to first-break time (also called time
zero). If the Start Gain is 1 or more it is only applied after first-break time (leaving pre-first-break data
unchanged).

Typically values for the Start Gain are 0 to 5 with 1 being the default value. Data with high attenuation may
require a higher value for Start Gain, perhaps as high as 10.

Since the Start Gain is a multiplier for the exponential (Attenuation) value, the Start Gain value affects the
steepness of the ramp associated with the Attenuation value. Higher values for the Start Gain will result in
steeper ramps (more gain).

Maximum Gain

Since the SEC gain is an exponential function, it could go to infinity. The Maximum Gain is the highest
multiplication factor for the GPR cross-section data. The ramp defined by the Attenuation stops increasing
once it has reached the Maximum Gain value. 

Typically values for the Maximum Gain are 20 to 1000 with 500 being the default value.
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5.8.4.4 AGC (Automatic Gain Control)

The Automatic Gain Control (AGC) attempts to bring weak and strong signals to the same level by
applying a gain function that is inversely proportional to the signal strength. 

This type of gain is most useful for defining continuity of reflecting events. The user should realize that
AGC does not preserve relative amplitude information. Hence once the data have been AGC gained, one
can no longer make reliable deductions concerning the strength of any particular reflector relative to other
reflectors.

Each trace in the GPR section is processed such that the average signal is computed over a time window
and then the data point at the center of that time window is amplified (or attenuated) by the ratio of the
desired output value to the average signal amplitude. 

Note that if a data point value multiplied by the gain value exceeds 50 mV absolutely, the new data point
value becomes 50 or -50.

 Figure 5-16:  Cross-section image with an AGC gain applied. The AGC is calculated for each trace so varies for each trace. The 
AGC gain for the trace at position 1.5m is shown on the right. In general, the Window Width is usually 1.5 pulse widths and the 

Maximum Gain is 500.

There are two input parameters for the AGC gain, Window Width and Maximum Gain. Figure 5-16 shows
the data with an AGC gain applied using a Maximum Gain value of 500 and a Window Width of 1.5. 
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Window Width

In computing the gain to be applied at each point, the program calculates the average signal level over a
window of points given by Window Width and centered about the point. The Window Width is specified in
units of pulsewidth based on the nominal antenna frequency. In the case of data collected at 100 MHz with
a sampling interval of 0.8 ns, and a window width of 1.5, 28 points would be used to compute the average
signal strength. 

The Default of 1.5 for Window Width is perfectly adequate in most cases.

Maximum Gain

Since the AGC gain is inversely proportional to the signal strength, very small signals can produce very
large gains. Therefore some type of gain limiting scheme must be applied. The Maximum Gain value
represents an upper limit on the gain that can be applied to the data and weaker signals that would
produce gains larger than this value, are capped at this maximum value.

The Maximum Gain can vary from 1 to 32767. The Default value is 500.

A typical value would be 50 - 2000 depending on the noise and average signal levels.

5.8.4.5 DVL Gain

The DVL Gain applies the same type of gain that is used on the DVL with Noggin systems. The DVL Gain
is a two-staged gain. 

First, it applies a linearly increasing gain (Beta) as a function of time. The second stage adjusts the
sensitivity to smaller signals by an “S” curve gain (Alpha).

 Figure 5-17:  The DVL Gain is a two-stage gain. First, the Beta value applies a linear gain with a ramp (left). The higher Beta is, 
the steeper the ramp and the higher the gain. Then Alpha defines an S-shaped curve used to translate amplitude values to a color 

on the color palette (right). 

There are two input parameters for the DVL Gain: Alpha and Beta:

Beta
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Beta defines the linear gain as a function of time. The units are in gain per nanosecond. The higher the
beta value, the steeper the slope and more gain applied to the data (see Figure 5-17). 

Beta varies from 0.01 to 100. The Default value is 0.04. 

Alpha

Alpha defines the S shape of the second gain. If Alpha is 100, curve is linear and all signals have the same
sensitivity. As Alpha decreases below 100, the S curve is larger, increasing the small signal sensitivity and
decreasing the large signal sensitivity. 

Alpha varies from 0.01 to 100. The Default is 1.0. 

5.8.4.6 Constant

A constant gain will multiply all data by the user specified value. Thus if the user enters the number 10, all
data points will be multiplied by a factor of 10. 

Since both strong and weak signals are multiplied by the same amount, a constant gain factor has the
potential to over-gain and clip the stronger signals shallow in the section and under-gain the weaker
signals deeper in the section.

 Figure 5-18:  A Constant Gain of 20. The top of the section is overgained while the bottom is under-gained.

The constant gain is the only parameter required:

Gain

The constant gain factor that the GPR data will be multiplied by.

Values can vary from 0.01 to 32767. Typical values for the Constant gain are in the range from 5 to 1000.
The Default value is 100. A Gain value less than 1 will reduce the signal amplitudes.
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5.9 Axes Tab
The Axes Tab under View Settings changes axes settings including units, titles, increment and grid lines.
The image direction can also be changed.

 Figure 5-19:  Axes tab to specify axes to display, grid lines, units and line direction.

5.9.1 Display Units

The Display Units setting determines the units that will be used for the Position and Depth axes; either
meters or feet.

The units default to those used during the original data collection but can be converted and displayed in
either meters (m) or feet (ft). For example, data collected in feet can be plotted in meters.

The display units can also be changed by pressing the “meters” or “feet” buttons on the Toolbar:
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5.9.2 Reverse Direction

The Reverse Direction checkbox is used to reverse the direction of the cross-section image, for example, if
the data positions go from 0 to 10m, reversing the direction will display the data from 10 to 0m. 

 Figure 5-20:  The Reverse Direction option.

Note that all features associated with position get reversed. This includes the position axis, GPS, fiducial
markers and skipped traces.

This option is designed to allow users to compare lines in collected in a zig-zag (also called Forward -
Reverse) survey format in the same orientation. 
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5.9.3 Axes

Cross-section images are typically displayed with a position axis across the top, time axis on the right side
and depth or elevation axis on the left side. The axes settings are changed in this tab.

Features common to all axes are:

1) Any axis can be removed from the cross-section image by unchecking the appropriate Axis 
checkbox.

2) All Axes can be quickly displayed or removed from the cross-section image by checking or 
unchecking the View > Show Axes option.

3) The position, depth and elevation axes units default to the units used during data acquisition 
but can be changed under Display Units.

4) The Title for the axis can be left as the Default Title or the user can uncheck the Default Title 
checkbox and enter a custom title. 

5) The axis Label Increment is automatically set from the data limits if Auto is selected. The user 
can define the axis label increment by unchecking the Auto checkbox and entering a value. The 
axis labels are displayed with the number of decimal places specified in the input value; for 
example, a value of 10.00 will display axis label values of 0.00, 10.00, 20.00 etc.

6) Grid lines associated with an axis can be removed from the cross-section image by unchecking 
the appropriate Grid Lines checkbox.

7) All Grid Lines can be quickly displayed or removed from the cross-section image by checking 
or unchecking the View > Show Grid Lines option.

5.9.3.1 Position Axis    

The Position Axis is displayed along the top of the cross-section image (see Figure 2-1) if it is checked in
this dialog box. 

Vertical Grid Lines corresponding to the Position Axis labels are displayed on the cross-section image if
the Grid Lines option is checked (see Figure 2-1).

5.9.3.2 Time Axis

The Time Axis is displayed in nanoseconds (ns) along the right side of the cross-section image (see
Figure 2-1) if it is checked in this dialog box. If, however, the Depth axis is unchecked and removed from
the image, the Time axis moves to the left side of the cross-section image.

Horizontal Grid Lines corresponding to the Time Axis labels are displayed on the cross-section image if
the Grid Lines option is checked (see Figure 2-1). Note that only time OR depth horizontal grid lines can
be displayed; not both.
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5.9.3.3 Depth Axis

The Depth Axis is displayed on the left side the cross-section image (see Figure 2-1) if it is checked in this
dialog box. The depth axis is non-linear (squished on the top) to correct for the antenna separation.

GPR data are measured in time and to convert time to depth, a velocity value for the material scanned
must be entered in the Velocity field on the Axes tab. This velocity value is displayed in the Depth Axis
title. 

If you need help selecting an appropriate velocity, click on the “?” button beside the velocity value and a
table of typical velocity values for various materials is displayed. The default velocity is 0.10 m/ns or 0.328
ft/ns.

An inaccurate velocity value will result in an inaccurate depth scale. If a hyperbolic response is observed in
the data, the velocity can be extracted from the data by performing a calibration (see Velocity Calibration
for Depth Determination). Velocity can also be extracted from CMP/WARR data (see CMP/WARR
Velocity Calibration)

Horizontal Grid Lines corresponding to the Depth Axis labels are displayed on the cross-section image if
the Grid Lines option is checked (see Figure 2-1). Note that only time OR depth horizontal grid lines can
be displayed; not both.

5.9.3.4 Elevation Axis

If topographic data were added to GPR data file using the “Add Topography” routine in EKKO_View
Enhanced or EKKO_View Deluxe software, the cross-section image can be shifted to compensate for
topography and plotted with an elevation axis. 

 Figure 5-21:  Cross-section image displayed with an elevation axis. 
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The Elevation Axis is displayed on the left side the cross-section image (see Figure 5-21) if it is checked in
the dialog box under View > Settings > Axes tab. 

GPR data are measured in time and to convert time to elevation, a velocity value for the material scanned
must be entered in the Velocity field on the Axes tab. This velocity value is displayed in the Elevation Axis
title. An inaccurate velocity value will result in an inaccurate elevation scale.

Horizontal Grid Lines corresponding to the Elevation Axis labels are displayed on the cross-section image
if the Grid Lines option is checked (see Figure 2-1). Note that only time OR elevation horizontal grid lines
can be displayed; not both.

On a normal depth plot, the depth axis is non-linear (squished on the top) to compensate for the antenna
separation. When plotting data with topography, part of the topographic shifting of the data file includes
correcting for the antenna separation so the elevation axis is linear. This correction results in the upper part
of the cross-section image being slightly stretched. 

Previously Topo-Shifted Data Files

If a historical GPR data file was topographically shifted using the “Shift Topography” routine in the
EKKO_View Deluxe program, when the file is opened in EKKO_View 2, a warning message is displayed: 

In this case topographic shifting should be the last process performed after other processing like Dewow
and Gain have been applied. When a topographically shifted file is opened, the user is advised against
applying more processing in the Processing Tab.

Previously topo-shifted data can only be plotted with an elevation axis, not a depth axis.

With EKKO_View 2’s ability to apply topographic corrections without altering the data file, it is no
longer necessary or desirable to use the “Shift Topography” routine in EKKO_View Deluxe.
EKKO_View Deluxe should only be used to integrate the elevation data into the GPR data file using
the “Add Topography” routine.
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5.10 Limits Tab
The Limits Tab under View Settings changes depth, elevation or time limits for the cross-section image. 

If data are plotted with a Depth Axis (set under the View Settings > Axes Tab), the limits of the data
image can be set using time and/or depth limits. In this mode Elevation limits are not accessible (Figure 5-
22).

If data are plotted with an Elevation Axis (set under the View Settings > Axes Tab), the limits of the data
image can be set using time and/or elevation limits. In this mode Depth limits are not accessible (Figure 5-
25).

The Available Data Range box shows the depth and time ranges. Depth ranges from zero (0.0) to the
maximum depth of the data based on the velocity set under the Depth Axis. Time ranges from the start
time (which is usually negative) to the end time in nanoseconds. 

 Figure 5-22:  The View Settings > Limits Tab when the axis under the Axes Tab is set to Depth. In this case the Elevation limits are 
not accessible.

The Limits option and the Apply to All checkbox are useful for plotting multiple data files, even those with
different time window lengths, with the same limits so they can be easily compared on-screen. 
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5.10.1 Time Limits

5.10.1.1 Top Time

The Top Time Limit option allows the user to set the minimum time displayed on cross-section images
(Figure 5-23). There are 3 options for this setting:

1) Zero Time (the default) displays data starting at time zero.

2) Min Time displays the data starting at the minimum time; a negative time that includes all the 
data before zero time.

3) User Time allows the user to input the minimum time to be displayed in the cross-section 
image. Be cautious when using a positive top User Time because it will remove data at 
the top of the cross-section image (Figure 5-23, bottom image).

 Figure 5-23:  Zero Time (top left), Min Time (top right) and User Time (bottom) settings for the Top Time Limit.

5.10.1.2 Bottom Time

The Bottom Time Limit option allows the user to set the maximum time displayed on cross-section images.

There are 2 options for this setting:

1) Max (the default) displays the full time range of the cross-section data,

2) User Time allows the user to input the maximum time to be displayed in the cross-section 
image. A User Time less than the Max time will crop data from the bottom of the image.

If the Bottom User Time is set to a value larger than the maximum time of the cross-section, the cross-
section will show the time axes but the data below the Maximum time will be blank (Figure 5-24, middle
image).
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5.10.2 Depth Limit

The Bottom Depth Limit option allows the user to change the maximum depth displayed on cross-section
images.

If the maximum depth value is less than the maximum depth in the data, the bottom of the cross-section
image is cropped. If the maximum depth value is greater than the maximum depth in the data, white space
is added to the bottom of the cross-section image (Figure 5-24, middle image). 

 Figure 5-24:  The Bottom Depth/Time Limit (left) shows the full depth/time of the cross-section (left) while the User Depth and 
User Time options can be set to show more (middle) or less (right) data. 
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5.10.3 Elevation Limit

The Elevation Limits are only accessible if data are plotted with an Elevation Axis (set under the View
Settings > Axes Tab). 

 Figure 5-25:  The View Settings > Limits Tab when the axis under the Axes Tab is set to Elevation. In this case the Depth limits are 
not accessible.

The Elevation Limits allow the user to change the maximum and minimum elevations displayed on cross-
section images. 

 Figure 5-26:  The elevation limits default to the highest and lowest elevations in the data file. These values can be edited in the 
Limits dialog. 
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5.10.3.1 Top Elevation

The Top Elevation defaults to the highest elevation value in the data file (Figure 5-26).

If the Top Elevation is set greater than the highest elevation in the cross-section, the full elevation axis is
displayed but white space is added to the top of the cross-section image (Figure 5-27). 

 Figure 5-27:  If the Top Elevation value is higher than the highest elevation value in the data file, white space is added to the top 
of the image.

Be cautious when using a Top Elevation that is set less than the highest elevation in the data
because it will remove data at the top of the cross-section image (Figure 5-28).

 Figure 5-28:  If the Top Elevation value is lower than the highest elevation value in the data file, data at the top of the image is cut 
off.

A popular use of the Top User Elevation value is to set a common datum value for a number of related
cross-sections so they can be easily compared.
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5.10.3.2 Bottom Elevation

The Bottom Elevation defaults to the lowest elevation value in the data file (Figure 5-26).

If the Bottom Elevation is set less than the lowest elevation in the cross-section, the full elevation axis is
displayed but white space is added to the bottom of the cross-section image. 

 Figure 5-29:  If the Bottom Elevation value is lower than the lowest elevation value in the data file, white space is added to the 
bottom of the image.

If the Bottom Elevation is set greater than the lowest elevation in the cross-section, data is cropped off the
bottom of the image. 

 Figure 5-30:  If the Bottom Elevation value is higher than the lowest elevation value in the data file, data at the bottom of the 
image is cut off.
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5.10.4 Fit to View Limits

If the Fit to View option is selected, the Top and Bottom Limits defined are displayed in the full window. 

For example, the original data has a Bottom Limit set to the Max of 9.5m. If the Bottom Limit is changed to
5m, the data image is expanded vertically to fill the full window (Figure 5-31).

 Figure 5-31:  Fit to View On: The Bottom Limit is set to the maximum of 9.5m (left). If the Bottom Limit is changed to 5m and Fit 
to View is on, the data image is expanded vertically to fill the window with a maximum depth of 5m (right).

If the Fit to View option is not selected, the Top and Bottom Limits are displayed in the window at the
original vertical scale and the data will be truncated and white space will appear at the bottom of the image.
For example, the original data has a Bottom Limit set to the Max of 9.5m. If the Bottom Limit is changed to
5m, the vertical scale remains the same as the original and the data image is truncated at 5m (Figure 5-
32).

 Figure 5-32:  Fit to View Off: The Bottom Limit is set to the maximum of 9.5m (left). If the Bottom Limit is changed to 5m and Fit 
to View is off, the vertical scale does not change and the data image is truncated at 5m (right).
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5.11 Legend Tab
The Legend Tab is used to select the options and order of the options displayed on the legend (see Figure
2-1). 

 Figure 5-33:  The Legend tab controls the options and order of the options displayed on the legend under the data image.

The Legend appears on the bottom of the data image if:

1) the Show Legend checkbox is checked in this dialog,

2) the Show Legend button on the Toolbar is pressed, or

3) the Show Legend option under the View menu is selected.

To show the legends for multiple data images at once, check the Show Legend and Apply to All
checkboxes and then press OK. To hide the legends for multiple data images at once, uncheck the Show
Legend checkbox, check the Apply to All checkbox and then press OK.

Check the options that you want to appear in the legend. Change the order by highlighting the option and
then using the Up and Down buttons to move the option. 
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The legend options are:

1) Title: as defined in the View > Settings > General Tab. The default Title is the File Name, so if 
that Title and the File Name (below) is selected in this dialog, the file name will appear twice in 
the Legend.

2) File Path: the string of folders and sub-folders where the data file is located on the computer. 
The path makes it easy to find the original data files after they have been printed or pasted into 
a report.

3) File Name: the name of the data file.

4) Collection Date: the date the data file was collected.

5) Center Frequency: the antenna frequency the data file was collected with.

6) Velocity: in meters/nanosecond (m/ns) or feet/nanosecond (ft/ns) as listed under View > 
Settings > Axes > Depth Axis. The Velocity is also automatically displayed on the Depth 
Axis. The velocity can be calculated using the option under Tool > Hyperbola Velocity 
Calibration. 

7) Processing Parameters: Indicates if the Dewow filter is on (see See View > Settings > 
Processing Tab > Dewow). Also lists the Gain Type and gain parameters applied to the cross-
section images (see View > Settings > Processing Tab > Gain Type). 

8) Sensitivity and Contrast: (S) in percent listed under View > Settings > Color Palette Tab > 
Sensitivity and (C) in percent listed under View > Settings > Color Palette Tab > Contrast.

9) Color Bar: displays a graphic image of the color bar used for the data image and listed under 
View > Settings > Color Palette Tab > Color Palette.

10)Palette: the name of the Color palette used for the data image and listed under View > 
Settings > Color Palette Tab > Color Palette.

11)GPS: if the data file contains GPS information, this option displays the GPS start and end 
positions. The format is set by pressing the GPS Configuration from the Legend Tab. 
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5.11.1 GPS Configuration

If the GPR data file contains GPS data (added using the EKKO_View Deluxe, IcePicker or another
program), the GPS Configuration dialog box is available. 

5.11.1.1 Latitude/Longitude

If Latitude/Longitude is selected with the checkbox, the display options are:

1) Degrees Minutes Seconds

2) Decimal Degrees

The options for the Hemisphere are:

1) Do not show

2) Show as a plus or minus sign. A plus (+) sign if Latitude is in the Northern hemisphere or 
Longitude is in the Eastern Hemisphere and a minus (-) sign if Latitude is in the Southern 
hemisphere or Longitude is in the Western Hemisphere. 

3) Letter: For latitude, “N” for North or “S” for South. For Longitude, “E” for East or “W” for West.

4) Word: For latitude, “North” or “South”. For Longitude, “East” or “West”.

A sample of the current GPS output is shown at the bottom of the dialog box.
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5.11.1.2 UTM

If UTM is selected with the checkbox, the Reference Ellipsoid can be selected from the drop-down list.
The default is WGS-84.

To display the UTM Zone Number and/or the UTM Letter Designator, select those options.

A sample of the current GPS output is shown at the bottom of the dialog box.
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6 View Menu
The View menu option allows the user to change various aspects of the images including increasing and
decreasing gain, sensitivity, contrast, zoom, pan, link views, change units, font and showing or hiding color
scale images, wiggle traces, fiducials, skipped traces, axes, grid lines, the legend, toolbar and status bar.

Note that the View > Settings options are described in the View Settings Menu section of this document.

6.1 Gain Increase / Decrease
Gain is described in detail under View > Settings > Processing Tab > Gain Type. 

The options in the View menu are shortcuts for quickly changing the Gain Level. 

The gain level is increased by selecting View > Gain Increase or clicking the following button on the
Toolbar: 

The gain level is decreased by selecting View > Gain Decrease or clicking the following button on the
Toolbar: 

These buttons will be disabled if the Gain Level is set to Auto, Default or User. To enable them, set the
Gain Level to a numbered value.

The Gain Level can also changed using the Gain Level dropdown list on the Toolbar:

The possible options are: Numbered Level, Default, User and Auto.

The Level Gain can also be increased by pressing the “+” key and decreased by pressing the “-” key on the
numeric key pad on standard keyboards.
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6.2 Contrast & Sensitivity
Contrast and Sensitivity are described in detail under View > Settings > Color Palette Tab. 

The options in the View menu are shortcuts for quickly changing the Contrast and Sensitivity values using
the menus. 

The Contrast and Sensitivity values can also be changed using the buttons on the toolbar or pressing keys
on the keyboard.

6.2.1 Sensitivity Decrease / Increase

Sensitivity is increased by 5% by selecting the View > Contrast & Sensitivity > Sensitivity Increase
option.

Sensitivity is decreased by 5% by selecting the View > Contrast & Sensitivity > Sensitivity Decrease
option.

If the the Ctrl key is pressed at the same time, the value changes by 1%.

If the the Shift key is pressed at the same time, the value changes by 10%.

6.2.2 Contrast Decrease / Increase

Contrast is increased by 5% by selecting the View > Contrast & Sensitivity > Contrast Increase option.

Contrast is decreased by 5% by selecting the View > Contrast & Sensitivity > Contrast Decrease
option.

If the the Ctrl key is pressed at the same time, the value changes by 1%.

If the the Shift key is pressed at the same time, the value changes by 10%.

6.3 Apply Normal Settings to Contrast & Sensitivity
The View > Apply Normal Settings to Contrast & Sensitivity option sets the Contrast and Sensitivity
values for the Active Window to the defaults of zero (0) and 100 respectively.
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6.4 Zoom
The Zoom options zoom in and out of the cross-section image in the position direction. 

Before zooming, make sure that the cross-section image you want to zoom is the Active Window.

There are 4 ways of using the Zoom option:

1) Zoom in to an area 50% of the current image size by selecting View > Zoom > In or by 
pressing the Insert key or the following button on the Toolbar:

Zoom in only applies to the position direction. It does not apply to the time or depth direction.

2) Zoom out to an area 200% of the current image size by selecting View > Zoom > Out or by 
pressing the Delete key or the following button on the Toolbar:

Zoom out only applies to the position direction. It does not apply to the time or depth direction.

3) Draw a box around the area to zoom to by selecting View > Zoom > Select Area or by 
pressing the following button on the Toolbar:

After selecting the option to zoom to an area, draw a box on the image by clicking and dragging
from one corner diagonally to the opposite corner. A box will be superimposed on the image as
you drag it. Dropping the box will cause the image in the box to zoom to the full window size.

4) Zoom to the full window size by pressing the Home key or by selecting View > Zoom > Fit to 
Window or by pressing the following button on the Toolbar:

This option is usually selected to quickly return to the full image view (as determined by the
data limits in the Limits Tab) after zooming in.

After zooming into an image, use the scroll bars to move around and view different areas. The width of the
scroll bar gets narrower each time the image is zoomed in to indicate that a smaller percentage of the full
image range is displayed. 

When zoomed in on an image, the Page Up and Left Arrow keys scroll to the left and Page Down and
Right Arrow keys scroll to the right. 

Page Up and Page Down moves one whole screen to the left and right respectively while the Left Arrow
and Right Arrow scrolls the image a little bit to the left or right.

If your mouse has a wheel, the image can be scrolled left or right using the wheel.



6-View Menu EKKO_View 2 Help

62

The Up Arrow key scrolls the image up and the Down Arrow key scrolls the image down.

A zoomed in image will still display the position, depth and time scales. 

If you scroll beyond the limits of the data into an area with no data, press the Fit to Window button to
return to the data view.

 Figure 6-1:  Zoomed image.Use the scroll bars on the right and bottom to move the zoomed area around the image.

The zoomed in image may show more data than defined by the box because the additional data will be
added to the right or bottom of the image so it always retains the correct aspect ratio.

6.5 Pan
Pan allows the user to move around a zoomed in image. In Pan mode, the mouse cursor becomes a hand
that can be dragged and dropped to view different areas of the image.

It can be selected under View > Pan or by pressing the following button on the Toolbar:

Once in Pan mode, click and drag the data image to a new location. 

To exit from Pan mode, select the option again under View > Pan or depress the same button on the
Toolbar.
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6.6 Link View Position Range
Two or more data images can be linked together and scrolled together horizontally in the position direction.
This option is very handy for comparing parallel lines.

The Link View Position Range option is most useful when the data files were collected with different
frequencies so that you want to scroll the positions but keep the depth range for each window different
(see Figure 6-2).

 Figure 6-2:  250, Parallel lines linked by positions and scrolled together. Note that since only the positions are linked, the vertical 
time/depth scales can be different.
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6.7 Link View Position and Time/Depth Range
All open data images can be linked together and scrolled together horizontally in the position direction and
vertically in the time/depth direction. This option is very handy for comparing parallel lines.

The Link View Position and Time/Depth Range option is most useful when the data files were collected
with the same or similar frequencies so that you want to be able to scroll horizontally in the position
direction and also vertically in the time/depth direction (Figure 6-3). 

 Figure 6-3:  Six 250 MHz parallel lines linked by positions and scrolled together. 

If the data files are different frequencies, i.e. 100 MHz and 1000 MHz, all cross-section images are plotted
with the same vertical scale so the shallower, high frequency image may be difficult to see (Figure 6-4). 

 Figure 6-4:  1000, 500 and 250 MHz parallel lines linked by position and time/depth and scrolled together. Note that since both 
position and time/depth are linked, the vertical scales for each data image is identical. This has resulted in the higher frequency 

data on the left being concentrated at the top of the image compared to the low frequency data on the right.
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6.8 Show Color Scale Image / Show Wiggle Trace
Data images are displayed as a Color Scale image, a Wiggle Trace image or both.

If the View > Show Color Scale Image option is checked, the Color Scale image is displayed in the
Active Window. 

If the View > Show Wiggle Trace option is checked, it shows the Wiggle Trace image in the Active
Window. 

If both the Show Color Scale Image and the Show Wiggle Trace options are checked, both images are
displayed in the Active Window. 

For more details, see Color Scale and Wiggle Trace.

These options are tied to the associated checkboxes in the General Tab.

6.9 Show Fiducials
Fiducials are markers and/or comments added during data acquisition at specific trace positions along the
line. Fiducials can also be edited or added after the survey using a routine in the EKKO_View Deluxe
software.

If the DT1 file contains Fiducials, they are displayed on the data image if the View > Show Fiducials
option is checked. 

The fiducials will appear as colored triangles on the bottom of the cross-section (see Figure 2-1). The color
of the fiducial can be changed in View > Settings > Marker Color.

If View > Show Fiducial Text is on, the text associated with the Fiducial is also displayed.

If the data file does not contain any fiducials, this option is greyed out and not accessible.

6.10 Show Fiducial Text
If Show Fiducials is enabled, the View > Show Fiducial Text option is accessible. This option displays
the text associated with the fiducials (see Figure 2-1).

The font size of the Fiducial Text is the same as the Axis and is changed in View > Font or View >
Settings > General Tab > Font.

If the DT1 file does not contain any fiducials, this option is greyed out and not accessible.

6.11 Show Skipped Traces
If the data file contains positions where traces were skipped during data collection, this can be indicated on
the data image by selecting View > Show Skipped Traces.

Skipped traces appear as colored rectangles on the bottom of the cross-section (see Figure 2-1). The
color of the skipped traces can be changed in View > Settings > Marker Color.

Skipped traces are filled in with interpolated or repeated traces.
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6.12 Show Axes
Checking the View > Show Axes option displays axes around the data image (see Figure 2-1). 

The depth scale is displayed on the left side of the image, the time scale is displayed on the right side of
the image and a position scale is displayed across the top of the image. 

Before selecting the Show Axes option, make sure that the image you want to display or hide the axes is in
the Active Window.

6.13 Show Grid Lines
Checking the View > Show Grid Lines option superimposes a grid of dashed lines onto the cross-section
image (see Figure 2-1). 

Horizontal grid lines appear at time or depth label increments and/or vertical grid lines positions label
increments. 

Show Grid Lines is greyed out and not available unless grid lines are selected under View > Settings >
Axes Tab. 

Before selecting the Show Grid Lines option, make sure that the image you want to add the grid lines to is
in the Active Window.

The Show Grid Lines option is available by selecting View > Grid Lines from the menu or by selecting
the Toggle Legend button from the Toolbar: 

The grid color can be changed under View > Settings > General Tab > Grid Color.

6.14 Show Legend
Checking the Show Legend option adds a legend to the cross-section image (see Figure 2-1). 

The Legend appears as lines of text below the cross-section image. It contains user-defined information
about the cross-section including the line name, velocity, data processing, gain, color palette, contrast and
sensitivity, etc. (see View > Settings > Legend Tab).

Before selecting the Show Legend option, make sure that the image you want to add the legend to is in the
Active Window.

The Show Legend option is available by selecting View > Show Legend from the menu or by selecting
the Toggle Legend button from the Toolbar: 
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6.15 Feet/Meters
The units of the position and depth axes can be set to meters or feet. Select View > Feet or View >
Meters. 

The units can also be changed using the buttons on the Toolbar:

Note that the option selected in the View menu changes the option under View > Settings > Axes >
Display Units.

6.16 Font
The Font option is described in more detail under View > Settings > General Tab > Font.

The View > Font option is a shortcut to the font dialog used for the position, depth and time axes as well as
the text in the Legend. 

6.17 Toolbar
If View > Toolbar is checked, the Toolbar appears below the menu bar (Figure 2-1).

6.18 Status Bar
If View > Status Bar is checked, the Status Bar appears along the bottom of the EKKO_View 2 Window
(Figure 2-1).

The information text that appears on the right side of the Status Bar corresponds to the mouse cursor
position within the data image (Figure 2-1). This text information can be copied to the Clipboard by
pressing the F8 key. For more details see Status Bar. 
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7 Tools Menu
The Tools menu has tools to calibrate GPR velocity, measure distances, display and print the header
(.HD) file and set EKKO_View 2 as the viewer for EKKO_View Deluxe and EKKO_View Enhanced
software.

7.1 How Depth is Determined
Ground penetrating radar systems record the time for a radio wave to travel to a target and back. The
depth to that target is calculated based on the velocity at which the wave travels to the target and back. 

In simple terms, it is calculated as: 

D = V x T/2

where: D is Depth (meters or feet) 

      V is Velocity (meters/nanosecond or feet/nanosecond) 

      T is Two-way travel time (nanoseconds) 

The finite separation between antennas complicates this calculation, especially for shallow depths.
Correcting for the antenna separation is why the depth axis appears non-linear at the top (see Depth
Axis).

To calculate the depth to a target, it is critical that the velocity of the material be known. 

Velocity can be measured using the Velocity Calibration for Depth Determination described below but if
depth data is desired but radar velocity cannot be measured, it must be estimated. The table below gives
typical radar velocities for many common materials. If the material is unknown, a good average velocity to
use for geological materials is 0.10 m/ns or 0.328 ft/ns. 
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7.1.1 Typical GPR Velocities of Common Materials

A velocity can be input in the View > Settings > Axes Tab > Depth Axis velocity field. 

7.2 Velocity Calibration for Depth Determination
The correct velocity is necessary for accurately determining the depth of an object from the cross-section
images. 

The velocity defaults to a typical average velocity of 0.10 m/ns or 0.328 ft/ns.

Velocity can be determined by calibrating to a hyperbola in the cross-section data. This method requires
the user to fit a typical response curve (a hyperbola) to the raw data to extract the velocity.

Select the Tool > Velocity Calibration for Depth Determination from the menu or the Hyperbola
Velocity Calibration button from the Toolbar:

Material Velocity (m/ns) Velocity (ft/ns)

Air 0.30 0.98

Ice 0.16 0.53

Dry Soil 0.15 0.49

Granite 0.13 0.49

Dry Salt 0.13 0.43

Dry Rock 0.12 0.39

Limestone 0.12 0.39

Wet Rock 0.10 0.33

Concrete 0.08-0.12 0.26-0.39

Pavement 0.10 0.33

Shale 0.09 0.30

Silt 0.07 0.23

Wet Soil 0.06 0.20

Clay 0.06 0.20

Fresh Water 0.033 0.11
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It is very important that hyperbola fitting only be performed on target responses where the GPR system
has crossed the target perpendicularly. Hyperbola-fitting on a target that was crossed at an angle will result
in a poor velocity value and inaccurate depth measurements.

When Hyperbola Velocity Calibration is selected, a hyperbola is superimposed on the current cross-section
image. The details of fitting the hyperbola to the data are described below.

If necessary, the user can also change the Gain Type value used for the cross-section to make the
hyperbola more visible.

7.2.1 Hyperbola Velocity Calibration

The objective for hyperbola fitting is to move the hyperbola superimposed over the data on top of a
hyperbola in the cross-section image and match the shape by dragging the handles on the end of the
hyperbola tails.

To determine the velocity, the superimposed hyperbola does not necessarily need to be placed at the very
top of hyperbola in the image. Try to choose the top edge of a colored band on the hyperbola that has the
longest tails and looks the most complete.

The superimposed hyperbola can be moved by clicking on the position on the cross-section image where
you want the apex (top) of the hyperbola to go. The hyperbola will immediately jump to this location.

X
X
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 Figure 7-1:  Hyperbola-fitting (1) is done by first clicking or dragging the superimposed hyperbola onto one of the colored bands 
on the hyperbola in the data (2). Choose the top edge of a band that has long tails. This is not necessarily the top band. Then, click 

and drag one of the diamond-shaped handles on the ends of the hyperbola until the shape matches (3). During this process, the 
velocity, depth and time are displayed on the Status Bar on the bottom of the screen. After the process is complete, the depth axis is 

updated using the new velocity value (4).

After the hyperbola has been positioned at the apex of the hyperbola in the cross-section image, the next
step is to match the shape. The shape of the hyperbola can be changed by clicking on either diamond-
shaped handle on the ends of the hyperbola tails and dragging it to the position that best matches the
shape of the image hyperbola. 

After the calibration is complete, press the Hyperbola Velocity Calibration button again to exit from velocity
calibration mode. 

1 2

3 4
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The message “Use Toolbar button to exit Hyperbola Calibration Mode” appears on the upper left of the
image to remind the user.

After exiting from Hyperbola calibration Mode, if the velocity value has changed, the user is prompted to
answer Yes or No to changing the velocity value and updating the depth axis.

During the hyperbola velocity calibration, the Status Bar along the bottom of the EKKO_View 2 screen
displays information including the velocity, depth and time of the hyperbola. As the hyperbola shape is
changed, the velocity and depth also change. 

7.2.2 Target of Known Depth

The Hyperbola Velocity Calibration window can also be used to determine the velocity using a target at a
known depth. 

 Figure 7-2:  For a target at a known depth, like in this case the known thickness of ice, the apex of the hyperbola is placed on the 
reflection of the target (left) and the velocity adjusted by dragging the hyperbola handles until the depth value listed at the bottom 

of the screen matches the known depth. The velocity will then be listed on the bottom of the screen as well.

For example, if the reflection from the bottom of the ice is visible in the cross-section image and the depth
of the ice is known, the apex of the hyperbola can be positioned on that reflection and the velocity changed
until the depth value displayed on the status bar at the bottom of the window matches the known depth. 

Target depth should be measured at the top of the highest band in the GPR response.
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7.2.3 CMP/WARR Velocity Calibration

Common Mid Point (CMP) and Wide Angle Reflection and Refraction (WARR) are different types of GPR
surveys compared to reflection mode surveys typically plotted with EKKO_View 2. 

 Figure 7-3:  CMP data collection method.

 Figure 7-4:  WARR data collection method.

The data can only be collected with fully bi-static GPR systems like the pulseEKKO and is used for
subsurface velocity determinations. For more information on CMP or WARR data collection, see the
pulseEKKO PRO User’s Guide.

When Hyperbola Velocity Calibration is selected for a CMP/WARR file, the superimposed hyperbola can
be moved to the top of one of the data hyperbolas at the approximate zero antenna separation point at the
edge of the image (for data with a relatively large starting separation, it may be necessary to scroll the
image slightly to the right to see the zero antenna separation point). The shape of the hyperbola can then
be changed by clicking on either diamond-shaped handle on the ends of the hyperbola tails and dragging it
to the position that best matches the shape of the image hyperbola (Figure 7-5). 
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 Figure 7-5:  When determining velocity from a Common Mid Point (CMP) data file, move the superimposed hyperbola to the zero 
antenna separation point near the edge of the screen so only half is visible. Click and drag the diamond-shaped handle until it fits 
the curve in the data image. The average velocity for all the material above that reflector is displayed on the Status Bar at the bot-

tom of the screen.

During the hyperbola velocity calibration, the Status Bar along the bottom of the EKKO_View 2 screen
displays the velocity of the hyperbola. As the hyperbola shape is changed, the velocity also change. 

After the calibration is complete, press the Hyperbola Velocity Calibration button again to exit from velocity
calibration mode. 

The message “Use Toolbar button to exit Hyperbola Calibration Mode” appears on the upper left of the
image to remind the user.

The velocity extracted from a CMP/WARR file can then be used as the velocity for reflection mode survey
lines collected in the same area as the CMP/WARR data (see Depth Axis).
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7.2.4 Determining Target Depth

After measuring the GPR velocity using the Hyperbola Velocity calibration described above, the depth axis,
depth grid lines and mouse cross-hairs can be used to determine the depths of targets in the cross-section
image. 

It is important to understand that the depth of the target should always be measured from the highest band
in the GPR response from that target; not necessarily the strongest band. 

 Figure 7-6:  The depth to a target should always be measured from the highest band in the GPR response from the target. This 
band may not necessarily be the strongest. In this case, the depth of the pipe is determined by placing the mouse cross-hairs on the 

top of the white band.
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7.3 Measure
The measure tool allows the user to measure the straight-line distance between any two points on a cross-
section image.

The Measure tool is accessed by selecting Tool > Measure from the menu or by selecting the Toggle
Measure Tool button from the Toolbar: 

To measure the distance between two points, click the mouse at the start position and drag and drop the
mouse cursor at the end position. The distance between the two points (in the current units) will be
displayed on the Status Bar at the bottom of the screen.

It is important to understand that vertical measurements made on cross-sections are based on the
velocity so an accurate velocity is critical for an accurate measurement.

To exit from the Measure tool, select Toggle Measure Tool again, either by using the menu or by clicking
the button on the Toolbar.

The color of the Measure tool is set under the View > Settings > General Tab > Marker Color.



7-Tools Menu EKKO_View 2 Help

78

7.4 HD File Information
The Tool > HD File Information option displays the header (.HD) file. This is a text file saved with data
(.DT1) file when data are collected. It contains survey parameter information as well as details of any
editing or post-processing performed on the data file. An example is shown in Figure 7-7.

 Figure 7-7:  Header (.HD) file display.

This header file can also be printed from this dialog box by pressing the Print button.

7.5 Use as EKKO_View Deluxe/Enhanced Section View
The EKKO_View Enhanced and EKKO_View Deluxe programs use EKKO_View 2 as the viewer to display
cross-sectional GPR data files. If an earlier version of EKKO_View Enhanced or EKKO_View Deluxe is
already installed on the PC when EKKO_View 2 is installed, EKKO_View 2 will automatically become the
default viewer. 

This option allows the user to select which version of EKKO_View they want to use as the default viewer
for EKKO_View Enhanced and EKKO_View Deluxe. Selecting this option will set EKKO_View 2 as the
default viewer. Unselecting this option will set the earlier version of EKKO_View as the default viewer. 
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8 Window

8.1 New Window
Selecting Window > New Window opens another cross-section window for the current DT1 data file. 

This is especially useful for looking at the same cross-section in different windows with different processing
to see differences.

When multiple instances of a data file are open, Windows displays a version number on the right side of
the title banner. For example, the second instance of a data file will have a number 2 in the banner. 

When there are multiple cross-section windows on the screen, only one is active at a time. Changing
display settings under View > Settings only apply to the current Active Window unless the Apply to All
button is selected.
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8.2 Window Cascade
Selecting Window > Window Cascade will rearrange open windows so they cascade on the screen, that
is, the front section is completely visible and the title lines from the other sections are visible and
accessible.
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8.3 Tile Vertically
Selecting Window > Tile Vertically will rearrange all open sections so they are tiled vertically on the
screen, that is, all sections are resized so they are all visible and accessible.

The Tile Vertically option can also be accessed by clicking the following button on the Toolbar:

If there are many windows, this option may tile them in multiple rows rather than just one row.
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8.4 Tile Horizontally
Selecting Window > Tile Horizontally will rearrange all open windows so they are tiled horizontally on the
screen, that is, all sections are resized so they are all visible and accessible.

The Tile Horizontally option can also be accessed by clicking the following button on the Toolbar:

If there are many windows, this option may tile them in multiple columns rather than just one column.
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8.5 Arrange Icons
Selecting Window > Arrange Icons will order all the icons (minimized windows).

8.6 Close All Windows
Selecting Window > Close All Windows will close all currently opened windows, whether they have been
minimized or not. 

8.7 Selecting an Open Window
A list of all the currently open windows is available under the Window menu option. The current Active
Window is indicated by a check-mark. The active window can be changed by selecting a different one
from the list.
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9 Help

9.1 Help Topics
The Contents option opens this document in PDF for viewing. 

The Adobe Acrobat Reader program must be installed on the PC to open this document. If not, the user is
prompted to download it from the Adobe website.

9.2 Sensors & Software Contact Information
Displays contact information for Sensors & Software including mailing address, email addresses, phone
and fax numbers.

9.3 Feedback Form
The Feedback Form allows the user to document a problem about or suggestion for the EKKO_View 2
software and report it to Sensors & Software by email, fax or letter.

9.3.1 Suggestions

To send a suggestion for the EKKO_View 2 software, select the Suggestion button.
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9.3.2 Problems

To report a problem with the EKKO_View 2 software, select the Problem Description button

The more information you include about the problem, the better chance we have of solving it. If the error is
reproducible, list the steps that generate it. You must also fill-in the Severity, Type of Defect and
Frequency descriptions from the drop down lists.

Checking the Send Diagnostic Information checkbox will scan a log file saved with the EKKO_View 2
software on your PC and add additional text to your message that may help Sensors & Software to
diagnose why the problem is occurring.

To help us troubleshoot the problem, you can ZIP the data files and attach them to your email message.

9.3.3 Contact Information

The upper part of the form is your contact information. Any information filled in here will be included in the
report sent to Sensors & Software. You are not required to fill in these fields but remember that, if you want
us to contact you about the report you send, we need your contact information.

Clicking the Fax Header checkbox will automatically add Sensors & Software’s fax information to the top of
the email or text file.

After writing the suggestion or problem description in the field provided, select one of the report options.
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9.3.3.1 Email

Clicking on the Email option will automatically generate an email to Sensors & Software as long as your
system is MAPI-enabled. MAPI is short for Messaging Application Programming Interface, a system built
into Microsoft Windows applications like Outlook. 

If selecting the Email option does not open your email application program, contact your IT department or
consider using one of the other methods below. 

9.3.3.2 Save to File

This option prompts the user to save the report as a text file. This text file can be attached to an email or
printed out and faxed or mailed to Sensors & Software.

9.3.3.3 Notepad...

The Notepad option opens the Notepad program and automatically writes the report text into the program.
The report can then be saved as a text file can be attached to an email or printed out and faxed or mailed
to Sensors & Software.

9.3.3.4 Clipboard

The Clipboard open writes the report text to the clipboard so it can be quickly pasted into an email and sent
or pasted into any word processing software like Microsoft Word. The report can then be saved and
attached to an email or printed out and faxed or mailed to Sensors & Software.

9.4 Diagnostic Mode
Diagnostic Mode is used to help resolve the issue when EKKO_View 2 unexpectedly terminates or freezes
without a warning or error message. 

If you have a cross section that consistently causes the program to crash or freeze, the next time you run
the program, turn Diagnostic Mode on. Then, open the DT1 data file and perform the steps necessary for
the crash to occur again. Diagnostic Mode causes the program to run much slower than normal, because it
is logging all the data processing steps, so please be patient. 

After the crash, run the program again but DO NOT open any data. Immediately go to Help > Feedback
Form and send a message to Sensors & Software. The message will contain valuable diagnostic data to
help us determine the cause of the problem. Please mention that the attached message is to report a crash
and the program was in diagnostic mode.

Large data files with Interpolation turned on may take a long time to process so give the program a good
chance to recover before concluding that it has crashed or is frozen. 

9.5 About EKKO_View
This option displays a description, version number and product number of the EKKO_View program
currently in use.
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10 Troubleshooting

10.1 Out of Memory - Too Many Files Open
If so many DT1 files have been opened that the computer memory has been exceeded, the user will see
the following warning:

Some files need to be closed before others can be opened.

10.2 Opening Corrupted Data Files
Sometimes with a corrupted data, the header (.HD) file lists less traces than there are in the data (.DT1)
file. EKKO_View 2 will display a warning message that the file is corrupt:

but will plot the number of traces listed in the header file.

If the data (.DT1) or header (.HD) file is corrupted and cannot be displayed, a message will be written to
the screen and the plotting aborted.

10.3 Slow Display Response
If the data are stored on an external storage drive, the display response may be irritatingly slow when
changes are made to the View Settings. To improve the response time, date files should be copied locally.
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10.4 Corrupted Configuration File
When a GPR data file is opened in EKKO_View 2, a configuration (.ini) file is created to save the plotting
parameters. This file is located in the same folder as the GPR data file and has the same name. 

If EKKO_View is behaving oddly, the configuration file may have become corrupted. Using Windows
Explorer, find the folder containing the GPR data file and delete the corresponding configuration (.ini) file.
The next time the file is opened in EKKO_View 2, a new configuration file will be generated.
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 Appendix A: EKKO_View Glossary

Line: is the term used to identify the location of data acquisition.  A line is normally
straight and data are recorded from the start to the end of the line.

Line Profiling is the term to describe collecting data along one or more lines for immediate
site assessment using cross-section images.  

Maximum Depth: is the term which describes the maximum depth selected for viewing, pro-
cessing or data acquisition along a line.

Maximum Time: is the term which describes the maximum time selected for viewing, process-
ing or data acquisition along a line.

Time Window: same as Maximum Time.

Velocity: is the term used to characterize the speed at which GPR signals travel.
Velocity is a critical parameter when estimating depths of targets since veloc-
ity is used to convert travel-time to depth.

Color Palette: is the term used to refer to the table that converts a data attribute like ampli-
tude into color in the creation of cross-section images.    

Line Name/Number:is the identifier for a line of data saved when surveying along a line. (e.g.
XL0010.DT1)

Gain: when displaying cross sections formed from traces, a display control is often
needed to allow strong responses from shallow targets to be viewed at the
same time as weaker responses from deep targets.  Gain is applied to weak
signals to make them larger. 

Depth Gain: is a display gain applied that varies with depth along a trace.

Time Gain: is a display gain applied that varies with time along a trace.

Cross-Section Imagethe term used when line profiling data are displayed as a computer gener-
ated image, showing signal amplitude varying in time or depth versus posi-
tion along the line.  Quite often the term is shortened to cross-section or
section.

Depth or Depth-Section Image:the term used when line profiling data are displayed as a cross-
section with the vertical depth scale.  Quite often the term is shortened to
depth-section or section.

Time or Time-Section Image: the term used when line profiling data are displayed as cross-sec-
tion with the vertical time scale. Quite often the term is shortened to time-
section or section.

Image Sensitivity How sensitive the image is to small signal variations. Effectively the Color
Palette "widens" around the zero signal level. Given as 0-100%, with default
being 100% (most sensitive)

Image Contrast: How much of image is at extremes of Color Palette. Effectively the Color Pal-
ette increases the area of extremes of data signal. Given as 0-100%, with
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default of 0% (no added contrast)

Hyperbola Velocity EstimateA point source GPR refection appears as a hyperbola in the Cross
Section Image. Hyperbolic fitting enables the media velocity and target depth
to be estimated.

Hyperbolic Fitting Process of fitting a hyperbolic shape to a local GPR response in the space-
time domain. The fitting process yields a velocity above target and a depth
estimate. 

General GPR Terms

Alpha exponential attenuation coefficient - normal units dB/m (see attenuation)

K relative permittivity or dielectric constant

Sigma electrical conductivity - normal units mS/m

v propagation velocity - normal units m/ns

dB/m decibels/metre, common unit for attenuation,  

m/ns metre/nanosecond, common unit of  GPR velocity, v (see nanosecond)

mS/m milli Siemens/metre, common unit for conductivity,  

ns nanosecond, normal unit of GPR time (see nanosecond)

ps picosecond = 0.001 ns =10-12s, occasion unit of GPR time

us microsecond = 1000ns =10-6s, occasion unit of GPR time

COR common offset reflection (survey type where a constant antenna separation
is maintained).

CMP common mid-point (survey type where a transmitter and receiver antenna
separation are changed but the mid point remains constant)

GPR ground penetrating radar

EM electromagnetic (common abbreviation)

antenna Device used to couple electromagnetic energy into the ground. Sometimes
called a transducer. 

antenna separation Spacing between transmitting and receiving antennas. 

attenuation A reduction in signal amplitude caused by energy dissipation in the transmit-
ting media (see Alpha). 

bandwidth The range of frequencies over which a given device transmits or detects sig-
nals above a specified amplitude or power

center frequency Middle of the frequency band defined by a device's bandwidth

conductivity The ability of a material to conduct electrical current. In isotropic materials
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the reciprocal of resistivity. Sometimes called specific conductance. Units are
siemen/m or S/m. (Or occasionally, mhos/m). For GPR, usually expressed as
mS/m. Common symbol  

nanosecond 10-9s (One Billionth of a second)

radio wave Electromagnetic fields that travel through a material as waves and typically
have oscillating frequencies in the 1 GHz to 10 GHz range

receiver (Rx) General term for electronics devices used to detect fields and translate sig-
nals into records or displays

resolution The minimum separation of two objects before their individual responses
merge into a single response

signal amplitude A measure of the strength of the radio wave signal 

station interval Spatial distance between observation points along a survey line

step size See station interval

transmitter(Tx) General term used for electronics devices used to create propagating elec-
tromagnetic fields

transducer Name used where GPR antenna, electronics, and shield are combined into
one physical unit

sample  point Signal amplitude measured at specific point in time

trace Sequence of sample points from a single GPR channel that indicate time
variation of signal amplitude

cross section Image that results from side-by-side display of a number of traces which are
from adjacent spatial measurement position

gain Process of amplifying signals to match recording device or display dynamic
range
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