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SENSORS & SOFTWARE INC. PRODUCT LICENCE, COPYRIGHT, LIABILITY AND WARRANTY INFORMATION

Important
Please read this document carefully before removing the SOFTWARE PRODUCT storage media from their protective cover 
or assembling the HARDWARE PRODUCT. By removing the storage media or assembling the hardware, you are agreeing 
to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, promptly contact Sen-
sors & Software, Inc. at the address indicated at the end of this document.

Definition
The word PRODUCT as used herein defines any tangible item sold by Sensors & Software, Inc. and may be comprised 
of HARDWARE PRODUCT which consists of physical objects and SOFTWARE PRODUCT which means computer programs, 
codes and related support materials.

Software Product Licence Agreement

In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. (hereafter SSI) does not 
sell any rights to its Software product. Rather, SSI grants the right to use its software, diskettes (or other storage 
media) and documentation (hereafter collectively called SOFTWARE PRODUCT) by means of a SOFTWARE PRODUCT 
licence. You acknowledge and agree that SSI retains worldwide title and rights to all its software and that the SOFTWARE 
PRODUCT contains proprietary materials protected under copyright, trademark and trade secret laws.

Grant of Software Product Licence
In consideration of payment of the licence fee which is the price you pay for the SOFTWARE PRODUCT and your agree-
ment to abide by the terms and conditions of this Licence Agreement, SSI grants to you, the Licensee, a non-exclusive 
right to use the SOFTWARE PRODUCT under the following conditions:

You may:
• use the SOFTWARE PRODUCT on a single workstation owned, leased or otherwise controlled by you
• copy the SOFTWARE PRODUCT for backup purposes in support of  your use of the product on a single workstation

You may not:
• copy, distribute or sell copies of the SOFTWARE PRODUCT or accompanying written materials, including modified or 

merged SOFTWARE PRODUCT to others
• sell, licence, sublicence, assign or otherwise transfer this licence to anyone without the prior written consent of 

SSI
• modify, adapt, translate, decompile, disassemble or create derivative works based on the SOFTWARE PRODUCT

Termination
This licence is effective until terminated. You may terminate the licence at any time by returning the SOFTWARE PROD-
UCT and all copies to SSI. The licence will automatically terminate without notice by SSI if you fail to comply with any 
terms or conditions of this agreement. Upon termination, you agree to return all copies of the SOFTWARE PRODUCT to 
SSI.

Update Policy
SSI may create, from time to time, updated versions of its SOFTWARE PRODUCT. At its option, SSI will make such 
updates available to licencees who have paid the update fee.

Product Warranty, Limited Remedy and Limited Liability 
SSI warrants the PRODUCT to be free from defect in material and workmanship under normal use for a period of one 
year (365 days) from the date of shipment. Any third party computer systems or other items not manufactured directly 
by SSI purchased with any PRODUCT or independently from SSI are subject to the original manufacturer's warranty and 
are not the responsibility of SSI.

SSI makes no other warranties including, but not limited to, any implied warranty of merchantability or fitness for a par-
ticular purpose.  If this product is defective within the warranty period stated above, your exclusive remedy shall be, at 
SSI’s option to replace or repair the SSI product or refund the purchase price of the SSI product.  Except where prohib-
ited by law, SSI will not be liable for any loss or damage arising from this SSI product, whether direct, indirect, special, 
incidental or consequential regardless of the legal theory asserted.



All statements, technical information, and recommendations related to SSI products are based on information believed 
to be reliable, but the accuracy or completeness is not guaranteed. Before using this product, you must evaluate it and 
determine if it is suitable for your intended application.  You assume all risks and liability associated with such use.  Any 
statements related to the product which are not contained in SSI current publications, or any contrary statements con-
tained on your purchase order shall have not force or effect unless expressly agreed upon, in writing, by an authorized 
officer of SSI.

SSI warrants the diskettes or other storage media on which the SOFTWARE PRODUCT is furnished to be free from defects 
in material and workmanship under normal use for a period of ninety (90) days from the date of purchase as evidenced 
by a copy of your invoice.

Except as specified above, any SOFTWARE PRODUCT is provided "as is" without warranty of any kind, either expressed 
or implied, including, but not limited to, the use or result of use of the product in terms of correctness, accuracy, reliabil-
ity, currentness or otherwise. The entire risk as to the results and performance of the PRODUCT is assumed by you. If 
the PRODUCT is defective or used improperly, you, and not SSI or its dealers, distributors, agents, or employees, 
assume the entire cost of all necessary servicing, repair or correction.

SSI's entire liability and your exclusive remedy for SOFTWARE PRODUCT shall be, at SSI's option, either

• the replacement of any diskette or hardware components which do not meet SSI's Limited Warranty and which are 
returned to SSI postage prepaid with a copy of the receipt, or

• if SSI is unable to deliver a replacement diskette which is free of defects in material or workmanship, Licensee 
may terminate this agreement and have the licence fee refunded by returning all copies of the SOFTWARE PRODUCT 
postage prepaid with a copy of the receipt.

If failure of any PRODUCT resulted from accident, abuse or misapplication, SSI shall have no responsibility to replace 
the SOFTWARE PRODUCT, refund the licence fee, or replace or repair the HARDWARE PRODUCT.

Do not tamper with any PRODUCT.  PRODUCT contains no user serviceable parts.  If tampering is evident in SSI’s 
opinion, warranty is void and null.

No oral or written information or advice given by SSI, its dealers, distributors, agents or employees shall create a war-
ranty or in any way increase the scope of this warranty and you may not rely on any such information or advice.

Neither SSI nor anyone else who has been involved in the creation, production or delivery of the PRODUCT shall be lia-
ble for any direct, indirect, special, exemplary, incidental or consequential damages, claims or actions including lost 
information, lost profits, or other damages arising out of the use or inability to use this PRODUCT even if SSI has been 
advised of the possibility of such damages.

This warranty gives you specific rights.  You may have other rights which vary from province to province, territory to ter-
ritory and certain limitations contained in this limited warranty may not apply to you.

General

pulseEKKO®, Noggin®, SpiView®, Conquest® and SnowScan® are registered trademarks of SSI. No right, licence, or 
interest to such trademarks is granted hereunder with the purchase of the PRODUCT or the SOFTWARE PRODUCT licence.

Governing Law
In the event of any conflict between any provision in this licence agreement and limited warranty and any applicable 
provincial legislation, the applicable provincial legislation takes precedence over the contravening provision. This 
agreement shall be governed and construed in accordance with the laws of the Province of Ontario, Canada.

Serviceability
Should any term of this agreement be declared void or not enforceable by any court of competent jurisdiction, the 
remaining terms shall remain in full effect.

Waiver
Failure of either party to enforce any of its rights in this agreement or take action against any other party in the event of 
a breach of this agreement shall not be considered a waiver of the right to subsequent enforcement of its rights or 
actions in the event of subsequent breaches by the other party.



Acknowledgement
You acknowledge that you have read this agreement, understand it and agree to be bound by its terms and conditions. 
You further agree that this agreement is the complete and exclusive statement of agreement between the parties and 
supersedes all proposals or prior agreements oral or written between the parties relating to the subject matter of this 
agreement.

Should you have any questions concerning this agreement, please contact in writing:

Sensors & Software Inc.
1040 Stacey Court

Mississauga, Ontario
Canada L4W 2X8
Tel:(905) 624-8909
Fax:(905) 624-9365

E-mail: radar@sensoft.ca

pulseEKKO, Noggin, SpiView, SnowScan, Conquest, SmartCart, SmartHandle, Conquest for Windows, Win_EKKO, EKKO_Mapper, 
EKKO_3D and EKKO_Pointer are Trademarks of Sensors & Software Inc
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1 Introduction
Ground Penetrating Radar (GPR) data are usually presented as two dimensional cross-sections of the
subsurface.  However, in areas where GPR data have been collected in a grid of survey lines, data
interpretation of many 2D cross-sections can often become confusing and tedious.

The interpretation and presentation of GPR data can often be enhanced through the use of plan map
displays of the data. This type of display provides a powerful means of obtaining highly detailed subsurface
information.  The ability to see GPR responses as depth slices allows users to see the spatial correlation of
targets.  This can make interpretation easier as sought-after targets can be differentiated from targets of no
interest.  For example, responses from utilities will tend to produce linear targets while local targets like
rocks will appear as point targets. This type of display can simplify the task of interpreting large volumes of
data.

EKKO_Mapper is designed to create depth slices of GPR data collected in a grid. Data are quickly
processed to enhance targets. EKKO_Mapper will permit you to analyze grid data by slicing through it
horizontally, print and save color images and reprocess and display the data with different velocity values.
If GPS was added to the GPR data, the GPS position for any point in the depth slice is displayed and can
be extracted and written to other types of files for further analysis.

EKKO_Mapper also exports grid data to 3D data files for import into 3D visualization software like Golden
Software’s Voxler program (available from Sensors & Software).

 Figure 1-1:  A conceptual Grid image to understand the relationship between depth slice images and X and Y cross-section 
images. 
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2 Overview

2.1 Using EKKO_Mapper
A GFP file can be opened by selecting File > Open GFP File.

When a GFP file is opened for the first time, the Data Processing dialog opens.

 Figure 2-1:  The Data Processing dialog sets the processing for the depth slices. Typically the default settings are used except the 
user should set the Velocity based on the Hyperbola Velocity Calibration. 

The most important Data Processing value to set is the Signal Velocity. The best way to determine this
value is through the Hyperbola Fitting method. To quickly generate images, the other data processing
settings can usually be set to their default values and, if required, modified later. See Data Processing for
details. 
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Selecting OK from the Data Processing dialog processes the data. Processing is indicated by an image of
spinning gears and may take several minutes depending on the size of the grid. When processing is
complete, the EKKO_Mapper main screen appears consisting of two windows displaying plan views and
cross-section images. 

 Figure 2-2:  The EKKO_Mapper main screen.

One window is the Plan View Window displaying plan view images like depth slice images. This image is
like looking down on the top of the 3D cube of GPR data (Figure 1-1).

The depth range of the current slice displayed is indicated by the Slice Cursor Lines (Figure 2-2) on the
cross-section. Each slice image represents the average signal amplitude of a finite Thickness of the
subsurface. 

The user can scroll up and down through the slices (see Plan View Window). 

Moving up and down through the slice image causes the Slice Cursor Lines (Figure 2-2) on the cross-
section image to move up or down as well, indicating the depth range used to generate the current slice
image in the plan view window.

The Plan View Legend beside the slice image provides details about the current slice image. 

The second window is a Cross-Section Window for the particular X or Y line indicated by the Cross-
Section Cursor Line on the slice image in the plan view window. The cross-section image is like looking
on the sides of the 3D cube of Conquest data (Figure 1-1).

The user can move to different cross section images (see Cross-Section Window).

The Cross-Section Legend under the cross-section image provides details of the current cross-section
image
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The Menus and buttons on the Toolbar allow the user to further modify and customize the images, and
when satisfied with the results, Print hard copy output or graphics file output (Save As File).

2.2 Plan View Window
The plan view window displays plan view images associated with the current grid survey data.

The plan view images currently supported in EKKO_Mapper are:

1) Depth Slice images of the average amplitude attribute in the specified depth range (or 
thickness). Depth slice images are dependent on the current Signal Velocity value.

2) Time Slice images of the average amplitude attribute in the specified time range. 

Different types of plan view images, like other attributes, survey line location maps and surface maps will
be added in future versions of EKKO_Mapper.

Axes scales corresponding to the X and Y positions appear on the left and top of the plan view image
respectively. The right scale axis is time in nanoseconds.

For depth and time slices, the Plan View window title banner lists the current depth or time range used to
generate the slice image. The Plan View Legend on the upper right also lists the depth or time range of
the current slice image as well as other information.

The user can move through all the slices by:

3) clicking on the Slice Up and Slice Down buttons on the Toolbar,

4) using the Mouse Wheel (if present),

5) pressing the Page Up and Page Down keys on the keyboard,

6) selecting Navigation > Slice Up and Slice Down from the menus, or

7) clicking on a particular depth or time on the cross-section image. The slice image will change to 
the one that includes that depth or time point.

Each slice image represents a finite thickness of material; the Thickness defaults to a value appropriate
for the antenna frequency used for the grid survey. 

The Slice Color Palette can be changed under the View > Settings > Slice option from the menu or by
selecting the Settings button from the Toolbar. 
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Lines corresponding to all the data lines collected during the grid survey can be displayed in the plan view
window by selecting the View > Show Collected Lines or by selecting the Toggle Collected Lines button
from the Toolbar. 

The Lines Color can be changed under View > Settings > Cross-Section.

If Show Collected Lines option is on, fiducial markers added to the line data are displayed by selecting
Show Fiducials:

The text associated with the fiducial is displayed by selecting Show Fiducial Text.

Grid lines corresponding to the major position labels can be displayed in the plan view window. The option
is available by selecting View > Show Scale Grid from the menu or by selecting the Toggle Show Grid
button from the Toolbar. 

The Scale Color can be changed under View > Settings. 

If Show Collected Lines is enabled, a colored line, called the Cross-Section Cursor Line (Figure 2-2),
will appear in the plan view window. This line shows the position, on the data collection grid, of the cross-
section currently displayed in the Cross-Section Window. 

As the slice image is updated, the Slice Cursor Lines, superimposed over the cross-section image,
change in depth. These lines indicate exactly what data on the cross-section are being used to create the
current slice image in the plan view window.

The Plan View Legend, beside the slice image, provides details about the current slice image including
the start and end depths (Thickness), velocity (Hyperbola Velocity Calibration), Slice Color Palette,
Contrast and Sensitivity.

The font for the scales and Legends can be changed under View > Font. 
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2.3 Cross-Section Window
The cross-section window displays the current cross-section image (Figure 2-2). 

The user can move to different cross-section images by:

1) clicking on the Line Left and Line Right and Line Up and Line Down buttons on the Toolbar:

2) pressing the Left Arrow, Right Arrow, Up Arrow or Down Arrow keys on the keyboard, 

3) selecting Line Up and Line Down or Line Left and Line Right under the Navigation menu.

4) clicking on a collected line in the plan view window. The Cross-Section Cursor Line (Figure 
2-2) will immediately change to that line and the corresponding cross-section will be displayed. 

There are two Slice Cursor Lines (Figure 2-2) superimposed on the cross-section image. These lines
represent the depth range that is being displayed in the current slice image in the Plan View window. This
is particularly useful for understanding how features that appear in the cross-sections correspond to the
slice images.

The Cross-Section Color Palette can be changed under the View > Settings > Cross Section options
from the menu or by selecting the Settings button from the Toolbar. 

Gain is the amplification applied to the cross-sectional images. It can be changed by selecting View >
Settings > Cross-section > Gain.

Lines corresponding to the major positions and depth labels can be superimposed on the cross-sections.
This option is available by selecting View > Show Scale Grid from the menu or by selecting the Toggle
Show Grid button from the Toolbar. 

The Scale Color can be changed under View > Settings. 

The Cross-Section Legend under the cross-section image provides details of the current cross-section
image including the line name, velocity (Hyperbola Velocity Calibration), Gain, Cross-Section Color
Palette, Contrast and Sensitivity.

The font for the scales and Legends can be changed under View > Font. 
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2.4 Window Operations

2.4.1 Active Window
The EKKO_Mapper screen typically has two or more windows open. However, only one window at a time
is “active” and can have changes made to it, for example, changing the Contrast value or enabling the
Show Legend option. The Active Window is always indicated by its dark (usually) blue title banner. 

 Figure 2-3:  The Active Window is indicated by the darkly-colored title banner.

The current active window is also checked in the list under the Window menu.

2.4.2 Resizing Windows

To change the size of a window, click and drag any frame or corner. 

As the size of the plan view window changes, the size of the plan view image will also change to maintain
the correct aspect ratio. 

As the size of the cross-section window changes, the cross-section will distort to fill the maximum size
within the window. 

The windows can also be resized and closed using the buttons located in the upper right corner:
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Any window can be maximized to take up the full screen by pressing the maximize button:

A maximized window can be restored by pressing the restore down button in the upper right corner of the
window:

Any window can be minimized by pressing the minimize button: 

2.4.3 Tiling Windows

Use the menu option Window > Tile Horizontally or the following Toolbar button to arrange the windows
horizontally:

The current Active Window will always appear on top.

Use the menu option Window > Tile Vertically or the following Toolbar button to arrange the windows
vertically:

The current Active Window will always appear on the left.
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2.4.4 Opening a New Window
A new Plan View Window can be opened by selecting Window > New Plan View Window. 

A new Cross-Section Window can be opened by selecting Window > New Cross-Section View
Window. 

When multiple Plan View Windows or Cross-section windows are opened at once, only one cross-section
window and one plan view window can be modified. These two windows are indicated by the same bright
green number in the upper left corner along the title banner.

 Figure 2-4:  When multiple windows are opened, the current pair of windows are indicated by matching green numbers.

2.4.5 Closing a Window

Any window can be closed by pressing the close button in the upper right corner of the window: 
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2.5 Legends
The Plan View Window and the Cross-Section have a legend that displays information about the plan view
or the cross-section (Figure 2-2) images.

The display of the legends can be enabled and disabled under the menu option View > Show Legend or
pressing or depressing the Toggle Legend Viewing button on the Toolbar:

Make sure that the window you want to enable or disable the legend in is the current Active Window.

2.5.1 Plan View Legend

The legend in the Plan View Window lists the following information:

1) GFP File name

2) Slice Range: The start and end depths (or times) for the current slice in the plan view window. 
These values correspond to the Slice Cursor Lines on the cross-section images.

3) Lines: The type of lines used to create the depth slice (X Only, Y Only or X and Y Mixed). See 
Lines to Include in Depth Slice Image.

4) Velocity: in meters/nanosecond (m/ns) or feet/nanosecond (ft/ns). Used for depth calculations.

5) Frequency: the antenna center frequency (in MHz) used for the GPR grid survey data.

6) Settings:

a)Sensitivity (S) in percent listed under View > Sensitivity

b)Contrast (C) in percent listed under View > Contrast

c)Background Subtraction (BgS): Lists the current setting under Tool > Data 
Processing. Either Total, Local or Off.

d)DME: Dewow (D), Migration (M) and Envelope (E): Either on or off depending if 
selected under Tool > Data Processing.

e)Amplitude Equalization Gain (AmpEq): Lists the type and current value under Tool > 
Data Processing. Either Auto, User or Off. If Auto or User, the values for Start Gain (S), 
Attenuation (A) and Max Gain (M) are listed.

f)Interpolation Limit (Interp lim): Maximum interpolation distance under Tool > Data 
Processing.

g)Resolution: The total number of samples in the X and Y directions and the physical size 
that pixel (or sample) in the plan view image represents. Selected under Tool > Data 
Processing.
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h)Color Palette: Listed under View > Settings > Slice > Slice Color Palette

7) Grid Survey collection date: The date the GFP file for the grid survey was created.

8) Analyzed date: The current date.

2.5.2 Cross-Section Legend

1) Line Name

2) Velocity: in meters/nanosecond (m/ns) or feet/nanosecond (ft/ns) as listed under Tool > 
Signal Velocity. Used for the depth scale.

3) Sensitivity (S) in percent listed under View > Sensitivity. 

4) Contrast (C) in percent listed under View > Contrast.

5) Background Subtraction (BgS): Lists the current setting under Tool > Data Processing. 
Either Total, Local or Off. 

6) DME: Dewow (D), Migration (M) and Envelope (E): Either on or off depending if selected under 
Tool > Data Processing.

7) Gain: Listed if selected under View > Settings > Cross-section > Gain as the Attenuation, 
Start Gain and Maximum Gain applied to the cross-section images.

8) Color Palette (CP): Listed under View > Settings > Cross-section > Cross-Section Color 
Palette

2.6 Toolbar
Most operations can be performed using the toolbar. The Toolbar is made visible by checking it under View
> Toolbar.

A brief description of the function of a button is displayed by holding the mouse cursor on the button for
about 1 second.

There is also a longer description of the button on the Status Bar on the bottom of the screen.
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2.7 Status Bar
The status bar is visible on the bottom of the screen when the View > Status Bar option is checked
(Figure 2-2).

As the mouse cursor is moved over buttons on the toolbar, the status bar, at the bottom of the screen,
provides helpful descriptions of the purpose of the particular button. For example, holding the mouse over
the Settings button will display the following on the Status Bar:

The right side of the status bar displays information about the position of the mouse cursor when it is
located on the plan view image:

or the cross-sections: 

2.7.1 GPS on Status Bar

If GPS data were added to the GFP file using the GFP_Edit program, GPS positions are displayed on the
right side of the Status Bar as the mouse cursor is moved around the slice or cross section images.

The format of the GPS information is defined by the GPS format in the GFP_Edit program when the GPS
was added.  It could be Latitude-Longitude (in decimal degrees or degrees-minutes-seconds) or UTM
(Universal Transverse Mercator) or both.

Note that there may be a difference between GPS positions on GPR Lines displayed in GFP_Edit/
EKKO_Mapper software and the EKKO_View software.

For EKKO_View, which plots GPR cross-sectional lines, the GPS position is based interpolating the GPS
positions saved to the GPS file during data collection.

For GFP_Edit/EKKO_Mapper, which use many GPR lines combined into a grid, GPS positions are
determined by using the defined Local-Global Coordinate Relationship and grid line positions. 

Therefore, the GPS positions for any individual line in the grid will differ slightly from the GPS file collected
with that line. See the GFP_Edit User’s Guide for more details.
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2.7.2 Exporting Status Bar Information to Other Documents
The data information text on the Status Bar can be copied to the Clipboard by pressing the F8 key. The
text can then be Pasted into another document like a Word or Excel file. 

This feature is handy for extracting significant positions from the data image and writing them to other
documents.

Pressing the “Shift” key while pressing F8 will also save the text for the column headings.

To create a file like the one above, press Shift F8 and paste the first line into the document. Then press F8
for all the subsequent lines.
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3 Menus
The following sections describe the EKKO_Mapper menus.

Menu options can be accessed by clicking on them with the mouse cursor or by pressing the Alt key
followed by the underlined letter.

Alt+F = File

Alt+V = View

Alt+N = Navigation

Alt+T = Tool

Alt+W = Window

Alt+H = Help

Sub-menus can then be accessed by pressing the next underlined letter. For example, to select the Open
sub-menu under the File menu, press Alt+F and then O.

Sensitivity and Contrast can be increased and decreased using keys. 

Navigating through Slices (Slice Up and Slice Down) and Lines (Line Up and Line Down, Line Left and
Line Right) is also possible using specific keys on the keyboard.
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4 File 

4.1 Open GFP File
The File > Open option allows the user to select the GFP (GPR Files and Processing) file for the grid data
to be displayed. 

The Open dialog allows the user to select a file with a .GFP extension.  For convenience, the GFP file
usually resides in the same folder as the grid data files.

The File > Open option can also be accessed by pressing Ctrl-O on the keyboard or by clicking on the
Open button on the Toolbar:

GFP files can contain more than one grid survey but EKKO_Mapper can only process one grid from a GFP
file. If the GFP file opened contains more than one grid, the user must select one grid survey from the list. 

More than one GFP file can be opened at the same time resulting in multiple windows open on the screen.
Windows always have a green number on the left side of the title banner that indicates which data set they
belong to (Figure 2-4). For example, all the windows associated with the first GFP file opened will have a
number 1 in the banner, all windows associated with the second GFP file opened will have a number 2 in
the banner, etc. 

4.2 Close GFP File
The File > Close option closes all the windows associated with the current GFP file.

4.3 Create New GFP File for Grid Lines
Not all GPR grid data files will have an associated GFP file.  Specifically, earlier grid data acquisition
software on a PC or the DVL does not automatically generate a GFP file.  Consequently, the user must
create a GFP file for the grid data before continuing to use the EKKO_Mapper software for data analysis.

The File > Create New GFP File for Grid Lines option launches the GFP_Edit program used to create a
GFP file for GPR data lines.  The program allows the user to Import data lines and specify their positions
within the grid. Data lines must be saved under the same Grid Name to be processed as one grid using
EKKO_Mapper. GFP_Edit is also used to import fiducials (Show Fiducials) into the GFP file.

For more details, see the GFP_View & GFP_Edit User's Guide.  This document can be viewed from
the GFP_Edit program under Help or opened independently. The PDF document is located in the
\Program Files\EKKO_Mapper\manual folder or on the software CD under \EKKO_Mapper\manual.
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4.4 Edit Current GFP File
This option opens the GFP_Edit program, loads the current GFP file and displays information about the file
including the positions and geometry of the GPR line data files.  GFP_Edit is used to edit the GFP file,
specifically, adding and deleting line data files and changing the positions of the data lines.

For more details, see the GFP_Edit User's Guide.  This document can be viewed from the GFP_Edit
program under Help or opened independently.  Look for the PDF document in the \Program
Files\EKKO_Mapper\ manual folder or on the CD.

4.5 Export Data
EKKO_Mapper data can be exported as a 3D file or depth slices to various formats. 

Specifically, 3D files can be exported in HDF (Hierarchical Data Format) or CSV (Comma Separated
Values) files. 

Depth Slices can be exported to Google Earth KMZ, Surfer ASCII GRD or CSV (Comma Separated
Values) files.

4.5.1 3D

The File > Export Data > 3D option allows the user to export the grid survey data to an HDF (Hierarchical
Data Format) or CSV (Comma Separated Values) file for use with third-party processing and visualization
software like Golden Software’s Voxler (available from Sensors & Software). 

 Figure 4-1:  GPR data displayed in 3D using Voxler.
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Data are exported as the 3D location of each point within the grid (X, Y, Z) and the average signal strength
at that point (amplitude). The X and Y voxel dimensions are controlled by the Tool > Data Processing >
Slice Resolution value while the Z voxel dimension is controlled by the Tool > Data Processing >
Thickness value. 

For more resolution in the 3D visualization, it may be necessary to increase the Slice Resolution and
reduce the depth slice Thickness from the default value before generating the 3D file.

The default processing for depth slices and 3D files is designed to reveal linear targets like utilities, rebar,
foundations and point targets like archaeological artefacts and bodies. These processes may not be
appropriate for all 3D GPR data, for example, geological data. To display geological data in 3D that looks
like Figure 4-2, turn off the migration and enveloping processes (Tool > Data Processing > DME
Processing). To preserve flat-lying layers in the data, also consider turning off the Background
Subtraction process.

 Figure 4-2:  This 3D geological data displayed in Voxler was processed in EKKO_Mapper without Migration or Envelope.

Geological data that has not been enveloped looks best when the Slice Thickness is set finer than the
default thickness; ideally the same as the temporal sampling interval. This is typically about 1/5 of the
default slice thickness value.
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4.5.1.1 3D HDF File

HDF files are a binary format that cannot be easily viewed without software that imports this format. HDF
files can be opened with the Voxler program (available from Sensors & Software).

To export the 3D data to an HDF file, select File > Export Data > 3D to open the Export Slices to Files
dialog. Select Voxler HDF file from the file type drop-down list. 

When a grid survey is exported to HDF, the HDF file has the same name as the GFP file, except with the
name of the grid (listed in the GFP file) appended to the name, for example GPRData-Grid.HDF. 

The HDF file will list X, Y and depth values in metres or feet depending on the setting under Tool > Data
Processing > Units.

The HDF file will list depth or time depending on the setting under Tool > Data Processing > Slice
Processing > Slice Units.

4.5.1.2 3D CSV File

CSV files can be imported into many programs like Microsoft’s Excel. 

To export the 3D data to a CSV file, select File > Export Data > 3D to open the Export Slices to Files
dialog. Use the dropdown list to set the file type to XYZ-Amplitude Pairs.

The header line indicates the X, Y, Z and depth columns with the half-width of the voxel (or cell) in that
direction. The header line also lists the total number of samples in the CSV file.

The CSV file will list X, Y and depth values in metres or feet depending on the setting under Tool > Data
Processing > Units.

The CSV file will list depth or time depending on the setting under Tool > Data Processing > Slice
Processing > Slice Units.

Depth

The format of the CSV file is X Y Z Depth Amplitude. The Amplitude values are the average signal strength
in the thickness of the depth slice.

The Z values (column 3) are elevation values with the surface at elevation zero (0.0) so the values are
negative. The Depth values (column 4) are the same as the Z values but positive. 

X ± 0.0250m  Y ± 0.0250m  Z ± 0.0025m  Depth ± 0.0025m  58176 Values

0.025 0.025  -0.003  0.003  2801
0.025 0.075  -0.003  0.003  4432
0.025 0.125  -0.003  0.003  4195
0.025 0.175  -0.003  0.003  3826
0.025 0.225  -0.003  0.003  3315
0.025  0.275  -0.003  0.003  2465
0.025 0.325  -0.003  0.003  2698
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Time

For time, the format of the CSV file is X Y Z Time Amplitude. 

The Z values (column 3) are time values with the surface at time zero (0.0) so the values are negative. The
Time values (column 4) are the same as the Z values but positive. 

X ± 0.0250m  Y ± 0.0250m  Z ± 0.0500ns  Time ± 0.0500ns  57600 Values

0.025 0.025  -0.05  0.05  384
0.025 0.075  -0.05  0.05  633
0.025 0.125  -0.05  0.05  495
0.025 0.175  -0.05  0.05  581
0.025 0.225  -0.05  0.05  467
0.025 0.275  -0.05  0.05  342

4.5.2 Current Slice or All Slices

4.5.2.1 Requirements for Exporting to Google Earth KMZ Files

Saving EKKO_Mapper depth slice images to Google Earth (.kmz) files is available if GPS data have been
added to the GFP file.  

Adding GPS: If a GFP file is opened in EKKO_Mapper that has GPS files residing in the same folder, the
user is prompted to import the GPS files into the GFP file using the GFP_Edit program.  Selecting "Yes" to
this prompt launches the GFP_Edit program and automatically imports the GPS data using a best-fit
routine.  

If the GPR data were collected without GPS it is still possible to add GPS to the GFP file using two GPS
positions at known points within the grid or one GPS position and the heading the Y axis of the GPR grid
(see Edit Current GFP File and the GFP_Edit User’s Guide). 

GPS Accuracy: The accuracy of the GPS is indicated in the GFP_Edit program by displaying the Raw
GPS lines and the corresponding GPR lines. The difference in linearity and the distance between the Raw
GPS line and the corresponding GPR line is an indication of the accuracy of the GPS used for data
collection.  Non-linear Raw GPS lines indicate poor GPS accuracy and the user should be cautious when
using the extracted GPS positions of targets in the GPR grid.

4.5.2.2 Export Slice(s) to Google Earth KMZ File

To export the current slice to a Google Earth KMZ file, select File > Export Data > Current Slice to open
the Export to File dialog. 

To export the all slices to a Google Earth KMZ file, select File > Export Data > All Slices to open the
Export to File dialog. 

Select the Google Earth KMZ file from the file type drop-down list. 

The file defaults to the same name as the GFP file and the current folder but the user can change this
before saving the file.
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4.5.2.3 Viewing Slices in Google Earth

To display Google Earth (.kmz) files, Google Earth must be installed and the computer have internet
access.  Open the .kmz file using one of the following methods:

1) After saving the .kmz file, Google Earth is automatically launched and the kmz file displayed.

2) Using Windows Explorer to find the folder where the kmz file is saved and double-click the file 
name. 

3) Running Google Earth, selecting File > Open and finding the kmz file and opening it.

When the kmz file opens, Google Earth will "fly" to the location of the GPR slice and superimpose it over
the ground image.  

 Figure 4-3:  GPR slice plotted in Google Earth. Use the controls under Places to enable and disable the display of the slice, col-
lected lines and fiducial markers.

The kmz file is listed in Temporary Places under Places on the left side of the Google Earth screen. When
exiting Google Earth, the user is prompted if they want to save the kmz file to the My Places list.

Initially, the slice image is displayed with the Collected Lines and Fiducial Markers on the data image.
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Collected Lines

Collected Lines are listed by clicking on the plus sign (+) beside the kmz file name and can all be turned off
by unchecking the "Collected Lines" checkbox. 

 Figure 4-4:  Use the controls under Places to enable and disable the display of the collected lines.
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Fiducial Markers

Fiducial Markers are listed by clicking on the plus sign (+) beside the kmz file name and can all be turned
off by unchecking the "Fiducials" checkbox.  Individual Fiducial Markers can be listed by clicking on the
plus sign (+) beside Fiducials.  Specific Fiducials in the list can be turned off by unchecking the
corresponding checkbox. 

 Figure 4-5:  Use the controls under Places to enable and disable the display of the fiducial markers.
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Slices

If more than one Depth Slice is saved to the kmz file, the list of slices is displayed by clicking on the plus
sign (+) beside the kmz file name.  To change the depth slice image to a different one, click on the desired
slice in the list (Figure 4-6).  

 Figure 4-6:  When the Google Earth KMZ file contains multiple slices, select the slice to display using the controls under Places.

Google Earth Accuracy

It is important to be aware that Google Earth images may be out several meters from the actual GPS loca-
tion. 

Google Earth also seems to have problems placing Depth slice images accurately at high latitudes.
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4.5.2.4 Surfer ASCII Grid (.GRD) File

Surfer is a popular third-party processing and visualization software developed by Golden Software for
plotting two-dimensional data like GPR slices. 

To export the current slice to a Surfer ASCII Grid (.grd) file, select File > Export Data > Current Slice to
open the Export to File dialog. 

To export the all slices to Surfer ASCII Grid files, select File > Export Data > All Slices to open the Export
to File dialog. 

Use the dropdown list to set the file type to Surfer ASCII Grid (grd).

The file(s) name defaults to the same name as the GFP file and the current folder but the user can change
this before saving the file.

The GRD file will list X, Y and depth values in metres or feet depending on the setting under Tool > Data
Processing > Units.

The GRD file will list depth or time depending on the setting under Tool > Data Processing > Slice
Processing > Slice Units.

Here is an example of the GRD file:

For specific details on the GRD file format, contact Golden Software.

4.5.2.5 CSV File

CSV (Comma Separated Values) files can be imported into many programs like Microsoft’s Excel. 

To export the current slice to a CSV file, select File > Export Data > Current Slice to open the Export to
File dialog. 

To export the all slices to CSV files, select File > Export Data > All Slices to open the Export to File
dialog. 
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Use the dropdown list to set the file type to Comma Separated Values (.CSV).

The file(s) name defaults to the same name as the GFP file and the current folder but the user can change
this before saving the file.

The header line indicates the X, Y, Z and depth columns with the half-width of the voxel (or cell) in that
direction. The header line also lists the total number of samples in the CSV file.

The CSV file(s) will list X, Y and depth values in metres or feet depending on the setting under Tool > Data
Processing > Units.

The CSV file(s) will list depth or time depending on the setting under Tool > Data Processing > Slice
Processing > Slice Units.

Depth

The format of the CSV file is X Y Z Depth Amplitude. The Amplitude values are the average signal strength
in the thickness of the depth slice.

The Z values (column 3) are elevation values with the surface at elevation zero (0.0) so the values are
negative. The Depth values (column 4) are the same as the Z values but positive. 

X ± 0.0250m  Y ± 0.0250m  Z ± 0.0025m  Depth ± 0.0025m  58176 Values

0.025 0.025  -0.003  0.003  2801
0.025 0.075  -0.003  0.003  4432
0.025 0.125  -0.003  0.003  4195
0.025 0.175  -0.003  0.003  3826
0.025 0.225  -0.003  0.003  3315
0.025  0.275  -0.003  0.003  2465
0.025 0.325  -0.003  0.003  2698

Time

For time, the format of the CSV file is X Y Z Time Amplitude. 

The Z values (column 3) are time values with the surface at time zero (0.0) so the values are negative. The
Time values (column 4) are the same as the Z values but positive. 

X ± 0.0250m  Y ± 0.0250m  Z ± 0.0500ns  Time ± 0.0500ns  57600 Values

0.025 0.025  -0.05  0.05  384
0.025 0.075  -0.05  0.05  633
0.025 0.125  -0.05  0.05  495
0.025 0.175  -0.05  0.05  581
0.025 0.225  -0.05  0.05  467
0.025 0.275  -0.05  0.05  342
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4.6 Advanced File Options
The File > Advanced File Options menu allows the user to perform advanced operations to clean up
folders of intermediate files, remove all processing from the current GFP file or restore the Default
Application Settings.

4.6.1 Clean Intermediate Files on Exit

After opening a GFP file and processing the GPR data files, EKKO_Mapper generates intermediate files
for the display of depth slices and cross-section images. These intermediate files allow images to be
quickly displayed on the main screen while working with the GFP file. They are also stored to allow the
images to be quickly displayed the next time the GFP file is opened.

The option automatically deletes the intermediate files every time the user exits EKKO_Mapper to reduce
the volume of files saved with a grid of data.

In general, if hard disk space is not an issue, it is better to leave this option off so that data images are
quickly displayed without having to reprocess the data every time the GFP file for a grid of data is opened.
For small grids, the data can be reprocessed and displayed fairly quickly but for large grids this process
may take many minutes.

4.6.2 Clean Intermediate Files

After opening a GFP file and processing the GPR data files, EKKO_Mapper generates intermediate files
for the display of depth slices and cross-section images. These intermediate files allow images to be
quickly displayed on the main screen while working with the GFP file. They are also stored to allow the
images to be quickly displayed the next time the GFP file is opened.

The option automatically deletes the intermediate files for the current grid data and GFP file. Deleting
these files and then reprocessing the data may fix file errors. If this step does not fix the file problem, try the
option Remove EKKO_Mapper Processing from GFP below.

4.6.3 Remove EKKO_Mapper Processing from GFP

The GFP files saves the data files names, grid geometry and the selected data processing for a survey of
GPR data files. Selecting this option deletes the data processing settings from the GFP file. This option
should only be used when trying to recover from an error with the processing of the data.

4.6.4 Restore Default Application Settings

Selecting this option will reset all the settings in the GFP file to default values. Use this option only when a
severe error has occurred and recovery using other means has not solved the problem. 

4.7 Recent Files
If the desired GFP file is one of the last four (4) GFP files opened, rather than using the File > Open option,
it can be opened by selecting it from the recent files list under File.



EKKO_Mapper Help 4-File

29

4.8 Exit
Selecting this option will close all windows that are open as part of the current EKKO_Mapper session and
exit the application.
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5 View

5.1 Export Image
This option is used to export any depth slice or cross-section view to the clipboard, save it as a graphics
image file or send it to a printer.

The image can be modified by having the following options, accessible under the View menu, turned on or
off:

1) Show Collected Lines (depth slices only)

2) Show Scale

3) Show Scale Grid

4) Show Legend

5) Show Slice

6) Show Fiducials

7) Show Fiducial Text

These options are useful if you want to add your own scales or annotations using a graphics program or if
you want to tile several individual images together into one larger image.

5.1.1 Copy to Clipboard

The View > Export Image > Copy to Clipboard option copies the image in the current Active Window to
the Clipboard so it can be pasted into other documents like a Word document or an email message. This
image can be a depth slice image or a cross-section image.

See Export Image for details on modifying the image.

This option can also be accessed from the Toolbar by pressing the Ctrl+C keys or by clicking on the Copy
Screen to Clipboard button on the Toolbar.

5.1.2 Save As File
The View > Export Image > Save As File option allows the user to save an electronic copy of the image
in the current Active Window. The plot can be saved in BMP, JPG, PNG, TIFF or GIF graphics file formats. 

Select the graphics format file type from the drop-down list. Then input a filename and folder to save the
image to. 
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In general, the BMP file is the largest while the JPG image is quite small and good for emailing.

See Export Image for details on modifying the image.

This option can also be accessed from the Toolbar by clicking on the Save As File button:

5.1.3 Print

The View > Export Image > Print option allows the user to produce hard copies of the image in the
current Active Window. After selecting this option, a standard print dialog opens which allows the user to
select the printer they wish to print to as well as customize other printing parameters. For example, the
user can select to print the data image to a Landscape rather than a Portrait orientation.

The image can be sent directly to the default printer by pressing the Ctrl-P keys or by clicking the Print
button from the Toolbar:
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5.2 Settings
The View > Settings option allows the user to change various aspects of the cross-section and slice
images including color palettes, line, scale and cursor colors, contrast and sensitivity values.

The Settings option can also be accessed from the Toolbar by clicking on the Settings button:

The Settings dialog box allows changes in the settings for Slices or Cross-Sections by toggling the buttons
at the top: 

 Figure 5-1:  The Settings dialog box toggles from Slice to cross-section by pressing the buttons on the top. 
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5.2.1 Slice

 Figure 5-2:  Slice Settings dialog.

5.2.1.1 Lines to Include in Depth Slice Image

Grid data can be collected in three different ways: 

1) X grids, where the area is covered by a series of parallel lines in the X direction, 

2) Y grids, where the area is covered by a series of parallel lines in the Y direction and 

3) Mixed grids, where the area is covered by lines in both the X and Y directions.

 Figure 5-3:  Grids are collected as X grids (left), Y grids (middle) or Mixed (XY) grids (right). With an XY grid, the user has the 
option of generating depth slice images based on the X line data only, the Y line data only or both the X and Y lines. If both X and 

Y lines are available, it is recommended that the Mixed (XY) setting be used.
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EKKO_Mapper can be used to plot data in any of these survey types. As well, in the case of an XY grid,
the user can generate depth slices based on only the X lines, only the Y lines or a combination of both the
X and Y lines.

When X and Y lines are available in a grid, the setting recommended for most users is Mixed
because it uses all the data lines. 

When Mixed is selected, the slice image in the Plan View Window is generated using both X and Y data
lines in the grid. Any Cross-Section Window can display an X line or a Y line. 

 Figure 5-4:  Depth slices based on a combination of both X and Y Lines. X or Y lines can be displayed in the cross-section Win-
dow.

When X is selected, the slice image in the Plan View Window is generated using only X data lines in the
grid. Any Cross-Section Window will only display X data lines. 

 Figure 5-5:  Depth slices based on X Lines only. The depth slice image emphasizes targets perpendicular to the X line direction. X 
lines can only be displayed in the cross-section Window.
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When Y is selected, the slice image in the Plan View Window is generated using only Y data lines in the
grid. Any Cross-Section Window will only display Y data lines. 

 Figure 5-6:  Depth slices based on Y Lines only. The depth slice image emphasizes targets perpendicular to the Y line direction.Y 
lines can only be displayed in the cross-section Window.

Selecting to display X or Y lines only can help to emphasize targets perpendicular to the line direction. In
the figures above, rebar are actually running in two directions but the rebar parallel to the X lines have
been eliminated. Selecting to display Y lines only would do the opposite, that is, show the rebar
perpendicular to the Y lines and eliminate the rebar parallel to that direction. Compare the depth slice
images above to see this effect.

5.2.1.2 Slice Color Palette

The default color palette for cross-sections is jet. This option allows the user to choose from a number of
predefined color palettes for the depth slice image. Quite often one color palette may bring out features in
a data set better than others so some experimentation may be required to determine the optimal color
palette for a particular grid scan data set.

The CnG color palette displays data on the screen in color and prints well to a black and white printer.
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5.2.1.3 Cursor Color

The position of the cross-section image is indicated by a colored line superimposed on the slice image in
the plan view window. As well, the thickness range of the slice image is indicated by two parallel lines
superimposed on the cross-section image. All these lines are called the Cursor Lines (Figure 2-2). 

The color of the lines can be changed in this option under View > Settings. 

It is recommended to choose a color that provides high cursor line visibility on the slices and cross-
sections.

The Cross-Section Cursor Line (Figure 2-2) on the slice image in the plan view window will not be visible
if the Show Collected Lines option has been turned off.

5.2.1.4 Lines Color

Lines corresponding to all the data lines collected during the grid survey can be displayed in the plan view
window (Figure 2-2). This option is available under View > Show Collected Lines or by selecting the
Toggle Collected Lines button from the Toolbar:

This option is only available if the plan view window is the current Active Window. Otherwise, the View >
Show Collected Lines option and button on the Toolbar are greyed out and not accessible.

The color of the lines can be changed in this option under View > Settings.

It is recommended to choose a color that provides high line visibility on the depth slices.

5.2.1.5 Scale Color

Scale Grid Lines corresponding to the major position and depth labels can be superimposed on the depth
slice and the cross-sections (Figure 2-2). This option is available by selecting View > Show Scale Grid
from the menu or by selecting the Toggle Show Scale Grid button from the Toolbar: 

The Show Scale Grid option only applies to the image in the current Active Window. To turn on the Scale
Grid for a plan view window, make sure that window is the current active window. Similarly, to turn on the
Scale Grid for a cross-section window, make sure that window is the current active window.

The color of the lines can be changed in this option under View > Settings. 

It is recommended to choose a color that provides high line visibility on the image.

5.2.1.6 Defaults

Clicking the Default button will return all the Slice Settings to their default values.
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5.2.1.7 Preview

Clicking on the Preview button allows the user to see the effect of changes they have made to the Slice
Settings before permanently applying those changes by clicking on the OK button.

5.2.1.8 OK

Clicking the OK button applies any changes to the settings for the current slice image and closes the
Settings dialog box.

5.2.1.9 Cancel

Clicking the Cancel button closes the Settings dialog box ignoring any changes that may have been made
to the settings, including any changes made using the Preview button (Preview).

5.2.1.10 Auto Preview

Clicking on the Auto Preview checkbox from the Settings dialog allows the user to instantly see the effect
of changes made to the settings, including Sensitivity, Contrast and the color palette. This is much faster
than changing the settings and then clicking on Preview. However, it may be undesirable for large grids or
grids with a fine resolution because the screen update may be sluggish.
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5.2.2 Cross-Section
Cross-section settings are displayed in the Settings > Cross-Section dialog (Figure 5-7). These settings
apply to all cross-section windows with the exception of the GPR Processing which only applies to the
current active cross-section window (see Active Window).

 Figure 5-7:  Cross-Section Settings dialog Need new fig.

5.2.2.1 GPR Processing

The GPR Processing dropdown list allows the user to select the type of processing that will be applied to
the current active cross-section image. 

 Figure 5-8:  Cross-section data processing list.

This setting is generally for advanced users who understand GPR data processing routines like Dewow,
background subtraction, migration and enveloping. Descriptions of these processing techniques are
described in Data Processing.

The default GPR Processing and the one highly recommended for most users, is: “Dewow + Bgr.
Subtraction + Gain”.
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To display the cross-sections with exactly the same processing as the depth slices, select “Depth Slice
Processing” from the list. The cross-section images becomes a “side view” of the depth slice data. The
cross-sections and depth slices are automatically plotted with the same color palette, amplitude
equalization, contrast and sensitivity. Contrast, Sensitivity and Gain are “locked” to the Slice Settings
dialog and cannot be changed in the Cross-Section Settings dialog. 

The number of processing streams in the list varies depending on the processing routines selected under
Tool > Data Processing. For example, if the Migration process is not selected under Data Processing,
then the processing streams listed will not include Migration.

5.2.2.2 Cross-Section Color Palette

The default color palette for cross-sections is bone.This option allows the user to choose from a number of
predefined color palettes for the cross-section images. Quite often one color palette may bring out features
in a data set better than others so some experimentation may be required to determine the optimal color
palette for a particular data set.

5.2.2.3 Cross-Section Depth Limit

The Depth Limit option allows the user to change the maximum depth displayed on cross-section images.
There are 3 options for this depth limit setting:

1) Max (the default) displays the full depth range of the cross-section data,

2) User allows the user to input the maximum depth to be displayed in the cross-section image, 
and

3) Slice Depth Limit allows the user to input a multiplication factor for the Slice Depth Limit listed 
under Tool > Data Processing > Slice Depth Limit. For example, a multiplication factor of 2 
will set the cross-section depth limit to 2 times the current slice depth limit. A multiplication 
factor of 0.5 would result in half the slice depth limit "zooming in" on the shallow data in the 
cross-section image. 

If the Depth Limit is set to a value larger than the maximum depth of the cross-section, the cross-section
will show full depth and time axes but the data below the maximum depth will be blank.
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 Figure 5-9:  The Max Depth Limit (left) shows the full depth of the cross-section (left) while User and the Multiplier options can 
be set to show more (middle) or less (right) data. 

Note that the Depth Limit is strictly for the display of the cross-section images. If the depth limit is set to
less than the maximum depth, it does NOT limit the cross-section data used for generating depth slices.
Depth slices deeper than the depth limit are still visible. In fact, the slice cursor lines (Figure 2-2) on the
cross-section that define the thickness of the depth slice, will disappear off the bottom of the cross-section
as you scroll down through the depth slices.

If you want to limit the maximum depth of the data used for generating depth slices, see the Depth Slice
Depth Limit.

5.2.2.4 Gain

Gain is used to "amplify" the strength of the GPR data signals in the cross-section images. Applying gain is
similar to adjusting the "volume" knob on a music stereo. 

Gain requires three parameters: Attenuation, Start Gain and Maximum Gain. Attenuation is the most
important parameter. The other parameters are considered Advanced Options.

The strongest GPR signals come from shallow targets at the top of the GPR cross-section while deeper
targets lower in the cross-section have weaker signal strength. Therefore, the gain applied to the GPR
cross-section increases with increasing depth. The gain is a ramp that starts off at the Start Gain value at
the top of the cross-section, ramps up on a slope with the steepness depending on the Attenuation value
(alpha) and levels off to a constant multiplier when the Maximum Gain value is reached.

The gain setting is only applied to the display of the cross-section images. Changing the gain setting has
no effect on depth slice images. 

The current gain value is displayed in the Cross-Section Legend. 

Gain can be turned off by unchecking the Gain checkbox in the View > Settings > Cross-Section dialog
box (Figure 5-7).
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 Figure 5-10:  Cross-section image with the gain function shape and parameters on the right. In general, the Start Value is usually 
1 or 0, attenuation (a), which controls the steepness of the slope is usually 0.5 to 8 and the Maximum Gain, which cuts off the expo-
nential rise is usually 20 to 1000. Try to avoid over-gaining the data. Start with low values for Attenuation and Maximum Gain and 

increase as necessary.

The gain parameters can be set manually in User mode or automatically in Auto mode by clicking the
desired option (see Figure 5-7). 

Auto uses the average decay curve of the GPR signal strength over time to calculate an appropriate gain
parameter values for Attenuation, Maximum Gain and Start Gain. If the cross-section images look good
using the Auto values and are not over-gained or under-gained, then using Auto Gain is acceptable.

However, Auto does not always gain the data properly, especially if the data has strong, high amplitude
signals deep in the section. In this case, it tends to use an attenuation value that may be too low, resulting
in under-gained data and cross-sections with low amplitude signals at depth which makes interpretation
more difficult. When this occurs, use Auto to set the initial values for the gain parameters and then switch
the gain to User and then experiment using different values. 

The following describes, in more detail, each gain parameter.

Attenuation

The Attenuation values defines the “steepness” of the gain function ramp. Lower values mean a more
gradual slope while higher values are steeper. The ramp starts at the Start Gain value and ramps up to the
Maximum Gain value. 
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Low values for Attenuation are typically used but higher values may help to improve the imaging of deeper
targets. Try to use the lowest value possible as the data can be "overgained" making it more difficult to
understand.

 Figure 5-11:  A low value for Attenuation makes the cross-section image look good (left) while a high value overgains the data, in 
this case (right). 

Typical values for the Attenuation are 0.0 to 20.0 (selected from the dropdown list) but any value can be
input by typing it directly into the field. 

The Attenuation value applies a gain to the cross-sections in the same way that the Amplitude Equalization
Gain value applies gain to the slices. Therefore, when an Attenuation value is found that makes the cross-
section images look “good” without being over-gained, the same value can be used as a User Amplitude
Equalization Gain value to make the depth slice images look their best (see Amplitude Equalization
Gain).

Start Gain

The Start Gain is the gain value at zero depth at the top of the GPR cross-section. Typically values for the
Start Gain are 0 or 1 with 1 being the default value.

Maximum Gain

The Maximum Gain is the highest multiplication factor for the GPR cross-section data. The ramp defined
by the Attenuation stops increasing once it has reached the Maximum Gain value. Typically values for the
Maximum Gain are 20 to 1000 with 500 being the default value.

5.2.2.5 Defaults

Clicking the Default button will return all the cross-section Settings to their default values.

5.2.2.6 Preview

Clicking on the Preview button allows the user to see the effect of changes they have made to the cross-
section settings before permanently applying those changes by clicking on the OK button.

5.2.2.7 OK

Clicking the OK button applies any changes to the settings for the cross-section image and closes the
Settings dialog box.
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5.2.2.8 Cancel

Clicking the Cancel button closes the Settings dialog box ignoring any changes that may have been made
to the settings.
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5.3 Contrast
The Contrast setting controls how much of the image area is at the extremes of the color palette. The
contrast ranges from 0 to 100%, less contrast to more contrast. The default setting is 0% (no added
contrast).

Before changing the Contrast value, make sure that the depth slice or cross-section image you want to
change is the Active Window.

The Contrast is increased by five percent (5%) by selecting View > Contrast > Increase or clicking the
following button on the Toolbar: 

The Contrast is decreased by five percent (5%) by selecting View > Contrast > Decrease or clicking the
following button on the Toolbar: 

Pressing the “Shift” key while increasing or decreasing the contrast will cause the value to increase or
decrease by 10% rather than 5%.

Pressing the “Ctrl” key while increasing or decreasing the contrast will cause the value to increase or
decrease by 1% rather than 5%.

Contrast can also be increased by 5% by pressing the “/” key and decreased by 5% by pressing the “.” key
on the keyboard. 

The Contrast can also be changed by using the appropriate slider bars in the Settings dialog box. 

The Contrast setting for the image can also be modified by clicking on the slider bar and then using the left
and right arrows on the keyboard to increase or decrease the value respectively. If you select the Auto
Preview checkbox beforehand, the changes made to the Contrast setting will be instantly visible on the
image.

As Contrast increases, more and more of the data is displayed at the extreme value of the color palette.
Contrast can be useful for making weak targets more visible in the image.



5-View EKKO_Mapper Help

46

Cross-section images: Cross-section signals vary from extreme negative values to extreme positive
values with the zero signal in the middle. As the Contrast setting increases, the colors associated with the
high positive and negative signal levels at the ends of the color palette widen, resulting in the weaker
signals looking stronger in the image. 

 Figure 5-12:  For cross-sections, the Contrast value defaults to 0% meaning no contrast is added to the image (left, Contrast=0). 
As Contrast is increased on cross-section images, the colors on the left and right of the color bar associated with the strongest sig-

nals, widen into the middle, resulting in weaker signals looking stronger in the image (right, Contrast=50). 

Depth Slice Images: Depth Slice signals vary from zero to extreme positive values. As the Contrast
setting increases, the color associated with the extreme positive signal level on the right side of the color
palette widens to the left, resulting in the weaker signals looking stronger in the image. 

 Figure 5-13:  For Depth Slice images, the Contrast value defaults to 0% (left). As Contrast is increased on depth slice image, the 
colors on the right of the color bar associated with the strongest signals, widen to the left, resulting in weaker signals looking 

stronger in the image (right, Contrast=50%). 
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5.4 Sensitivity
The Sensitivity setting controls how sensitive the image is to small signal variations. The sensitivity value is
from 0 to 100%, least sensitive to most sensitive. The default setting is 100% (most sensitive).

Before changing the Sensitivity value, make sure that the depth slice or cross-section image you want to
change is the Active Window.

The Sensitivity is increased by five percent (5%) by selecting View > Sensitivity > Increase or clicking the
following button on the Toolbar: 

The Sensitivity is decreased by five percent (5%) by selecting View > Sensitivity > Decrease or clicking
the following button on the Toolbar: 

Pressing the “Shift” key while increasing or decreasing the sensitivity will cause the value to increase or
decrease by 10% rather than 5%.

Pressing the “Ctrl” key while increasing or decreasing the sensitivity will cause the value to increase or
decrease by 1% rather than 5%.

Sensitivity can also be increased by 5% by pressing the “]” key and decreased by 5% by pressing the “[”
key on the keyboard. 

The Sensitivity can also be changed by using the appropriate slider bars in the Settings dialog box. 

The Sensitivity setting for the image can also be modified by clicking on the slider bar and then using the
left and right arrows on the keyboard to increase or decrease the value respectively. If you select the Auto
Preview checkbox beforehand, the changes made to the Sensitivity setting will be instantly visible on the
image.

Decreasing the Sensitivity from 100% widens the color palette around the zero signal level, removing the
weaker signals in the image so only the strongest signals are visible.
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Cross-section images: Cross-section signals vary from extreme negative values to extreme positive
values with the zero signal in the middle. As the Sensitivity setting decreases, the color associated with the
zero signal level in the middle of the color palette widens, resulting in the weaker signals being removed
from the image. 

 Figure 5-14:  For cross-sections, the Sensitivity value defaults to 100% (left) meaning the image is most sensitive to weak signals. 
As Sensitivity is decreased on cross-section images, the color in the middle of the color bar associated with weaker signals around 

zero, widens, removing weaker signals from the image (right, Sensitivity=80). 

Depth Slice Images: Depth Slice signals vary from zero to extreme positive values. As the Sensitivity
setting decreases, the color associated with the zero signal level on the left side of the color palette widens
to the right, resulting in the weaker signals being removed from the image. 

 Figure 5-15:  For depth slice images, the Sensitivity value defaults to 100% (left). As Sensitivity is decreased on depth slice 
images, the color in the left of the color bar associated with weaker signals around zero, widens to the right, removing weaker sig-

nals from the image (right, Sensitivity=50%). 
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5.5 Apply Default to Contrast Sensitivity
The View > Apply Default to Contrast Sensitivity option sets the Contrast and Sensitivity values for the
Active Window to the defaults of zero (0) and 100 respectively.

5.6 Zoom
The Zoom options zoom in and out of the depth slice or cross-section image.  

Before zooming, make sure that the depth slice or cross-section image you want to zoom is the Active
Window.

There are 4 ways of using the Zoom option:

1) Zoom into the current image size by selecting View > Zoom > In or by pressing the following 
button on the Toolbar:

2) Zoom out of the current image size by selecting View > Zoom > Out or by pressing the 
following button on the Toolbar:

3) Draw a box around the area to zoom to by selecting View > Zoom > Select Area or by 
pressing the following button on the Toolbar:

After selecting the option to zoom to an area, draw a box on the image by clicking and dragging
from one corner diagonally to the opposite corner. A box will be superimposed on the image as
you drag it. Dropping the box will cause the image in the box to zoom to the full window size.

4) Zoom to the full grid size by selecting View > Zoom > Fit to Window or by pressing the 
following button on the Toolbar:

This option is usually selected to quickly return to the full image view after zooming in.
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After zooming into an image, scroll bars will appear on the edges. Use the scroll bars to move around on
the image and view different areas. The width of the scroll bar gets narrower each time the image is
zoomed in to indicate that a smaller percentage of the full image range is displayed.  

A zoomed in image will still display the X and Y scales. 

 Figure 5-16:  Zoomed image.Use the scroll bars on the right and bottom to move the zoomed area around the image.

The zoomed in image may show more data than defined by the box because the additional data will be
added to the right or bottom of the image so it always retains the correct aspect ratio.

5.7 Pan
Pan allows the user to move around a zoomed in image. In Pan mode, the mouse cursor becomes a hand
that can be dragged and dropped to view different areas of the image.

It can be selected under View > Pan or by pressing the following button on the Toolbar:

Once in Pan mode, click and drag the data image to a new location. As the image is dragged, a dashed
box outlining the current viewed image is formed. The image will move to the location of this dashed box.

To exit from Pan mode, select the option again under View > Pan or depress the same button on the
Toolbar.
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5.8 Show Collected Lines
Checking the Show Collected Lines option superimposes lines onto the depth slice image to show where
data lines were collected during the data collection of the grid (see Figure 2-2). 

Before selecting the Show Collected Lines option, make sure that the depth slice is the Active
Window.The Show Collected Lines option is greyed out and not accessible if the Active Window is a
cross-section window.

The Show Collected Lines option is available under View or by selecting the Toggle Collected Lines
button from the Toolbar: 

This feature is especially useful when only a partial grid or partial lines were collected in a survey so the
user does not interpret a target in an area where no data were collected.

Show Collected Lines is sometimes turned off because the lines can add clutter to the depth slice image. 

The color of the collected lines can be changed by selecting the View > Settings > Lines Color button.

5.9 Show Scale
Checking the Show Scale option displays scales around the image (see Figure 2-2). For slice images, X
and Y position scales are displayed across the top and left side of the image respectively. For cross-
section images, a depth scale is displayed on the left side of the image, a time scale is displayed on the
right side of the image and a position scale is displayed across the top of the image. 

Before selecting the Show Scale option, make sure that the image you want to add the scales to is in the
Active Window.

The Show Scale option is available by selecting View > Show Scale from the menu. 

Show Scale is sometimes turned off to avoid the scale being superimposed on a zoomed in image (see
Apply Default to Contrast Sensitivity).

The Scale Color can be changed under View > Settings.

5.10 Show Scale Grid
Checking the Show Scale Grid option superimposes a grid of dashed lines onto the depth slice or cross-
section image (see Figure 2-2). Horizontal and vertical grid lines appear at major positions and depths as
indicated on the position and/or depth scales. 

Before selecting the Show Scale Grid option, make sure that the image you want to add the scale lines to
is in the Active Window.
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The Show Scale Grid option is available by selecting View > Show Scale Grid from the menu or by
selecting the Toggle Scale Grid button from the Toolbar: 

The Scale Color can be changed under View > Settings.

In normal operation the Scale Grid is turned off because it adds clutter to the image. Leave the grid scale
off unless you need detailed positioning information to assist with the interpretation.

5.11 Show Legend
Checking the Show Legend option adds a legend to the depth slice or cross-section image (see Figure 2-
2). 

The Plan View Legend appears as a box to the right of the slice image. It contains additional information
about the depth slice including the slice range, resolution, velocity, data collection date, data analysis date
and settings including data processing, color palette, sensitivity and contrast.

The Cross-Section Legend appears as a line of text below the cross-section image. It contains
information about the cross-section including the line name, velocity, data processing, gain, color palette,
contrast and sensitivity.

Before selecting the Show Legend option, make sure that the image you want to add the legend lines to is
in the Active Window.

The Show Legend option is available by selecting View > Show Legend from the menu or by selecting
the Toggle Legend button from the Toolbar: 

The plan view legend is often turned off to allow the slice image to be as large as possible in the plan view
window.

5.12 Show Slice
Checking the Show Slice option displays the depth slice image in the plan view window. This option
defaults to being on. The user has to specifically turn it off.

Before selecting the Show Slice option, make sure that the plan view window is the Active Window.The
Show Slice option is greyed out and not accessible if the Active Window is a cross-section window.

The Show Slice option is available by selecting View > Show Slice from the menu. 

This feature is useful when you only want to see the position of collected lines without the clutter of the
slice image.
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5.13 Show Fiducials
Fiducials are markers and/or comments added during data acquisition at specific trace positions along the
line. Fiducials can also be edited or added after the survey using a routine in the EKKO_View Deluxe
software.

 Figure 5-17:  Fiducial markers (bottom of image) are added at significant positions during data collection. The usually consist of 
an “f” followed by an incrementing value. Existing fiducials are edited and new ones inserted using the EKKO_View Deluxe soft-

ware.

When a GFP file is created using the GFP_View or GFP_Edit utility program, fiducials are automatically
imported into the GFP file when the lines are imported. 

However, there are two cases when it is necessary to manually import fiducials into the GFP file using the
GFP_View or GFP_Edit utility program:

1) Some legacy GPR systems do not write fiducials to the GFP file created during grid data 
acquisition. In this case, fiducials must be imported separately into the GFP file. 

2) If fiducials in the DT1 files are edited using the EKKO_View Deluxe software package, they are 
not automatically changed in the any GFP files associated with those DT1 files. To ensure the 
GFP file contains the latest fiducials from the DT1 files, the fiducials must be imported again. 

If the GFP file contains Fiducials on any of the data lines, they are automatically displayed on the image in
the Plan View Window providing the Show Collected Lines option is on. The fiducials will appear as
small squares on the line. 

Fiducials can be turned on and off by checking or unchecking the View > Display Fiducials option or by
clicking the Fiducial toggle button on the Toolbar:
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Fiducials do not appear if Show Collected Lines is off.

If Show Fiducial Text is on, the text associated with the Fiducial is also displayed.

 Figure 5-18:  Fiducial markers added during data acquisition or added later are displayed by turning on the Show Fiducials 
option. Fiducials appear as little squares on the plan view image.

If the grid survey data does not contain any fiducials, this option is greyed out and not accessible.

5.14 Show Fiducial Text
If Show Fiducials is enabled, the View > Show Fiducial Text option is accessible. This option displays
the text associated with the fiducials.

 Figure 5-19:  The text associated with fiducials is displayed by enabling the Show Fiducial Text option.

Fiducials and fiducial text do not appear if Show Collected Lines is off.

If the grid survey data does not contain any fiducials, this option is greyed out and not accessible.
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5.15 Font
The Font option determines the font used for the position, depth and time axes as well as the text in the
Legends. When selected, the standard Windows font dialog opens allowing the user to select the Font,
Font Style and Size. Changing the font type and size can increase the available screen area to display
data images on and improve the readability of printed images or graphics image files.

5.16 Toolbar
If View > Toolbar is checked, the Toolbar appears below the menu bar (Figure 2-2).

5.17 Status Bar
If View > Status Bar is checked, the Status Bar appears along the bottom of the EKKO_Mapper Window
(Figure 2-2).
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6 Navigation

6.1 Slice Up and Slice Down
These options allow the user to scroll up and down through the depth slices. When Navigation > Slice:
Up or Navigation > Slice: Down is selected, the depth slice image is incremented up or down by a single
depth slice. 

The same actions can be performed by pressing the Page Up and Page Down keys on the keyboard,
using the wheel on the mouse or by clicking on the following Toolbar buttons to move the depth slice up or
down respectively:

When the highest or lowest depth slice is reached, the depth slice image does not change even if the user
continues to try moving higher or lower. 

If there is a cross-section window open, notice that as you move up and down through the slices in the plan
view window, the slice cursor lines (Figure 2-2) on the cross-section image move up and down
corresponding to the slice image.

Stepping Up and Down through the slice images provides insight into the depth of various features in the
three dimensional volume. 

6.2 Line Up and Line Down
If X lines were collected and are being included to generate the depth slice image (see Lines to Include in
Depth Slice Image) and there is a Cross-Section Window open, the user can move through the various
X cross-section images one at a time by using the Up Arrow and Down Arrow on the keyboard or by
selecting Navigation > Line: Down or Navigation > Line: Up from the menu. The user can also move
through the X line cross-sections by clicking on the following buttons on the Toolbar: 

If the Show Collected Lines option is on, a horizontal Cross-Section Cursor Line (Figure 2-2),
corresponding to the grid position of the current X line will be displayed on the slice image in the plan view
window. As the X line cross-section image changes, the cross-section cursor line on the slice image moves
to a new position corresponding to the new X line cross-section. 

The cross-section window can be quickly switched from X lines to Y lines by clicking on any of the options
under Line Left and Line Right.

These buttons are active when selecting an X line for Hyperbola Velocity Calibration.
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6.3 Line Left and Line Right
If Y lines were collected and are being included to generate the depth slice image (see Lines to Include in
Depth Slice Image) and there is a Cross-Section Window open, the user can move through the various
Y cross-section images one at a time by using the Left Arrow and Right Arrow on the keyboard or by
selecting Navigation > Line: Left or Navigation > Line: Right from the menu. The user can also move
through the Y line cross-sections by clicking on the following buttons on the Toolbar: 

The cross-section window can be quickly switched from Y lines to X lines by clicking on any of the options
under Line Up and Line Down.

If the Show Collected Lines option is on, a vertical Cross-Section Cursor Line (Figure 2-2),
corresponding to the grid position of the current Y line will be displayed on the slice image in the plan view
window. As the Y line cross-section image changes, the cross-section cursor line on the slice image moves
to a new position corresponding to the new Y line cross-section. 

These buttons are active when selecting an Y line for Hyperbola Velocity Calibration.
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7 Tool

7.1 Data Processing
The Data Processing dialog box is used to set the parameters for the processing of the depth slice
images. 

 Figure 7-1:  Data Processing dialog. 

The Data Processing dialog box is accessed by selecting the Tool > Data Processing menu item or the
following button on the Toolbar:

Slices produced by EKKO_Mapper are displays of GPR signal amplitude versus XY position.  The
amplitude value is the average amplitude value over the depth or time thickness. Keep in mind that data
processing steps such as Dewow, migration, background subtraction and envelope affect the original
amplitude. 
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7.1.1 Data Position Limits
The Data Position Limits define the positions at the edges of the depth slice image. This setting always
defaults to the Outer positions so a depth slice is generated that includes all the available data but the user
can select other settings like Clipped, Inner or User to define other grid dimensions.

7.1.1.1 Outer

Selecting the Outer Data Position Limit for the grid means the longest lines in the X and/or Y direction are
used to define the size of the grid so the depth slice generated is the largest possible and uses all the
available data in the grid. Cross-sections that are shorter than the longest lines are padded with zero data
so all lines are the same length.

For example, if all the lines are 10m long except one in the X direction that is 10.5m and one in the Y
direction that is 10.2m, the grid size plotted in the depth slice will be 10.5 x 10.2m.

7.1.1.2 Clipped

It is quite common during grid data collection to collect extra data that slightly exceeds the desired grid
size. This means that some cross-sections are longer than others. 

Selecting Clipped Data Position Limit means that X lines are cropped by the furthest Y lines on the left and
the right and the Y lines are limited likewise by the X lines.

If we only have X lines or Y lines then clipped data limit option is not available (there is no Y lines to clip the
X lines and vice versa).

7.1.1.3 Inner

Selecting the Inner Data Position Limit for the grid means the shortest lines in the X and/or Y direction are
used to define the size of the grid so the grid contains solid data with no padding of zeroes. This option is
useful when you have one or more cross-sections that exceed the desired size of the grid but you want to
truncate those lines and display a grid with no padding of zero data.

For example, if all the lines are 10m long except one in the X direction that is 10.5m and one in the Y
direction that is 10.2m, the grid size plotted in the depth slice will be 10 x 10m.

Sometimes the inner limit might not be available. 
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7.1.1.4 User

Selecting the User Data Position Limit for the grid means the user can define exactly what positions they
want for the minimum X, maximum X, minimum Y and maximum Y of the grid. Cross-sections are
truncated and/or padded with zero data as necessary to fit the grid size defined. 

7.1.2 Units

The distance and depth units displayed on the axes around the depth slice and cross-section images can
be displayed in metres or feet. The units default to those used during the original grid data collection but
can be converted and displayed in either metres (m) or feet (ft). For example, data collected in feet can be
plotted in metres.

7.1.3 Background Subtraction

At the top of all GPR cross-sections are the horizontal events associated with the direct air wave and the
direct ground wave. These events are not reflections from within the ground and therefore, it is often
desirable to remove them from the data before generating depth slice images. The background subtraction
process is primarily used to remove these events. It can also be used to remove other horizontal reflectors
in the cross-section data.

The background subtraction filter defaults to on and including this process is recommended for most data
sets, however, it can be turned off by unchecking the checkbox.

One situation where it may be desirable to turn off background subtraction is when exporting geological
data to 3D (see Export Data).

7.1.3.1 Total Background

When the Total Background is used, the average trace for the entire grid survey is calculated and
subtracted from every trace in the survey. This results in the removal of the air wave - ground wave events
on the top of each cross-section.

 Figure 7-2:  A cross-section image before (left) and after (right) Total Background Subtraction has been applied. This process 
removes the direct air and ground waves on the top of the data to improve the very shallow depth slice images.



7-Tool EKKO_Mapper Help

62

This filter is most effective when the air wave - ground wave events are fairly constant throughout the grid
of cross-sections. If the surface varies in composition or water content, the air wave - ground wave events
will vary in amplitude and time and using the total background subtraction filter may not remove them
satisfactorily on all cross-sections. In this case, using a Local Background Subtraction filter may be more
effective.

7.1.3.2 Local Background

With Local Background, an average trace in a window width defined by the user is calculated and
subtracted from the trace in the center of the window. The window is then moved over one trace and the
process repeated. This type of filter is called a running average background subtraction filter. 

This background subtraction filter is more effective for removing local flat-lying events in the data, for
example, when the air wave - ground wave varies or when there is localized banding on one cross-section
in the grid.

 Figure 7-3:  A cross-section image before (left) and after (right) Local Background Subtraction of 2 feet has been applied. This 
process removes the direct air and ground waves on the top of the data as well as local flat-lying reflectors.

To determine an appropriate window width for the local background subtraction filter, scroll through the
cross-sections in your grid survey and determine the length of the shortest flat-lying reflection that you
want removed from the data. 

Be cautious when using short distances for Local Background Subtraction as these can result in
the removal of a significant amount of data.
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7.1.4 Signal Velocity
An accurate signal velocity is necessary for creating the best depth slice images. A poor value for the
velocity may result in fuzzy images that are difficult to interpret and inaccurate depth estimates. 

The velocity defaults to a typical average velocity of 0.10 m/ns or 0.328 ft/ns.

The user can directly input a velocity into the Signal Velocity field in the units displayed (either metres per
nanosecond, m/ns or feet per nanosecond, ft/ns). Clicking on the:

button displays a list of typical velocities for different materials. 

The other method of determining the velocity is to measure it from a hyperbola in the grid data set. Select
the Hyperbola Velocity Estimate button from this dialog box, Tool > Hyperbola Velocity Calibration
from the menu or the Hyperbola Velocity Calibration button from the Toolbar:

Velocity is calibrated by fitting a curve to hyperbolas from rebar or other targets in the cross-section
images. Details of this method are described in Tools > Hyperbola Velocity Calibration.

7.1.5 Slice Processing

Slice Processing allows the user to select the type of processing that will be applied to the current active
slice before it is displayed. 

The Slice Processing checkbox defaults to checked, meaning that slice processing will be performed when
the OK button is pressed from the Data Processing dialog. Unchecking the Slice Processing checkbox
means that no slice processing will be performed so no slice images will be displayed. Unchecking this
option is useful when the user just wants to display cross-sections, perhaps in a situation when the user is
still trying to determine the best Slice Processing options for a large grid and knows that slice processing
will take a substantial period of time. 

7.1.5.1 Slice Units

The Slice Units setting determines the units that will be used for the slice thickness parameter, either
depth in metres or feet or time in nanoseconds. Some users may prefer to use time in nanoseconds.

The Slice Units defaults to depth in the same units that the data were collected in, i.e. metres or feet, but
these units can be changed (see Units). 
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7.1.5.2 Slice Resolution

In the depth slice image, the smallest “box” that is one solid color is called a “pixel” or a “sample”. Slice
Resolution defines the physical size of the sample in a depth slice image. Decreasing the sample size
increases the total number of samples and consequently the details of the images increase but so does the
time required to process and display the image. Increasing the sample size decreases the total number of
samples and decreases data processing time but the “fuzzier” the image is.

0.16ft (116x117 samples) 0.20ft (93x94 samples) 0.50ft (37x37 samples) 1.0ft (19x19 samples)

 Figure 7-4:  Slice Resolution can be selected as Max, High, Medium or Low or a user-defined value. As the Pixel or sample size 
gets smaller, the total number of samples increases and the image has more detail but the processing time increases.

Depth slices with a very small sample size are very detailed but take longer to process. The increase in
processing time can be very significant. 

The Slice Resolution defaults to value appropriate for the step size (the distance between traces) and the
screen resolution. The slice resolution can be changed but cannot be made finer (smaller) than the
smallest step size (the distance between traces) in the data. A coarser (larger) resolution value will result in
faster data processing.

The Plan View Legend displays the current Slice Resolution value along with the total number of samples
in the X and Y direction. To change the Slice Resolution value, input a new value or use a value from the
drop-down list. There are 4 values available from lowest resolution to highest: low, medium, high and max.

Changing the Slice Resolution is most effective for large grid data sets. It is often a good idea to set the
Slice Resolution to a coarse value at first and make sure that the depth slices generated are what you
expect before proceeding with a finer sample size that will take longer to process.

7.1.5.3 DME Processing

DME stands for Dewow, Migration and Enveloping. These are standard processing routines for GPR data
and are used especially before generating slice images. These options are generally for advanced users
who understand these GPR data processing routines. 

The default setting (and the one highly recommended for novice users) is to have all these processes
checked so that they are performed before generating the slice images.

The processes selected in this option affect the number of processing streams available in the dropdown
list under View > Settings > Cross-Section > GPR Processing. For example, if the Migration process is
not selected, then the GPR processing streams listed will not include Migration.
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One situation when DME should all be turned off (unchecked) is when the user has processed the grid
data in some other program (like EKKO_View Deluxe) and now just wants to use EKKO_Mapper as a
visualization tool of the data. In this case, Dewow, Migration and Envelope should be turned off as well as
Background Subtraction. Depending on whether the grid data were gained, the user may also want to
turn off Amplitude Equalization Gain.

Review the DME settings when exporting geological data to 3D. It may look better in 3D without the
Migration and Enveloping processes (see Export Data).

Dewow

Depending on the proximity of the transmitter and receiver as well as the electrical properties of the
ground, the transmit signal may induce a slowly decaying low frequency “wow” on the trace which is
superimposed on the high frequency reflections.

The Dewow process is designed to remove this unwanted low frequency while preserving the high
frequency signal.  The removal of this wow in the data is also called the “signal saturation correction”.

 Figure 7-5:  Data line showing raw data with the low frequency “wow” component (left) and after the Dewow process removes 
the low frequency component (right). The Dewow process is highly recommended when data processing cross-sections and slices.

The wow is removed from the data by applying a running average filter on each trace.  A window with a
width the same as that of one pulsewidth at the nominal frequency is set on the trace.  The average value
of all the points in this window is calculated and subtracted from the central point.  The window is then
moved along the trace by one point and the process is repeated.  

While any filter produces unwanted artifacts in the data to which it is applied, Dewow has been optimized
after many experiments over many years to reach a satisfactory compromise filter. 

The Dewow process is highly recommended when data processing cross-sections and slices.
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Migration

Targets in the subsurface often generate hyperbolic responses on the GPR cross-section. A hyperbola is
the result of the wide beam-width inherent in most GPR systems. 

The actual location of the target is at the apex or top of the hyperbola. Migration is a process that focuses
the energy spread over the hyperbolic shape back to the apex of the hyperbola. This is an essential and
highly recommended part of the data processing when generating depth slice maps. Migration allows
linear targets viewed on depth slice images look like linear objects rather then hyperbolic shapes that can
make interpretation difficult.

 Figure 7-6:  The Migration process focuses hyperbolas back to a point at the location of the object. It is a critical processing step 
for most depth slice images. 

Migration requires an accurate Signal Velocity value. If the velocity value is too low, hyperbolic reflectors
will not be focussed back to a point and the target will have fuzzy edges in the depth slice. If the velocity
value is too high, hyperbolic reflectors will over-migrate and become inverted, again resulting a target with
fuzzy edges in the depth slice image.

Migration defaults to on and is highly recommended for most grid data sets but the user can turn the
migration process off by unchecking the checkbox.
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Envelope

The basic idea behind enveloping a trace is to convert the trace from a wavelet with both positive and
negative components to a monopulse wavelet with all positives.  This is illustrated in Figure 7-7.  The
process removes the oscillatory nature of the radar wavelet and shows the data in its true resolution. 

 Figure 7-7:  The original trace (top) consists of positive and negative components.  The enveloping process makes the negative 
component positive (middle) and smooths the outline of the wavelet (bottom).

At a single time or depth value the amplitude value will be similar to the raw amplitude value but always
positive. Average enveloped amplitude is calculated by averaging the amplitude values over a depth or
time thickness.

 Figure 7-8:  The enveloping process replaces the negative signal amplitudes visible in the raw data (left) with positive values 
(right). This process is important because amplitudes are averaged over a depth or time thickness and if it was not done the posi-

tive and negative amplitudes would cancel each other out, resulting in uninterpretable slice images.
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Envelope is highly recommended for the display of slices. Slices are generated by averaging all the
amplitude values in the thickness range. If data are not enveloped the negative values are retained and
averaging can result in the positive or negative amplitudes cancelling each other out and producing slices
with zero or low amplitudes.

If Envelope is turned off, the data retains the negative amplitude values and the color palette becomes bi-
polar, which means that the colors display amplitude data values that are positive, negative or zero.

7.1.5.4 Thickness 

The Slice Thickness defines the thickness of the depth slices. It is indicated by the slice cursor lines on
the slice image (Figure 2-2) in the plan view window. 

It is important to understand that depth slices are a plot of the average signal amplitude between two
depths or two times. A depth slice with a thickness of 0.5 foot uses the signal amplitudes in 0.5 foot thick
3D slabs and averages those into 2D plan images.

 Figure 7-9:  Conceptually, EKKO_Mapper divides the data volume into slabs of equal thickness and displays depth slice images 
of the average amplitude in each slab.

The default thickness value is based on the antenna frequency used for the grid survey. In general, as
antenna frequency decreases and wavelength increases, the default depth slice thickness is increased. 

The default value in feet is (1000/frequency) / 12. 

The default value in metres is (1000/frequency) * 0.025. 

Frequency is in MHz. For example, the default thickness for 250 MHz data is 0.33 feet or 0.10 meters.

Events with a large depth extent will be seen over several depth slices. In this case it may be possible to
increase the thickness of the slice and still see the target. Be careful not to make the slice thickness too
large, as the averaging process with reduce the amplitude of even very strong reflectors if they are
averaged over too large a thickness interval.
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Similarly, to see reflectors with a small depth extent or low amplitude, you may need to set the thickness to
a smaller value.

7.1.5.5 Overlap

Overlap defines the percentage of overlap between depth slices. For example, an overlap of 50% means
that each depth slice will overlap the depth slices above and below it by 50%. If the depth slice thickness is
1 foot, depth slice depth ranges would be 0.0-1.0, 0.5-1.5, 1.0-2.0 etc.

The default setting is 0% which means there is no overlap between depth slices.

Overlap is useful for seeing a feature gradually appear and disappear as you step through several depth
slices.

7.1.5.6 Slice Depth Limit

The Depth Limit specifies the maximum depth of the data used to generate depth slice images. The Depth
slice depth limit is automatically set to Auto and defaults to the maximum depth in the cross-section data.
The value can be changed by selecting User and entering a new value that is less than or equal to the
maximum depth value. If the user depth limit value is set higher than the maximum depth, the value is
ignored and maximum depth value is used.

Reducing the depth limit decreases the number of depth slice images. It is most useful when the GPR
signal depth of penetration is significantly less then the maximum depth of the cross-section data. The
depth limit can be set to the actual depth of penetration so depth slice images of the background noise
signals towards the bottom of the cross-sections are not generated and displayed. 

7.1.5.7 Interpolation Limit

EKKO_Mapper generates depth slice images by interpolating data into the gaps between the cross-
sections (see Figure 7-10). As the line separation or the distance between cross-sections increases,
interpolating data into the gap is less desirable as artifacts may be created in the depth slice.

 Figure 7-10:  Conceptually, EKKO_Mapper interpolates data between cross-sections to generate a solid data set that is then dis-
played as depth slices.

The Interpolation Limit defines the maximum distance (in metres or feet) that data will be interpolated. If
the distance two cross-sections exceeds this limit, a gap of zero data will be left between them (see Figure
7-11).
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 Figure 7-11:  Depth slice image from a Y line data grid showing a gap with zero data where the line separation exceeded the Inter-
polation Limit.

This value defaults according to the data set and can usually be left as Auto. The default setting is 1.5
times the average survey line separation. 

The User setting allows the user to define the distance.

7.1.5.8 Amplitude Equalization Gain

Amplitude Equalization Gain applies a gain to the depth slice data to compensate the weaker signals at
depth. When done properly, this allows the user to compare the relative signal strengths of targets in
different depth slices. 

Amplitude Equalization Gain requires three parameters: Attenuation, Start Gain and Maximum Gain. 

The strongest GPR signals come from shallow targets while deeper targets have weaker signal strength.
Therefore, the gain applied to the GPR data increases with increasing depth. The gain is a ramp that starts
off at the Start Gain value at the top of the data, ramps up on a slope with the steepness depending on the
Attenuation value and levels off to a constant multiplier when the Max Gain value is reached.
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 Figure 7-12:  The concept of applying Amplitude Equalization Gain to the grid data. The gain at the shallowest depth slice is set 
by the Start Gain. The gain increases for deeper slices on a ramp set by the Attenuation. If the attenuation value is low, the gain 

ramp increases slowly with depth. If the attenuation value is high, the gain ramp increases quickly with depth. The ramp increases 
until it reaches the Max Gain value, which is the highest gain applied to the deepest slices.

The Amplitude Equalization Gain setting is only applied to the display of the depth slice images. Changing
the gain setting has no effect on cross-section images. 

The current Amplitude Equalization Gain value is displayed in the Plan View Legend. 

The Amplitude Equalization Gain can be turned off by unchecking the checkbox (Figure 7-1). If Amplitude
Equalization Gain is turned off, the slice images are generated using the raw data amplitudes with no gain
applied. When this is done, it is not advised to compare the signal amplitudes of targets in different slices.

The Amplitude Equalization Gain parameters can be set manually in User mode or automatically in Auto
mode by clicking the desired option (see Figure 7-1). 

Auto uses the average decay curve of the GPR signal strength over time to calculate an appropriate gain
parameter values for Attenuation, Maximum Gain and Start Gain. If the depth slices look good using the
Auto values and are not over-gained or under-gained, then using Auto Amplitude Equalization Gain is
acceptable.

However, Auto does not always gain the data properly, especially if the data has strong, high amplitude
signals deep in the section. In this situation, it tends to use an attenuation value that may be too high,
resulting in overgained data and depth slices with too many high amplitude signals which can be confusing
for data interpretation. When this occurs with your data, use Auto to set the initial values for the gain
parameters and then switch the gain to User and then experiment using different values.

The following describes, in more detail, each gain parameter.
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Attenuation

The Attenuation values defines the “steepness” of the gain function ramp. Lower values mean a more
gradual slope while higher values are steeper. The ramp starts at the Start Gain value and ramps up to the
Maximum Gain value. 

Low values for Attenuation are typically used but higher values may help to improve the imaging of deeper
targets. Try to use the lowest value possible as the data can be "overgained" making it more difficult to
understand.

 Figure 7-1:  Amplitude Equalization applies a gain to the weaker signals at depth. If the Auto value is not high enough (left) or is 
too high (right), set it to User and experiment with different values that generate images with a good balance of colors (middle).

Typical values for the Attenuation are 0.0 to 20.0 but any value can be input by typing it directly into the
field. 

The Amplitude Equalization Gain value applies a gain to the slices in the same way that the Attenuation
value applies gain to the cross-sections. Therefore, when a Attenuation value is found that makes the
cross-section images look “good” without being over-gained (see Attenuation), the same value can be
used as the Attenuation value to make the depth slice images look their best.

Start Gain

The Start Gain is the gain value at zero depth at the top of the GPR cross-section. Typically values for the
Start Gain are 0 or 1 with 1 being the default value.

Maximum Gain

The Maximum Gain is the highest multiplication factor for the GPR cross-section data. The ramp defined
by the Attenuation stops increasing once it has reached the Maximum Gain value. Typically values for the
Maximum Gain are 20 to 1000 with 500 being the default value.

7.1.6 Defaults
Clicking the Default button will return all the Data Processing Settings to their default values.
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7.1.7 Preview
Clicking on the Preview button allows the user to see the effect of changes they have made to the Data
Processing Settings before permanently applying those changes by clicking on the OK button.

7.1.8 OK

Clicking the OK button closes the dialog box and, if the Data Processing settings have changed, processes
(or reprocesses) the current grid survey data and generates slice images. Depending on the changes
made to the processing, the time to process the data could take longer (or shorter) than before.

7.1.9 Cancel

Clicking the Cancel button closes the Data Processing dialog box ignoring any changes that may have
been made to the settings.

7.1.10 Un-Processed Data

Checking the Always open this dialog when loading un-processed data checkbox from the Data
Processing dialog means that, after opening a GFP file (Open GFP File), this dialog will automatically
open for the user to confirm that all the data processing settings, especially the velocity and the slice
thickness, are correct before starting the data processing. 

If you do not want to automatically see this dialog when a GFP file is opened and want to select it manually
before processing the data and generating slice images, uncheck this checkbox. 

7.2 Hyperbola Velocity Calibration
The correct velocity is necessary for generating the clearest depth slice images and accurately
determining the depth of an object from the cross-section images. 

The Hyperbola Velocity Calibration allows the user to calculate the a velocity value using the hyperbola-
fitting method. This method requires the user to fit a typical response curve (a hyperbola) to the raw data to
extract the velocity.

It is very important that hyperbola fitting only be performed on target responses where the GPR system
has crossed the target perpendicularly. Hyperbola-fitting on a target that was crossed at an angle will result
in a poor velocity value, fuzzy depth slice images and inaccurate depth measurements.

The velocity calibration is accessed by selecting Tool > Hyperbola Velocity Calibration from the menu or
by selecting the Toggle Hyperbola Velocity Calibration button from the Toolbar: 

Note that this button toggles the Hyperbola Velocity Calibration window on and off so it must be clicked
again after calibration is completed. If the velocity value has changed, the user is prompted to answer Yes
or No to changing the velocity value.
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7.2.1 Velocity Calibration Window
When Hyperbola Velocity Calibration is selected, a hyperbola is superimposed on the current cross-section
image. If no cross-section window is opened, a new one is automatically opened. 

The window always first displays the current cross-section. The user can use the Line Up and Line Down
and Line Left and Line Right options to move through the cross-sections and display one with a good
hyperbola for the velocity calibration. 

If necessary, the user can also change the Gain value used for the cross-section to make the hyperbola
more visible.

7.2.1.1 Hyperbola Fitting

The objective for hyperbola fitting is to move the hyperbola superimposed over the data on top of a
hyperbola in the cross-section image and match the shape by dragging the handles on the end of the
hyperbola tails.

To determine the velocity, the superimposed hyperbola does not necessarily need to be placed at the very
top of hyperbola in the image. Try to choose the colored band on the hyperbola that has the longest tails
and looks the most complete.

The superimposed hyperbola can be moved by clicking on the position on the cross-section image where
you want the apex (top) of the hyperbola to go. The hyperbola will immediately jump to this location.

 Figure 7-1:  Hyperbola-fitting is done by first clicking or dragging the superimposed hyperbola onto one of the colored bands on 
the hyperbola in the data. Choose a band that has long tails. This is not necessarily the top band (left). Then, click and drag one of 
the diamond-shaped handles on the ends of the hyperbola until the shape matches (right). During this process, the velocity, depth 

and time are displayed on the Status Bar on the bottom of the screen.
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After the hyperbola has been positioned at the apex of the hyperbola in the cross-section image, the next
step is to match the shape. The shape of the hyperbola can be changed by clicking on either diamond-
shaped handle on the ends of the hyperbola tails and dragging it to the position that best matches the
shape of the image hyperbola. 

Once the desired fit has been achieved, select Hyperbola Velocity Calibration again, using the menu or the
button, to exit from velocity calibration mode. 

If the velocity value has changed, the user is prompted to answer Yes or No to changing the velocity value.
Click Yes to accept the new velocity. The grid data will automatically be reprocessed using the new
velocity. Depending on the size of the grid, the reprocessing may take several minutes. The depth slice
images and depth axis in the cross-section window will automatically update.

During the hyperbola velocity calibration, the Status Bar along the bottom of the EKKO_Mapper screen
displays information including the velocity, depth and time of the hyperbola. As the hyperbola shape is
changed, the velocity and depth also change. The depth value is always for the apex (top) of the
superimposed hyperbola.
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7.2.1.2 Target of Known Depth

The Hyperbola Velocity Calibration window can also be used to determine the velocity using a target at a
known depth. 

 Figure 7-2:  For a target at a known depth, like in this case the known thickness of a concrete slab, the apex of the hyperbola is 
placed on the reflection of the target and the velocity adjusted by dragging the hyperbola handles until the depth value listed at the 

bottom of the screen matches the known depth. The velocity will then be listed on the bottom of the screen as well.

For example, if the reflection from the bottom of the concrete is visible in the cross-section image and the
depth of the concrete is known, the apex of the hyperbola can be positioned on that reflection and the
velocity changed until the depth value displayed on the bottom of the window matches the known depth. 



EKKO_Mapper Help 7-Tool

77

7.3 Measure
The measure tool allows the user to measure the straight-line distance between any two points on a depth
slice or cross-section image.

The Measure tool is accessed by selecting Tool > Measure from the menu or by selecting the Toggle
Measure Tool button from the Toolbar: 

To measure the distance between two points, click the mouse at the start position and drag and drop the
mouse cursor at the end position. The distance between the two points (in the current units) will be
displayed on the Status Bar at the bottom of the screen.

It is important to understand that measurements made on cross-sections are based on the velocity
so an accurate velocity is critical for an accurate measurement.

To exit from the Measure tool, select Toggle Measure Tool again, either by using the menu or by clicking
the button on the Toolbar.
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8 Window

8.1 New Plan View Window
Selecting Window > New Window opens another window (instance) of the current plan view window. 

This is especially useful for looking at different plan views (like slices) at the same time. 

Windows always have a green number on the left side of the title banner that indicates which data set they
below to. For example, all the windows associated with the first GFP file opened will have a number 1 in
the banner, all windows associated with the second GFP file opened will have a number 2 in the banner,
etc. 

When there are multiple plan view windows on the screen, only one is active at a time. However, changing
some variables such as data processing parameters like velocity and slice thickness and color palette,
changes the values for all instances of a plan view window. Other variables, such as Show Collected Lines,
Show Scale, Show Scale Grid, Show Legend and Show Slice only apply to the current Active Window.
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8.2 New Cross-Section View Window
Selecting Window > New Cross-Section View Window opens another cross-section window for the
current grid survey. 

This is especially useful for looking at different cross-section images at the same time. 

Windows always have a green number on the left side of the title banner that indicates which data set they
below to. For example, all the windows associated with the first GFP file opened will have a number 1 in
the banner, all windows associated with the second GFP file opened will have a number 2 in the banner,
etc. 

When there are multiple cross-section windows on the screen, only one is active at a time. However,
changing some variables such as gain, velocity and color palette changes the values for all instances of a
grid scan. Other variables, such as GPR Processing, Show Scale, Show Scale Grid and Show Legend
only apply to the current Active Window.



EKKO_Mapper Help 8-Window

81

8.3 Cascade
Selecting Window > Cascade will rearrange open sections so they cascade on the screen, that is, the
front section is completely visible and the title lines from the other sections are visible and accessible.
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8.4 Tile Horizontally
Selecting Window > Tile Horizontally will rearrange all open windows so they are tiled horizontally on the
screen, that is, all sections are resized so they are all visible and accessible.

The Tile Horizontally option can also be accessed by clicking the following button on the Toolbar:
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8.5 Tile Vertically
Selecting Window > Tile will rearrange all open sections so they are tiled vertically on the screen, that is,
all sections are resized so they are all visible and accessible.

The Tile Vertically option can also be accessed by clicking the following button on the Toolbar:
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8.6 Arrange Icons
Selecting Window > Arrange Icons will order all the icons (minimized windows).

8.7 Selecting an Open Window
A list of all the currently open windows is available under the Window menu option. The current Active
Window is indicated by a check-mark. The active window can be changed by selecting a different one
from the list.
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9 Help

9.1 Contents
The Contents option opens this document in PDF for viewing. 

The Adobe Acrobat Reader program must be installed on the PC to open this document. If not, the user is
prompted to download it from the Adobe website.

9.2 Sensors & Software contact information...
Displays contact information for Sensors & Software including mailing address, email addresses, phone
and fax numbers.

9.3 Feedback Form
The Feedback Form allows the user to document a problem about or suggestion for the EKKO_Mapper
software and report it to Sensors & Software by email, fax or letter.

9.3.1 Suggestions

To send a suggestion for the EKKO_Mapper software, select the Suggestion button.



9-Help EKKO_Mapper Help

86

9.3.2 Problems
To report a problem with the EKKO_Mapper software, select the Problem Description button

The more information you include about the problem, the better chance we have of solving it. If the error is
reproducible, list the steps that generate it. You must also fill-in the Severity, Type of Defect and
Frequency descriptions from the drop down lists.

Checking the Send Diagnostic Information checkbox will scan a log file saved with the ConquestView
software on your PC and add additional text to your message that may help Sensors & Software to
diagnose why the problem is occurring.

To help us troubleshoot the problem, you can ZIP the grid scan data files and attach them to your email
message.

9.3.3 Contact Information

The upper part of the form is your contact information. Any information filled in here will be included in the
report sent to Sensors & Software. You are not required to fill in these fields but remember that, if you want
us to contact you about the report you send, we need your contact information.

Clicking the Fax Header checkbox will automatically add Sensors & Software’s fax information to the top of
the email or text file.

After writing the suggestion or problem description in the field provided, select one of the report options.
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9.3.3.1 Email

Clicking on the Email option will automatically generate an email to Sensors & Software as long as your
system is MAPI-enabled. MAPI is short for Messaging Application Programming Interface, a system built
into Microsoft Windows applications like Outlook. 

If selecting the Email option does not open your email application program, contact your IT department or
consider using one of the other methods below. 

9.3.3.2 Save to File

This option prompts the user to save the report as a text file. This text file can be attached to an email or
printed out and faxed or mailed to Sensors & Software.

9.3.3.3 Notepad...

The Notepad option opens the Notepad program and automatically writes the report text into the program.
The report can then be saved as a text file can be attached to an email or printed out and faxed or mailed
to Sensors & Software.

9.3.3.4 Clipboard

The Clipboard open writes the report text to the clipboard so it can be quickly pasted into an email and sent
or pasted into any word processing software like Microsoft Word. The report can then be saved and
attached to an email or printed out and faxed or mailed to Sensors & Software.

9.4 Diagnostic Mode
Diagnostic Mode is used to help resolve the issue when EKKO_Mapper unexpectedly terminates or
freezes without a warning or error message. 

If you have a grid survey that consistently causes the program to crash or freeze, the next time you run the
program, turn Diagnostic Mode on. Then, open the GFP file for the grid survey and perform the steps
necessary for the crash to occur again. Diagnostic Mode causes the program to run much slower than
normal, because it is logging all the data processing steps, so please be patient. 

After the crash, run the program again but DO NOT open any data. Immediately go to Help > Feedback
Form and send a message to Sensors & Software. The message will contain valuable diagnostic data to
help us determine the cause of the problem. Please mention that the attached message is to report a crash
and the program was in diagnostic mode.

Large data grids or small Slice Resolution values can take a long time to process so give the program a
good chance to recover before concluding that the program has crashed or is frozen. 

9.5 About EKKO_Mapper
This option displays a description, version number and product number of the EKKO_Mapper program
currently in use.
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 Appendix A: EKKO_Mapper Glossary

Grid is the term describing a square or rectilinear set of straight lines which cover
an area.  Acquiring data on a grid means acquiring data along each line
forming the grid.  Acquiring data on a grid is a pre-requisite for creating depth
or time slice images.  Conventional notation is to use a Cartesian coordinate
system with X and Y axes.

Grid Survey is the term to describe the process of acquiring data on a grid over an area
with the end goal being to create depth or time slice images.

Line: is the term used to identify the location of data acquisition.  A line is normally
straight and data are recorded from the start to the end of the line.

Line Profiling is the term to describe collecting data along one or more lines for immediate
site assessment using cross-section images.  A series of lines can be used
to help define site conditions prior to a grid survey

X Y Axes: X and Y are the names given to the two orthogonal directions of a grid. When
positioned at the specific corner of the grid which is selected to be the origin
of the coordinate system and facing diagonally across the grid, the positive X
direction runs to the right along the edge of the grid and the positive Y direc-
tion runs off to the left.

X Line: A line oriented in the X direction. (i.e. Y = constant while X position varies).

Y Line: A line oriented in the Y direction. (i.e. X = constant while Y position varies).

X Line Spacing: the term used to refer to the spacing between X lines when a grid is covered
by equi-spaced X lines.

Y Line Spacing: the term used to refer to the spacing between Y lines when a grid is covered
by equi-spaced Y lines.

Maximum Depth: is the term which describes the maximum depth selected for viewing, pro-
cessing or data acquisition along a line.

Maximum Time: is the term which describes the maximum time selected for viewing, process-
ing or data acquisition along a line.

Time Window: same as Maximum Time.

Depth Slice: is the term to describe a data attribute derived from data  between two
depths - top  of depth slice and bottom of depth slice.  Most often a grid sur-
vey has the depth range from 0 to the maximum depth subdivided into a
number of depth slices of equal thicknesses.  

Time Slice: is the term to describe the data acquired between two times - top of time
slice and bottom of time slice.  Most often a grid survey has the maximum
time subdivided into a number of time slices of equal thicknesses.  

Depth Slice Image: is the term used to describe a depth slice when the slice attribute is dis-
played as a computer generated image.  This term will normally be short-
ened to depth slice.  
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Time Slice Image: is the term used to describe a time slice when the slice attribute is displayed
as a computer generated image.  This term will normally be shortened to
time slice.

MultiSlice or  MultiSlice View:is the term used when displaying a number of contiguous depth or
time slice images which, when viewed together, enable the user to view a
complete volume described by the grid area and the maximum depth or max-
imum time. 

Grid Size: term used to describe a real extent of a grid (i.e. 5m x 10m, 20ft x 50ft.).

Grid Resolution: is the term used to describe the XY spatial resolution attained in a grid and is
controlled by the largest line or trace spacing.  

Velocity: is the term used to characterize the speed at which GPR signals travel.
Velocity is a critical parameter when creating depth slice images and estimat-
ing depths of targets since velocity is used to convert travel-time to depth.

Color Palette: is the term used to refer to the color palette or color table that converts a data
attribute like amplitude into color in the creation of depth or time slice images
and section views.    

Line Name/Number:is the identifier for a line of data saved when surveying along a line. (e.g.
XL0010.DT1)

Gain: when displaying cross sections formed from traces, a display control is often
needed to allow strong responses from shallow targets to be viewed at the
same time as weaker responses from deep targets.  Gain is applied to weak
signals to make them larger. 

Depth Gain: is a display gain applied that varies with depth along a trace.

Time Gain: is a display gain applied that varies with time along a trace.

3D View: the term used when displaying depth or time slices and selected cross sec-
tions through a volume and used to enable 3D visualization of grid survey
data.  

Cross-Section Imagethe term used when line profiling data are displayed as a computer gener-
ated image, showing signal amplitude varying in time or depth versus posi-
tion along the line.  Quite often the term is shortened to cross-section or
section.

Depth or Depth-Section Image:the term used when line profiling data are displayed as a cross-
section with the vertical depth scale.  Quite often the term is shortened to
depth-section or section.

Time or Time-Section Image: the term used when line profiling data are displayed as cross-sec-
tion with the vertical time scale. Quite often the term is shortened to time-
section or section.

Slice Type: standard grids use line names beginning with X for lines in X direction and
line names beginning with Y for lines in Y direction.  Time or depth slice
images can be formed from X lines or Y lines, or combined XY.  Combined
slices are the standard but sometimes advanced users can benefit from
viewing alternate slice types.
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X Slice: time or depth slice image created from X lines in a grid.

Y Slice: time or depth slice image created from Y lines in a grid.

XY Slice: time or depth slice image created from combining both X and Y lines in a
grid.  

Amplitude Depth / Time Equalization:process of equalizing the average amplitudes in all depth/
time slices such that equivalent features in slices from different depths/times
will appear to have the similar amplitude in the generated image.

Slice Image Resolution:spacing (m or ft) between the regularized grid data points in the XY plane
for the processed and interpolated slice attribute data.  This is the parameter
that determines the spatial resolution in the depth/time slice images.

Slice Overlap Overlap (% of slice thickness) between the adjacent depth/time slices.  

Slice Thickness Thickness (m or ft) of the time/depth slice.   

Plan View window that displays a plan view of the surveyed area. The depth/time
slices, line location map, and surface images (future development) are all
displayed as layers, possibly overlaid, (e.g. line locations over depth slice
image)  within this window.  

Attribute term applied to some characteristic derived from original data. Examples are
the average amplitude of the dominant frequency between two times or
depths. 

Line Spacing Conversion FactorWhen importing X or Y Lines, the position of the line on the grid
area is determined using the Conversion Factor. If the Line name has a num-
ber N, the position is N* Factor. If the Line name does not have a number, a
Line Spacing of Factor is used. I.e. XLine010, with a factor of 0.5 m, would
be placed 10*0.5=2 meters from origin along Y axis.

Image Sensitivity How sensitive the image is to small signal variations. Effectively the Color
Palette "widens" around the zero signal level. Given as 0-100%, with default
being 100% (most sensitive)

Image Contrast: How much of image is at extremes of Color Palette. Effectively the Color Pal-
ette increases the area of extremes of data signal. Given as 0-100%, with
default of 0% (no added contrast)

Cross Section Maximum Slice Depth Multiplier:Multiplication factor used to set the maximum
depth displayed on the cross-section view. Maximum depth displayed is this
factor multiplied by the Max Depth Limit specified in the slice processing.
(shortened to Max Slice Depth Multiplier

Interpolation Limit The maximum separation between lines when interpolating Slice data. Paral-
lel Lines separated by more than the limit will result in an area on the Slice
between the Lines with no GPR signal.(zero amplitude)

Hyperbola Velocity EstimateA point source GPR refection appears as a hyperbola in the Cross
Section Image. Hyperbolic fitting enables the media velocity and target depth
to be estimated.
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Hyperbolic Fitting Process of fitting a hyperbolic shape to a local GPR response in the space-
time domain. The fitting process yields a velocity above target and a depth
estimate. 

GFP File An XML format computer file which provides information on multiple files of
data and enables a Sensors & Software program to automatically read and
process the data to final form.
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